Office 365'te geçiş sırasında TooManyBadItemsPermanentException

Özgün KB numarası:   4023340

Belirtiler

Microsoft Office 365'de geçiş sırasında aşağıdaki hata iletisini alısınız:

TooManyBadItemsPermanentException

Not

Eksik öğelerin sayısı hatalı öğe sınırı içinde olduğundan (ancak artmamakla) bu makaledeki bilgiler "TooManyMissingItemsPermanentException" hatasına da uygulanabilir.

Neden

Bu sorun, hatalı öğe sayısı ayarlanmış sınırdan büyük olduğunda ortaya çıkar. Sınır artırana veya sınırsız olarak ayarlanıncaya kadar geçiş devamamaz.

Çözüm

Bu sorunu çözmek için şu adımları izleyin:

  1. Taşıma isteğini dışarı aktarın ve ardından PowerShell'de çözümlemek için içeri aktarın.

    $stats= Get-MailboxStatistics <SMTP address> -IncludeMoveReport
    $report = $stats.MoveHistory[0].Report
    $report.BadItems
    
  2. Varsayılan baditemlimit değeri 0 olan değeri güncelleştirin. Daha büyük bir değer kullanın veya sınırsız olarak ayarlayın. (Bu, önceki adımda belirlenen sayıya bağlıdır.)

    Get-Moverequest <identity> | Set-Moverequest –baditemlimit <input value>
    Resume-Moverequest <identity>