VSS_E_WRITERERROR_RETRYABLE daG'de pasif veritabanı kopyasını yedeklerken hata Exchange verir
Özgün KB numarası: 4037535
Belirtiler
2013 veya Exchange Server 2016'da da Exchange Server var. DAG'nin, uzak bir sitede bulunan bir posta kutusu veritabanı kopyası vardır. Pasif bir veritabanı kopyasını yedeklemeye çalışabilirsiniz, yedekleme başarısız olur ve aşağıdaki sorunları gözlemlersiniz.
Şu hata iletisini alısınız:
Yazar adı: 'Microsoft Exchange Yazarı'
Yazar Kimliği: WriterId
Writer Örnek Kimliği: WriterInstanceId
Durum: [1] Kararlı
Son hata: Yeniden denenebilir hataBETEST aracını çalıştırsanız, şu ileti döndürülür:
Yazar Microsoft Exchange Yazarı'nın durumu: STABLE(0x800423f3 - VSS_E_WRITERERROR_RETRYABLE)
Pasif Exchange kopyasının yedeğini başlatan bir veritabanı sunucusunda, olay 2153 Uygulama günlüğüne kaydedilir:
Günlük Adı: Uygulama
Kaynak: MSExchangeRepl
Tarih: Tarih
Olay Kimliği: 2153
Görev Kategorisi: Hizmet
Düzey: Hata
Anahtar Sözcükler: Klasik
Kullanıcı: Yok
Bilgisayar: BilgisayarAdı
Açıklama: Günlük kopyaıcı sunucuyla iletişim <FQDN of the Active Server> kuramadı. Veritabanının kopyası <Mailbox Database\Local Server> bağlantısı kesik durumda. İletişim hatası: sunucu ile iletişim kurarken bir hata <Active server> oluştu. Hata: Aktarım bağlantısından veriler okunamıyor: Ana makinenizin yazılım tarafından durdurulan bir bağlantı. Kopyaıcı kısa bir gecikmeden sonra otomatik olarak yeniden sınılır.
Not
Bu makalede pasif veritabanı sunucusu, etkin veritabanını barındıran Exchange sunucusuna başvurmak için pasif veritabanı kopyasının ve etkin veritabanı sunucusunun yedeğini başlatan Exchange sunucusu kullanır.
Neden
Bu sorun, edilgen veritabanı sunucusu ile etkin veritabanı sunucusu arasındaki uzak yordam çağrısı (RPC) kanalında iletişimi engellenen veya kesen ağ sorunları nedeniyle oluşabilir. RPC kanalının açıklaması için DAG yedeklemesinde dikkate alınacak noktalar bölümüne bakın.
Çözüm
Bu sorunu çözmek için aşağıdaki kılavuzu kullanın:
- Ağ topolojinizi ve Exchange kontrol edin.
- Ağ tarama işlevselliği olan güvenlik yazılımı bu soruna neden olabilir. Yazılımın doğru yapılandırıldığından emin olun.
- Ağ ayarları, Exchange sunucularına ve ağ cihazlarına yedeklemeleri başlatacak ve DAG'daki diğer Exchange sunucularla iletişim kuracak kadar süre ver olmalıdır.
- Exchange sunucularında KeepAliveTime kayıt defteri girdisi değeri, ağ cihazlarında yapılandırılan boşta oturum zaman aşımından az olmalıdır. Kayıt defteri girdisi değerinin
KeepAliveTime15 dakikadan fazla olması önerilir.
Olası ağ ve performans sorunlarının daha iyi olan dayanıklılığı için işlem günlükleri aralığındaki sorguların zaman aşımı değerini artırabilirsiniz. Varsayılan değer 30 saniyedir. Zaman aşımı değerini artırmak için şu adımları izleyin:
Kayıt Defteri Düzenleyicisi'nde, aşağıdaki kayıt defteri alt anahtarına göz atabilirsiniz:
HKEY_LOCAL_MACHINE\ SOFTWARE\Microsoft\ExchangeServer\v15\Replay\ParametersDWORD (32 bit) Değerinin kayıt defteri anahtarını oluşturun.
Kayıt defteri anahtarının adını QueryLogRangeTimeoutInMsec olarak ayarlayın.
Değeri 120.000 olarak ayarlayın; bu da 120 saniye anlamına gelir. (Veya iş gereksinimlerinize bağlı olarak farklı bir değer de ayarlayın.)
Microsoft Exchange Çoğaltma Hizmeti'i (msexchangerepl) yeniden başlatın.
DAG yedeklemesinde dikkate alınacak noktalar
Pasif veritabanı kopyasının yedeğini başlatmak için, edilgen veritabanı sunucusundaki Exchange çoğaltma hizmeti, etkin veritabanı sunucusunda işlem günlüklerinin aralığını almak için bir sorgu oluşturur. Etkin veritabanı sunucusu meşgulse, özellikle de çok sayıda günlük dosyası varsa, sorgu beklenenden uzun sürebilir. Ardından, Exchange çoğaltma hizmeti, sunucuya yedeklemenin devam ediyor olduğunu bildirmek için etkin veritabanı sunucusuna bir RPC kanalı açar. Yedekleme sırasında RPC kanalı açık olması gerekir.
DAG yedeklemeleri hakkında aşağıdaki noktaları göz önünde bulundurarak:
- Yedekler için pasif veritabanı kopyalarını kullanın. Etkin veritabanı kopyalarının size destek olması önerilmez. Etkin veritabanı kopyaları, devam eden iş işlemlerine ayrılmış olmalıdır.
- Etkin veritabanı kopyalarını herhangi bir nedenle yedeklemeniz gerekirse, edilgen veritabanı kopyalarının aynı anda yedek için yapılandırılmamış olduğundan emin olun. Aksi takdirde, yedekleme hatasıyla ve YENIDEN DENENEBILIR hatasıyla karşılaştınız.
- Yedekleme sırasında, veritabanları DAG'da başka bir Exchange sunucuya taşınmaması gerekir.
- Ağ bağlantıları etkin ve kararlı olmalıdır.