IMAP istemcileri, Exchange Server 2016'da birlikte yer alan Exchange Server 2010'da oturum açayken Exchange Server başarısız oluyor

Belirtiler

İnternet Posta Erişim Protokolü (IMAP) istemcilerinin kimlik doğrulaması art arda aşağıdaki koşullarda istenir:

  • Microsoft Exchange Server 2016 ortamıyla birlikte Microsoft Exchange Server bir deneyim.
  • Etkilenen kullanıcının posta kutusu Exchange 2010 sunucularında barındırıldı ve bağlantı uç noktası Exchange 2016 sunucusunda.
  • Çok Windows/Yanıt (NTLM) kimlik doğrulama yöntemi kullanılır.

Neden

Exchange 2016 sunucusu, Exchange 2010 sunucularında proxy isteklerini doğrularken NTLM veya Kerberos kimlik doğrulama yöntemlerini desteklemez.

Çözüm

Yöntem 1

  1. Aşağıdaki cmdlet'i çalıştırarak, 2016 sunucusunda EnableGSSAPIAndNTLMAuth Exchange Server False olarak ayarlayın:

    Set-IMAPSettings -EnableGSSAPIAndNTLMAuth $false
    
  2. Exchange 2016 sunucusunda aşağıdaki IMAP hizmetlerini yeniden başlatın:

    • Microsoft Exchange IMAP4 (MSExchangeImap4)
    • Microsoft Exchange IMAP4 Arka Uç (MSExchangeIMAP4BE)

Not

Güvenli değil (TCP 143) IMAP kullanıyorsanız LoginType'ı PlainTextAuthentication olarak ayarlamanız gerekir. Bu çoğunlukla eski IMAP istemcileri için geçerlidir. SecureLogin ayarlanırsa, kimlik doğrulaması öncesinde IMAP istemcisinin STARTTLS işlemi yapmaları gerekir. STARTTLS desteği olmayan istemcilerin LoginType değerini PlainTextAuthentication olarak ayarlaması gerekir.

Yöntem 2

Etkilenen posta kutularını Exchange 2016 sunucularına taşıma.