RPC şifreleme gereksinimi sebebiyle Outlook ile Exchange posta kutularıyla ilgili bağlantı sorunları
Orijinal KB numarası: 3032395
Bu makale yalnızca RPC şifreleme sebebiyle oluşan Microsoft Outlook bağlantı sorunları için geçerlidir.
Belirtiler
Microsoft Office Outlook'u, Microsoft Exchange Server 2010, Exchange Server 2013 veya Exchange Server 2016 çalıştıran bir sunucuda posta kutusu içeren bir profil kullanarak başlattığınızda, aşağıdaki hata iletilerini alabilirsiniz:
Microsoft Office Outlook başlatılamıyor. Outlook penceresi açılamıyor. Klasör kümesi açılamadı.
Varsayılan e-posta klasörleriniz açılamıyor. Microsoft Exchange Server bilgisayarı kullanılamıyor. Ağ sorunları var ya da Microsoft Exchange Server bilgisayarı bakım için kapatılmış.
Microsoft Exchange Server bağlantısı kullanılamıyor. Outlook bu eylemi tamamlamak için çevrimiçi veya bağlı olmalıdır.
Varsayılan e-posta klasörleriniz açılamıyor. Bilgi deposu açılamadı.
Outlook oturum açamadı. Ağa bağlı olduğunuzdan ve düzgün sunucu ile posta kutusu adını kullandığınızdan emin olun. Microsoft Exchange Server bağlantısı kullanılamıyor. Outlook bu eylemi tamamlamak için çevrimiçi veya bağlı olmalıdır.
Bununla birlikte, önbelleğe alınmış mod profili kullanıyorsanız Outlook bir hata görüntülemez. Aşağıdaki belirtileri deneyimleyebilirsiniz:
Outlook, Bağlantı Kesildi durumuyla başlar (Outlook penceresinin sağ alt köşesinde "Bağlantı kesildi" yazar, durumla ilgili ekran görüntüsü aşağıda gösterilmiştir).
Outlook başlar ve e-posta iletileri gönderebilir ve alabilirsiniz. Ancak "Microsoft Exchange Bağlantı Durumu" içinde yalnızca iki bağlantı görürsünüz ve Tür Dizini'nini Bağlantı Kesildi/Bağlanıyor olarak görebilirsiniz.
Exchange 2010 veya Exchange Server 2013 çalıştıran bir sunucudaki posta kutusu için yeni bir Outlook profili oluşturmaya çalıştığınızda, aşağıdaki hata iletilerini alabilirsiniz:
Eylem tamamlanamadı. Microsoft Exchange Server bağlantısı kullanılamıyor. Outlook bu eylemi tamamlamak için çevrimiçi veya bağlı olmalıdır.
İsim çözümlenemedi. Microsoft Exchange Server bağlantısı kullanılamıyor. Outlook bu eylemi tamamlamak için çevrimiçi veya bağlı olmalıdır.
Outlook oturum açamadı. Ağa bağlı olduğunuzdan ve düzgün sunucu ile posta kutusu adını kullandığınızdan emin olun. Microsoft Exchange Server bağlantısı kullanılamıyor. Outlook bu eylemi tamamlamak için çevrimiçi veya bağlı olmalıdır.
İsim çözümlenemedi. Eylem tamamlanamadı.
Sunucu veya Posta kutusu adları çözümlenemedi.
Çözüm
Not
Otomatik yöntemlerden birini (Grup İlkesi veya bir .prf dosyası) kullanıyorsanız, yöntemi büyük ölçekli dağıtmadan önce tam olarak sınadığınızdan emin olun.
Yöntem 1: RPC şifrelemesi ile Outlook profilinizi güncelleştirme veya oluşturma
Varolan profili el ile güncelleştirme
Mevcut bir Outlook profilini RPC şifrelemesi kullanacak şekilde el ile güncelleştirmek için aşağıdaki adımları izleyin:
Denetim Masası'nda, Posta öğesini açın.
Profilleri Göster'e tıklayın.
Profilinizi seçin ve ardından Özellikler'e tıklayın.
E-posta Hesapları'na tıklayın.
Microsoft Exchange (varsayılan olarak bu hesaptan gönder) hesap > Değiştir'i seçin.
Posta kutusu sunucunuzu ve kullanıcı adınızı içeren iletişim kutusunda Diğer Seçenekler'i seçin.
Microsoft Exchange iletişim kutusunda Güvenlik sekmesine tıklayın.
Microsoft Office Outlook ile Microsoft Exchange arasında veri şifrele > Tamam'ı seçin (Bu adımın ekran görüntüsü burada görülebilir).
İleri > Son'a tıklayın.
Kapat > Kapat > Tamam'ı seçin
Mevcut Outlook profillerini RPC şifrelemesi ile güncelleştirmek için bir Grup İlkesi ayarı dağıtma
İstemci açısından bakıldığında Outlook-Exchange şifreleme ayarını dağıtmak, çok Outlook istemcisi olan kuruluşlar için muhtemelen en basit çözümdür. Bu çözüm, sunucu (etki alanı denetleyicisi) üzerinde tek bir değişiklik içerir ve ilke istemciye indirildikten sonra istemcileriniz otomatik olarak güncelleştirilir.
Outlook 2010
Varsayılan olarak, Outlook 2010'da RPC şifreleme ayarı etkindir. Dolayısıyla bu ayarı, yalnızca aşağıdaki nedenlerden biri için Grup İlkesi kullanarak dağıtmalısınız:
- Özgün Outlook 2010 dağıtımınızda, Outlook ile Exchange arasında RPC şifrelemesini devre dışı bırakılmış.
- Kullanıcıların, kendi Outlook profillerinde RPC şifreleme ayarını değiştirmelerini engellemek istiyorsunuz.
Outlook 2010 için varsayılan Grup İlkesi şablonu, Outlook-Exchange RPC şifrelemesini kontrol eden Grup İlkesi ayarını içerir. Grup İlkesi kullanarak var olan Outlook 2010 profillerini güncelleştirmek için şu adımları izleyin:
.adm dosyasını, etki alanı denetleyicinize ekleyin.
Not
.adm dosyasını bir etki alanı denetleyicisine ekleme adımları, çalıştırılan Windows sürümüne göre değişir. Buna ek olarak, ilkeyi etki alanına değil bir kuruluş birimine uygulayabileceğiniz için adımlar, ilke uygulama konusunda da değişiklik gösterebilir. Bu nedenle, ayrıntılı bilgi için Windows belgelerinize bakın.
.adm şablonunu Yerel Grup İlkesi Düzenleyicisi'ne ekledikten sonra 3. adıma gidin.
Kullanıcı Yapılandırması'nın altında, Yönetim Şablonları (ADM)'nı genişletin ve şablona yönelik ilke düğümünü bulun. Outlk14.adm şablonunu kullanarak, bu düğüm Microsoft Outlook 2010 olarak adlandırılacaktır.
Hesap Ayarlar altında, Exchange düğümünü seçin (Bu adımın ekran görüntüsü burada görülebilir).
RPC şifrelemeyi etkinleştir ilkesi ayarına çift tıklayın.
Ayar sekmesinde, Etkinleştir'i seçin.
Tamam'ı seçin.
Bu noktada, Grup İlkesi güncelleştirmesi çoğaltılırken, Outlook istemci iş istasyonlarınıza ilke ayarı uygulanacaktır. Bu değişikliği doğrulamak için şu komutu çalıştırın:
gpupdate /force
Bu komutu çalıştırdıktan sonra, istemcide aşağıdaki kayıt defteri verilerin var olduğundan emin olmak için iş istasyonu üzerinde Kayıt Defteri Düzenleyicisi'ni çalıştırın:
Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\Outlook\RPC
DWORD: EnableRPCEncryption
Value: 1
Kayıt defterinde bu kayıt defteri verilerini görüyorsanız, bu istemciye Grup İlkesi ayarı uygulanmıştır. Değişikliğin sorunu çözdüğünü doğrulamak için Outlook'u başlatın.
Outlook 2013
Varsayılan olarak, Outlook 2013'te RPC şifreleme ayarı etkindir. Dolayısıyla bu ayarı, yalnızca aşağıdaki nedenlerden biri için Grup İlkesi kullanarak dağıtmalısınız:
- Özgün Outlook 2013 dağıtımınız, Outlook ile Exchange arasında RPC şifrelemesini devre dışı bırakmıştır.
- Kullanıcıların, kendi Outlook profillerinde RPC şifreleme ayarını değiştirmelerini engellemek istiyorsunuz.
Outlook 2013 için varsayılan Grup İlkesi şablonu, Outlook-Exchange RPC şifrelemelerini kontrol eden Grup İlkesi ayarını içerir. Grup İlkesi kullanarak var olan Outlook 2013 profillerini güncelleştirmek için şu adımları izleyin:
Office 2013 ADM şablonlarını indirin.
Etki alanı denetleyicinize .admx ve .adml dosyalarını ekleyin. Bu, Outlook ADM şablonununu, Yerel Grup İlkesi Düzenleyicisi'nde kullanılabilir hale getirmek için ekler.
Not
Etki alanı denetleyicisine .admx ve adml dosyalarını ekleme adımları, çalıştırdığınız Windows sürümüne göre değişir. Buna ek olarak, ilkeyi etki alanına değil bir kuruluş birimine uygulayabileceğiniz için adımlar, ilke uygulama konusunda da değişiklik gösterebilir. Bu nedenle, ayrıntılı bilgi için Windows belgelerinize bakın. (Bu makale Office 2010 için etiketledir. Bununla birlikte Office 2013 için de geçerlidir.)
Yerel Grup İlkesi Düzenleyicisi'ni başlatın.
Kullanıcı Yapılandırması'nın altında, Yönetim Şablonları (ADM)'nı genişletin ve şablona yönelik ilke düğümünü bulun. Outlk15.admx şablonunu kullandığınızda bu düğüm, Microsoft Outlook 2013 olarak adlandırılacaktır.
Hesap Ayarlar altında, Exchange düğümünü seçin (Bu adımın ekran görüntüsü burada görülebilir).
RPC şifrelemeyi etkinleştir ilkesi ayarına çift tıklayın.
Ayar sekmesinde, Etkinleştir'i seçin.
Tamam'ı seçin.
Bu noktada, Grup İlkesi güncelleştirmesi çoğaltılırken, Outlook istemci iş istasyonlarınıza ilke ayarı uygulanacaktır. Bu değişikliği sınamak için aşağıdaki komutu bir iş istasyonunda çalıştırın:
gpupdate /force
Bu komutu çalıştırdıktan sonra, istemcide aşağıdaki kayıt defteri verilerin var olduğundan emin olmak için iş istasyonu üzerinde Kayıt Defteri Düzenleyicisi'ni çalıştırın:
Key: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Outlook\RPC
DWORD: EnableRPCEncryption
Value: 1
Kayıt defterinde bu kayıt defteri verilerini görüyorsanız, bu istemciye Grup İlkesi ayarı uygulanmıştır. Değişikliğin sorunu çözdüğünü doğrulamak için Outlook'u başlatın.
Yöntem 2: Tüm CAS sunucularında şifreleme gereksinimini devre dışı bırakma
Önemli
Microsoft, şifreleme gereksinimini sunucunuzda etkin durumda bırakmanızı ve bu makalede listelenen diğer yöntemlerden birini kullanmanızı şiddetle tavsiye eder. Yöntem 2, yalnızca bu makalede, Outlook istemcilerinizde gerekli RPC şifreleme ayarlarını hemen dağıtamadığınız durumlar için sağlanmıştır. Yöntem 2'yi Outlook istemcilerinin RPC şifrelemesi olmadan bağlanmasına izin vermek için kullanırsanız, istemciden sunucuya en yüksek iletişim düzeyini korumak için CAS sunucularınızda RPC şifreleme gereksinimini mümkün olan en hızlı şekilde yeniden etkinleştirin.
Outlook ile Exchange arasında gerekli şifrelemeyi devre dışı bırakmak için şu adımları izleyin:
Exchange Yönetim Kabuğu'nda aşağıdaki komutu çalıştırın:
Set-RpcClientAccess -Server <Exchange server name> -EncryptionRequired:$FalseNot
Exchange_server_name yer tutucusu, İstemci Erişim Sunucusu rolü olan bir Exchange Server adını temsil eder.
Bu cmdlet'i, Exchange Server 2010 veya sonraki bir sürümü çalıştıran tüm İstemci Erişimi sunucuları için çalıştırmalısınız.
İstemci Erişim Sunucusu rolüne sahip her Exchange sunucusu için bu komutu yeniden çalıştırın. Komut ayrıca, Ortak Klasör Deposu içeren her Posta Kutusu Sunucusu rolünde de çalıştırılmalıdır. MAPI istemcisinin Ortak Klasör bağlantıları, doğrudan Posta Kutusu sunucusundaki RPC İstemci Erişim Hizmeti'ne gider.
Outlook istemcileriniz, Exchange ile şifrelenmiş RPC iletişimini etkinleştirme ayarıyla güncelleştirildikten sonra (aşağıdaki adımlara bakın), İstemci Erişimi Sunucusu rolüne sahip Exchange sunucularınız üzerinde RPC şifreleme gereksinimini yeniden etkinleştirebilirsiniz.
İstemci Erişim Sunucusu rolüne sahip olan Exchange sunucularınız üzerinde RPC şifreleme gereksinimini yeniden etkinleştirmek için aşağıdaki komutu Exchange Yönetim Kabuğu'nda çalıştırın:
Set-RpcClientAccess -Server <Exchange server name> -EncryptionRequired:$TrueNot
Exchange_server_name yer tutucusu, İstemci Erişim Sunucusu rolü olan bir Exchange Server adını temsil eder.
Bu cmdlet'i, Exchange Server 2010 veya sonraki bir sürümü çalıştıran tüm İstemci Erişimi sunucuları için çalıştırmalısınız.
Neden
Bunun olası nedenlerinden biri, Outlook kullanıyor ve Microsoft Office Outlook ile Microsoft Exchange arasındaki veriyi şifrele profil ayarını devre dışı bırakmanızdır. Exchange Server 2013 için varsayılan yapılandırma, Outlook istemcisinden RPC Şifrelemesi gerektirir. Bu, istemcinin bağlanmasına engel olur.
Not
Üretim için Exchange Server 2010 Sürümü (RTM) varsayılan yapılandırması, RPC şifrelemesi ister. Bu davranış, RPC şifreleme gereksiniminin varsayılan olarak devre dışı olduğu Exchange Server 2010 Hizmet Paketi 1'den gelen bir değişikliktir. Bununla birlikte, Hizmet Paketi 1'den önce dağıtılan veya Hizmet Paketi 1'e yükseltilen tüm İstemci Erişimi Sunucuları (CAS), istemcinin bağlanmasını engelleyebilecek var olan RPC şifreleme gereksinimi ayarını koruyacaktır.