2010'da çok posta kutusuyla arama Exchange Server hata iletisi: Kullanıcının Exchange posta kutusu yok

Özgün KB numarası:   2702446

Belirtiler

Aşağıdaki senaryoyu inceleyin:

  • Exchange 2010'da veya 2010 Standard Microsoft Exchange Server da Enterprise Denetim Masası'nı (ECP) Exchange Server başlatabilirsiniz.
  • Çok posta kutusuyla arama yapar.
  • Çok posta kutusuyla yapılan aramada, aramanın hedefi olarak Sistem posta kutusu, Bulma Araması posta kutusu veya Federasyon posta kutusu kullanılır.

Bu senaryoda, aşağıdaki hata iletisini alabilirsiniz:

Kullanıcının Bir Exchange posta kutusu yok

Buna ek olarak, aşağıdaki olay Uygulama günlüğüne kaydedilir:

Log Name: Application
Source: MSExchange Configuration Cmdlet - Remote Management
Event ID: 5
Task Category: General
Level: Error
Keywords: Classic
Description:
(PID 6268, Thread 53) Task New-MailboxSearch throwing terminating exception at stage Microsoft.Exchange.Data.Storage.UserHasNoMailboxException: The user does not have an Exchange mailbox.
at Microsoft.Exchange.Data.Storage.ExchangePrincipal.InternalFromADUser(ADUser user, ADObjectId mdb, DatabaseLocationInfo databaseLocationInfo, Boolean ignoreSiteBoundary)
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataStore.OpenMailboxSession(ADUser adUser)
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataStore..ctor(ADUser adUser)
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.OpenMailboxStore()
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.Exists[T](String name)
at Microsoft.Exchange.Management.Tasks.NewMailboxSearch.PreSaveValidate(SearchObject savedObject)
at Microsoft.Exchange.Management.Tasks.NewMailboxSearch.InternalEndProcessing(). Exception: {4c1ab22a-bd1d-41e9-b178-5e75ffd14563}

Neden

Bu sorun, aşağıdaki posta kutularından biri veya birden fazlası tutarsız bir durumda olduğunda, öznitelik için değer ayarlanamazsa HomeMDB oluşabilir:

  • Bir veya birden çok Sistem posta kutusu
  • Federasyon posta kutusu
  • Bulma Arama posta kutusu

Çözüm

Bu sorunu çözmek için şu adımları izleyin:

  1. ECP'yi başlatma.

  2. Bir veya birden çok posta kutusunun tutarsız durumda olduğunu doğrulayın. Bunu yapmak için, aşağıdaki cmdlet'i yazın ve Enter tuşuna basın:

    Get-Mailbox -Arbitration |fl name, alias
    

    Not

    Aşağıdakine benzer bir hata iletisi alabilirsiniz. Bu hata iletisi bir veya birden çok Sistem posta kutusu veya Federasyon posta kutusunun tutarsız bir durumda olduğunu onaylar:

    UYARI: SystemMailbox{1f05a927-9daf-4003-9bf7-036822f96290} nesnesi bozulmuş ve bozulmuştur
    tutarsız bir durumda. Aşağıdaki doğrulama hataları gerçekleşti:
    UYARI: UserMailbox'ta veritabanı zorunludur.
    UYARI: UserMailbox'ta veritabanı zorunludur.

  3. Özniteliğin değerinin posta HomeMDB kutusunda eksik olduğunu doğrulayın. Bunu yapmak için ECP'de aşağıdaki cmdlet'i yazın ve Enter tuşuna basın:

        Get-Mailbox |fl name, alias
    

    Not

    Aşağıdaki hata iletisi özniteliğin değerinin HomeMDB eksik olduğunu gösterir:
    UserMailbox'ta veritabanı zorunludur

  4. Sistem posta kutusu, Federasyon posta kutusu veya Bulma Araması posta kutusuyla aynı veritabanındaki bir posta HomeMDB kutusunun öznitelik değerini kopyalayın. Bunu yapmak için şu adımları uygulayın:

    1. Başlat düğmesine tıklayın, Programları ve dosyaları ara kutusuna Adsi Düzenleme yazın ve Enter tuşuna basın.

    2. Eylem menüsünde, seçeneğine Bağlan.

    3. Seç'e tıklayın ya da bir etki alanı veya sunucu yazın, istediğiniz sunucuyu seçin ve ardından Tamam'a tıklayın.

    4. Varsayılan adlandırma bağlamını genişletin ve ardından aşağıdaki öğeye tıklayın:

      DC=etki alanı,DC=com

    5. CN=Kullanıcılar'a çift tıklayın.

    6. Kullanıcı posta kutusuna sağ tıklayın ve Özellikler'e tıklayın.

    7. Öznitelik altında homeMDB Edit > 'e tıklayın.

    8. Özniteliğin değerini kopyalayın HomeMDB ve iki kez Tamam'a tıklayın.

  5. Sistem posta HomeMDB kutusunda, Federasyon posta kutusunda veya Bulma Araması posta kutusu hesabında öznitelik değerini ayarlayın. Bunu yapmak için şu adımları uygulayın:

    1. ADSI Düzenleme'de Sistem posta kutusunun, Federasyon posta kutusunun veya Bulma Arama posta kutusunun hesabına sağ tıklayın ve ardından Özellikler'e tıklayın.
    2. Öznitelik altında homeMDB Edit > 'e tıklayın.
    3. HomeMDB4. adımda kopyalanmış olan öznitelik değerini yazın veya yapıştırın.
    4. İki kez Tamam'a tıklayın.
  6. Dosya menüsünde Çıkış'a tıklayın.

  7. Ormanın çoğaltılması. Bunu yapmak için yükseltilmiş komut istemine aşağıdaki cmdlet'i yazın ve enter tuşuna basın:

    repadmin /syncall /e
    

Daha fazla bilgi

Öznitelik hakkında daha fazla bilgi HomeMDB için bkz. HomeMDB Özelliği.

System Attendant posta kutusunda özniteliğin değeri eksik olduğunda ortaya çıkabilir bir sorun hakkında daha fazla bilgi için HomeMDB bkz. System Attendant homeMDB özniteliği eksik.