Exchange Server 2010'da birden çok posta kutusu araması yaptığınızda hata: Kullanıcının exchange posta kutusu yok

Özgün KB numarası: 2702446

Belirtiler

Aşağıdaki senaryoyu inceleyin:

  • Exchange Denetim Masası'ni (ECP) Microsoft Exchange Server 2010 Enterprise'da veya Exchange Server 2010 Standard'da başlatırsınız.
  • Çok posta kutusu araması yaparsınız.
  • Birden çok posta kutusu araması, aramanın hedefi olarak bir Sistem posta kutusu, Bulma Arama posta kutusu veya Federasyon posta kutusu kullanır.

Bu senaryoda aşağıdaki hata iletisini alabilirsiniz:

Kullanıcının exchange posta kutusu yok

Ayrıca, aşağıdaki olay Uygulama günlüğüne kaydedilir:

Log Name: Application
Source: MSExchange Configuration Cmdlet - Remote Management
Event ID: 5
Task Category: General
Level: Error
Keywords: Classic
Description:
(PID 6268, Thread 53) Task New-MailboxSearch throwing terminating exception at stage Microsoft.Exchange.Data.Storage.UserHasNoMailboxException: The user does not have an Exchange mailbox.
at Microsoft.Exchange.Data.Storage.ExchangePrincipal.InternalFromADUser(ADUser user, ADObjectId mdb, DatabaseLocationInfo databaseLocationInfo, Boolean ignoreSiteBoundary)
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataStore.OpenMailboxSession(ADUser adUser)
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataStore..ctor(ADUser adUser)
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.OpenMailboxStore()
at Microsoft.Exchange.Data.Storage.Infoworker.MailboxSearch.MailboxDataProvider.Exists[T](String name)
at Microsoft.Exchange.Management.Tasks.NewMailboxSearch.PreSaveValidate(SearchObject savedObject)
at Microsoft.Exchange.Management.Tasks.NewMailboxSearch.InternalEndProcessing(). Exception: {4c1ab22a-bd1d-41e9-b178-5e75ffd14563}

Neden

Öznitelik için HomeMDB hiçbir değer ayarlanmadığından, aşağıdaki posta kutularından biri veya daha fazlası tutarsız durumdaysa bu sorun oluşabilir:

  • Bir veya daha fazla Sistem posta kutusu
  • Federasyon posta kutusu
  • Bulma Arama posta kutusu

Çözüm

Bu sorunu çözmek için şu adımları izleyin:

  1. ECP'yi başlatın.

  2. Bir veya daha fazla posta kutusunun tutarsız durumda olduğunu doğrulayın. Bunu yapmak için aşağıdaki cmdlet'i yazın ve Enter tuşuna basın:

    Get-Mailbox -Arbitration |fl name, alias
    

    Not

    Aşağıdakine benzer bir hata iletisi alabilirsiniz. Bu hata iletisi, bir veya daha fazla Sistem posta kutusunun veya Federasyon posta kutusunun tutarsız durumda olduğunu onaylar:

    UYARI: SystemMailbox{1f05a927-9daf-4003-9bf7-036822f96290} nesnesi bozulmuş ve
    tutarsız bir durumda. Aşağıdaki doğrulama hataları oluştu:
    UYARI: UserMailbox'ta veritabanı zorunludur.
    UYARI: UserMailbox'ta veritabanı zorunludur.

  3. Bir posta kutusu için özniteliğin değerinin HomeMDB eksik olduğunu doğrulayın. Bunu yapmak için ECP'ye aşağıdaki cmdlet'i yazın ve Enter tuşuna basın:

        Get-Mailbox |fl name, alias
    

    Not

    Aşağıdaki hata iletisi, özniteliğin değerinin HomeMDB eksik olduğunu gösterir:
    UserMailbox'ta veritabanı zorunludur

  4. HomeMDB Sistem posta kutusu, Federasyon posta kutusu veya Bulma Arama posta kutusuyla aynı veritabanındaki bir posta kutusunun öznitelik değerini kopyalayın. Bunu yapmak için şu adımları uygulayın:

    1. Başlat'a tıklayın, Program ve dosya ara kutusuna Adsi Düzenle yazın ve enter tuşuna basın.

    2. Eylem menüsünde Bağlan'a tıklayın.

    3. Etki alanı veya sunucu seçin veya yazın'a tıklayın, istediğiniz sunucuyu seçin ve ardından Tamam'a tıklayın.

    4. Varsayılan adlandırma bağlamı'nı genişletin ve aşağıdaki öğeye tıklayın:

      DC=etki alanı,DC=com

    5. CN=Kullanıcılar'a çift tıklayın.

    6. Bir kullanıcı posta kutusuna sağ tıklayın ve ardından Özellikler'e tıklayın.

    7. Öznitelik'in altında homeMDB>Düzenle'ye tıklayın.

    8. Özniteliğin değerini HomeMDB kopyalayın ve ardından iki kez Tamam'a tıklayın.

  5. HomeMDB Sistem posta kutusunda, Federasyon posta kutusunda veya Bulma Arama posta kutusu hesabında öznitelik değerini ayarlayın. Bunu yapmak için şu adımları uygulayın:

    1. ADSI Düzenle'de Sistem posta kutusu, Federasyon posta kutusu veya Bulma Arama posta kutusu için hesaba sağ tıklayın ve özellikler'e tıklayın.
    2. Öznitelik'in altında homeMDB>Düzenle'ye tıklayın.
    3. 4. adımda kopyaladığınız öznitelik değerini yazın veya yapıştırın HomeMDB .
    4. İki kez Tamam'a tıklayın.
  6. Dosya menüsünde, Çıkış'a tıklayın.

  7. Ormanı çoğaltma. Bunu yapmak için, yükseltilmiş bir komut istemine aşağıdaki cmdlet'i yazın ve enter tuşuna basın:

    repadmin /syncall /e
    

Daha fazla bilgi

Özniteliği hakkında HomeMDB daha fazla bilgi için bkz. HomeMDB Özelliği.

Sistem Santrali posta kutusunda özniteliğin değeri eksik olduğunda oluşabilecek bir sorun hakkında daha fazla bilgi için HomeMDB bkz. System Attendant homeMDB özniteliği eksik.