OAuth istemci kimlik bilgileri verilmişken POX Otomatik Bulma desteklenmiyor
Belirtiler
Düz Eski XML (POX) Otomatik Bulma hizmetini OAuth 2.0istemci kimlik bilgileri ile birlikte kullanırsanız, 500 hata kodunu gösteren ve aşağıdaki örneği gösteren bir "e-posta adresi bulunamadı" hata iletisini alırsınız:
POST : https://outlook.office365.com/autodiscover/autodiscover.xml
Request Body :
<?xml version="1.0" encoding="utf-8"?>
<Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/requestschema/2006">
<Request>
<EMailAddress>recipient@domain</EMailAddress>
<AcceptableResponseSchema>http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a</AcceptableResponseSchema>
</Request>
</Autodiscover>
Not:" recipient@domain " kullanıcı tarafından sağlanan bir parametredir.
Response : The email address can't be found
<?xml version="1.0" encoding="utf-8"?>
<Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
<Response>
<Error Time="22:32:50.1642866" Id="2945626231">
<ErrorCode>500</ErrorCode>
<Message>The email address can't be found.</Message>
<DebugData />
</Error>
</Response>
</Autodiscover>
Neden
Bu sorunun nedeni, bu senaryoda POX Otomatik Bulma hizmetinin verilen istemci kimlik bilgileriyle birlikte kullanımı desteklemesi değildir.
Otomatik Bulma, yönlendirme için kullanıcı kimliğine bağlıdır. POX Otomatik Bulma hizmetini istemci kimlik bilgileri atama ile birlikte kullanırsanız, alınan yalnızca uygulama belirteci aramanın bir uygulamadan geldiğine ve kullanıcının bunu doğrulamasına sahip olmadığını gösterir. Bu durumda, POX Otomatik Bulma yüklemesi yüklemesi kullanıcıların kimliğine bürünülmelerini belirtamaz.
Çözüm
Bu sorunu çözmek için, bunun yerine SOAP Otomatik Bulma hizmetini kullanın.