Email iletileri, merkezi posta denetimi kullanan Exchange karma dağıtımlarında yanlış karantinaya alınıyor

Özgün KB numarası: 3079142

Not

Microsoft Exchange Server 2010'daki Exchange Yönetim Konsolu eklenen Karma Yapılandırma sihirbazı artık desteklenmiyor. Bu nedenle, artık eski Karma Yapılandırma sihirbazını kullanmamalısınız. Bunun yerine Microsoft 365 Karma Yapılandırma sihirbazını kullanın. Daha fazla bilgi için bkz. Exchange 2010 için Microsoft 365 Karma Yapılandırma sihirbazı.

Sorun

Microsoft 365'te şirket içi Exchange Server ve Exchange Online karma dağıtımınız vardır. Bu dağıtımda merkezi posta denetimini kullanırsınız. Bu, iletileri Exchange Online posta kutularına teslim etmeden önce şirket içi posta sunucusuna yönlendirmeye zorlar. Bu senaryoda, aşağıdaki belirtilerden biriyle veya daha fazlası ile karşılaşırsınız:

  • Kullanıcılara istenmeyen posta bildirimleri karantinaya alınır.
  • İzin Ver listesindeki Email iletiler karantinaya alınır.
  • Karantinadan çıkarılan Email iletiler yeniden oluşturulur.
  • Sender Policy Framework (SPF) denetimleri ikinci geçişte başarısız olur.

Neden

Bu sorun, Exchange Online kuruluş veya şirket içi kuruluş, e-posta üst bilgilerini şirket içi olarak (Exchange Online şirket içi sunucudan Microsoft 365'e) yükseltmek için ayarlanmadıysa oluşur.

Çözüm

  1. Merkezi posta denetiminin etkinleştirildiğini ve Microsoft 365'te üst bilgileri yükseltecek şekilde ayarlandığını doğrulayın. Bunu yapmak için şu adımları uygulayın:

    1. Uzak Windows PowerShell oturumu kullanarak Exchange Online bağlanın. Daha fazla bilgi için bkz. Uzak PowerShell kullanarak Exchange Online bağlanma.

    2. Exchange Online kuruluşundaki karma giden bağlayıcının yapılandırma bilgilerini görüntüleyin. Bunu yapmak için aşağıdaki komutu çalıştırın:

      Get-OutboundConnector "Contoso Outbound Connector" | Format-List
      

      özelliğinin değerinin RouteAllMessagesViaOnPremises$true olarak ayarlandığını doğrulayın.

    3. Exchange Online kuruluşundaki karma gelen bağlayıcının yapılandırma bilgilerini görüntüleyin. Bunu yapmak için aşağıdaki komutu çalıştırın:

      Get-InboundConnector "Contoso Inbound Connector" | Format-List
      

      özelliğinin değerinin CloudServicesMailEnabled$true olarak ayarlandığını doğrulayın.

    4. Üst bilgilerde aşağıdaki satırı bulun:

      X-MS-Exchange-Organization-Cross-Premises-Headers-Promoted: <Microsoft 365 Server Name>

      Örneğin , server.contoso.com.

      Not

      RouteAllMessagesViaOnPremises Özellik ve CloudServicesMailEnabled özellik $false olarak ayarlanırsa ve X-MS-Exchange-Organization-Cross-Premises-Headers-Promoted: <Microsoft 365 Server Name> üst bilgi bulunmazsa, bu çözüm kuruluşunuzun yapılandırması için geçerli değildir.

  2. önce iletiyi şirket içi sunucudan yönlendirerek bir Exchange Online posta kutusuna gelen test iletisi gönderin. İleti üst bilgilerinde aşağıdaki X üst bilgi satırlarını bulun. Bu, iletinin aktarım sırasında iki kez tarandığını belirtmeye yardımcı olur.

    • X-Forefront-Antispam-Report-Untrusted: Bu ilk geçiştir. İleti Microsoft 365'te ilk kez alındığında gerçekleşir. Bu satırdaki bağlanan IP adresi (CIP) bir İnternet IP adresi olacaktır.
    • X-Forefront-Antispam-Report: Bu ikinci pas. İleti şirket içi sunucu tarafından döndürülür ve Microsoft 365'te ikinci kez alındığında gerçekleşir. Bağlanan IP adresi, kuruluşunuzun şirket içi sunucu IP adresi olacaktır.

    Not

    Yalnızca bir X-Forefront üst bilgisi varsa, bu çözüm kuruluşunuzun yapılandırması için geçerli değildir.

  3. Üst bilgileri şirket içi ortamdan Microsoft 365'e yükseltmek için şu adımları izleyin:

    1. Üstbilgilerin şu anda yükseltilmediğini doğrulayın. Bunu yapmak için üst bilgilerde aşağıdaki satırın eksik olup olmadığını denetleyin:

      X-MS-Exchange-Organization-Cross-Premises-Headers-Promoted: <On-premises Server Name>

      Örneğin, şirket içi sunucu adı contoso_on_premises.contoso.com.

    2. Üst bilgilerden öğesini bulun X-OriginatorOrg . contoso.onmicrosoft.com biçiminde olacaktır.

    3. Exchange 2013 veya Exchange 2010'da Exchange Management Shell'i açın ve aşağıdaki komutları çalıştırın:

      • New-RemoteDomain -Name 'Hybrid Domain - contoso.onmicrosoft.com' -DomainName 'contoso.onmicrosoft.com'
        
      • Set-RemoteDomain 'Hybrid Domain - contoso.onmicrosoft.com' -TrustedMailOutboundEnabled $true -TrustedMailInboundEnabled $true
        
    4. Sorunun düzeltildiğini doğrulayın. Yeni bir ileti gönderin ve üst bilgilerde aşağıdaki satırın bulunduğunu doğrulayın:

      X-MS-Exchange-Organization-Cross-Premises-Headers-Promoted: <On-premises Server Name>

      Örneğin, şirket içi sunucu adı contoso_on_premises.contoso.com.

Daha fazla bilgi

Daha fazla bilgi için aşağıdaki Microsoft kaynaklarına bakın: