DAG'da yeni oluşturulan veritabanında posta kutusuna erişirken "NoSupportException" hatası
Belirtiler
Microsoft Exchange Server 2019 posta kutusu sunucusunu veritabanı kullanılabilirlik grubuna (DAG) düğüm olarak ekleyen ve ek posta kutusu veritabanları oluşturduktan sonra, aşağıdaki sorunları yaşamanız gerekir:
Posta kutusu sunucusundaki posta kutusuna, Posta Kutusu'Web üzerinde Outlook erişmeye çalışsanız, aşağıdaki hata iletisini alırsınız:
Posta kutunuzu kullanmaya çalışırken bir sorun oluştu.
X-OWA-Hata Microsoft. Exchange. Veriler. Depolama. NoSupportExceptionPosta kutusunu, posta kutusu sunucusundaki bir veritabanına taşımaya çalışsanız, aşağıdaki hata iletisini alırsınız:
Posta kutusu veritabanıyla iletişim kurılamadı. Bu işlem için destek yoktur.
Neden
Bu sorunlar, posta kutusu veritabanının şema sürüm değeri yanlış olduğundan oluşur. Başka posta kutusu veritabanları oluşturmadan önce, düğüm DAG'ye eklendikten sonra her düğümde Bilgi Deposu hizmetinin yeniden başlatılması gerekir. Aksi takdirde, küme veritabanı doğru şema sürümü için güncelleştirilmez.
Geçici Çözüm
Kümeye düğüm ekledikten sonra, düğümde Bilgi Deposu hizmetini yeniden başlatın.
Zaten kümede yeni veritabanları oluşturduysanız, kümedeki tüm düğümlerde Bilgi Deposu hizmetini yeniden başlatmadan önce şema sürüm değerinin 121 olarak ayar olup olmadığını kontrol edin. Posta kutusu veritabanının veritabanı şema sürümünü kontrol etmek için aşağıdaki cmdlet'i çalıştırın:
Get-MailboxDatabase DB01 -Status | fl *Schema*
Aşağıdakine benzer bir sonuç alalisiniz:
IsExcludedFromProvisioningBySchemaVersionMonitoring: False
CreationSchemaVersion : 0.121
CurrentSchemaVersion : 0.121
RequestedSchemaVersion : 0.121
Şema sürüm değerini güncelleştirmeniz gerekirse, veritabanı şemasını güncelleştirin ve ardından veritabanının en yüksek ve en yüksek değerini oluşturun:
Update-DatabaseSchema DB01
Dismount-Database DB01
Mount-Database DB01
Değer hala CurrentSchemaVersion 121 değerini gösteriyorsa, küme genelindeki tüm Bilgi Deposu hizmetleri yeniden başlatılmaz.