Mobil cihazlar, mobil cihazlardan kaldırıldıktan sonra beklendiği gibi karantinaya Exchange Online
Özgün KB numarası: 4090814
Belirtiler
Başka Microsoft Exchange Online, bazı mobil cihazlar beklendiği gibi karantinaya alınmz.
Örneğin, aşağıdaki senaryoyu düşünün:
Etki Office 365, erişim Exchange ActiveSync Karantina - Engellemeye veya daha sonra izin vermeme izin ver olarak yapılandırıldı. Karantinaya alınmış bir cihaza izin verilir. Cihaza izin verilmiyorsa, cmdlet'te ve parametrelerde İzin verilen
Get-CASMailboxve Engellenen cihazlar yerActiveSyncAllowedDeviceIDsActiveSyncBlockedDeviceIDsalmaktadır.Daha sonra, cihazı kaldırmak istediğiniz. Aşağıdaki yöntemlerden birini kullanarak bunu yapabilirsiniz:
Yöntem 1
- Alıcıların Exchange kutularını > Yönetim > Merkezi'ni bulun.
- Sağ tarafta, Mobil Cihazlar 'ın altında Ayrıntıları görüntüle'yi seçin ve cihazı tüm mobil cihazlar listesinden kaldırın.
Yöntem 2
Remove-MobileDevicePowerShell cmdlet'ini kullanın.Cihaz kaldırıldıktan sonra, kullanıcı aynı cihazı eklemeye veya yapılandırmaya çalışır.
Bu senaryoda, cihaz karantinaya alınmış durumda değildir ve bağlanmaya izin verilir. Office 365 Exchange yönetim merkezinde, kullanıcının mobil cihaz ayrıntıları Access'e erişim verildi durumunu gösterir ve cmdlet parametre değerinin İzin Verilen Get-MobileDevice parametre değerini DeviceAccessState gösterir. Bu beklenen sonuç değildir. Bunun yerine, cihazın karantinaya alınmasını beklersiniz.
Neden
Cihaz kaldırıldığı zaman (Office 365 Exchange Yönetim Merkezi'nde veya cmdlet kullanılarak PowerShell aracılığıyla), ve Remove-MobileDevice ActiveSyncAllowedDeviceIDs parametreler ActiveSyncBlockedDeviceIDs temizlanmaz. Bu nedenle, kullanıcı daha önce kaldırılmış olan cihazı kullanarak bağlanmayı çalıştığında, cihaz kimliği yine parametrede doldurulur; dolayısıyla cihaz karantinaya alınmış olmaz ve bağlanmasına ActiveSyncAllowedDeviceIDs izin verilir.
Geçici Çözüm
Cihazın bağlanmasını önlemek için, ActiveSyncAllowedDeviceIDs ve ActiveSyncBlockedDeviceIDs parametreleri, cihazı kaldır $null olarak ayarlayın. Örneğin, aşağıdaki cmdlet'i çalıştırın:
Set-CASMailbox joe@contoso.com -ActiveSyncAllowedDeviceIDs $null
Bu parametreler $null olarak $null bağlanmaya çalıştığında cihaz karantinaya alınır.
Yine de yardım mı gerekiyor? Microsoft Community web sitesine gidin.