Hedef posta kutusunda, posta kutusu geçişte eşleşen smtp ara sunucusu yok
Sorun
Şirket içi dağıtım için karma dağıtımınız olduğunu ve şirket içinde Microsoft Exchange Server Exchange Online olduğunu Office 365. Posta kutularını şirket içi ortamınıza taşımaya Exchange Online, aşağıdaki hata iletisini alırsınız:
Hedef posta kutusunda '.mail.onmicrosoft.com' ile eşleşen bir smtp <domain> ara mail.onmicrosoft.com
Neden
Aşağıdaki koşullardan biri doğruysa bu sorun oluşabilir:
- Kaynak posta kutusuna .mail.onmicrosoft.com smtp adresi <domain> sağlandı.
- .mail.onmicrosoft.com ara sunucu adresi, ilgili bulut Office 365 kullanıcı nesnesinde bulunan <domain> adresle eşitlanmaz.
Çözüm
Sorunun nedenini bulmak ve .mail.onmicrosoft.com e-posta adresinin eksik olduğunu belirlemek için, Exchange Yönetim Kabuğu'Exchange Online <domain> PowerShell'de çalıştırın:
Şirket Exchange Kabuğu'ta:
Get-Mailbox <AffectedUser> | FL EmailAddresses, EmailAddressPolicyEnabledExchange Online PowerShell'de:
Get-MailUser <AffectedUser> | Select -ExpandProperty emailaddresses
Senaryo 1: mail.onmicrosoft.com kaynak posta kutusunda <domain> .Exchange e-posta adresi eksik
Bu sorunu çözmek için, <domain> .mail.onmicrosoft.com-posta adresini şirket içi kaynak posta kutusuna ekleyin.
Şirket içi posta kutusunda e-posta adresi ilkesi uygulanmışsa (başka bir ifadeyle, EmailAddressPolicyEnabled parametre değeri True olduğunda veya Exchange Yönetim Merkezi'nde veya başka bir yönetim merkezinde kullanıcı için Bu alıcıya uygulanan e-posta adresi ilkesine göre e-posta adreslerini otomatik olarak güncelleştir onay kutusu Exchange Yönetim Konsolu ) bu, e-posta adresi ilkesi şablonunun ikincil SMTP <domain> .mail.onmicrosoft.com etki alanını içermesi anlamına gelir. Yönetim Kabuğu'na aşağıdaki komutu çalıştırarak bu ilkeyi Exchange:
Get-EmailAddressPolicy | FL Identity, EnabledEmailAddressTemplates
Bu durumda, <domain> e-posta mail.onmicrosoft.com ilkesine .mail.onmicrosoft.com .mail.onmicrosoft.com ekleyin. Bunu yapmak için şu adımları uygulayın:
Şirket Exchange Yönetim Merkezi'ni Exchange açın.
Posta akışı'ne ve ardından E-posta adresi ilkeleri'ne tıklayın.
Değiştirmek istediğiniz e-posta adresi ilkesine tıklayın ve sonra da Düzenle'ye tıklayın.
E-posta adresi biçiminde, ilkeye etki alanını ( .mail.onmicrosoft.com) ekleyin, Kaydet'e tıklayın ve ardından değişikliği alıcılara uygulamak için <domain> Uygula'ya tıklayın.
Şimdi, aşağıdaki komutu mail.onmicrosoft.com.mail.onmicrosoft.com SMTP adresinin şirket içi <domain> posta kutusuna damgalı olduğunu görüyor olun:
Get-Mailbox <AffectedUser> | FL EmailAddresses, EmailAddressPolicyEnabledDizin eşitlemenin çalışması için bekleyin. Ya da delta dizin eşitlemesini zorlar. Bunun nasıl olduğu hakkında daha fazla bilgi için bkz. Zamanlayıcıyı Başlatma.
Şirket içi posta kutusunda uygulanmış bir e-posta adresi ilkesi yoksa (başka bir ifadeyle, EmailAddressPolicyEnabled parametre değeri False olduğunda veya Exchange Yönetim Merkezi'nde veya başka bir yönetim merkezinde kullanıcı için Bu alıcıya uygulanan e-posta adresi ilkesine göre e-posta adreslerini otomatik olarak güncelleştir onay kutusu seçili Exchange Yönetim Konsolu ) veya herhangi bir nedenle e-posta adresi ilkesi alıcıya smtp adresini damgalamiyor veya uygulamiyorsa, kullanıcıya .mail.onmicrosoft.com e-posta adresini el ile eklemeniz ve ardından değişikliği Azure AD'ye eşitlemeniz user@domain.mail.onmicrosoft.com <domain> gerekir. Bunu yapmak için şu adımları uygulayın:
Şirket Exchange Yönetim Merkezi'ni Exchange açın.
Alıcılar 'a tıklayın ve sonra da posta kutuları'ne tıklayın.
Değiştirmek istediğiniz şirket içi posta kutusunu seçin ve çift tıklayın.
E-posta adreslerinde, kullanıcının e-posta adreslerine e-posta adresi eklemek için ekle simgesine () user@domain.mail.onmicrosoft.com tıklayın.
Tamam'a ve ardından Kaydet'e tıklayın.
Şimdi, aşağıdaki komutu mail.onmicrosoft.com posta kutusunda <domain> .mail.onmicrosoft.com damgasını görüyor olun:
Get-Mailbox <AffectedUser> | FL EmailAddressesDizin eşitlemenin çalışması için bekleyin. Ya da delta dizin eşitlemesini zorlar. Bunun nasıl olduğu hakkında daha fazla bilgi için bkz. Zamanlayıcıyı Başlatma.
Senaryo 2: mail.onmicrosoft.com-posta adresi şirket içi kaynak posta kutusuna damgalandı ancak bulut posta kullanıcısı nesnesinde <domain> (Exchange Online PowerShell) yok
Bu durumda, büyük olasılıkla bir eşitleme sorun vardır. Dizin eşitlemenin çalışır durumda olup olmadığını ve Azure Active Directory (Azure AD) yönetim merkezinde Bağlan veya Office 365 hatanız olup olmadığını belirler. Bunun nasıl olduğu hakkında daha fazla bilgi için bkz.Office 365.
Zaten e-posta adresinin damgalı olduğu bir bulut kullanıcı nesneniz varsa kullanıcı user@domain.mail.onmicrosoft.com doğrulama hatasıyla da karşılaştınız.
Bu hatayı görmek için, Office 365 PowerShell'e bağlanmanız ve MSOnline (MSOL) hizmetine mi yoksa Windows PowerShell için Azure AD'ye mi bağlanıp bağlanmanıza bağlı olarak aşağıdaki komutlardan birini Windows PowerShell:
(Get-MsolUser -UserPrincipalName <AffectedUserUPN>).Errors.ErrorDetail.ObjectErrors.ErrorRecord.ErrorDescription
(Get-AzureADUser -ObjectId <AffectedUserUPN>).Errors.ErrorDetail.ObjectErrors.ErrorRecord.ErrorDescription
Daha fazla bilgi için bkz. Office 365 portalına veya Azure Active Directory Modülü'ne kullanıcıların doğrulama hatalarını Windows PowerShell.
Ardından, Office 365 PowerShell'de, Azure AD'de ara sunucu adreslerinin e-posta adresini içerip içere olmadığını kontrol user@domain.mail.onmicrosoft.com edin. Bunu yapmak için aşağıdaki komutlardan birini çalıştırın:
(Get-MsolUser -UserPrincipalName <AffectedUserUPN>).ProxyAddresses
(Get-AzureADUser -ObjectId <AffectedUserUPN>).ProxyAddresses
Komut sonucunda kullanıcının smtp adresini bulursanız, ancak yine de bu e-posta adresini Exchange Online PowerShell'de komutu kullanarak bulamıyorsanız, bu durum Dizin Eşitleme aracının adresi Azure AD'ye başarıyla getirdiği ve büyük olasılıkla Azure AD ile Exchange Online arasında bir eşitleme sorunun olduğu anlamına user@domain.mail.onmicrosoft.com Get-MailUser gelir.
Bunun bir diğer nedeni domain.mail.onmicrosoft.com şirket içi kullanıcıya damgalanmış olan smtp etki alanının yanlış olması olabilir. Örneğin, etki alanı sizin kiracınız veya Office 365 etki Exchange Online yoktur. Kabul edilen etki alanları hakkında daha fazla bilgi için bkz. Kabul edilen etki alanlarını görüntüleme.
Sorunun nedenini belirleye belirlerken daha fazla araştırma yapmak için Microsoft Destek ekibiyle bir destek sorunu açın.
Daha fazla bilgi
E-posta adresi ilkeleri ve karma dağıtımları Exchange daha fazla bilgi için, Terimleriniz üzerinde bulut ("E-posta adresi ilkesi" bölümüne bakın) (BÖLÜM I): karma blog gönderisini dağıtma.
E-posta adresi ilkesi düzenleme hakkında daha fazla bilgi için bkz. E-posta adresi ilkesi düzenleme.
Karma Yapılandırma sihirbazı tarafından eklenen birlikte kullanılabilirlik etki alanı hakkında daha fazla bilgi için, Karma Yapılandırma sihirbazında "Etki Alanları" girdisi'ne bakın.
Yine de yardım mı gerekiyor? Microsoft Community veya Exchange TechNet forumlarına gidin.