Outlook veya OWA'da ortak klasörler genişlet Outlook ekleneme

Belirtiler

Microsoft Outlook'de, ortak klasör üzerinde yeterli izinlere sahip bir kullanıcı ortak klasör ağacını genişletmeyi çalışırsa, aşağıdaki hata iletisi görüntülenir:

Klasör genişletildi. başarısız Exchange oldu.

Diğer Web üzerinde Outlook, kullanıcı ortak klasörü Sık Kullanılanlar'a eklemeyi deniyorsa "ortak klasör ekleme" penceresi görünmez. Buna ek olarak, F12tanılama araçlarını kullanarak GetFolder isteğine bakarsanız, yanıt metninde aşağıdaki hata iletisini alabilirsiniz:

"Posta kutusuna sahip olarak erişil olmalı. Sahip: ortak klasör posta kutusu guid; Kullanıcıya erişme: Kullanıcı ExchangelegacyDN"

Not

Microsoft, lisanslı bir kullanıcının varsayılan izinler üzerinden klasöre erişmesine izin vermeden, kimliğe bürünme yoluyla ortak klasör bilgilerine erişim sağlayan üçüncü taraf çözümlerini desteklemez.

Neden

Bu sorun, kullanıcının EffectiveDefaultPublicFolderMailbox özelliğinde Tam Erişim gibi açık izinlere sahip olmasıyla ortaya çıkar.

Bu koşulu doğrulamak için aşağıdaki cmdlet'leri çalıştırın:

Get-Mailbox <mailbox name of the affected user> | FL *public*
Get-MailboxPermission <EffectiveDefaultPublicFolderMailbox name>

Örneğin:

İzin denetleme ekran görüntüsü.

Çözüm

Bu sorunu çözmek için Remove-MailboxPermission cmdlet'ini çalıştırarak EffectiveDefaultPublicFolderMailbox özelliğinin açık izinlerini kaldırın:

Remove-MailboxPermission pfmbx1 -User exo1 -AccessRights FullAccess

Ardından, bu açık izinlerin kaldırılmış olduğunu doğrulamak için Get-MailboxPermission cmdlet'ini çalıştırın:

Get-MailboxPermission pfmbx1