Ortak klasör geçişi sırasında büyük öğeler atlanır

Belirtiler

Şirket içi Microsoft Exchange Server'tan Exchange Online ortak klasör geçişini çalıştırsanız, geçiş sırasında bir veya birden çok öğenin atlanmış olduğunu fark edin çünkü bunlar büyük öğeler olarak işaretlenmiştir. Geçiş raporu, aşağıdakine benzer bir "Büyük öğe yeniden fotokopisi başarısız oldu" bilgi iletisi görüntüler:

[ ] Büyük öğe yeniden yüklenemedi: <ServerName> Öğe ([len=70, data=000000001A447390AA6611 CD9BC800AA002FC45A0900C1F54ED028C6E54FBFB688ACA28186DB00012A862020000C1F54ED028C6E54FBFB688ACA28186DB00012A8638D70000]) MessageClass:"IPM. Gönderi", Boyut: (16,63 MB (17,436,461 bayt)), Klasör: ([len=46, data=000000001A447390AA6611CD9BC800AA002FC45A0300C1F54ED028C6E54FBFB688ACA28186DB00012A862020000])

Bu örnekte, geçiş sırasında büyük olarak işaretlenen ve atlanan öğenin boyutu 16,63 MB'tır.

Neden

Bu sorun, aşağıdaki koşullardan herhangi biri veya her ikisi de doğru olduğundan oluşur:

  • Şirket içinde yer alan tek tek ortak klasörlerin Exchange Server değeri, atlanan MaxItemSize   öğenin boyutundan küçük olur.
  • Ortak klasör posta MaxReceiveSize kutuları Exchange Online parametrenin değeri atlanan öğenin boyutundan küçük olur. 

Çözüm

Birden çok öğe atlandısa, PowerShell'de aşağıdakiler gibi komutları çalıştırarak bunların Exchange Online bulabilirsiniz:

$pf = Get-PublicFolderMailboxMigrationRequest | Get-PublicFolderMailboxMigrationRequestStatistics -IncludeReport  
$pf.Report.LargeItems | Select-Object *,@{ Name="MessageSizeInMB"; Expression={ [Math]::Round(($_.MessageSize / 1MB), 2) } } |FT DateReceived, Subject, MessageSizeInMB  

Ardından, şirket içinde ve şirket içi Exchange Online için Exchange Server sınırları kontrol edin. Atlanan en büyük öğenin boyutunu kabul etmek için, uygun olan sınırları artırabilirsiniz.

Exchange Online'ta ortak klasör posta kutularındaki geçerli öğe Exchange Online

  1. Bağlan'Exchange Online PowerShell'e Exchange Online.

  2. Geçerli sınırı belirlemek için aşağıdaki cmdlet'i çalıştırın:

    Get-Mailbox -PublicFolder | FT Identity, MaxReceiveSize
    
  3. Geçerli sınıra atlanan büyük öğelerin boyutunu karşılaştırın. 

    Varsayılan olarak, bir ortak klasör posta kutularına gönder veya alınan öğelerin (veya parametrelerin değeri) en Exchange Online MaxReceiveSize    MaxSendSize boyutu 35 MB'tır. Bu sınır, aşağıdaki cmdlet'i çalıştırarak en çok 150 MB'ye kadar artırılabilir:

    Set-Mailbox -PublicFolder <Mailbox1> -MaxReceiveSize 150MB
    

    Notlar:

    • Atlanan en büyük öğenin boyutu geçerli sınırdan büyük ama 150 MB'den küçükse, öğenin boyutunu kabul etmek için geçerli sınırı daha büyük bir değere artırabilirsiniz.
    • Atlanan büyük öğelerin boyutu 150 MB'den büyükse, öğeler tasarım tarafından atlanır. Bu durumda, sorunu güvenle yoksayabilirsiniz.Bu atlama işlemi kabul edilebilir değilse, geçişi durdurabilirsiniz.

Şirket içinde tek tek ortak klasörler için geçerli Exchange Server denetleme

  1. Dış Exchange Kabuğu'nuniçinde, etkilenen ortak klasörde ayarlanmış olan parametrenin değerini belirlemek için aşağıdaki cmdlet'i  MaxItemSize çalıştırın:

    Get-PublicFolder <\PF1> |FT Identity, MaxItemSize
    

    Not: Bu cmdlet'te, <\PF1> etkilenen ortak klasörün yolunu veya kimliğini değiştirin.

    Parametre için değer kümesi olan bir ortak klasörün kimliğini belirlemek için, Yönetim Kabuğu'Exchange  MaxItemSize   çalıştırın: 

    Get-PublicFolder \ -Recurse | where {$_.MaxItemSize -ne $null}| FT Identity, MaxItemSize
    
  2. Atlanan en büyük öğenin boyutu ortak klasörde ayarlanmış olan parametrenin değerinden daha büyükse, parametrenin değerini artırmak için Exchange Yönetim  MaxItemSize   Kabuğu'ta aşağıdaki cmdlet'i çalıştırın:

    Set-PublicFolder <\PF1> – MaxItemSize Unlimited
    

    Not: Bu cmdlet'<\PF1> etkilenen ortak klasörün yolu veya kimliğiyle değiştirin.

Artmlı eşitlemeyi sürdür

Geçişin devam etmesi için, ortak klasör posta kutusu geçiş isteğinde bir sonraki Exchange Online artımlı eşitlemeyi bekleyin. Eşitleme sırasında, büyük öğeler kopyalanır.

Alternatif olarak, ortak klasör geçiş isteğini devamlayarak artımlı eşitlemeyi zorlamak için Exchange Online PowerShell'de aşağıdaki cmdlet'leri çalıştırabilirsiniz:

Get-PublicFolderMailboxMigrationRequest | where {$_.TargetMailbox -eq "<Mailbox1>"} | Resume-PublicFolderMailboxMigrationRequest

Not: Bu cmdlet'te, <Mailbox1> geçirilen ortak klasör posta kutusunun kimliğiyle değiştirin.

Ardından, ortak klasör geçiş toplu işlemini yeniden başlatın:

Stop-MigrationBatch PublicFolderMigration
Start-MigrationBatch PublicFolderMigration

Daha fazla bilgi

Öğeler büyük olarak işaretlenir ve ortak klasör geçişi sırasında atlanırsa, "MapiExceptionMaxSubmissionExceed" hata türü "MapiExceptionMaxSubmissionExceed" ile "MapiExceptionPermanentImportFailure" kaydedilir. Bu hata türü, geçiş sırasında Exchange yönetim merkezinin Geçiş bölmesinde görüntülenmeyebilirsiniz veya geçiş raporunda listeleniyor olabilir. Bununla birlikte, aşağıdaki adımları kullanarak bulabilirsiniz:

  1. Ortak klasör posta kutusu geçiş Exchange Online istatistiklerinde listelenen tüm hataları almak için PowerShell'de aşağıdaki cmdlet'i çalıştırın: 

    $pf_stats = Get-PublicFolderMailboxMigrationRequest | where {$_.TargetMailbox -eq "<Mailbox1>"} | Get-PublicFolderMailboxMigrationRequestStatistics -IncludeReport 
    $pf_stats.Report.Failures | group failuretype | ft -a   
    

    Not: Bu cmdlet'te, <Mailbox1> etkilenen ortak klasör posta kutusunun kimliğiyle değiştirin.

  2. MapiExceptionPermanentImportFailure hata türünü bulmak için aşağıdaki cmdlet'i çalıştırın ve ilişkili hata iletisini kontrol edin:

    $pf_stats.Report.Failures | where {$_.FailureType -eq "MapiExceptionPermanentImportFailure"} | select -last 1
    

    Çıkış listesinde genellikle MapiExceptionPermanentImportFailure en son hatadır. 

    İletiyle ilişkilendirilmiş hata iletisi aşağıdakine benzer: 

    İleti : MapiExceptionPermanentImportFailure: Veri içeri aktarma başarısız oldu (hr=0x80004005, ec=0)
                         --> Depolamak istediğiniz bir öğede yapılan değişiklikler kaydediyebilirsiniz. --> MapiExceptionMaxSubmissionExceed: Değişiklikler kaydedemiyor. (hr=0x80004005, ec=1242)

  3. Hatanın Bulucu Kimliği (Acı) yığınında, aşağıdaki Asılar durumundan birinin değerlerini kontrol edin:

    57370, 32794, 53274, 40986, 45098, 61482, 59176, 34600, 42114, 58498

    Bu Alık, Alı 59176 için aşağıdaki örnekte gösterildiği gibi, bunların sonuna "Limitation" anahtar sözcüğünü eklemış olabilir:

    Ayla: 59176 dwParam: 0x800000    Msg: Limitation

    Bu örnek, boyutu 16,63 MB olan ve geçiş sırasında atlanan öğe için MapiExceptionPermanentImportFailure hata türünde belirtilen değerdir.

    Şirket içi klasördeki tek tek ortak klasördeki parametre Exchange Server değer kümesi 0x800000 değerdir  MaxItemSize   (buna eşittir 8 MB). Bununla birlikte, bu değer 16,63 MB'den küçüktür. Tek tek şirket içi ortak klasörler için bu ayar nedeniyle, Exchange Online Posta Kutusu Çoğaltma Hizmeti (MRS) aynı geçiş öğesi boyut sınırını zorunlu klar ve boyutu 16,63 MB olan öğeyi atlar.

    Not: Görüntülenen boyutun (örneğin, 0x800000) MB olarak eşdeğerini belirlemek için, aşağıdaki ekran görüntüsünde gösterildiği gibi boyutu 1 MB'ye bölün:

    1 MB'ye bölünen sınırlama değerinin ekran görüntüsü.