Ortak klasör geçişine EndpointNotFoundTransientException hatası

Belirtiler

Microsoft Exchange Server'tan Exchange Online'e ortak klasör geçiş toplu işlemini çalıştırdığınızda, "EndpointNotFoundTransientException" hatasıyla karşılaştınız ve aşağıdaki hata iletilerini alısınız:

  • Sizi dinleyen hiçbir uç nokta https://mail.<Domain Name>.com/EWS/mrsproxy.svc iletiyi kabul etmiyordu.
  • Uzak sunucu bir hata döndürür: (404) Bulunamadı.

"EndpointNotFoundTransientException" hata iletisi örneği.

EndpointNotFoundTransientException için ayrıntılı hataların ekran görüntüsü.

Bununla birlikte, aşağıdaki cmdlet'i çalıştırarak ortak klasör uç noktasının geçiş sunucusu kullanılabilirliğini sınarsanız, sonuç başarılı olur:

Test-MigrationServerAvailability -Endpoint <PublicFolderMigrationEndPoint>

Cmdlet ve çıktı örneği.

Uç nokta için cmdlet ve çıktının ekran görüntüsü.

Neden

Bu sorun, geçiş toplu işlemini oluşturmak yerine geçiş toplu işlemini Exchange Online SourcePFPrimaryMailboxGuid parametresini Exchange Server.

Geçiş toplu işleminin yanlış kullandığını doğrulamak SourcePFPrimaryMailboxGuid için, cmdlet'leri aşağıdaki adımlarda çalıştırabilirsiniz:

  1. Bağlan PowerShell Exchange Online' a .

  2. Aşağıdaki SourcePFPrimaryMailboxGuid cmdlet'i çalıştırarak geçiş toplu işleminde belirtilen parametrenin değerini tanımlayabilirsiniz:

    (Get-MigrationBatch | ?{$_.MigrationType.ToString() -eq "PublicFolder"}).SourcePFPrimaryMailboxGuid
    

    Cmdlet ve çıktı örneği.

    GUID için bir cmdlet örneği ekran görüntüsü.

  3. Aşağıdaki cmdlet'i çalıştırarak sağlanan GUID Exchange Online doğrula:

    Get-Mailbox -PublicFolder <GUID>
    

    Not: <GUID> 2. adımda cmdlet'den edinen değerle değiştirin.

    Ortak klasör posta kutusu posta kutusu posta kutusundan Exchange Online şekilde listeleniyorsa, geçiş toplu işleminin doğru biçimde oluşturulmadı anlamına gelen işlemi doğru bir şekilde doğru şekilde çalıştırabilirsiniz. Cmdlet ve çıktı örneği.

    GUID olarak doğru olup Exchange Online ekran görüntüsü.

Çözüm

Bu sorunu çözmek için, şirket içi sunucuda ortak klasör posta kutusunun belirterek geçiş SourcePFPrimaryMailboxGuid toplu Exchange yeniden oluşturun. Geçiş toplu işlemini şu şekilde yeniden oluşturabilirsiniz:

  1. Bir Exchange sunucuda Dış Yönetim Exchange'i açın.

  2. Ortak klasör posta kutusu GUID'lerini Exchange Server cmdlet'i çalıştırarak şunları yapın:

    (Get-OrganizationConfig).RootPublicFolderMailbox.HierarchyMailboxGuid.GUID
    

    Cmdlet ve çıktı örneği.

    Şirket içi posta guid'lerini alma Exchange ekran görüntüsü.

  3. Geçiş toplu işlemini aşağıdaki adımları Exchange Online yeniden oluşturun:

    1. Bağlan PowerShell Exchange Online' a .

    2. Aşağıdaki cmdlet'i çalıştırarak var olan ortak klasör geçiş toplu işlemini kaldırın:

      Get-MigrationBatch | ?{$_.MigrationType.ToString() -eq "PublicFolder"} | Remove-MigrationBatch
      

      Not: Geçiş toplu işleminin kaldırılması 10 - 15 dakika arasında sürebilir.

    3. Aşağıdaki cmdlet'i çalıştırarak geçiş toplu işleminin kaldırıldı olduğundan emin olun:

      Get-MigrationBatch | ?{$_.MigrationType.ToString() -eq "PublicFolder"}
      
    4. Aşağıdaki cmdlet'i çalıştırarak yeni bir ortak klasör geçiş toplu işlemi oluşturun:

      [byte[]]$bytes = Get-Content -Encoding Byte <folder_mapping.csv>
      New-MigrationBatch -Name PublicFolderMigration -CSVData $bytes -SourceEndpoint <PublicFolderMigrationEndPoint> -SourcePfPrimaryMailboxGuid <GUID from step 2> -AutoStart -NotificationEmails <email addresses for migration notifications>
      

Ortak klasör geçişleri hakkında daha fazla bilgi için bkz. Ortak klasörleri veya Exchange Server geçirmek için toplu geçişi Exchange Online.