Ortak klasör izin sorunlarını tanılama ve düzeltme

Belirtiler

Genel Exchange Online bir ortak klasörde öğeleri veya alt klasörleri oluşturma veya silme gibi belirli görevleri gerçekleştiramazsınız. Ayrıca, bunun izinle ilgili bir sorun olduğunu belirten bir hata iletisi de alabilirsiniz.

Neden

Bu sorun genellikle ortak klasör hiyerarşisi çoğaltması tamamlanmay olduğundan veya sorun olduğundan oluşur.

Sorun giderme adımları

  1. Kullanıcıya atanan ortak klasör posta kutusunu doğrulayın. Bunu yapmak için aşağıdaki komutu çalıştırın (örneğin):

    Get-Mailbox -Identity User1 | Format-List *public*
    
  2. Ortak klasör izninin kullanıcıya atanan ortak klasör posta kutusuna çoğaltılmış olduğunu doğrulayın. Bunu yapmak için şu adımları uygulayın:

    a) önce birincil hiyerarşi ortak klasör posta kutusu izinlerini denetleyin. Bunu yapmak için aşağıdaki cmdlet'i çalıştırın (örneğin):

    Get-PublicFolderClientPermission \puf1 -User User1 -Mailbox (Get-Mailbox -PublicFolder | ?{$_.IsRootPublicFolderMailbox -eq "True"}).Name
    

    b) 1. adımda sahip olduğunuz ortak klasör posta kutusunda kullanıcının klasör izinlerini denetleyin (örneğin).

    Get-PublicFolderClientPermission "\puf1" -User1 -Mailbox pubmbx1
    

    Bu cmdlet, aşağıdaki çıkışı verir:

    There is no existing permission entry found for user: user1.
        + CategoryInfo          : NotSpecified: (:) [Get-PublicFolderClientPermission], UserNotFoundInPermissionEntryExcep
       tion
        + FullyQualifiedErrorId : [Server=<*ServerName*>,RequestId=<*RequestId*>,TimeStamp=3/19/2020
        5:22:40 AM] [FailureCategory=Cmdlet-UserNotFoundInPermissionEntryException] 91D3F338,Microsoft.Exchange.Managemen
      t.StoreTasks.GetPublicFolderClientPermission
    + PSComputerName        : outlook.office365.com
    

    Çıkışta izinlerin kullanıcıya atanmış olan ortak klasör posta kutusuna henüz çoğaltılmış olmadığını gösterir. Bazı durumlarda izin görünebilir, ancak 2b. adımda döndürülen izinden farklı olabilir.

Çözüm

Bu sorunu çözmek için, aşağıdaki cmdlet'i çalıştırarak (örneğin):

Update-PublicFolderMailbox pubmbx1 -InvokeSynchronizer

Ardından, cmdlet'i yinelayarak izinleri yeniden doğrulayın:

Get-PublicFolderClientPermission \puf1 -User User1 -Mailbox pubmbx1

Not

İzin değişikliğinin göstermek birkaç dakika sürebilir.

Ek Bilgi

İzinler yine eşitlenmezse veya hiyerarşi eşitlemesini zorlarken hatayla uyarsanız, hiyerarşi eşitleme günlüklerini almak için şu adımları izleyin:

  1. Ortak klasör posta kutuları arasındaki hiyerarşiyi karşılaştırın:

    $P=Get-PublicFolderMailboxDiagnostics <Primary_pfmailboxname> -IncludeHierarchyInfo
    $S= Get-PublicFolderMailboxDiagnostics <pfmailboxname_notreceiving_hierarchy> -IncludeHierarchyInfo
    
  2. Her iki posta kutusundan "HiyerarşiBilgileri" çıkışını karşılaştırın:

    $p.HierarchyInfo
    $s.HierarchyInfo
    
  3. Hiyerarşi bilgisinin aynı olmadığını belirlerse, son eşitlemenin saati görüntülemek için aşağıdaki komutu çalıştırın:

    $s.SyncInfo.LastAttemptedSyncTime.LocalTime
    

    Bu komut, eşitlemenin en son ne zaman başarısız olduğunu gösterir. Verim değeri eşitlemenin hiçbir zaman başarısız olduğunu gösterir.

    $s.SyncInfo.LastFailedSyncTime.LocalTime
    

    Aşağıdaki komut, son eşitleme hatasından ayrıntılı bir hata iletisi sağlar. Boş bir çıkış, eşitlemenin hiçbir zaman başarısız olduğunu gösterir:

    $s.SyncInfo.LastSyncFailure
    

    YardımcıBilgiler ve HiyerarşiBilgileri blokları gibi diğer değerleri de keşfedebilirsiniz.

Microsoft Desteği'ne başvurun, raporu XML biçiminde dışarı aktarın ve ardından Destek temsilcisine gönderin. Raporu dışarı aktaracak şekilde aşağıdaki komutu çalıştırın (örneğin):

Get-PublicFolderMailboxDiagnostics <pf mailbox failing to sync> -IncludeHierarchyInfo |Export-Clixml epf.xml