Ortak klasör izin sorunlarını tanılama ve düzeltme

Belirtiler

Exchange Online'da, ortak klasörde öğe veya alt klasör oluşturma veya silme gibi belirli görevleri gerçekleştiremezsiniz. Ayrıca, bunun izinle ilgili bir sorun olduğunu belirten bir hata iletisi alabilirsiniz.

Neden

Bu sorun genellikle ortak klasör hiyerarşisi çoğaltması tamamlanmadığından veya sorun yaşadığından oluşur.

Sorun giderme adımları

  1. Kullanıcıya atanan ortak klasör posta kutusunu doğrulayın. Bunu yapmak için aşağıdaki komutu çalıştırın (örneğin):

    Get-Mailbox -Identity User1 | Format-List *public*
    
  2. Ortak klasör izninin kullanıcıya atanan ortak klasör posta kutusuna çoğaltıldığını doğrulayın. Bunu yapmak için şu adımları uygulayın:

    a) Önce birincil hiyerarşi ortak klasör posta kutusu üzerindeki izinleri denetleyin. Bunu yapmak için aşağıdaki cmdlet'i çalıştırın (örneğin):

    Get-PublicFolderClientPermission \puf1 -User User1 -Mailbox (Get-Mailbox -PublicFolder | ?{$_.IsRootPublicFolderMailbox -eq "True"}).Name
    

    b) 1. adımdan (örneğin) edindiğiniz ortak klasör posta kutusunda kullanıcının klasör üzerindeki izinlerini denetleyin.

    Get-PublicFolderClientPermission "\puf1" -User User1 -Mailbox pubmbx1
    

    Bu cmdlet aşağıdaki çıkışı döndürür:

    There is no existing permission entry found for user: user1.
        + CategoryInfo          : NotSpecified: (:) [Get-PublicFolderClientPermission], UserNotFoundInPermissionEntryExcep
       tion
        + FullyQualifiedErrorId : [Server=<*ServerName*>,RequestId=<*RequestId*>,TimeStamp=3/19/2020
        5:22:40 AM] [FailureCategory=Cmdlet-UserNotFoundInPermissionEntryException] 91D3F338,Microsoft.Exchange.Managemen
      t.StoreTasks.GetPublicFolderClientPermission
    + PSComputerName        : outlook.office365.com
    

    Çıkış, izinlerin kullanıcıya atanan ortak klasör posta kutusuna henüz çoğaltılamadığına işaret eder. Bazı durumlarda izin görüntülenebilir, ancak 2b. adımda döndürülen izinden farklı olacaktır.

Çözüm

Bu sorunu düzeltmek için, aşağıdaki cmdlet'i (örneğin) çalıştırarak kullanıcıda atanan ortak klasör posta kutusuna izinleri el ile çoğaltın:

Update-PublicFolderMailbox pubmbx1 -InvokeSynchronizer

Ardından cmdlet'ini yineleyerek izinleri yeniden doğrulayın:

Get-PublicFolderClientPermission \puf1 -User User1 -Mailbox pubmbx1

Not

İzin değişikliğinin gösterilmesi birkaç dakika sürebilir.

Ek Bilgi

İzinler hala eşitlenmemişse veya hiyerarşi eşitlemesini zorladığınızda bir hatayla karşılıyorsanız, hiyerarşi eşitleme günlüklerini almak için şu adımları izleyin:

  1. Ortak klasör posta kutuları arasındaki hiyerarşiyi karşılaştırın:

    $P=Get-PublicFolderMailboxDiagnostics <Primary_pfmailboxname> -IncludeHierarchyInfo
    $S= Get-PublicFolderMailboxDiagnostics <pfmailboxname_notreceiving_hierarchy> -IncludeHierarchyInfo
    
  2. Her iki posta kutusundan "HierarchyInfo" çıktısını karşılaştırın:

    $p.HierarchyInfo
    $s.HierarchyInfo
    
  3. Hiyerarşi bilgilerinin aynı olmadığını belirlerseniz, son eşitlemenin zamanını görüntülemek için aşağıdaki komutu çalıştırın:

    $s.SyncInfo.LastAttemptedSyncTime.LocalTime
    

    Bu komut, eşitlemenin son başarısız olduğu zamanı gösterir. Anlamsız bir değer eşitlemenin hiçbir zaman başarısız olmadığını gösterir.

    $s.SyncInfo.LastFailedSyncTime.LocalTime
    

    Aşağıdaki komut, son eşitleme hatasından ayrıntılı bir hata iletisi sağlar. Boş çıkış, eşitlemenin hiçbir zaman başarısız olmadığını gösterir:

    $s.SyncInfo.LastSyncFailure
    

    AssistantInfo ve HierarchyInfo blokları gibi diğer değerleri de keşfedebilirsiniz.

Microsoft Desteği başvurmanız gerekiyorsa raporu XML biçiminde dışarı aktarın ve destek aracısına gönderin. Raporu dışarı aktarmak için aşağıdaki komutu çalıştırın (örneğin):

Get-PublicFolderMailboxDiagnostics <pf mailbox failing to sync> -IncludeHierarchyInfo |Export-Clixml epf.xml