Karma dağıtımdaki kullanıcılar Exchange Online 'da oluşturulmuş paylaşılan bir posta kutusuna erişemez

Not

Microsoft Exchange Server 2010 ' de Exchange Yönetim konsoluna dahil olan karma Yapılandırma Sihirbazı artık desteklenmemektedir. Bu nedenle, eski karma Yapılandırma sihirbazını kullanamazsınız. Bunun yerine, Office 365 karma Yapılandırma Sihirbazı 'nı kullanın. Daha fazla bilgi için, Exchange 2010 Için Office 365 karma Yapılandırma Sihirbazı'na bakın.

Sorun

Aşağıdaki senaryoyu inceleyin:

  • Office 365 ' te şirket içi Microsoft Exchange Server ve Microsoft Exchange Online 'ın karma dağıtımınız vardır.
  • Paylaşılan posta kutusunu doğrudan Exchange Online 'da oluşturursunuz.
  • Bir veya daha fazla kullanıcıya tam erişim izinleri atarsınız.

Bu senaryoda, aşağıdaki sorunlardan bir veya birkaçı ile karşılaşabilirsiniz:

  • Kullanıcılar Outlook 'ta paylaşılan posta kutusunu açamaz.
  • Kullanıcılar paylaşılan posta kutusunun serbest/meşgul bilgilerini görüntüleyemez.
  • Kullanıcılar paylaşılan posta kutusuna posta gönderemeyecektir.

Neden

Paylaşılan posta kutusu Exchange Online yönetim araçları kullanılarak oluşturulursa, bu sorunlar oluşabilir. Bu durumda, şirket içi Exchange ortamında paylaşılan posta kutusu için başvurulacak hiçbir nesne yoktur. Bu nedenle, bu SMTP adresi için tüm sorgular başarısız olur.

Çözüm

Şirket içi ortamda bir uzak posta kutusu oluşturun ve ardından posta kutusunu Exchange Online 'a taşıyın. Bunu yapmak için şu adımları uygulayın.

Not

Exchange Server 2013 (toplu güncelleştirme 21 veya sonraki sürümleri) veya Exchange Server 2016 (toplu güncelleştirme 10 veya sonraki sürümleri) kullanan şirket içi ortamlarda, aşağıdaki adımları atlayabilir ve bunun yerine Alternatif yöntem bölümündeki adımları izleyebilirsiniz.

  1. Exchange Online 'da Exchange Yönetim merkezini kullanarak paylaşılan posta kutusunu normal bir posta kutusuna dönüştürün. Bunu yapmak için şu adımları uygulayın:

    1. Exchange Yönetim merkezini Exchange Online 'da açın.
    2. Alıcılar'ı ve ardından paylaşılan'ı tıklatın.
    3. Paylaşılan posta kutusunu seçin ve sonra Dönüştür'e tıklayın.
    4. Uyarı sayfasında, paylaşılan posta kutusunu dönüştürmek için Evet 'i seçin.
  2. New-RemoteMailboxExchange Yönetim Kabuğu 'nda cmdlet 'i kullanarak bulut posta kutusu için şirket içi bir nesne oluşturun.

    Not

    Bu nesne, bulut posta kutusuyla aynı ada, diğer ada ve Kullanıcı asıl adına (UPN) sahip olmalıdır.

    Daha fazla bilgi için bkz.

  3. Adım 2 ' de oluşturduğunuz yeni şirket içi nesnesinin ExchangeGuid özelliğini bulut posta kutusuyla eşleşecek şekilde ayarlayın. Bunu yapmak için şu adımları uygulayın:

    1. Windows PowerShell 'in uzak oturumunu kullanarak Exchange Online 'a bağlanın.

      Bunu yapma hakkında daha fazla bilgi için bkz: Exchange Online PowerShell 'e bağlanın.

    2. Get-MailboxBulut posta kutusunun özelliğinin değerini almak için cmdlet 'i kullanın ExchangeGuid . Örneğin, aşağıdaki komutu çalıştırabilirsiniz:

      Get-Mailbox <MailboxName> | FL ExchangeGuid  
      

      Daha fazla bilgi için bkz .

    3. Şirket içi Exchange sunucusunda Exchange Yönetim Kabuğu 'nu açın.

    4. Set-RemoteMailbox ExchangeGuid Şirket içi nesnesindeki özelliğin değerini adım 3b'de aldığınız değere ayarlamak için cmdlet 'i kullanın. Örneğin, aşağıdaki komutu çalıştırabilirsiniz:

      Set-RemoteMailbox <MailboxName> -ExchangeGuid <GUID>
      

      Daha fazla bilgi için set-RemoteMailboxkonusuna bakın.

  4. Dizin eşitlemesinin gerçekleşmesini bekleyin. Veya dizin eşitlemeyi zorunlu kılın.

    Daha fazla bilgi için bkz.

  5. Office 365 kullanıcı nesnesinin Active Directory Ile eşitlenmiş gibi görüntülendiğinden emin olun.

  6. Posta kutusunu Exchange Online 'dan şirket içi ortama taşıyın.

    Daha fazla bilgi için, karma dağıtımlardaki şirket içi ve Exchange Online kuruluşları arasında posta kutularını taşımakonusuna bakın.

  7. Set-MailboxExchange Yönetim Kabuğu 'nda cmdlet 'i kullanarak posta kutusunu paylaşılan posta kutusuna dönüştürün. Örneğin, aşağıdaki komutu çalıştırabilirsiniz:

    Set-Mailbox <MailboxName> -Type Shared
    

    Daha fazla bilgi için Set-Mailbox.

  8. Posta kutusunu şirket içi ortamdan Exchange Online 'a taşıyın.

    Daha fazla bilgi için, karma dağıtımlardaki şirket içi ve Exchange Online kuruluşları arasında posta kutularını taşımakonusuna bakın.

Alternatif Yöntem

Exchange Server 2013 (toplu güncelleştirme 21 veya sonraki sürümleri) veya Exchange Server 2016 (toplu güncelleştirme 10 veya sonraki sürümleri) kullanan şirket içi ortamlarda:

New-RemoteMailboxExchange Yönetim Kabuğu 'nda cmdlet 'i kullanarak bulut posta kutusu için şirket içi bir nesne oluşturun.

Not

Bu nesne, bulut posta kutusuyla aynı ada, diğer ada ve Kullanıcı asıl adına (UPN) sahip olmalıdır. Daha fazla bilgi için bkz.

Örneğin, aşağıdaki komutu çalıştırabilirsiniz:

New-Remotemailbox sharedmailbox@contoso.com -Remoteroutingaddress sharedmailbox@contoso.mail.onmicrosoft.com -Shared

Daha fazla bilgi

Uzak paylaşılan posta kutuları hakkında daha fazla bilgi için, Şirket Içi Exchange ortamında uzak paylaşılan posta kutusu oluşturma veya değiştirme

Yine de yardım mı gerekiyor? Microsoft Topluluğu 'Na veya Exchange TechNet forumlarınagidin.