Bir sorgu, form veya rapor çalıştırdığınızda "Parametre Değeri girin" iletişim kutusu görüntülenir

Not

Office 365 ProPlus, Microsoft 365 Kurumsal Uygulamaları olarak yeniden adlandırılıyor. Bu değişiklik hakkında daha fazla bilgi için, bu blog yazısını okuyun.

Orta: Temel makro, kodlama ve birlikte çalışabilirlik becerileri gerektirir.

Bu makale yalnızca bir Microsoft Access veritabanı (.mdb) için geçerlidir.

Belirtiler

Bir sorguyu, formu veya raporu çalıştırmayı denediğinizde, Parametre Değeri Girin iletişim kutusu beklenmedik bir şekilde görünebilir.

Neden

Bu davranış, bir sorgu, form veya rapor daki bir alan, ölçüt, ifade veya denetim Access'in bulamadığı bir ada başvururğunda oluşur. Örneğin, bir ad yanlış yazılmış olabilir veya bu kapsamda bir alan kullanılamayabilir.

Çözüm

Bu davranışı gidermek için, geçerli bir alan adı için başvuru yeniden adlandırın. Başvurunun nerede olduğunu bilmiyorsanız, Parametre Değeri girin iletişim kutusunda listelenen nesne için Veritabanı Belgeleyicisini çalıştırın ve ardından bilgileri bir metin dosyasına girin. Bunu yapmak için aşağıdaki adımları izleyin:

  • Access 2002 ve 2003 kullanıyorsanız, aşağıdaki adımları izleyin:
    1. Araçlar menüsünde Çözümle'yiişaret edin ve ardından Documenter'ıtıklatın.

    2. Aradığınız veritabanı nesnesinin türüne karşılık gelen sekmeyi tıklatın ve ardından sorgunun onay kutusunu, formu veya çalıştırmayı denediğiniz raporu seçmek için tıklatın.

      Not Nesne bir form veya raporsa, seçim listenizdeki tüm kaynak sorgularını ve alt formları veya alt raporları ekleyin.

    3. Yazdırmak istediğiniz seçili nesnenin hangi özelliğini belirtmek için Seçenekler'i tıklatın ve ardından Tamam'ıtıklatın.

    4. Documenter iletişim kutusunu kapatmak için Tamam'ı tıklatın.

    5. Dosya menüsünde Dışa Aktar'ıtıklatın.

    6. Tür Olarak Kaydet listesinde Metin Dosyaları'nıtıklatın ve ardından bilgilerin geri kalanını gerektiği gibi tamamlayın.

    7. Dışa aktarılan dosyayı Microsoft Word'de açın ve ardından Parametre Değeri girin iletişim kutusunda istenen parametreyi arayın.

  • Access 2007 veya daha sonraki bir sürümü kullanıyorsanız, aşağıdaki adımları izleyin:
    1. Veritabanı Araçları sekmesinde, Çözümle grubunda Veritabanı Belgeleyici'yi tıklatın.

    2. Aradığınız veritabanı nesnesinin türüne karşılık gelen sekmeyi tıklatın ve ardından sorgunun onay kutusunu, formu veya çalıştırmayı denediğiniz raporu seçmek için tıklatın.

      Not Nesne bir form veya raporsa, seçim listenizdeki tüm kaynak sorgularını ve alt formları veya alt raporları ekleyin.

    3. Yazdırmak istediğiniz seçili nesnenin hangi özelliğini belirtmek için Seçenekler'i tıklatın ve ardından Tamam'ıtıklatın.

    4. Documenter iletişim kutusunu kapatmak için Tamam'ı tıklatın.

    5. Veri grubunda Metin Dosyası'nıtıklatın ve ardından bilgilerin geri kalanını gerektiği gibi tamamlayın.

    6. Dışa aktarılan dosyayı Microsoft Word'de açın ve ardından Parametre Değeri girin iletişim kutusunda istenen parametreyi arayın.

Veritabanı Belgeleyicisini çalıştıramıyorsanız, eksik bir başvuru olup olmadığını denetleyin. Bu durumda en yaygın eksik başvuru Utility.mda içindir. Bu başvuruiçin aşağıdaki adımları izleyin:

  1. Veritabanı penceresinde, Nesneleraltındaki Modüller'i tıklatın.

    Not Veritabanı Araçları sekmesinde Access 2007 veya daha sonraki bir sürümü kullanıyorsanız, Visual Basic'itıklatın ve ardından adım 3'e gidin.

  2. Varolan herhangi bir modülü seçin ve ardından Tasarım'ı tıklatın veya yeni bir modül ekleyin. Bu Visual Basic Editor başlatacak.

  3. Araçlar menüsünde, Başvurular'ı tıklatın.

  4. Kullanılabilir Başvurular listesinde, adın önünde "MISSING: " olan herhangi bir başvuruarayın. Onay kutusunu temizlemek için tıklatın.

    NOT Utility.mda'ya başvurmanız gerekmiyorsa, adım 8'e geçin.

  5. Gözat'ı tıklatın.

  6. Tür listesinin Dosyalarında Eklentiler'i (*.mda) tıklatın.

  7. Utility.mda içeren klasöre göz atın, seçin ve sonra Aç'ı tıklatın. Varsayılan olarak, bu dosya C:\Program Files\Microsoft Office\Office\1033 klasöründedir.

  8. Tamam'a tıklayın.

  9. Hata Ayıklama menüsünde veritabanı adınıderle'i tıklatın.

  10. Dosya menüsünde Kapat ve Microsoft Access'e Dön'etıklayın.

Daha fazla bilgi

Access 2002 veya Access 2003'teki davranışı çoğaltma adımları

Dikkat

Bu örnekteki adımları izlerseniz, northwind.mdb örnek veritabanını değiştirirsiniz. Northwind.mdb dosyasını yedeklemek ve veritabanının bir kopyasında aşağıdaki adımları izlemek isteyebilirsiniz.

  1. Örnek veritabanı Northwind.mdb açın.
  2. Tasarım görünümündeSipariş Alt Toplamları sorgusunu açın.
  3. OrderID alanını OrderIDNumberolarak yeniden adlandırın.
  4. Sorguyu kapatın ve değişiklikleri kaydetmek için Evet'i tıklatın.
  5. Sipariş Subtotals sorgusunu çalıştırın.

Parametre Değerini Gir iletişim kutusunun göründüğünü unutmayın.