Access, Uygulamalar için Visual Basic başvurularını nasıl çözer?

Not

Office 365 ProPlus, Microsoft 365 Kurumsal Uygulamaları olarak yeniden adlandırılıyor. Bu değişiklik hakkında daha fazla bilgi için, bu blog yazısını okuyun.

Orijinal KB numarası:   824255

Not

Bu makale, bir Microsoft Access veritabanı (.mdb) ve bir Microsoft Access projesi (.adp) için geçerlidir. Uzman kodlama, birlikte çalışabilirlik ve çok kullanıcılı beceriler gerektirir.

Özet

Bu makalede, Microsoft Office Access 2007, Microsoft Office Access 2003, Microsoft Access 2002, Access 2000 veya Access 97'nin Microsoft Visual Basic for Applications (VBA) adresindeki başvuruları çözmek için gerçekleştirdiği görevler dizisi açıklanır.

Daha Fazla Bilgi

Önemli

Bu bölüm, yöntem veya görev, kayıt defterini nasıl değiştireceğinizi söyleyen adımlar içerir. Ancak, kayıt defterini yanlış değiştirirseniz ciddi sorunlar oluşabilir. Bu nedenle, bu adımları dikkatle izlediğinden emin olun. Daha fazla koruma için, değiştirmeden önce kayıt defterini yedekle. Ardından, bir sorun oluşursa kayıt defterini geri yükleyebilirsiniz. Kayıt defterini yedekleme ve geri yükleme hakkında daha fazla bilgi için, Makaleyi Microsoft Bilgi Bankası'nda görüntülemek için aşağıdaki makale numarasını tıklatın: 322756 Windows'da kayıt defterini yedekleme ve geri yükleme

Access'te, Visual Basic Düzenleyicisi'ni kullanarak şu anda seçilen VBA başvurularını görüntüleyebilirsiniz. Bunu yapmak için aşağıdaki adımları izleyin:

  1. Erişimi başlatın.

  2. Access veritabanını açın.

  3. Visual Basic Editor'ı açmak için ALT+F11 tuşuna basın.

  4. Visual Basic Editor penceresinde, Araçlar menüsünde Başvurular'ı tıklatın.

    Başvurular iletişim kutusunda, seçili başvuruları görebilirsiniz.

Not

Bir başvuru seçtiğinizde, başvuruyu kullanmak için yüklenmesi gereken dosyaya karşılık gelen bilgileri de görüntüleyebilirsiniz.

İlgili dosya bir tür kitaplığı, nesne kitaplığı veya denetim kitaplığı olabilir. Her başvuru için ilgili dosya, Başvurular iletişim kutusunda görünen bilgilere göre yüklenir. Ancak, dosya bulunmazsa, Access dosyayı bilgisayarınızdafarklı konumlarda arar.

Seçilen her VBA başvurusu için Access aşağıdaki görevleri gerçekleştirir:

  • Access, başvurulan dosyanın zaten yüklenip yüklenmediğini doğrular.

  • Access, RefLibPaths başvurulan dosya şu anda yüklenmiyorsa kayıt defteri anahtarının var olup olmadığını doğrular.

    Kayıt RefLibPaths defteri anahtarı varsa, Access başvuruyla aynı ada sahip adlandırılmış bir değeri arar. Eşleşme varsa, Access başvuruyu adlandırılmış değerde belirtilen yoldan yükler.

    Not

    Kayıt defteri anahtarını el ile kayıt defterine ekleyebilirsiniz RefLibPaths ve ardından, herhangi bir eklentinin veya kayıt defteri anahtarının altındaki kitaplıkların adlarını ve konumlarını RefLibPaths ekleyebilirsiniz. Bunu yapmak için aşağıdaki adımları izleyin:

    1. Başlat'ıtıklatın ve ardından Çalıştır'ıtıklatın.

    2. kutusunda regedit yazın ve ardından Tamam'ıtıklatın.

    3. Kayıt Defteri Düzenleyicisi penceresinde, aşağıdaki kayıt defteri anahtarını bulun:

      Erişim 2007:HKEY_LOCAL_MACHINE\Software\Microsoft\Office\12.0\Access

      Erişim 2003:HKEY_LOCAL_MACHINE\Software\Microsoft\Office\11.0\Access

      Erişim 2002:HKEY_LOCAL_MACHINE\Software\Microsoft\Office\10.0\Access

      Erişim 2000:HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Access

      Erişim 97:HKEY_LOCAL_MACHINE\Software\Microsoft\Office\8.0\Access

    4. Access kayıt defteri anahtarına sağ tıklayın, Yeni'yiişaret edin ve ardından Anahtar'ıtıklatın.

    5. Yeni oluşturulan anahtarı RefLibPaths adlandırın.

    6. RefLibPaths'itıklatın.

    7. Sağ bölmede herhangi bir yere sağ tıklayın ve ardından String değerinitıklatın.

    8. VBA başvurusuyla aynı adı kullanarak yeni oluşturulan String değerini adlandırın.

    9. Adım 8'de oluşturduğunuz String değerini sağ tıklatın ve sonra Değiştir'itıklatın.

    10. String'i Edit iletişim kutusunda, VBA'daki başvuruya karşılık gelecek şekilde yüklenmesi gereken dosyanın konumunu yazın.

      Kayıt defteri değeri adı dosya adı artı uzantısı olmalıdır. Konum (değer verileri) yol artı dosya adı olmalıdır. Örneğin, Northwind örnek veritabanına bir başvuru ayarlarsanız, aşağıdaki değerleri ekleyebilirsiniz:

      • Değer Adı: Northwind.mdb
      • Değer Verileri:C:\Program Files\Microsoft Office\Office11\Samples\Northwind.mdb
    11. Adları eklemek ve uygun eklentilerin veya uygun kitaplıkların konumlarını String değerleri olarak eklemek için adım 7'yi adım 10'a kadar yineleyin.

    12. Dosya menüsünde Çıkış'ıtıklatın.

  • Access, RefLibPaths kayıt defteri anahtarı yoksa veya doğru bir başvuru içermiyorsa, başvurulan dosyayı aramak için SearchPathAPI'yi kullanır. Aşağıdaki aramalar gerçekleştirilir.

    Arama Alanı Açıklama
    Uygulama Rehberi Msaccess.exe'nin yeri.
    Geçerli Dizin Dosya menüsünde Aç'ı tıklattığınızda gördüğünüz dizin.
    Sistem Dizini Windows klasöründe veya WINNT klasöründe bulunan Sistem klasörü ve System32 klasörü.
    Windir İşletim sistemi dosyalarının çalıştığı klasör. Bu genellikle Windows klasörü veya WINNT klasörüdür.
    PATH Çevre Değişkeni Bu sistem değişkeni, sistem tarafından doğrudan erişilebilen klasörlerin listesini içerir. Microsoft Windows NT 4.0: Denetim Masası'nda Sistem'içift tıklatın ve ardından Çevre sekmesini tıklatın. PATH değişkeni Sistem Değişkenleri listesindedir. Microsoft Windows 2000, Microsoft Windows XP ve Microsoft Windows Server 2003: Denetim Masası'nda, Sistem'içift tıklatın, Gelişmiş sekmesini tıklatın ve ardından Çevre Değişkenleri'nitıklatın. PATH, Sistem Değişkenleri listesindedir. Microsoft Windows Vista: Denetim Masası'nda "Sistem ve Bakım" öğesini açın. Sistem'etıklayın, Gelişmiş sistem ayarlarınıtıklatın, Gelişmiş sekmesini tıklatın ve ardından Çevre Değişkenleri'nitıklatın. PATH Sistem Değişkenleri listesinde
    Dosya Dizini .mdb dosyasını, .mde dosyasını, .adp dosyasını veya .ade dosyasını ve tüm alt klasörleri içeren klasör.

Not

RefLibPathsBaşvurmak istediğiniz dosya tabloda belirtilen dizinlerden herhangi birinde bulunuyorsa, access kayıt defteri anahtarını gerektirmez.

Access başvuruyu bulamıyorsa, projeyi derlediğinizde veya bir yordam çalıştırmaya çalıştığınızda aşağıdaki hata iletisini alırsınız:

Microsoft Office Access veritabanınız veya projeniz dosya adınaeksik veya bozuk bir başvuru içerir.
*Veritabanınızın veya projenizin düzgün çalıştığından emin olmak için bu başvurunuzu düzeltmeniz gerekir.

Not

Veritabanı açıkken, her bozuk başvuru için önceki hata iletisini bir kez alırsınız.

Örneğin, MyDatabase.mdb'yi ve MyDatabase.mdb'yi açarsanız, Microsoft Takvim Denetimi'ne ve Microsoft DAO kitaplığına bir başvuru eksikse, her eksik başvuru için bir tane olmak üzere iki hata iletisi alırsınız. Başvuruları düzeltmediğiniz, veritabanını kapatmadığınız ve veritabanını yeniden açmadığınız sürece hata iletilerini yeniden almazsınız. Başvuruları düzeltip veritabanını kaydederseniz, veritabanını bir sonraki açtığınızda hata iletilerini almazsınız.

BrokenReference özelliği

Access için Uygulama nesnesi, BrokenReference başvuruların bozulıp kırılmadığını belirten bir özelliğe sahiptir. Özelliği denetlemek için BrokenReference aşağıdaki adımları izleyin:

  1. Erişimi başlatın.

  2. Access veritabanını açın.

  3. Visual Basic Editor'ı açmak için ALT+F11 tuşuna basın.

  4. Hemen pencereyi açmak için CTRL+G tuşuna basın.

  5. Hemen penceresinde, aşağıdaki komutu yazın ve sonra ENTER tuşuna basın:

    ?Application.BrokenReference

    BrokenReferenceEksik başvurular varsa, Uygulama nesnesinin özelliğinin True döndürdüğüne dikkat edin. Aksi takdirde, BrokenReference özellik Falsedöndürür.

Başvuru

Başvurular hakkında daha fazla bilgi için Yardım menüsünde Microsoft Visual Basic Help'i tıklatın, Yardım bölmesinde Arama kutusuna Başvurular Koleksiyonu yazın ve sonra konuyu görüntülemek için Aramayı Başlat'ı tıklatın.

Eksik başvurular hakkında daha fazla bilgi için, Makaleyi Microsoft Bilgi Bankası'nda görüntülemek için aşağıdaki makale numarasını tıklatın:

283806 Visual Basic for Applications (VBA) işlevleri eksik referansları olan bir veritabanında kırılır