Share via


Microsoft 365'e veya Microsoft 365'ten geçirilen posta kutusu için arşiv posta kutusu sorunları

Özgün KB numarası: 2757430

Sorun

Posta kutusunu Microsoft 365'e veya Microsoft 365'ten geçirip bir arşiv posta kutusu kullandığınızda, Microsoft Exchange Online'daki Microsoft Exchange Posta Kutusu Çoğaltma hizmetinin (MRS) geçiş sonunda posta kutusunun ArchiveDomain özelliğinin hedef etki alanı değerini damgalama sorunuyla karşılaşırsınız.

Not

Sorun, arşiv posta kutusu olmayan bir hesapta oluşmamalıdır.

Arşiv posta kutularıyla ilgili beş senaryo vardır. Her senaryo farklı bir çözüm gerektirir.

  • Senaryo 1 - Ekleme: Şirket içi Microsoft Exchange Server posta kutularınızı Exchange Online taşırsınız.
  • Senaryo 2 - Ekleme: Arşiv posta kutunuz Exchange Online içinde bulunur ve birincil posta kutunuzu şirket içi Exchange Server ortamınızdan Exchange Online'a taşırsınız.
  • Senaryo 3 - Çıkarma: Bir arşiv posta kutusunu etkinleştirir ve hem birincil hem de arşiv posta kutularınızı Exchange Online şirket içi Exchange Server ortamınıza geçirirsiniz. Benzer bir senaryo, birincil posta kutunuz zaten şirket içinde olduğunda ve arşiv posta kutunuzu Exchange Online şirket içi Exchange Server ortamınıza eklemeye karar vermeniz durumunda ortaya çıkar.
  • Senaryo 4 - Çıkarma: Birincil posta kutunuzda etkinleştirilmiş bir arşiv posta kutusu yok ve birincil posta kutunuzu Exchange Online şirket içi Exchange Server ortamınıza taşırsınız.
  • Senaryo 5 - Çıkarma: Birincil posta kutunuz şirket içi Exchange Server ortamınızda ve arşiv posta kutunuz da Exchange Online'da bulunur. Bu senaryo, aşağıdaki eylemlerden birini gerçekleştirdiğinizde ortaya çıkabilir:
    • Birincil posta kutunuzu eklersiniz. Ancak arşiv posta kutunuzu Exchange Online bırakırsınız.
    • Hem birincil hem de arşiv posta kutuları şirket içi Exchange Server ortamınızda bulunur. Ancak, yalnızca arşiv posta kutunuzu eklersiniz.

    Not

    Desteklenen tek arşiv bölme senaryosu, şirket içi birincil posta kutusu ve Exchange Online arşiv posta kutusudur.

Neden

Bu sorun, bir posta kutusu şirket içi Exchange Server ortamı ile Exchange Online arasında geçirilirse oluşur.

Arşiv özelliklerini görüntülemek için aşağıdaki Windows PowerShell cmdlet'ini kullanırsanız, arşiv durumunun Etkin olduğunu fark edeceksiniz. Ancak arşiv bilgilerinin çoğu eksiktir.

Get-Mailbox alias |fl Name, Archive*

Not

Cmdlet'ini çalıştırmak için şirket içi Exchange Yönetim Kabuğu'nı veya PowerShell'i Exchange Online kullanabilirsiniz. Exchange Online PowerShell'i kullanma hakkında daha fazla bilgi için Windows PowerShell Hizmete Bağlama'ya gidin.

Cmdlet'ini çalıştırdığınızda sonuç aşağıdakine benzer:

Name : jsmith
ArchiveDatabase :
ArchiveGuid : 00000000-0000-0000-0000-000000000000
ArchiveName : {}
ArchiveQuota : 100 GB (107,374,182,400 bytes)
ArchiveWarningQuota : 90 GB (96,636,764,160 bytes)
ArchiveDomain : contoso.mail.onmicrosoft.com
ArchiveStatus : Active

Çözüm

Bu sorunu çözmek için senaryonuza uygun olarak aşağıdaki yöntemlerden birini kullanın.

Senaryo 1

Senaryo 1'deki sorun şu şekilde çözüldü: Exchange Online tüm ekleme geçişleri giderilir ve arşiv posta kutusu kiracı yöneticisi tarafından etkinleştirilene kadar ArchiveDomain özelliği artık ayarlanmamıştır.

Bu sorun çözülmeden önce, kullanıcılar Outlook'ta bir arşiv posta kutusunun varlığını bildirdi ve kimlik doğrulama istemleri aldı. Ancak, kullanıcılar Outlook Web App'da aynı arşiv posta kutusunu göremez. (Microsoft, kullanıcılar tarafından erişilebilen gerçek bir arşiv posta kutusu olmadığından arşivi 'hayalet arşiv' olarak ifade eder.

Senaryo 2

Senaryo 2'deki sorun şu şekilde çözüldü: Posta kutularının taşınmasından sorumlu OLAN MRS bileşeni artık bir Exchange Online arşiv posta kutusunun varlığında doğru faktörlere neden oluyor. Bu nedenle, kullanıcılar arşiv posta kutularına Outlook'ta doğru şekilde erişebilir veya herhangi bir hata olmadan Outlook Web App. Eylem gerekmez.

Senaryo 3

Senaryo 3'ün her iki varyasyonundaki sorun şu şekilde çözülür: Exchange Online'da MRS, ArchiveDomain özelliğinin değerini şirket içi etki alanına ayarlar. Bu nedenle, kullanıcılar arşiv posta kutularına Outlook'ta doğru şekilde erişebilir veya herhangi bir hata olmadan Outlook Web App. Eylem gerekmez.

Senaryo 4

Senaryo 4'teki sorun şu şekilde çözüldü: Bu senaryoda, Exchange Online'deki MRS, ArchiveDomain özelliğinin değerini şirket içi etki alanına ayarlar. Bu nedenle, kullanıcılar arşiv posta kutusu etkinleştirilmemiş olsa bile Outlook'ta bir arşiv posta kutusunun varlığını görür. Bu arşiv, senaryo 1 için 'Çözüm' bölümünden bahsedilen 'hayalet arşiv'e benzer. Ancak arşiv, şirket içi Exchange Server ortamının Exchange yöneticisinin 'Senaryo 5'in Çözümü' bölümünde sağlanan betiği çalıştırmasını gerektirir. Microsoft bu senaryoya çözüm getirmek için bir güncelleştirme dağıttı. Bu nedenle, gelecekteki çıkarmalar etkilenmez.

Exchange Online'dan bir çıkarma geçişi gerçekleştirdiğinizde etkilenip etkilenmeyebileceğinizi belirlemek için tarama modunda 'Senaryo 5'in Çözümü' bölümünde sağlanan betiği çalıştırın.

Senaryo 5

Bu senaryoda ArchiveDomain özelliğinin değeri şirket içi etki alanına ayarlanır. Bu nedenle, Outlook arşiv posta kutusunu bulamıyor ve açamıyor.

4. ve 5. senaryoları çözmek için Microsoft, posta kutularınızı Exchange Online şirket içi Exchange Server ortamınıza geri taşırsanız gerekli özniteliklerin otomatik olarak değiştirilmesine yardımcı olmak için aşağıdaki betiği sağlar. Betiği çalıştırmak için şu adımları izleyin:

  1. Not Defteri'ni başlatın.
  2. Aşağıdaki betiği kopyalayıp Not Defteri'ne yapıştırın:
#-------------------------------------------------------------------------------
#
# Copyright (c) Microsoft Corporation. All rights reserved.
#
# PLEASE NOTE:
# Microsoft Corporation (or based on where you live, one of its affiliates)
# licenses this supplement to you. You may use it with each validly licensed
# copy of Microsoft Online Services Migration Tools software (the "software").
# You may not use the supplement if you do not have a license for the software.
# The license terms for the software apply to your use of this supplement.
# Microsoft may provide support services for the supplement as described at
# http://www.support.microsoft.com/common/international.aspx.
#
#-------------------------------------------------------------------------------
#
# PowerShell Source Code
#
param([Parameter(Mandatory = $false)]
[string]$TenantCloudDomain,
[Parameter(Mandatory = $false)]
[string]$Domain,
[Parameter(Mandatory = $false)]
[Switch]$Fix,
[Parameter(Mandatory = $false)]
[Switch]$FindAllUsersInForest
)
function GetNameFromDN([string]$dn)
{
if ($dn.Length -eq 0) { return $null; }
return ($dn -split ",")[0].Replace("CN=", "")
}
Import-Module ActiveDirectory
If ($TenantCloudDomain.Length -eq 0) {
$ldapQuery = "(&(objectClass=user)(msExchArchiveAddress=*))"
} else {
$ldapQuery = "(&(objectClass=user)(msExchArchiveAddress=*)(!(&(msExchArchiveGuid=*)(!(msExchArchiveDatabaseLink=*))(msExchArchiveAddress=$TenantCloudDomain))))"
}
if ($Domain.Length -eq 0) {
# default domain to computer's domain
$computer = Get-WmiObject -Class Win32_ComputerSystem
$Domain = $computer.Domain
}
if ($FindAllUsersInForest -and $Fix) {
throw "You cannot specify -FindAllUsersInForest when running in -Fix mode, only one domain can be cleaned up at a time."
}
Write-Host "Looking for objects to clean up in ${Domain}: ${ldapQuery}"
$propertiesToLoad = @("msExchMailboxGuid","homeMDB","msExchArchiveGuid","msExchArchiveDatabaseLink","msExchArchiveAddress")
$tsStart = [DateTime](Get-Date)
if ($FindAllUsersInForest) {
$m = Get-ADObject -Server "${Domain}:3268" -SearchBase "" -LDAPFilter $ldapQuery -ResultSetSize $null -Properties $propertiesToLoad
} else {
$m = Get-ADObject -Server $Domain -LDAPFilter $ldapQuery -ResultSetSize $null -Properties $propertiesToLoad
}
$elapsed = [DateTime](Get-Date) - $tsStart
if ($m -eq $null) {
Write-Host "No objects need to be cleaned up."
return
}
$cleanedCount = 0
$failedCount = 0
$filename = $("~\ArchiveDomainCleanup_{0:yyyymmdd_HHmmss}.csv" -f (Get-Date))
# Run cleanup and output data to CSV file
Write-Host "Writing output to $filename..."
try {
$m | %{
$success = $true
if ($Fix) {
$prevError = $error[0]
Set-ADObject -Identity $_ -Server $Domain -Clear "msExchArchiveAddress"
if ($error[0] -ne $prevError) {
$success = $false
Write-Host "x" -NoNewLine
} else {
Write-Host "." -NoNewLine
}
}
if ($success) {
$cleanedCount++
# object was cleaned up successfully, let's append it to output CSV.
$mm = $_ | Select ObjectGuid,DistinguishedName
# Morph guid values from binary blob to proper guid
$mbxGuid = [Guid]$_.msExchMailboxGuid
if ($_.msExchArchiveGuid -ne $null) {
$archiveGuid = [Guid]$_.msExchArchiveGuid
} else {
$archiveGuid = $null
}
Add-Member -InputObject $mm -MemberType NoteProperty -Name CleanedArchiveDomain -Value $($_.msExchArchiveAddress)
Add-Member -InputObject $mm -MemberType NoteProperty -Name ExchangeGuid -Value $mbxGuid
Add-Member -InputObject $mm -MemberType NoteProperty -Name Database -Value $(GetNameFromDN $_.homeMDB)
Add-Member -InputObject $mm -MemberType NoteProperty -Name ArchiveGuid -Value $archiveGuid
Add-Member -InputObject $mm -MemberType NoteProperty -Name ArchiveDatabase -Value $(GetNameFromDN $_.msExchArchiveDatabaseLink)
$mm
} else {
$failedCount++
}
} | Export-CSV $filename -NoTypeInformatio
}
finally {
if ($Fix) {
Write-Host ""
Write-Host "Cleaned up $cleanedCount recipients."
if ($failedCount -gt 0) {
Write-Warning "Failed to update $failedCount recipients."
}
} else {
Write-Host "Discovered $cleanedCount recipients."
}
}
  1. Dosya menüsünde Kaydet'e tıklayın.
  2. Kayıt Türü kutusunda Tüm Dosyalar (.)'e tıklayın.
  3. Dosya adı kutusunda typeCleanup-ArchiveDomain.ps1 ve kaydet'e tıklayın.
  4. Cleanup-ArchiveDomain.ps1 dosyasını kaydettiğiniz dizini bulun ve betiği aşağıdaki parametrelerle birlikte çalıştırın:
Cleanup-ArchiveDomain.ps1 [-TenantCloudDomain serviceDomain] [-Domain domain] [-Fix] [-FindAllUsersInForest]

Not

  • TenantCloudDomain parametresi yalnızca kiracı bulut arşiv işlevini kullanıyorsa belirtilmelidir. parametresinin değeri, kiracının contoso.com gibi bulut arşivlerine erişmek için kullandığı DNS etki alanı adı olmalıdır.
  • Domain parametresi, temizleme işlevini geçerli bilgisayarın etki alanı olmayan bir etki alanında çalıştırmak için kullanılır.
  • Düzeltme anahtarı, gerçek temizleme işlevini tetikler. Anahtarın varsayılan işlevi ('tarama modu' olarak da bilinir) yalnızca kullanıcıları bulmak ve ardından bir CSV dosyasına çıkarmaktır.
  • FindAllUsersInForest anahtarı bir genel katalogda arama yapıp yerel ormandaki (tüm etki alanlarında) etkilenen tüm kullanıcıları bulur. Ancak, bu anahtar Düzeltme anahtarıyla birleştirilemiyor. Aynı anda yalnızca bir etki alanındaki kullanıcıları düzeltebilirsiniz.

Daha fazla bilgi

Yine de yardım mı gerekiyor? Microsoft Community web sitesine gidin.