"Bu ada sahip bir kullanıcı zaten var. Farklı bir isim kullan." Office 365 portalındaki hata

Not

Office 365 ProPlus kurumsal olarak Microsoft 365 uygulamalarıolarak yeniden adlandırıldı. Bu değişiklik hakkında daha fazla bilgi için Bu blog gönderisini okuyun.

Sorun

Microsoft Office 365'te, Microsoft Office 365 portalında aşağıdaki gibi bir hata iletisi alırsınız:

Bu ada sahip bir kullanıcı zaten var. Başka bir isim kullan.

Neden

Bu sorun, kullanıcı adı zaten kullanılıyorsa veya kullanıcı adını temel alan varolan bir e-posta adresi zaten varsa oluşabilir.

Sağlama işlemi, başka bir nesnenin zaten bir kullanıcı adı veya oluşturulan kullanıcı adıyla eşleşen bir e-posta adresine sahip olduğunu belirlerse, lisans girişimi başarısız olur.

Varsayılan olarak, kullanıcılara exchange online lisansı eklendiğinde veya atandığında, kullanıcılara kullanıcı adlarını temel alan birincil Bir SMTP adresi sağlanır. Ayrıca, kullanıcılara, örneğin contoso.onmicrosoft.com gibi Microsoft Çevrimiçi Doğrudan Yönlendirme Etki Alanı'nı (MODRD) temel alan bir e-posta adresi sağlanır. Ayrıca, bir kullanıcı adı değiştirildiğinde, birincil SMTP adresi de değiştirilebilir. Ancak, alternatif adresler güncelleştirilemez veya kaldırılmaz.

Aşağıda bazı örnek senaryolar verilmiştir.

Senaryo 1

Bir kullanıcı, kuruluş için MODRD contoso.onmicrosoft.com kullanıcı adı vardır john@contoso.com eklenir ve kullanıcı bir Exchange Online Lisans atanır. Bu senaryoda, aşağıdaki e-posta adresleri sağlanır:

  • Kullanıcıya birincil SMTP adresi john@contoso.com verilir.
  • Kullanıcıya alternatif bir e-posta adresi john@contoso.onmicrosoft.com verilir.

Senaryo 2

Bir kullanıcı, kuruluş için MODRD contoso.onmicrosoft.com kullanıcı adı vardır john@contoso.onmicrosoft.com eklenir ve kullanıcı bir Exchange Online Lisans atanır. Bu senaryoda, aşağıdaki e-posta adresi sağlanır:

  • Kullanıcıya birincil SMTP adresi john@contoso.onmicrosoft.com verilir.

Senaryo 3

Kullanıcı adı ' ndan john@contoso.com johnsmith@contoso.com ' a değiştirilir. Bu senaryoda, aşağıdaki olaylar oluşur:

  • Birincil SMTP john@contoso.com adresi, ' olarak johnsmith@contoso.com değiştirilebilir.
  • Alternatif e-posta john@contoso.com adresi, değiştirilmez. Bu nedenle, daha sonra eklemeye çalışırsanız sorunlar john@contoso.com oluşur.
  • Bunun için alternatif bir e-posta adresi johnsmith@contoso.onmicrosoft.com oluşturulmaz.

Çözüm

Bu sorunu gidermek için aşağıdakilerden birini veya birkaçını yapın:

  • Bir kullanıcı eklediğinizde, farklı bir kullanıcı adı kullanın.
  • Bir kullanıcı eklediğinizde, sorunu yaşadığınız kullanıcı adını kullanabilmek için varolan kullanıcı adını bulun ve değiştirin.
  • Bir kullanıcıyı Exchange Online lisansına eklediğinizde veya atadığınızda, kullanmaya çalıştığınız kullanıcı adını temel alan varolan e-posta adreslerini bulun ve değiştirin.

Bir e-posta adresinin zaten var olup olmadığını denetlemek için aşağıdaki adımları izleyin:

  1. Uzak PowerShell'i kullanarak Exchange Online'a bağlanın. Bunun nasıl yapılacıyla ilgili daha fazla bilgi için şeni Microsoft web sitesine gidin:

    Remote PowerShell kullanarak Exchange Online bağlanın

  2. Aşağıdaki cmdlet çalıştırın:

    get-mailbox| where {$_.EmailAddresses -match "user name"} | ft Name, RecipientType, EmailAddresses
    

    Not

    "kullanıcı adı", sorunu yaşadığınız kullanıcı adıdır.

  3. Cmdlet'i çalıştırdıktan sonra aldığınız sonuçlara göre, varolan e-posta adresini güncelleyin veya silin.

Yine de yardım mı gerekiyor? Microsoft Community web sitesine gidin.