Eklentilerin bir kullanıcı öğe kimliğine Office REST aramaları yapmalarına neden olan Hata Outlook hatası
Özgün KB numarası: 4483878
Belirtiler
Aşağıdaki senaryoyu inceleyin:
- Bir Office eklenti kullanırsiniz.
- Eklenti, Web Hizmetleri'Exchange (EWS) veya Temsili Durum Aktarımı'nın (REST) bir öğenin öğe kimliğini Outlook yapar.
- Aramalar, Office ön uç uygulamasından veya arka uçtan yapılır.
Bu senaryoda, aktarma çağrıları başarısız olur ve Outlook Bir HataNazıldı hatası üretir.
Neden
Outlook Önbellekli Exchange Modunda olduğunda, Office JavaScript API'si (Office.context.mailbox.item.itemId) aracılığıyla sağlanan öğe kimliği güncel değildir veya sunucuda henüz güncelleştirilmez.
Daha fazla bilgi
Bu sorun aşağıdaki senaryolarda ortaya çıkar:
E-posta iletisi ayrı bir Outlook masaüstü penceresinde açıkken, iletiyi başka bir Outlook klasörde taşımanız gerekir. Örneğin, iletiyi iOS ve Android Outlook Web Access 'e (OWA) veya Microsoft Outlook sitesine taşıabilirsiniz. Ardından, Outlook masaüstü uygulamasına döner ve API kullanan Office eklentisini
ItemIDkullanırsınız.Bu durumda, özgün öğe kimliği artık geçerli değildir. Bu nedenle, Office eklenti Web Hizmetleri aracılığıyla e-posta iletisine erişmeyi çalıştığında, ileti taşındığında veya silindikten sonra işlem tamamlanamadı olarak hata iletisi alırsınız.
E-posta iletisi arşivlenir, silinir veya başka bir klasöre taşınır. Kısa bir süre sonra, Office API kullanan bir eklenti
ItemIDOutlook.Bu durumda, Outlook öğe kimliğini sağlar. Ancak, sunucuyla eşitlenene kadar Outlook kimlikle sahip olamabilirsiniz. Eşitleme Outlook, eşitleme normalde hızlı olur. Ancak bazı durumlarda bu işlem daha uzun sürebilir.
Not
Bu senaryoda gelen kutusu Outlook da katkıda bulunabilirsiniz.
E-posta iletisi taşındığında Web Hizmetleri öğe kimliğinin nasıl değiştikleriyle ilgili daha fazla bilgi için, web sitesinde EWS Tanımlayıcıları'nınTanımlayıcılarla çalışma Exchange.