Power BI Desktop'ta sorgulara genel bakışQuery overview in Power BI Desktop

Power BI Desktop ile veri dünyasına bağlanabilir, ilgi çekici ve temel nitelikte raporlar oluşturabilir ve çalışmanızı başkalarıyla paylaşabilirsiniz. Bu kişiler de çalışmanızı temel alıp kendi iş zekası çalışmalarını geliştirir.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop'ta üç görünüm vardır:Power BI Desktop has three views:

  • Rapor görünümü: İstediğiniz gibi görünen, birden çok sayfa içeren ve başka kullanıcılarla paylaşabileceğiniz ilgi çekici görselleştirmeler elde etmek için oluşturduğunuz sorguları kullanabilirsinizReport view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Veri görünümü: Raporunuzdaki verileri, veri modeli biçiminde görebilir; ölçüler ekleyebilir, yeni sütunlar oluşturabilir ve ilişkileri yönetebilirsinizData view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • İlişkiler görünümü: Veri modelinizde oluşturulan ilişkilerin grafik gösterimini elde edebilir ve bunları, gereken şekilde yönetebilir veya değiştirebilirsiniz.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Bu görünümlere, Power BI Desktop'ın sol tarafındaki üç simgeden birini seçerek erişebilirsiniz.These views are accessed by selecting one of the three icons along the left side of Power BI Desktop. Aşağıdaki görüntüde Rapor görünümü seçilmiştir ve bu seçim, simgenin yan tarafındaki sarı şerit ile belirtilmiştir.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Power BI Desktop ile birlikte sunulan Sorgu Düzenleyicisi'ni kullanarak bir veya daha çok veri kaynağına bağlanabilir, verileri ihtiyaçlarınızı karşılayacak biçimde şekillendirip dönüştürebilir ve ilgili modeli Power BI Desktop'a yükleyebilirsiniz.Power BI Desktop also comes with Query Editor, where you can connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Bu belgede, Sorgu Düzenleyicisi'nde verilerle çalışmaya yönelik bir genel bakış sağlanmıştır.This document provides an overview of the work with data in the Query Editor. Öğrenecekleriniz elbette bunlarla sınırlı değil. Desteklenen veri türleri, verilere bağlanma, verileri şekillendirme, ilişki oluşturma ve çalışmaya başlama hakkında ayrıntılı yönergeler içeren bağlantıları bu belgenin sonunda bulabilirsiniz.There's more to learn, of course, so at the end of this document you’ll find links to detailed guidance about supported data types, connecting to data, shaping data, creating relationships, and how to get started.

Öncelikle Sorgu Düzenleyicisi'ni tanıyalım.But first, let’s see get acquainted with Query Editor.

Sorgu DüzenleyicisiThe Query Editor

Sorgu Düzenleyicisi'ne ulaşmak için Power BI Desktop'ın Giriş sekmesinde Sorguları Düzenle'yi seçin.To get to Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Hiçbir veri bağlantısı olmadığında Sorgu Düzenleyicisi veri almaya hazır, boş bir bölme olarak görünür.With no data connections, Query Editor appears as a blank pane, ready for data.

Bir sorgu yüklendikten sonra Sorgu Düzenleyicisi daha ilgi çekici hale gelir.Once a query is loaded, Query Editor view becomes more interesting. Aşağıdaki Web veri kaynağına bağlanırsak Sorgu Düzenleyicisi, verilerle ilgili bilgileri yükler ve verileri şekillendirmeye başlayabilirsiniz.If we connect to the following Web data source, Query Editor loads information about the data, which you can then begin to shape.

https://www.bankrate.com/finance/retirement/best-places-retire-how-state-ranks.aspx

Veri bağlantısı oluşturulduktan sonra Sorgu Düzenleyicisi aşağıdaki gibi görünür:Here’s how Query Editor appears once a data connection is established:

  1. Sorgudaki verilerle etkileşim kurabilmeniz için şeritteki birçok düğmenin etkinleştirildiğini görürsünüzIn the ribbon, many buttons are now active to interact with the data in the query

  2. Sol bölmede sorgular listelenir; bu sorguları seçebilir, görüntüleyebilir ve şekillendirebilirsinizIn the left pane, queries are listed and available for selection, viewing, and shaping

  3. Ortadaki bölmede, seçilen sorgudaki veriler görüntülenir ve bu veriler şekillendirilebilirIn the center pane, data from the selected query is displayed and available for shaping

  4. Sorgunun özelliklerinin ve uygulanan adımların listelendiği Sorgu Ayarları penceresi görünürThe Query Settings window appears, listing the query’s properties and applied steps

Bu dört alanın (şerit, sorgular bölmesi, veri görünümü ve Sorgu Ayarları bölmesi) her birini aşağıdaki bölümlerde ele alacağız.We’ll look at each of these four areas – the ribbon, the queries pane, the data view, and the Query Settings pane – in the following sections.

Sorgu şeridiThe query ribbon

Sorgu Düzenleyicisi'ndeki şerit Giriş, Dönüştür, Sütun Ekle ve Görünüm olmak üzere dört sekmeden oluşur.The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and View.

Giriş sekmesinde, tüm sorguların ilk adımı olarak kullanılan Veri Al düğmesi de dahil olmak üzere sık kullanılan sorgu görevlerini bulabilirsiniz.The Home tab contains the common query tasks, including the first step in any query, which is Get Data. Aşağıdaki görüntüde Giriş şeridi gösterilmektedir.The following image shows the Home ribbon.

Verilere bağlanmak ve sorgu oluşturma işlemine başlamak için Veri Al düğmesini seçin.To connect to data and begin the query building process, select the Get Data button. En yaygın veri kaynaklarının listelendiği bir menü belirir.A menu appears, providing the most common data sources.

Mevcut veri kaynakları hakkında daha fazla bilgi için bkz. Veri Kaynakları.For more information about available data sources, see Data Sources. Örnekler ve adımlar da dahil olmak üzere verilere bağlanma hakkında bilgi edinmek için bkz. Verilere Bağlanma.For information about connecting to data, including examples and steps, see Connect to Data.

Dönüştür sekmesinde; sütun ekleme veya kaldırma, veri türlerini değiştirme, sütunları bölme ve diğer veri tabanlı görevler gibi sık kullanılan veri dönüştürme görevlerine erişebilirsiniz.The Transform tab provides access to common data transformation tasks, such as adding or removing columns, changing data types, splitting columns, and other data-driven tasks. Aşağıdaki görüntüde Dönüştür sekmesi gösterilmektedir.The following image shows the Transform tab.

Örnekler de dahil olmak üzere veri dönüştürme hakkında daha fazla bilgi edinmek için bkz. Verileri Birleştirme ve Şekillendirme.For more information about transforming data, including examples, see Combine and Shape Data.

Sütun Ekle sekmesinde; sütun ekleme, sütun verilerini biçimlendirme ve özel sütunlar ekleme ile ilişkili ek görevler bulunur.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. Aşağıdaki görüntüde Sütun Ekle sekmesi gösterilmektedir.The following image shows the Add Column tab.

Şeritteki Görünüm sekmesi, belirli bölmelerin veya pencerelerin görüntülenip görüntülenmeyeceğini belirlemek için kullanılır.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Gelişmiş Düzenleyici'yi görüntülemek için de kullanılır.It’s also used to display the Advanced Editor. Aşağıdaki görüntüde Görünüm sekmesi gösterilmektedir.The following image shows the View tab.

Şeritte sunulan görevlerin birçoğunu, orta bölmede bir sütuna veya diğer verilere sağ tıklayarak da kullanabileceğinizi unutmayın.It’s useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Sol bölmeThe left pane

Sol bölmede, etkin sorgu sayısının yanı sıra sorgunun adı görüntülenir.The left pane displays the number of active queries, as well as the name of the query. Sol bölmede bir sorguyu seçtiğinizde bu sorgunun verileri orta bölmede görüntülenir ve orta bölmede verileri ihtiyaçlarınıza göre şekillendirip dönüştürebilirsiniz.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. Aşağıdaki görüntüde, birden fazla sorgu içeren sol bölme gösterilmektedir.The following image shows the left pane with multiple queries.

Orta bölme (veri bölmesi)The center (data) pane

Orta bölmede (veya Veri bölmesinde) seçilen sorgudaki tarihler görüntülenir.In the center pane, or Data pane, data from the selected query is displayed. Sorgu görünümündeki çalışmanın büyük kısmı burada gerçekleşir.This is where much of the work of the Query view is accomplished.

Aşağıdaki görüntüde, daha önce kurulan Web veri bağlantısı görüntülenmektedir. Overall score sütunu seçilmiştir ve kullanılabilir menü öğelerinin gösterilmesi için bu sütunun başlığına sağ tıklanmıştır.In the following image, the Web data connection established earlier is displayed, the Overall score column is selected, and its header is right-clicked to show the available menu items. Sağ tıklandığında görüntülenen menü öğelerinin birçoğunun, şerit sekmelerindeki düğmelerle aynı olduğu görülmektedir.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Sağ tıklandığında görüntülenen menü öğelerinden birini (veya şeritteki bir düğmeyi) seçtiğinizde Sorgu, ilgili adımı verilere uygular ve sorgunun parçası olarak kaydeder.When you select a right-click menu item (or a ribbon button), Query applies the step to the data, and saves it as part of the query itself. Sonraki bölümde açıklandığı üzere, adımlar sıralı şekilde Sorgu Ayarları'nda kaydedilir.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Sorgu Ayarları bölmesiThe query settings pane

Sorgu Ayarları bölmesi, sorgu ile ilişkili tüm adımların görüntülendiği yerdir.The Query Settings pane is where all steps associated with a query are displayed. Örneğin, aşağıdaki görüntüde; Sorgu Ayarları bölmesinin Uygulanan Adımlar bölümünde, Overall score sütununun türünü değiştirdiğimiz gösterilmektedir.For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Sorguda uygulanan ek şekillendirme adımları, Uygulanan Adımlar bölümünde kaydedilir.As additional shaping steps are applied to the query, they are captured in the Applied Steps section.

Temel alınan verilerin değiştirilmediğini bilmek önemlidir. Sorgu Düzenleyicisi, veri görünümünü ayarlayıp şekillendirir ve temel alınan verilerle kurulan herhangi bir etkileşim, ilgili verilerin Sorgu Düzenleyicisi tarafından şekillendirilen ve değiştirilen hali temel alınarak gerçekleştirilir.It’s important to know that the underlying data is not changed; rather, Query Editor adjusts and shapes its view of the data, and any interaction with the underlying data occurs based on Query Editor’s shaped and modified view of that data.

Sorgu Ayarları bölmesinde adımları istediğiniz şekilde yeniden adlandırabilir, silebilir veya yeniden sıralayabilirsiniz.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Bunun için Uygulanan Adımlar bölümünde adıma sağ tıklayın ve görünen menüde seçim yapın.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Tüm sorgu adımları, Uygulanan Adımlar bölmesinde görünen sırada gerçekleştirilir.All query steps are carried out in the order they appear in the Applied Steps pane.

Gelişmiş DüzenleyiciThe Advanced Editor

Sorgu Düzenleyicisi'nin her adımda oluşturduğu kodu görmek veya kendi şekillendirme kodunuzu oluşturmak isterseniz Gelişmiş Düzenleyici'yi kullanabilirsiniz.If you want to see the code that Query Editor is creating with each step, or want to create your own shaping code, you can use the Advanced Editor. Gelişmiş düzenleyiciyi başlatmak için şeritte Görünüm'ü ve ardından Gelişmiş Düzenleyici'yi seçin.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Var olan sorgu kodunu gösteren bir pencere görünür.A window appears, showing the existing query code.

Gelişmiş Düzenleyici penceresinde kodu doğrudan düzenleyebilirsiniz.You can directly edit the code in the Advanced Editor window. Pencereyi kapatmak için Bitti veya İptal düğmesini seçin.To close the window, select the Done or Cancel button.

Çalışmanızı kaydetmeSaving your work

Sorgunuz istediğiniz gibi olduğunda Sorgu Düzenleyicisi'nin, değişiklikleri Power BI Desktop'taki veri modelinde uygulamasını sağladıktan sonra Sorgu Düzenleyicisi'ni kapatabilirsiniz.When your query is where you want it, you can have Query Editor apply the changes to the data model into Power BI Desktop, and close Query Editor. Bunu yapmak için Sorgu Düzenleyicisi'nin Dosya menüsünden Kapat & Uygula'yı seçin.To do that, select Close & Apply from Query Editor's File menu.

Power BI Desktop, ilerleme kaydedildiğinde durumu görüntülemek için bir iletişim kutusu sunar.As progress is made, Power BI Desktop provides a dialog to display its status.

Sorgunuz istediğiniz gibi olduğunda veya çalışmanızın kaydedildiğinden emin olmak istediğinizde Power BI Desktop, çalışmanızı .pbix dosyası biçiminde kaydedebilir.Once you have your query where you want it, or if you just want to make sure your work is saved, Power BI Desktop can save your work in the form of a .pbix file.

Çalışmanızı kaydetmek için aşağıdaki görüntüde gösterildiği üzere, Dosya > Kaydet'i (veya Dosya > Farklı Kaydet) seçin.To save your work, select File > Save (or File > Save As), as shown in the following image.

Sonraki adımlarNext steps

Power BI Desktop ile yapabileceğiniz çok şey var.There are all sorts of things you can do with Power BI Desktop. Özellikler hakkında daha fazla bilgi edinmek için aşağıdaki kaynaklara bakın:For more information on its capabilities, check out the following resources: