Power BI Desktop'ta sorgulara genel bakışQuery overview in Power BI Desktop

Power BI Desktop ile veri dünyasına bağlanabilir, ilgi çekici ve temel nitelikte raporlar oluşturabilir ve çalışmanızı başkalarıyla paylaşabilirsiniz. Bu kişiler de çalışmanızı temel alıp kendi iş zekası çalışmalarını geliştirir.With Power BI Desktop you can connect to the world of data, create compelling and foundational reports, and share your efforts with others – who can then build on your work, and expand their business intelligence efforts.

Power BI Desktop'ta üç görünüm vardır:Power BI Desktop has three views:

  • Rapor görünümü: İstediğiniz gibi görünen, birden çok sayfa içeren ve başka kullanıcılarla paylaşabileceğiniz ilgi çekici görselleştirmeler elde etmek için oluşturduğunuz sorguları kullanabilirsinizReport view – where you use queries you create to build compelling visualizations, arranged as you want them to appear, and with multiple pages, that you can share with others
  • Veri görünümü: Raporunuzdaki verileri, veri modeli biçiminde görebilir; ölçüler ekleyebilir, yeni sütunlar oluşturabilir ve ilişkileri yönetebilirsinizData view – see the data in your report in data model format, where you can add measures, create new columns, and manage relationships
  • İlişkiler görünümü: Veri modelinizde oluşturulan ilişkilerin grafik gösterimini elde edebilir ve bunları, gereken şekilde yönetebilir veya değiştirebilirsiniz.Relationships view – get a graphical representation of the relationships that have been established in your data model, and manage or modify them as needed.

Bu görünümlere, Power BI Desktop'ın sol tarafındaki üç simgeden birini seçerek erişebilirsiniz.Access these views by selecting one of the three icons along the left side of Power BI Desktop. Aşağıdaki resimde Rapor görünümü seçilmiştir ve bu seçim, simgenin yan tarafındaki sarı şerit ile belirtilmiştir.In the following image, Report view is selected, indicated by the yellow band beside the icon.

Rapor görünümünün seçili olduğunu gösteren Power BI Desktop’ın ekran görüntüsü.

Power BI Desktop ayrıca Power Query Düzenleyicisi ile gelir.Power BI Desktop also comes with Power Query Editor. Power Query Düzenleyicisi'ni kullanarak bir veya daha çok veri kaynağına bağlanabilir, verileri ihtiyaçlarınızı karşılayacak biçimde şekillendirip dönüştürebilir ve ilgili modeli Power BI Desktop'a yükleyebilirsiniz.Use Power Query Editor to connect to one or many data sources, shape and transform the data to meet your needs, then load that model into Power BI Desktop.

Bu belgede, Power Query Düzenleyicisi'nde verilerle çalışmaya yönelik bir genel bakış sağlanmıştır ama öğrenecek daha birçok şey vardır.This document provides an overview of the work with data in the Power Query Editor, but there's more to learn. Bu belgenin sonunda desteklenen veri türleri hakkındaki ayrıntılı kılavuzların bağlantılarını bulacaksınız.At the end of this document, you'll find links to detailed guidance about supported data types. Ayrıca verilere bağlanma, verileri şekillendirme, ilişki oluşturma ve çalışmaya başlama konusunda da kılavuzlar bulabilirsiniz.You'll also find guidance about connecting to data, shaping data, creating relationships, and how to get started.

Ama öncelikle Power Query Düzenleyicisi'ni tanıyalım.But first, let's see get acquainted with Power Query Editor.

Power Query DüzenleyicisiPower Query Editor

Power Query Düzenleyicisi'ne ulaşmak için Power BI Desktop'ın Giriş sekmesinde Sorguları Düzenle'yi seçin.To get to Power Query Editor, select Edit Queries from the Home tab of Power BI Desktop.

Power Query Düzenleyicisi Giriş sekmesini gösteren Power BI Desktop’ın ekran görüntüsü.

Hiçbir veri bağlantısı olmadığında Power Query Düzenleyicisi veri almaya hazır, boş bir bölme olarak görünür.With no data connections, Power Query Editor appears as a blank pane, ready for data.

Veri bağlantısı içermeyen Power Query Düzenleyicisi’ni gösteren Power BI Desktop’ın ekran görüntüsü.

Bir sorgu yüklendikten sonra Power Query Düzenleyicisi daha ilgi çekici hale gelir.Once a query is loaded, Power Query Editor view becomes more interesting. Aşağıdaki Web veri kaynağına bağlanırsak, Power Query Düzenleyicisi verilerle ilgili bilgileri yükler ve verileri şekillendirmeye başlayabilirsiniz:If we connect to the following Web data source, Power Query Editor loads information about the data, which you can then begin to shape:

https://www.bankrate.com/retirement/best-and-worst-states-for-retirement/

Veri bağlantısı oluşturulduktan sonra Power Query Düzenleyicisi aşağıdaki gibi görünür:Here's how Power Query Editor appears once a data connection is established:

  1. Sorgudaki verilerle etkileşim kurabilmeniz için şeritteki birçok düğmenin etkinleştirildiğini görürsünüz.In the ribbon, many buttons are now active to interact with the data in the query.

  2. Sol bölmede sorgular listelenir; bu sorguları seçebilir, görüntüleyebilir ve şekillendirebilirsiniz.In the left pane, queries are listed and available for selection, viewing, and shaping.

  3. Ortadaki bölmede, seçilen sorgudaki veriler görüntülenir ve bu veriler şekillendirilebilir.In the center pane, data from the selected query is displayed and available for shaping.

  4. Sorgunun özelliklerinin ve uygulanan adımların listelendiği Sorgu Ayarları bölmesi görünür.The Query Settings pane appears, listing the query's properties and applied steps.

    Power Query Düzenleyicisi’ndeki Sorgu Ayarları bölmesini gösteren Power BI Desktop’ın ekran görüntüsü.

Bu dört alanın (şerit, Sorgular bölmesi, Veri görünümü ve Sorgu Ayarları bölmesi) her birini ele alacağız.We'll look at each of these four areas: the ribbon, the Queries pane, the Data view, and the Query Settings pane.

Sorgu şeridiThe query ribbon

Power Query Düzenleyicisi'nde şerit dört sekmeden oluşur: Giriş, Dönüşüm, Sütun Ekle ve Görünüm.The ribbon in Power Query Editor consists of four tabs: Home, Transform, Add Column, and View.

Giriş sekmesi yaygın sorgu görevlerini içerir.The Home tab contains the common query tasks.

Power Query Düzenleyicisi sorgu şeridini gösteren Power BI Desktop’ın ekran görüntüsü.

Verilere bağlanmak ve sorgu oluşturma işlemine başlamak için Yeni Kaynak öğesini seçin.To connect to data and begin the query building process, select New Source. En yaygın veri kaynaklarının listelendiği bir menü belirir.A menu appears, providing the most common data sources.

Yeni Kaynak düğmesini gösteren Power BI Desktop’ın ekran görüntüsü.

Mevcut veri kaynakları hakkında daha fazla bilgi için bkz. Veri Kaynakları.For more information about available data sources, see Data Sources. Örnekler ve adımlar da dahil olmak üzere verilere bağlanma hakkında bilgi edinmek için bkz. Verilere Bağlanma.For information about connecting to data, including examples and steps, see Connect to Data.

Dönüşüm sekmesi yaygın veri dönüştürme görevlerine erişim sağlar, örneğin:The Transform tab provides access to common data transformation tasks, such as:

  • Sütunları ekleme veya kaldırmaAdding or removing columns
  • Veri türlerini değiştirmeChanging data types
  • Sütunları bölmeSplitting columns
  • Diğer veri temelli görevlerOther data-driven tasks

Giriş sekmesini gösteren Power BI Desktop’ın ekran görüntüsü.

Örnekler de dahil olmak üzere veri dönüştürme hakkında daha fazla bilgi edinmek için bkz. Öğretici: Power BI Desktop'ta verileri şekillendirme ve birleştirme.For more information about transforming data, including examples, see Tutorial: Shape and combine data in Power BI Desktop.

Sütun Ekle sekmesinde; sütun ekleme, sütun verilerini biçimlendirme ve özel sütunlar ekleme ile ilişkili ek görevler bulunur.The Add Column tab provides additional tasks associated with adding a column, formatting column data, and adding custom columns. Aşağıdaki görüntüde Sütun Ekle sekmesi gösterilmektedir.The following image shows the Add Column tab.

Sütun Ekle sekmesini gösteren Power BI Desktop’ın ekran görüntüsü.

Şeritteki Görünüm sekmesi, belirli bölmelerin veya pencerelerin görüntülenip görüntülenmeyeceğini belirlemek için kullanılır.The View tab on the ribbon is used to toggle whether certain panes or windows are displayed. Gelişmiş Düzenleyici'yi görüntülemek için de kullanılır.It's also used to display the Advanced Editor. Aşağıdaki görüntüde Görünüm sekmesi gösterilmektedir.The following image shows the View tab.

Görünüm sekmesini gösteren Power BI Desktop’ın ekran görüntüsü.

Şeritte sunulan görevlerin birçoğunu, orta bölmede bir sütuna veya diğer verilere sağ tıklayarak da kullanabileceğinizi unutmayın.It's useful to know that many of the tasks available from the ribbon are also available by right-clicking a column, or other data, in the center pane.

Son bölme (Sorgular bölmesi)The left (Queries) pane

Sol bölmede veya Sorgular bölmesinde etkin sorguların sayısı ve sorgunun adı görüntülenir.The left pane, or Queries pane, displays the number of active queries and the name of the query. Sol bölmede bir sorguyu seçtiğinizde bu sorgunun verileri orta bölmede görüntülenir ve orta bölmede verileri ihtiyaçlarınıza göre şekillendirip dönüştürebilirsiniz.When you select a query from the left pane, its data is displayed in the center pane, where you can shape and transform the data to meet your needs. Aşağıdaki resimde sorgu içeren sol bölme gösterilmiştir.The following image shows the left pane with a query.

Sol bölmedeki Sorguları gösteren Power BI Desktop’ın ekran görüntüsü.

Orta bölme (Veri bölmesi)The center (Data) pane

Orta bölmede veya Veri bölmesinde seçilen sorgudan veriler görüntülenir.In the center pane, or Data pane, data from the selected query is displayed. Sorgu görünümündeki çalışmanın büyük kısmı bu bölmede gerçekleşir.This pane is where much of the work of the Query view is accomplished.

Aşağıdaki resimde daha önce kurulan Web veri bağlantısı gösterilmiştir.In the following image shows the Web data connection established earlier. Product sütunu seçilidir ve kullanılabilir menü öğelerini görüntülemek için sütunun başlığına sağ tıklanmıştır.The Product column is selected, and its header is right-clicked to show the available menu items. Sağ tıklandığında görüntülenen menü öğelerinin birçoğunun, şerit sekmelerindeki düğmelerle aynı olduğu görülmektedir.Notice that many of these right-click menu items are the same as buttons in the ribbon tabs.

Ortadaki veriler bölmesini gösteren Power BI Desktop’ın ekran görüntüsü.

Sağ tıklandığında görüntülenen menü öğelerinden birini (veya şeritteki bir düğmeyi) seçtiğinizde, sorgu ilgili adımı verilere uygular.When you select a right-click menu item (or a ribbon button), the query applies the step to the data. Ayrıca adımı sorgunun bir parçası olarak kaydeder.It also saves step as part of the query itself. Sonraki bölümde açıklandığı üzere, adımlar sıralı şekilde Sorgu Ayarları'nda kaydedilir.The steps are recorded in the Query Settings pane in sequential order, as described in the next section.

Sağ bölme (Sorgu Ayarları bölmesi)The right (Query Settings) pane

Sağ bölme veya Sorgu Ayarları bölmesi, sorgu ile ilişkili tüm adımların görüntülendiği yerdir.The right pane, or Query Settings pane, is where all steps associated with a query are displayed. Örneğin, aşağıdaki görüntüde; Sorgu Ayarları bölmesinin Uygulanan Adımlar bölümünde, Overall score sütununun türünü değiştirdiğimiz gösterilmektedir.For example, in the following image, the Applied Steps section of the Query Settings pane reflects the fact that we just changed the type of the Overall score column.

Sağdaki bölmede Sorgu Ayarları’nı gösteren Power BI Desktop’ın ekran görüntüsü.

Sorguda uygulanan ek şekillendirme adımları, Uygulanan Adımlar bölümünde kaydedilir.As additional shaping steps are applied to the query, they're captured in the Applied Steps section.

Temel verilerin değişmediğini bilmeniz önemlidir.It's important to know that the underlying data isn't changed. Bunun yerine Power Query Düzenleyicisi verilerin görünümünü ayarlar ve şekillendirir.Rather, Power Query Editor adjusts and shapes its view of the data. Ayrıca temel verilerle kurulan ve Power Query Düzenleyicisi’nin söz konusu verilerin şekillendirilmiş ve değiştirilmiş görünümü temelinde gerçekleşen tüm etkileşimin görünümünü de şekillendirir ve ayarlar.It also shapes and adjusts the view of any interaction with the underlying data that occurs based on Power Query Editor's shaped and modified view of that data.

Sorgu Ayarları bölmesinde adımları istediğiniz şekilde yeniden adlandırabilir, silebilir veya yeniden sıralayabilirsiniz.In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as you see fit. Bunun için Uygulanan Adımlar bölümünde adıma sağ tıklayın ve görünen menüde seçim yapın.To do so, right-click the step in the Applied Steps section, and choose from the menu that appears. Tüm sorgu adımları, Uygulanan Adımlar bölmesinde görünen sırada gerçekleştirilir.All query steps are carried out in the order they appear in the Applied Steps pane.

Sorgu Ayarları Özellikleri ve Uygulanan Adımlar filtrelerini gösteren Power BI Desktop’ın ekran görüntüsü.

Gelişmiş DüzenleyiciAdvanced Editor

Gelişmiş Düzenleyici Power Query Düzenleyicisi'nin her adımda oluşturduğu kodu görmenizi sağlar.The Advanced Editor lets you see the code that Power Query Editor is creating with each step. Ayrıca kendi şekillendirme kodunuzu oluşturmanıza da olanak tanır.It also lets you create your own shaping code. Gelişmiş düzenleyiciyi başlatmak için şeritte Görünüm'ü ve ardından Gelişmiş Düzenleyici'yi seçin.To launch the advanced editor, select View from the ribbon, then select Advanced Editor. Var olan sorgu kodunu gösteren bir pencere görünür.A window appears, showing the existing query code.
Gelişmiş Düzenleyici iletişim kutusunu gösteren Power BI Desktop’ın ekran görüntüsü.Screenshot of Power B I Desktop showing Advanced Editor dialog box.

Gelişmiş Düzenleyici penceresinde kodu doğrudan düzenleyebilirsiniz.You can directly edit the code in the Advanced Editor window. Pencereyi kapatmak için Bitti veya İptal düğmesini seçin.To close the window, select the Done or Cancel button.

Çalışmanızı kaydetmeSaving your work

Sorgunuz istediğiniz yere geldiğinde Power Query Düzenleyicisi'nin Dosya menüsünde Kapat ve Uygula'yı seçin.When your query is where you want it, select Close & Apply from Power Query Editor's File menu. Bu eylemle değişiklikler uygulanır ve düzenleyici kapatılır.This action applies the changes and closes the editor.
Dosya sekmesindeki Kapat ve Uygula seçeneğini gösteren Power BI Desktop’ın ekran görüntüsü.Screenshot of Power B I Desktop showing Close and Apply option under File tab.

Power BI Desktop, ilerleme kaydedildiğinde durumu görüntülemek için bir iletişim kutusu sunar.As progress is made, Power BI Desktop provides a dialog to display its status.
Uygulanan Sorgu Değişiklikleri onay iletişim kutusunu gösteren Power BI Desktop’ın ekran görüntüsü.

Hazır olduğunuzda Power BI Desktop çalışmanızı .pbix dosyası biçiminde kaydedebilir.When you're ready, Power BI Desktop can save your work in the form of a .pbix file.

Çalışmanızı kaydetmek için, aşağıdaki resimde gösterildiği gibi Dosya > Kaydet'i (veya Dosya > Farklı Kaydet) seçin.To save your work, select File > Save (or File > Save As), as shown in the following image.
Power Query Düzenleyicisi Dosya sekmesini gösteren Power BI Desktop’ın ekran görüntüsü.Screenshot of Power B I Desktop showing Power Query Editor File tab.

Sonraki adımlarNext steps

Power BI Desktop ile yapabileceğiniz çok şey var.There are all sorts of things you can do with Power BI Desktop. Özellikler hakkında daha fazla bilgi edinmek için aşağıdaki kaynaklara bakın:For more information on its capabilities, check out the following resources: