Aracılığıyla paylaş


TooManyRequestsReceived veya SubscriptionRequestsThrottled hata kodu sorunlarını giderme

Bu makalede, bir Microsoft Azure Kubernetes Service (AKS) kümesini silmeye çalıştığınızda oluşan veya SubscriptionRequestsThrottled hatasını tanımlama ve çözme TooManyRequestsReceived işlemi açıklanır.

Belirtiler

AKS kümesini silmeye çalıştığınızda aşağıdaki hata iletisini alırsınız:

internalErrorCode: TooManyRequestsReceived

StatusCode: 429

{

message: "'.....'' aboneliği için okuma isteği sayısı '....' sınırını aştı 'XX:XX:XX' zaman aralığı için. Lütfen '.....' sonra yeniden deneyin saniye."

}

Neden

Her abonelik düzeyi ve kiracı düzeyi işlemi azaltma sınırlarına tabidir. Bu sınırlar Azure Resource Manager her örneği için geçerlidir. Sınıra ulaştığınızda, durum kodu 429'a işaret eden bir HTTP yanıtı alırsınız: "Çok fazla istek var."

Çözüm

HTTP yanıtı bir Retry-After değer içerir. Bu, uygulamanızın sonraki isteği göndermeden önce beklemesi (veya uyku moduna geçmesi) gereken saniye sayısını belirtir. Yeniden deneme değeri tamamlanmadan önce bir istek gönderirseniz, isteğiniz işlenmez ve yeni bir yeniden deneme değeri döndürülür. Azaltma sınırları hakkında daha fazla bilgi için bkz. Resource Manager isteklerini azaltma.

Yardım için bize ulaşın

Sorularınız veya yardıma ihtiyacınız varsa bir destek isteği oluşturun veya Azure topluluk desteği isteyin. Ürün geri bildirimini Azure geri bildirim topluluğuna da gönderebilirsiniz.