Hata AADSTS650056 - Yanlış yapılandırılmış uygulama

Bu makalede, Microsoft Entra ID ile tümleştirilmiş SAML tabanlı çoklu oturum açma (SSO) yapılandırılmış bir uygulamada oturum açmaya çalışırken aşağıdaki hata iletisini almanıza neden olan bir sorun açıklanır:

Hata AADSTS650056 - Yanlış yapılandırılmış uygulama. Bunun nedeni aşağıdakilerden biri olabilir: İstemci, istemcinin uygulama kaydındaki istenen izinlerde '{name}' için hiçbir izin listelemiyor. Ya da yönetici kiracıda onay vermemiştir. Alternatif olarak, yapılandırılan istemci uygulama tanımlayıcısı ile eşleştiğinden emin olmak için istekteki uygulama tanımlayıcısını denetleyin. Veya geçerli olduğundan emin olmak için istekteki sertifikayı denetleyin. Kiracı adına yapılandırmayı veya onayı düzeltmek için lütfen yöneticinize başvurun. İstemci uygulama kimliği: {id}. Kiracı adına yapılandırmayı veya onayı düzeltmek için lütfen yöneticinize başvurun.

Belirtiler

SAML tabanlı SSO kullanarak kimlik yönetimi için Microsoft Entra ID kullanmak üzere kurulmuş bir uygulamada oturum açmaya çalışırken hata AADSTS650056 alıyorsunuz.

Neden

Issuer Uygulamadan SAML isteğindeki Microsoft Entra ID gönderilen öznitelik, Microsoft Entra ID uygulama için yapılandırılan Tanımlayıcı değeriyle eşleşmiyor.

Çözüm

SAML isteğindeki özniteliğin Issuer Microsoft Entra ID'de yapılandırılan Tanımlayıcı değeriyle eşleştiğinden emin olun.

Tanımlayıcı metin kutusundaki değerin hatada görüntülenen tanımlayıcı değeriyle eşleştiğini doğrulayın.

Veren özniteliği hakkında daha fazla bilgi için bkz. Tek Sign-On SAML protokolü.

Ek Bilgi

Active Directory kimlik doğrulaması ve yetkilendirme hata kodlarının tam listesi için bkz. Microsoft Entra kimlik doğrulaması ve yetkilendirme hata kodları.

Yardım için bize ulaşın

Sorularınız veya yardıma ihtiyacınız varsa bir destek isteği oluşturun veya Azure topluluk desteği isteyin. Ürün geri bildirimini Azure geri bildirim topluluğuna da gönderebilirsiniz.