Visual Studio 'da pencere düzenlerini özelleştirmeCustomize window layouts in Visual Studio

Visual Studio 'da, Windows 'un konumunu, boyutunu ve davranışını çeşitli geliştirme iş akışları için en iyi şekilde çalışan pencere düzenleri oluşturacak şekilde özelleştirebilirsiniz.In Visual Studio, you can customize the position, size, and behavior of windows to create window layouts that work best for various development workflows. Düzeni özelleştirdiğinizde, IDE onu anımsar.When you customize the layout, the IDE remembers it. Örneğin, Çözüm Gezgini yerleştirme konumunu değiştirir ve ardından Visual Studio 'yu kapatırsanız, başka bir bilgisayarda çalışıyor olsanız bile, Visual Studio 'yu bir sonraki açışınızda Çözüm Gezgini aynı konuma yerleştirilmeyecektir.For example, if you change the docking location of Solution Explorer and then close Visual Studio, the next time that you open Visual Studio, even if you're working on another computer, Solution Explorer will be docked in that same location.

Ayrıca, özel bir düzen yazıp kaydedebilir ve sonra tek bir komutla birlikte mizanpajlar arasında geçiş yapabilirsiniz.You can also name and save a custom layout and then switch between layouts with a single command. Örneğin, düzenleme için bir düzen ve hata ayıklama için bir düzen oluşturabilir ve pencere > pencere düzeni uygula menü komutunu kullanarak bunlar arasında geçiş yapabilirsiniz.For example, you could create a layout for editing and a layout for debugging, and switch between them by using the Window > Apply Window Layout menu command.

Araç ve belge pencereleriTool and document windows

IDE 'nin iki temel pencere türü, araç penceresi ve belge pencereleri vardır.The IDE has two basic window types, tool windows and document windows. Araç pencereleri Çözüm Gezgini, Sunucu Gezgini, Çıkış penceresi, hata listesi, tasarımcılar, hata ayıklayıcı pencereleri vb. içerir.Tool windows include Solution Explorer, Server Explorer, Output Window, Error List, the designers, the debugger windows, and so on. Belge pencereleri, kaynak kodu dosyalarını, rastgele metin dosyalarını, yapılandırma dosyalarını vb. içerir.Document windows contain source code files, arbitrary text files, config files, and so on. Araç pencereleri, başlık çubuğuna göre yeniden boyutlandırılabilir ve sürüklenebilir.Tool windows can be resized and dragged by their title bar. Belge pencereleri, sekmesine göre sürüklenebilir. Penceredeki diğer seçenekleri ayarlamak için sekmeye veya başlık çubuğuna sağ tıklayın.Document windows can be dragged by their tab. Right-click on the tab or title bar to set other options on the window.

Pencere menüsü IDE 'deki yerleştirme, kayan ve gizleme seçeneklerini gösterir.The Window menu shows options for docking, floating, and hiding windows in the IDE. Belirli bir pencereyle ilgili ek seçenekleri görmek için pencere sekmesine veya başlık çubuğuna sağ tıklayın.Right click on a window tab or title bar to see additional options for that specific window. Belirli araç pencerelerinin aynı anda birden fazla örneğini görüntüleyebilirsiniz.You can display more than one instance of certain tool windows at a time. Örneğin, birden fazla Web tarayıcısı penceresi görüntüleyebilir ve pencere menüsünde yeni pencere ' yi seçerek bazı araç pencerelerinin ek örneklerini oluşturabilirsiniz.For example, you can display more than one web browser window, and you can create additional instances of some tool windows by choosing New Window on the Window menu.

Pencereleri BölSplit windows

Bir belgede iki konumu aynı anda görüntülemeniz veya düzenlemeniz gerektiğinde Windows 'u ayırabilirsiniz.When you have to view or edit two locations at once in a document, you can split windows. Belgenizi iki bağımsız kayan bölüme bölmek için pencere menüsünde Böl ' e tıklayın.To divide your document into two independently scrolling sections, click Split on the Window menu. Tek görünümü geri yüklemek için pencere menüsünde bölmeyi kaldır ' a tıklayın.Click Remove Split on the Window menu to restore the single view.

SekmelerTabs

Düzeninizi birkaç farklı şekilde düzenlemek için sekmeleri kullanabilirsiniz.You can use tabs to arrange your layout in several different ways. Örneğin, dosyayı açmadan düzenleyicide bir dosyanın önizlemesini görüntüleyebilmeniz için, sekmelerinizi gruplandırabilir ve daha fazlasını yapabilirsiniz.For example, you can view a preview of a file in the editor without opening the file, you can group your tabs, and more.

Önizleme sekmesi (belge pencereleri)Preview tab (document windows)

Önizleme sekmesinde, dosyaları açmadan düzenleyicide görüntüleyebilirsiniz.In the Preview tab, you can view files in the editor without opening them. Dosyalara tıkladığınızda hata ayıklama sırasında ve bir aramanın sonuçlarına göz atarken, dosyaları Çözüm Gezgini seçerek önizleyebilirsiniz, bu dosyaları görüntüleyebilirsiniz.You can preview files by choosing them in Solution Explorer, during debugging when you step into files, with Go to Definition, and when you browse through results of a search. Önizleme dosyaları belge sekmesi alanının sağ tarafındaki bir sekmede görüntülenir.Preview files appear in a tab on the right side of the document tab well. Dosyayı değiştirirseniz veya seçeneğini belirlerseniz dosya düzenlenmek üzere açılır.The file opens for editing if you modify it or choose Open.

Dikey belge sekmeleriVertical document tabs

Sürüm 16,4 ' deki yenilikler: Visual Studio 2019 sürüm 16,4 sürümündeki en önemli özellik isteklerinden birini, Dikey belge sekmeleriniekledik.New in version 16.4: We added one of the top feature requests, vertical document tabs, in the Visual Studio 2019 version 16.4 release. Şimdi, Düzenleyicinizde sol veya sağ taraftaki dikey bir listede belge sekmelerinizi yönetebilirsiniz.Now, you can manage your document tabs in a vertical list on either the left or right side of your editor.

Dikey belge sekmelerini aşağıdaki yollarla uygulayabilirsiniz:You can apply vertical document tabs in the following ways:

  • Menü çubuğundan Araçlar > Seçenekler > ortam > Sekmeler ve pencereler ' i seçin.Choose Tools > Options > Environment > Tabs and Windows from the menu bar. Ardından, küme sekmesi düzen denetiminden, açılan listeden üst, sol veya sağ ' yi seçin.Then, from the Set tab layout control, choose either Top, Left, or Right from the drop-down list.

  • Bir sekmeye sağ tıklayın, sekme yerleşimini ayarla' yı seçin ve sonra sol veya sağ' yi seçin.Right-click a tab, choose Set Tab Layout, and then choose either Left or Right. (Sekmeleri varsayılan konumlarına döndürmek için üst' i seçin.)(To return the tabs to their default position, choose Top.)

    Dikey belge sekmelerini eylemde gösteren bir animasyon

Sekme gruplarıTab groups

Sekme grupları, IDE 'de iki veya daha fazla açık belge ile çalışırken sınırlı çalışma alanını yönetme yeteneğinizi genişletmenizi sağlar.Tab groups extend your ability to manage limited workspace while you're working with two or more open documents in the IDE. Birden çok belge Windows ve araç pencerelerini dikey veya yatay sekme grupları halinde düzenleyebilir ve belgeleri bir sekme grubundan diğerine karıştırabilirsiniz.You can organize multiple document windows and tool windows into either vertical or horizontal tab groups and shuffle documents from one tab group to another.

Araç ÇubuklarıToolbars

Araç çubuklarını istediğiniz yere sürükleyerek veya Özelleştir iletişim kutusunu kullanarak düzenleyebilirsiniz.You can arrange toolbars by dragging them to where you want them, or by using the Customize dialog box. Araç çubuklarını konumlandırma ve özelleştirme hakkında daha fazla bilgi için bkz. nasıl yapılır: özelleştirme menüleri ve araç çubukları.For more information about how to position and customize toolbars, see How to: Customize menus and toolbars.

Pencereleri yerleştirme ve yerleştirmeArrange and dock windows

Bir belge penceresi veya araç penceresi, IDE pencere çerçevesi içinde bir konum ve boyut olması için yerleştirilebilir.A document window or tool window can be docked, so that it has a position and size within the IDE window frame. Ayrıca, bunu IDE dışında ayrı bir kayan pencere olarak konumlandırabilirsiniz.You can also position it as a separate floating window that's outside of the IDE.

Bir araç penceresini IDE çerçevesinin içinde herhangi bir yere yerleştirebilirsiniz.You can dock a tool window anywhere inside the IDE frame. Ayrıca, bazı araç pencerelerini Düzenleyici çerçevesinde sekmeli pencereler olarak sabitleyebilirsiniz.You can also dock some tool windows as tabbed windows in the editor frame. Ve, belge pencerelerini düzenleyici çerçevesinin içine sabitleyebilir ve bunları sekme sırasına göre geçerli konumlarına sabitleyebilirsiniz.And, you can dock document windows within the editor frame, and you can pin them to their current position in the tab order.

Ayrıca, IDE 'nin içinde veya dışında bir şekilde bir araya getirme için birden çok pencere yerleştirebilirsiniz.You can also dock multiple windows to float together in a raft over or outside of the IDE. Araç pencereleri de gizli veya küçültülmüş olabilir.Tool windows can also be hidden or minimized.

Pencereleri aşağıdaki yollarla düzenleyebilirsiniz:You can arrange windows in the following ways:

  • Belge pencerelerini sekme kutusu sol tarafında sabitleyin.Pin document windows to the left of the tab well.

  • Windows sekme yerleştirme çerçevesini Düzenle.Tab-dock windows to the editing frame.

  • Araç pencerelerini IDE içindeki bir çerçevenin kenarına yerleştirin.Dock tool windows to the edge of a frame in the IDE.

  • Belge veya araç pencerelerini IDE üzerinde veya dışında kaydır.Float document or tool windows over or outside the IDE.

  • Araç pencerelerini IDE 'nin kenarı üzerinde gizleyin.Hide tool windows along the edge of the IDE.

  • Pencereleri farklı izleyicilere göre görüntüleyin.Display windows on different monitors.

  • Pencere yerleşimini varsayılan düzene veya kaydedilmiş bir özel düzene sıfırlayın.Reset window placement to the default layout or to a saved custom layout.

Araç ve belge pencerelerini düzenlemek için imlecinizi pencerenin başlık çubuğuna yerleştirebilir ve sonra istediğiniz yere sürükleyebilirsiniz.To arrange tool and document windows, you can place your cursor on the title bar of a window and then drag it to where you want it. Alternatif olarak, pencerenin başlık çubuğuna sağ tıklayıp bağlam menüsünü kullanabilir veya pencere menüsündeki komutları kullanabilirsiniz.Alternatively, you can right-click the title bar of the window to use its context menu, or you can use the commands on the Window menu.

Pencereleri yerleştirDock windows

Bir araç penceresinin başlık çubuğunu tıklatıp sürüklediğinizde veya belge penceresi sekmesi göründüğünde, kılavuz elmas görünür.When you click and drag the title bar of a tool window, or the tab of document window, a guide diamond appears. Sürükleme işlemi sırasında fare imleci elmas içindeki oklardan birinin üzerindeyken, fare düğmesini şimdi serbest bırakırsanız pencerenin nereye yerleştirildiğini gösteren bir gölgeli alan görüntülenir.During the drag operation, when the mouse cursor is over one of the arrows in the diamond, a shaded area will appear that shows you where the window will be docked if you release the mouse button now.

Bir yerleştirilebilir penceresini yerinde yaslama olmadan taşımak için, pencereyi sürüklerken CTRL tuşuna basın.To move a dockable window without snapping it into place, press the Ctrl key while you drag the window.

Bir araç penceresini veya belge penceresini en son yerleştirilen konumuna döndürmek için, pencerenin başlık çubuğunu veya sekmesini çift tıklatırken CTRL tuşuna basın.To return a tool window or document window to its most recent docked location, press Ctrl while you double-click the title bar or tab of the window.

Aşağıdaki çizimde belge pencereleri için kılavuz elmas gösterilmektedir ve bu, yalnızca düzenleyen çerçevesinin içine yerleştirilebilir:The following illustration shows the guide diamond for document windows, which can only be docked within the editing frame:

Belge penceresi Kılavuzu elmas

Araç pencereleri, IDE 'deki veya Düzen çerçevesindeki bir çerçevenin bir tarafına kadar hızlı olabilir.Tool windows can be fastened to one side of a frame in the IDE or within the editing frame. Bir araç penceresini, pencereyi kolayca yeniden yerleştirmenize yardımcı olması için başka bir konuma sürüklediğinizde kılavuz elmas görünür.A guide diamond appears when you drag a tool window to another location to help you to easily redock the window.

Araç penceresi Kılavuzu elleri

Aşağıdaki çizimde, mavi gölgeli alanla ilgili yeni bir konuma yerleştirilmiş Çözüm Gezgini gösterilmektedir:The following illustration shows Solution Explorer being docked in a new location that's demarcated by the blue shaded area:

Yeni bir konumda Çözüm Gezgini sabitleme

Araç pencerelerini kapat ve otomatik gizleClose and auto-hide tool windows

Başlık çubuğunun sağ üst köşesindeki X simgesine tıklayarak bir araç penceresini kapatabilirsiniz.You can close a tool window by clicking the X in the upper right of the title bar. Pencereyi yeniden açmak için, klavye kısayolunu veya menü komutunu kullanın.To reopen the window, use its keyboard shortcut or menu command. Araç pencereleri, Otomatik Gizle adlı bir özelliği destekler ve bu, farklı bir pencere kullandığınızda pencerenin bu şekilde kaydırılmasına neden olur.Tool windows support a feature named auto hide, which causes a window to slide out of the way when you use a different window. Bir pencere gizli olduğunda, adı IDE 'nin kenarındaki bir sekmede görünür.When a window is autohidden, its name appears on a tab at the edge of the IDE. Pencereyi yeniden kullanmak için pencerenin görünüme geri dönmesi için sekmenin üzerine gelin.To use the window again, point to the tab so that the window slides back into view.

Otomatik Gizle

Not

Otomatik gizleme 'nin araç pencereleri için tek tek veya sabitlenmiş gruplar halinde çalışıp çalışmadığını belirlemek için otomatik gizleme düğmesini seçin veya temizleyin seçeneği yalnızca seçenekler iletişim kutusunda etkin araç pencerelerini etkiler .To set whether auto hide operates on tool windows individually or as docked groups, select or clear Auto Hide button affects active tool windows only in the Options dialog box. Daha fazla bilgi için bkz. Genel, ortam, Seçenekler iletişim kutusu.For more information, see General, Environment, Options dialog box.

Not

Otomatik gizleme özelliği etkin olan araç pencereleri, pencere odaklanıldığında geçici olarak görünüme kayarak çıkabilir.Tool windows that have auto hide enabled may temporarily slide into view when the window has focus. Pencereyi yeniden gizlemek için geçerli pencerenin dışında bir öğe seçin.To hide the window again, select an item outside of the current window. Pencere odağı kaybettiğinde, görünüm geri taşınır.When the window loses focus, it slides back out of view.

İkinci bir izleyici kullanınUse a second monitor

İkinci bir monitörünüz varsa ve işletim sisteminiz destekliyorsa, hangi izleyicinin bir pencere görüntüleyeceğini seçebilirsiniz.If you have a second monitor and your operating system supports it, you can choose which monitor displays a window. Diğer izleyicilerinde, Rafts içinde birden çok pencere de gruplandırabilirsiniz.You can even group multiple windows together in rafts on other monitors.

İpucu

Çözüm Gezgini birden çok örneğini oluşturabilir ve bunları başka bir monitöre taşıyabilirsiniz.You can create multiple instances of Solution Explorer and move them to another monitor. Pencereye sağ tıklayın ve yeni Çözüm Gezgini Görünüm' ü seçin.Right-click the window and choose New Solution Explorer View. CTRL tuşunu seçerken, tüm pencereleri geri ' ye çift tıklayarak özgün monitöre döndürebilirsiniz.You can return all windows back to the original monitor by double-clicking while choosing the Ctrl key.

Pencere düzenleri arasında sıfırlama, adlandırma ve geçiş yapmaReset, name, and switch between window layouts

Pencere mizanpajını Sıfırla komutunu kullanarak, ayarlar KOLEKSIYONUNUZ için IDE 'yi özgün pencere düzenine döndürebilirsiniz.You can return the IDE to the original window layout for your settings collection by using the Reset Window Layout command. Bu komutu çalıştırdığınızda, aşağıdaki eylemler gerçekleşir:When you run this command, the following actions occur:

  • Tüm pencereler varsayılan konumlarına taşınır.All windows are moved to their default positions.

  • Varsayılan pencere düzeninde kapatılan pencereler kapalıdır.Windows that are closed in the default window layout are closed.

  • Varsayılan pencere düzeninde açık olan pencereler açılır.Windows that are open in the default window layout are opened.

Özel düzenler oluşturma ve kaydetmeCreate and save custom layouts

Visual Studio, 10 ' a kadar özel pencere düzenini kaydetmenizi ve aralarında hızlıca geçiş yapmanızı sağlar.Visual Studio enables you to save up to 10 custom window layouts and quickly switch between them. Aşağıdaki adımlarda, yerleşik ve kayan araç pencereleri ile birden çok izleyiciden faydalanan özel düzenleri oluşturma, kaydetme, çağırma ve yönetme işlemleri gösterilmektedir.The following steps show how to create, save, invoke, and manage custom layouts that take advantage of multiple monitors with both docked and floating tool windows.

İlk olarak, her biri ayrı bir en uygun düzene sahip iki projesi olan bir test çözümü oluşturun.First, create a test solution that has two projects, each with a different optimal layout.

UI projesi oluşturma ve düzeni özelleştirmeCreate a UI project and customize the layout

  1. Yeni bir C# WPF uygulaması projesi oluşturun.Create a new C# WPF App project. Bu projede, bir kullanıcı arabirimi geliştirdiğinizi düşünelim.Imagine that in this project, you'll be developing a user interface. Tasarımcı penceresinin alanını en üst düzeye çıkarmak ve diğer araç pencerelerini bu şekilde taşımak istiyorsunuz.You want to maximize the space for the designer window and move other tool windows out of the way.

  2. Birden çok monitörünüz varsa, Çözüm Gezgini penceresini ve Özellikler penceresini ikinci monitörünüze çekin.If you have multiple monitors, pull over the Solution Explorer window and the Properties window to your second monitor. Tek bir izleme sisteminde, tasarımcı hariç tüm pencereleri kapatmayı deneyin.On a single monitor system, try closing all the windows except the designer.

  3. Ctrl + Alt + Araç kutusu penceresini göstermek için Ctrl alt X tuşlarına basın.Press Ctrl+Alt+X to display the Toolbox window. Pencere yerleştirilmişse, yerleştirmek istediğiniz yere kayabilecek şekilde sürükleyin.If the window is docked, drag it so that it floats somewhere where you'd like to position it.

  4. Visual Studio 'Yu hata ayıklama moduna almak için F5 tuşuna basın.Press F5 to put Visual Studio into debugging mode. Oto, çağrı yığınının ve Çıkış hata ayıklama pencerelerinin konumunu istediğiniz şekilde ayarlayın.Adjust the position of the Autos, Call Stack, and Output debugging windows the way you want them. Oluşturmakta olduğunuz düzen hem düzenleme modu hem de hata ayıklama modu için geçerlidir.The layout you're about to create will apply to both editing mode and debugging mode.

  5. Hem hata ayıklama modu hem de düzenleme modundaki mizanpajlarınız istediğiniz gibi olduğunda pencere > pencere düzenini kaydet' i seçin.When your layouts in both debugging mode and editing mode are how you want them, choose Window > Save Window Layout. Bu düzeni "tasarımcı" olarak çağırın.Call this layout "Designer."

    Yeni mizanpajınızı CTRL + alt + 1... 0' ın ayrılmış listesinden sonraki klavye kısayoluna atandığını unutmayın.Notice that your new layout is assigned the next keyboard shortcut from the reserved list of Ctrl+Alt+1...0.

Veritabanı projesi ve düzeni oluşturmaCreate a database project and layout

  1. Çözüme yeni bir SQL Server veritabanı projesi ekleyin.Add a new SQL Server Database project to the solution.

  2. Çözüm Gezgini yeni projeye sağ tıklayın ve Nesne Gezgini Görünüm' ü seçin.Right-click on the new project in Solution Explorer and choose View in Object Explorer. Bu, veritabanınızdaki tablolara, görünümlere ve diğer nesnelere erişmenizi sağlayan SQL Server Nesne Gezgini penceresini görüntüler.This displays the SQL Server Object Explorer window, which enables you to access tables, views and other objects in your database. Bu pencereyi kayabilir ya da yuvalanmış bırakabilirsiniz.You can either float this window or leave it docked. Diğer araç pencerelerini istediğiniz şekilde ayarlayın.Adjust the other tool windows the way you want them. Ek realronizme için gerçek bir veritabanı ekleyebilirsiniz, ancak bu izlenecek yol için gerekli değildir.For added realism, you can add an actual database, but it's not necessary for this walkthrough.

  3. Mizanpajınızı istediğiniz şekilde tercih ettiğinizde, ana menüden pencere > pencere yerleşimini kaydet' i seçin.When your layout is how you want it, from the main menu choose Window > Save Window Layout. Bu düzeni "DB Project" olarak çağırın.Call this layout "DB Project." (Bu proje için bir hata ayıklama modu düzeniyle ilgili değildir.)(We won't bother with a debug mode layout for this project.)

Düzenler arasında geçiş yapmaSwitch between the layouts

Düzenler arasında geçiş yapmak için klavye kısayollarını kullanın veya ana menüden pencere > pencere düzeni uygula' yı seçin.To switch between layouts, use the keyboard shortcuts, or from the main menu choose Window > Apply Window Layout.

Pencere Düzen menüsünü Uygula

Kullanıcı arabirimi düzeni uygulandıktan sonra, düzenin hem düzenleme modunda hem de hata ayıklama modunda nasıl korundığına göz önünde bulabilirsiniz.After applying the UI layout, note how the layout is preserved both in editing mode and in debug mode.

Evde çok sayıda izleme kurulumuna sahipseniz ve tek bir izleme dizüstü bilgisayarı evinizde, her makine için optimize edilmiş düzenler oluşturabilirsiniz.If you have a multi monitor setup at work and a single monitor laptop at home, you can create layouts that are optimized for each machine.

Not

Tek izlemeli bir sisteme çok monitörlü bir düzen uygularsanız, ikinci monitöre yerleştirdiğiniz kayan pencereler artık Visual Studio penceresinin arkasında gizlenir.If you apply a multi-monitor layout on a single-monitor system, the floating windows that you placed on the second monitor will now be hidden behind the Visual Studio window. Alt + Tab tuşlarına basarak bu pencereleri öne çıkarabilirsiniz. Daha sonra Visual Studio 'Yu birden çok izleyiciyle açarsanız, düzeni yeniden uygulayarak pencereleri belirtilen konumlarına geri yükleyebilirsiniz.You can bring these windows to the front by pressing Alt + Tab. If you later open Visual Studio with multiple monitors, you can restore the windows to their specified positions by re-applying the layout.

Düzenlerinizi yönetme ve dolaşımdaManage and roam your layouts

Pencere > düzenlerini Yönet' i seçerek özel düzeninizi kaldırabilir, yeniden adlandırabilir veya yeniden sıralayabilirsiniz.You can remove, rename, or reorder your custom layout by choosing Window > Manage Window Layouts. Bir düzeni taşırsanız, anahtar bağlama otomatik olarak listedeki yeni konumu yansıtacak şekilde ayarlanır.If you move a layout, the key binding is automatically adjusted to reflect the new position in the list. Bağlamalar başka bir zamanda değiştirilemez ve bu nedenle, aynı anda en fazla 10 düzen saklayabilirsiniz.The bindings can't be otherwise modified, and so you can store a maximum of 10 layouts at a time.

Pencere düzenlerini Yönet

Kendinize hangi klavye kısayolunun atandığını hatırlatmak için pencere > pencere düzeni uygula' yı seçin.To remind yourself which keyboard shortcut is assigned to which layout, choose Window > Apply Window Layout.

Bu düzenler, Visual Studio sürümleri arasında ve ayrıca ayrı makinelerde Blend örnekleri arasında ve tüm Express sürümlerinden diğer Express kuruluşlarına otomatik olarak dolaşımda yapılır.These layouts automatically roam between Visual Studio editions, and also between Blend instances on separate machines, and from any Express edition to any other Express organization. Ancak, düzenler Visual Studio, Blend ve Express arasında dolaşımda değildir.However, layouts do not roam across Visual Studio, Blend, and Express.

Ayrıca bkz.See also