Nasıl yapılır: Visual Studio 'da menüleri ve araç çubuklarını özelleştirmeHow to: Customize menus and toolbars in Visual Studio

Visual Studio 'Yu yalnızca menü çubuğuna araç çubukları ve menüler ekleyip kaldırarak ve ayrıca belirli bir araç çubuğu veya menüdeki komutları ekleyerek ve kaldırarak özelleştirebilirsiniz.You can customize Visual Studio not only by adding and removing toolbars and menus on the menu bar, but also by adding and removing commands on any given toolbar or menu.

Uyarı

Bir araç çubuğunu veya menüyü özelleştirdikten sonra, Özelleştirme iletişim kutusunda onay kutusunun seçili olmaya devam ettiğinden emin olun.After you customize a toolbar or menu, make sure that its check box remains selected in the Customize dialog box. Aksi takdirde, Visual Studio'yu kapatıp yeniden açtıktan sonra değişiklikleriniz kalıcı olmaz.Otherwise, your changes won't persist after you close and reopen Visual Studio.

Menü çubuğuna menü ekleme, kaldırma veya taşımaAdd, remove, or move a menu on the menu bar

  1. Menü çubuğunda Araçlar > Özelleştir' i seçin.On the menu bar, choose Tools > Customize.

    Özelleştir iletişim kutusu açılır.The Customize dialog box opens.

  2. Komutlar sekmesinde menü çubuğu seçenek düğmesini seçili bırakın, bu seçeneğin yanındaki listede bulunan menü çubuğunu seçili bırakın ve ardından aşağıdaki adım kümelerinden birini gerçekleştirin:On the Commands tab, leave the Menu bar option button selected, leave Menu Bar selected in the list next to that option, and then perform one of the following sets of steps:

    • Bir menü eklemek için yeni menü ekle düğmesini seçin, Seçimi Değiştir düğmesini seçin ve sonra eklemek istediğiniz menüyü adlandırın.To add a menu, choose the Add New Menu button, choose the Modify Selection button, and then name the menu that you want to add.

      Menünün nasıl ekleneceğini gösteren iletişim kutusunu özelleştirme

    • Menüyü kaldırmak için, denetimler listesinden seçin ve ardından Sil düğmesini seçin.To remove a menu, choose it in the Controls list, and then choose the Delete button.

    • Menü çubuğundaki menüyü taşımak için, denetimler listesinden menüyü seçin ve ardından Yukarı taşı veya aşağı taşı düğmesini seçin.To move a menu within the menu bar, choose the menu in the Controls list, and then choose the Move Up or Move Down button.

Araç çubuğunu ekleme, kaldırma veya taşımaAdd, remove, or move a toolbar

  1. Menü çubuğunda Araçlar > Özelleştir' i seçin.On the menu bar, choose Tools > Customize.

    Özelleştir iletişim kutusu açılır.The Customize dialog box opens.

  2. Araç çubuğu sekmesinde, aşağıdaki adım kümelerinden birini gerçekleştirin:On the Toolbar tab, perform one of the following sets of steps:

    • Bir araç çubuğu eklemek için Yeni düğmesini seçin, eklemek istediğiniz araç çubuğu için bir ad belirtin ve sonra Tamam düğmesini seçin.To add a toolbar, choose the New button, specify a name for the toolbar that you want to add, and then choose the OK button.

      Araç çubuğunun nasıl ekleneceğini gösteren iletişim kutusunu özelleştirme

    • Özel bir araç çubuğunu kaldırmak için araç çubukları listesinden seçin ve ardından Sil düğmesini seçin.To remove a custom toolbar, choose it in the Toolbars list, and then choose the Delete button.

      Önemli

      Kendi oluşturduğunuz araç çubuklarını silebilir, ancak varsayılan araç çubuklarını silemezsiniz.You can delete toolbars that you create but not default toolbars.

    • Bir araç çubuğunu farklı bir yerleştirme konumuna taşımak için, araç çubukları listesinden seçin, Seçimi Değiştir düğmesini seçin ve açılan listeden bir konum seçin.To move a toolbar to a different docking location, choose it in the Toolbars list, choose the Modify Selection button, and then choose a location in the list that appears.

      Ayrıca, bir araç çubuğunu, ana yerleştirme alanında herhangi bir konuma taşımak için sol kenarından sürükleyebilirsiniz.You can also drag a toolbar by its left edge to move it anywhere in the main docking area.

      Not

      Araç çubuklarının kullanılabilirliğini ve erişilebilirliğini geliştirme hakkında daha fazla bilgi için bkz. nasıl yapılır: IDE erişilebilirlik seçeneklerini ayarlama.For more information about how to improve the usability and accessibility of toolbars, see How to: Set IDE accessibility options.

Menüyü veya araç çubuğunu özelleştirmeCustomize a menu or a toolbar

  1. Menü çubuğunda Araçlar > Özelleştir' i seçin.On the menu bar, choose Tools > Customize.

    Özelleştir iletişim kutusu açılır.The Customize dialog box opens.

  2. Komutlar sekmesinde, özelleştirmek istediğiniz öğe türüne ilişkin seçenek düğmesini seçin.On the Commands tab, choose the option button for the type of element that you want to customize.

  3. Bu öğe türüne ilişkin listede, özelleştirmek istediğiniz menü veya araç çubuğunu seçin ve sonra aşağıdaki adım gruplarından birini gerçekleştirin:In the list for that type of element, choose the menu or toolbar that you want to customize, and then perform one of the following sets of steps:

    • Bir komut eklemek için Komut Ekle düğmesini seçin.To add a command, choose the Add Command button.

      Komut Ekle Iletişim kutusunda Kategoriler listesinden bir öğe seçin, Komutlar listesinden bir öğe seçin ve Tamam düğmesini seçin.In the Add Command dialog box, choose an item in the Categories list, choose an item in the Commands list, and then choose the OK button.

      Visual Studio 'da komut Ekle iletişim kutusu

    • Bir komutu silmek için, denetimler listesinden seçin ve ardından Sil düğmesini seçin.To delete a command, choose it in the Controls list, and then choose the Delete button.

    • Komutları yeniden sıralamak için, denetimler listesinde bir komut seçin ve ardından Yukarı taşı veya aşağı taşı düğmesini seçin.To reorder commands, choose a command in the Controls list, and then choose the Move Up or Move Down button.

    • Komutları yatay bir çizgi altında gruplandırmak için, denetimler listesinden ilk komutu seçin, Seçimi Değiştir düğmesini seçin ve açılan menüden bir Grup Başlat ' ı seçin.To group commands under a horizontal line, choose the first command in the Controls list, choose the Modify Selection button, and then choose Begin a Group in the menu that appears.

Menüyü veya araç çubuğunu sıfırlamaReset a menu or a toolbar

  1. Menü çubuğunda Araçlar > Özelleştir' i seçin.On the menu bar, choose Tools > Customize.

    Özelleştir iletişim kutusu açılır.The Customize dialog box opens.

  2. Komutlar sekmesinde, sıfırlamak istediğiniz öğe türüne ilişkin seçenek düğmesini seçin.On the Commands tab, choose the option button for the type of element that you want to reset.

  3. Bu öğe türüne ilişkin listede, sıfırlamak istediğiniz menü veya araç çubuğunu seçin.In the list for that type of element, choose the menu or toolbar that you want to reset.

  4. Seçimi Değiştir düğmesini seçin ve açılan menüden Sıfırla ' yı seçin.Choose the Modify Selection button, and then choose Reset in the menu that appears.

    Tümünü Sıfırla düğmesini seçerek de tüm menüleri ve araç çubuklarını sıfırlayabilirsiniz.You can also reset all menus and toolbars by choosing the Reset All button.

Ayrıca bkz.See also