Nasıl yapılır: kaydırma çubuğunu özelleştirmeHow to: Customize the scroll bar

Uzun kod dosyalarıyla çalışırken her şeyin dosyada nerede olduğunu izlemek zor olabilir.When you are working with long code files, it can be hard to keep track of where everything is in the file. Kodunuzda neler olduğunu bir genel bakış için kod düzenleyicisinin kaydırma çubuğunu özelleştirebilirsiniz.You can customize the scroll bar of the code editor to give you an overall picture of what's happening in your code.

Ek AçıklamalarAnnotations

Kaydırma çubuğunun kod değişiklikleri, kesme noktaları, yer işaretleri, hatalar ve giriş işareti konumu gibi ek açıklamaları gösterilip gösterilmeyeceğini belirleyebilirsiniz.You can select whether the scroll bar shows annotations such as code changes, breakpoints, bookmarks, errors, and caret position.

  1. Scroll Bars Araçlar > Seçenekler > metin düzenleyici > tüm diller > kaydırma çubukları' nı seçerek kaydırma çubukları Seçenekler sayfasını açın.Open the Scroll Bars options page by choosing Tools > Options > Text Editor > All Languages > Scroll Bars.

  2. Dikey kaydırma çubuğu üzerinde ek açıklamaları göster' i seçin ve ardından görmek istediğiniz ek açıklamaları seçin.Select Show Annotations over vertical scroll bar, and then select the annotations you want to see. Kullanılabilir ek açıklamalar şunlardır:The available annotations are:

    • değişikliklerchanges
    • işaretlermarks
    • hatalarerrors
    • şapka işareti konumucaret position

    İpucu

    Işaretleri göster seçeneği kesme noktaları ve yer işaretleri içerir.The Show marks option includes breakpoints and bookmarks.

Büyük bir kod dosyası açarak ve dosyadaki birkaç yerde oluşan bazı metinleri değiştirerek deneyin.Try it out by opening a large code file and replacing some text that occurs in several places in the file. Kaydırma çubuğu, değişikliklerinizin etkisini gösterir. bu sayede, sahip olmayan bir şeyi değiştirdiyseniz değişikliklerinizi geri alabilirsiniz.The scroll bar shows you the effect of the replacements, so you can back out your changes if you replaced something you shouldn't have.

Bu, bir dize aramadan sonra kaydırma çubuğunun nasıl göründüğünü aşağıda bulabilirsiniz.Here's how the scroll bar looks after a search for a string. Dizenin tüm örneklerinin kaydırma çubuğunda göründüğünü unutmayın.Notice that all instances of the string appear in the scroll bar.

Dize aramadan sonra Visual Studio kaydırma çubuğu

Dizenin tüm örnekleri değiştirildikten sonra kaydırma çubuğu.Here's the scroll bar after replacing all the instances of the string. Kaydırma çubuğundaki kırmızı işaretler metin değiştirme hatalarının nerede olduğunu gösterir.The red marks in the scroll bar show where the text replacement introduced errors.

Bir dizeyi hatalar ile değiştirdikten sonra Visual Studio kaydırma çubuğu

Görüntüleme modlarıDisplay modes

Kaydırma çubuğunun iki modu vardır: çubuk modu ve eşleme modu.The scroll bar has two modes: bar mode and map mode.

Çubuk moduBar mode

Çubuk modu , kaydırma çubuğundaki ek açıklama göstergelerini görüntüler.Bar mode displays annotation indicators on the scroll bar. Kaydırma çubuğuna tıkladığınızda sayfa yukarı veya aşağı kaydırılır, ancak dosyadaki bu konuma atlamaz.Clicking on the scroll bar scrolls the page up or down but does not jump to that location in the file.

Eşleme moduMap mode

Harita modu , kod satırlarını, kaydırma çubuğunda küçük olarak görüntüler.Map mode displays lines of code, in miniature, on the scroll bar. Eşleme sütununun ne kadar geniş olduğunu seçerek kaynak genel bakış' da bir değer seçebilirsiniz.You can choose how wide the map column is by selecting a value in Source overview. İşaretçiyi haritada tuttuğunuz zaman kodun daha büyük bir önizlemesini etkinleştirmek için Önizleme araç Ipucunu göster seçeneğini belirleyin.To enable a larger preview of the code when you rest the pointer on the map, select the Show Preview Tooltip option. Daraltılmış bölgeler farklı şekilde genişleyebilir ve çift tıkladığınızda genişletilir.Collapsed regions are shaded differently and expand when you double-click them.

İpucu

Kaynak genel bakışını kapalı olarak ayarlayarak, eşleme modunda küçük kod görünümünü kapatabilirsiniz.You can turn the miniature code view off in map mode by setting Source overview to Off. Önizleme araç Ipucunu göster seçiliyse, işaretçinizi kaydırma çubuğunun üzerine getirdiğinizde bu konumdaki kodun önizlemesini görmeye devam edersiniz ve imleç, tıkladığınızda dosyada bu konuma atlar.If Show Preview Tooltip is selected, you still see a preview of the code at that location when you hover your pointer on the scroll bar, and the cursor still jumps to that location in the file when you click.

Aşağıdaki görüntüde, harita modu açık olduğunda ve Genişlik Orta olarak ayarlandığında arama örneği gösterilmektedir:The following image shows the search example when map mode is on and the width is set to Medium:

Harita modunda Visual Studio kaydırma çubuğu

Aşağıdaki görüntüde Önizleme araç Ipucunu göster seçeneği gösterilmektedir:The following image shows the Show Preview Tooltip option:

Araç ipucuyla Visual Studio kaydırma çubuğu

İpucu

Harita modunda gördüğünüz renkleri değiştirmek için Araçlar > Seçenekler > ortam > yazı tipleri ve renkler' i seçin.To change the colors that you see in map mode, choose Tools > Options > Environment > Fonts and Colors. Daha sonra, görüntüleme öğeleri' nde, "genel bakış" ile başlayan öğelerden herhangi birini seçin, istediğiniz renk değişikliğini yapın ve ardından Tamam' ı seçin.Next, in Display items, choose any of the items that are preceded with "Overview", make the color changes you want, and then choose OK.

Ayrıca bkz.See also