Visual Studio için üretkenlik KılavuzuProductivity guide for Visual Studio

Kodu yazarken zaman kazanmak istiyorsanız, doğru yerde olursunuz.If you want to save time while you're writing code, you're in the right place. Bu üretkenlik Kılavuzu, Visual Studio kullanmaya başlamanıza, kod yazmanıza, kod hata ayıklamanıza, hataları işlemeye ve tek bir sayfada klavye kısayollarını kullanmanıza yardımcı olabilecek ipuçları içerir — .This productivity guide includes tips that can help you get started with Visual Studio, write code, debug code, handle errors, and use keyboard shortcuts—all on one page.

Faydalı klavye kısayolları hakkında daha fazla bilgi için bkz. üretkenlik kısayolları.For information about helpful keyboard shortcuts, see Productivity shortcuts. Komut kısayollarının tüm listesi için bkz. varsayılan klavye kısayolları.For a complete list of command shortcuts, see Default keyboard shortcuts.

Kullanmaya başlayınGet started

Komutlar, ayarlar, belgeler ve Install seçenekleri de dahil olmak üzere ihtiyacınız olan her şeyi hızlıca arayarak menüler aracılığıyla zaman ayırarak tasarruf edin.Save time digging through menus by quickly searching for anything you need, including commands, settings, documentation, and install options. Visual Studio 'da arama sonuçlarınızda bulunan komutlara yönelik klavye kısayollarına bakın. böylece bunları daha kolay bir şekilde yeniden deneyebilirsiniz.See keyboard shortcuts for commands within your search results in Visual Studio so you can memorize them more easily.

  • Görev listesini kullanan sahte kod.Mock code using task list. Kod parçasını tamamlamaya yetecek kadar gereksinimleriniz yoksa, ve gibi belirteçleri kullanan kod açıklamalarını izlemek için Görev Listesi kullanın TODO HACK ve sizi doğrudan kodda önceden tanımlanmış bir konuma götürür kısayolları yönetin.If you don't have enough requirements to complete a piece of code, use Task List to track code comments that use tokens such as TODO and HACK, or custom tokens, and to manage shortcuts that take you directly to a predefined location in code. Daha fazla bilgi için bkz. görev listesi kullanma.For more information, see Use the Task List.

  • Çözüm Gezgini kısayollarını kullanın.Use Solution Explorer shortcuts. Visual Studio 'ya yeni başladıysanız, bu kısayollar yararlı olur ve yeni bir kod tabanında hızlanırken size zaman kazandırır.If you're new to Visual Studio, these shortcuts will come in handy and save you time while you're coming up to speed on a new codebase. Kısayolların tam listesi için bkz. Visual Studio 'Da varsayılan klavye kısayolları.For the full list of shortcuts, see Default keyboard shortcuts in Visual Studio.

  • Visual Studio 'da klavye kısayollarını belirleyip özelleştirin.Identify and customize keyboard shortcuts in Visual Studio. Visual Studio komutları için kısayollar tanımlayabilir, bu kısayolları özelleştirebilir ve başkalarının kullanması için dışarı aktarabilirsiniz.You can identify keyboard shortcuts for Visual Studio commands, customize those shortcuts, and export them for others to use. Seçenekler iletişim kutusunda her zaman bir klavye kısayolunu bulabilir ve değiştirebilirsiniz.You can always find and change a keyboard shortcut in the Options dialog box.

  • Visual Studio 'yu daha erişilebilir hale getirin.Make Visual Studio more accessible. Visual Studio, ekran okuyucular ve diğer yardımcı teknolojilerle uyumlu yerleşik erişilebilirlik özelliklerine sahiptir.Visual Studio has built-in accessibility features that are compatible with screen readers and other assistive technologies. Kullanılabilir özelliklerin tam listesi için bkz. Visual Studio Için erişilebilirlik ipuçları ve püf noktaları .See Accessibility tips and tricks for Visual Studio for the full list of available features.

  • Visual Studio ürün yaşam döngüsünü ve bakımını inceleyin.Check out the Visual Studio Product Lifecycle and Servicing. Visual Studio güncelleştirmelerini alma hakkında daha fazla bilgi için, Enterprise ve Professional müşterilerine yönelik destek seçenekleri, Visual Studio 'nun eski sürümleri için destek ve Visual Studio hizmetinin kapsamadığı bileşenler için bkz. Visual Studio ürün yaşam döngüsü ve bakımı.For information on how to get updates for Visual Studio, support options for Enterprise and Professional customers, support for older versions of Visual Studio, and components not covered by Visual Studio servicing, see Visual Studio Product Lifecycle and Servicing.

  • Visual Studio 'Da NuGet paketlerini yükleyip yönetin.Install and manage NuGet packages in Visual Studio. Windows üzerinde Visual Studio 'daki NuGet Paket Yöneticisi Kullanıcı arabirimi, projelerde ve çözümlerde NuGet paketlerini kolayca yüklemenize, kaldırmanıza ve güncelleştirmenize olanak tanır.The NuGet Package Manager UI in Visual Studio on Windows allows you to easily install, uninstall, and update NuGet packages in projects and solutions. Daha fazla bilgi için bkz. NuGet paket yöneticisini kullanarak Visual Studio 'da paketleri yükleyip yönetme.For more information, see Install and manage packages in Visual Studio using the NuGet Package Manager.

Kod yazmaWrite code

Aşağıdaki özellikleri kullanarak daha hızlı bir şekilde kod yazın.Write code more quickly by using the following features.

  • Kullanışlı komutları kullanın.Use convenience commands. Visual Studio, yaygın Düzenle görevleri daha hızlı gerçekleştirmenize yardımcı olacak çeşitli komutlar içerir.Visual Studio contains various commands to help you accomplish common editing tasks faster. Örneğin, bir kod satırını kopyalamak zorunda kalmadan kolayca çoğaltmak için bir komut seçebilirsiniz, imleci yeniden konumlandırabilirsiniz ve yapıştırın.For example, you can choose a command to easily duplicate a line of code without having to copy it, reposition the cursor, and then paste it. Yinelemeyi Düzenle > Duplicate ' yi seçin veya CTRL + E,Vtuşlarına basın.Choose Edit > Duplicate or press Ctrl+E,V. Ayrıca Edit > ,Gelişmiş > Genişlet seçimini Düzenle veya Edit > Gelişmiş > sözleşme seçiminiDüzenle ' yi seçerek veya SHIFT + alt + = veya SHIFT + alt + - tuşlarına basarak bir metin seçimini hızlıca genişletebilir veya dağıtabilirsiniz.You can also quickly expand or contract a selection of text by choosing Edit > Advanced > Expand Selection or Edit > Advanced > Contract Selection, or by pressing Shift+Alt+= or Shift+Alt+-.

  • IntelliSense kullanın.Use IntelliSense. Düzenleyicide kod girerken, liste üyeleri, parametre bilgileri, hızlı bilgi, Imza yardımı ve tüm kelime gibi IntelliSense bilgileri görüntülenir.As you enter code in the editor, IntelliSense information, such as List Members, Parameter Info, Quick Info, Signature Help, and Complete Word, appears. Bu özellikler, metnin belirsiz eşleşmesini destekler; Örneğin, liste üyeleri için sonuç listeleri yalnızca girdiğiniz karakterlerle başlayan girişleri değil, aynı zamanda adlarının herhangi bir yerindeki karakter kombinasyonunu içeren girdileri de içerir.These features support fuzzy matching of text; for example, the results lists for List Members include not only entries that start with the characters that you have entered but also entries that contain the character combination anywhere in their names. Daha fazla bilgi için bkz. IntelliSense 'ı kullanma.For more information, see Use IntelliSense.

  • Kod girerken IntelliSense seçeneklerinin otomatik olarak eklenmesini değiştirin.Change auto-insertion of IntelliSense options as you enter code. IntelliSense 'i öneri moduna geçirerek, IntelliSense seçeneklerinin yalnızca açıkça seçtiğiniz durumlarda ekleneceğini belirtebilirsiniz.By switching IntelliSense to suggestion mode, you can specify that IntelliSense options are inserted only if you explicitly choose them.

    Öneri modunu etkinleştirmek için CTRL + alt + Ara çubuğu tuşlarını seçin veya menü çubuğunda IntelliSense Düzenle > IntelliSense > tamamlama modunuseçin.To enable suggestion mode, choose the Ctrl+Alt+Spacebar keys, or, on the menu bar, choose Edit > IntelliSense > Toggle Completion Mode.

  • Kod parçacıklarını kullanın.Use code snippets. Yerleşik kod parçacıklarını kullanabilir veya kendi kod parçacıklarınızı oluşturabilirsiniz.You can use built-in snippets, or create your own snippets.

    Bir kod parçacığı eklemek için, menü çubuğunda IntelliSense düzenleme > IntelliSense > kod parçacığı Ekle veya ile Çevrele' yi seçin veya kısayol menüsünü bir dosyada açın ve kod parçacığı > Ekle parçacık veya ile çevreleyin' i seçin.To insert a snippet, on the menu bar, choose Edit > IntelliSense > Insert Snippet or Surround With, or open the shortcut menu in a file and choose Snippet > Insert Snippet or Surround With. Daha fazla bilgi için bkz. kod parçacıkları.For more information, see Code Snippets.

  • Kod hatalarını satır Içinde düzeltir.Fix code errors inline. Hızlı Eylemler, tek bir eylem ile kodu kolayca yeniden düzenleme, oluşturma veya başka şekilde değiştirmenize olanak sağlar.Quick Actions let you easily refactor, generate, or otherwise modify code with a single action. Bu eylemler, Screwdriver  screwsürücü simgesi veya hafif Ampul ampul  simgesi simgeleri kullanılarak veya alt + ENTER ya da CTRLtuşlarına basarak uygulanabilir + .These actions can be applied using the screwdriver Screwdriver icon or light bulb Light bulb icon icons, or by pressing Alt+Enter or Ctrl+. imlecinizin uygun kod satırında olması durumunda.when your cursor is on the appropriate line of code. Daha fazla bilgi için bkz. hızlı eylemler .See Quick Actions for more information.

  • Bir kod öğesinin tanımını görüntüleyin ve düzenleyin.Show and edit the definition of a code element. Üye, değişken veya yerel gibi bir kod öğesinin tanımlandığı modülü hızlıca gösterebilir ve düzenleyebilirsiniz.You can quickly show and edit the module in which a code element, such as a member, a variable, or a local, is defined.

    Bir tanımı açılır pencerede açmak için, öğeyi vurgulayın, sonra alt + F12 tuşlarını seçin veya öğe için kısayol menüsünü açın ve ardından Gözat' ı seçin.To open a definition in a pop-up window, highlight the element and then choose the Alt+F12 keys, or open the shortcut menu for the element and then choose Peek Definition. Ayrı bir kod penceresinde bir tanımı açmak için, öğe için kısayol menüsünü açın ve ardından Tanıma Git' i seçin.To open a definition in a separate code window, open the shortcut menu for the element, and then choose Go to Definition.

  • Örnek uygulamaları kullanın.Use sample applications. Microsoft Developer Network'ten örnek uygulamalar indirerek ve yükleyerek uygulama geliştirmeyi hızlandırabilirsiniz.You can speed up application development by downloading and installing sample applications from Microsoft Developer Network. Ayrıca, bu alana yönelik bir örnek paketi indirerek ve inceleyerek belirli bir teknoloji veya programlama kavramı de öğrenebilirsiniz.You can also learn a particular technology or programming concept by downloading and exploring a Sample Pack for that area.

  • Biçimlendirme/yeni satırlarla küme ayracı biçimlendirmesini değiştirin.Change brace formatting with Formatting/New Lines. Yeni satırlar dahil olmak üzere kod düzenleyicisinde biçimlendirme kodu seçeneklerini ayarlamak için biçimlendirme seçenekleri sayfasını kullanın.Use the Formatting options page to set options for formatting code in the code editor, including new lines. Bu ayarın C# ' de nasıl kullanılacağı hakkında daha fazla bilgi için bkz. Seçenekler iletişim kutusu: metin düzenleyici > C# > kod stili > biçimlendirme.For more information on how to use this setting in C#, see Options dialog box: Text Editor > C# > Code Style > Formatting. C++ için bkz. Visual Studio 'Da c++ kodlama tercihlerinizi ayarlama.For C++, see Set your C++ coding preferences in Visual Studio. Python için bkz. Python kodunu biçimlendirme.For Python, see Format Python code.

  • Girintilerinizi sekmelerle değiştirin.Change your indentation with Tabs. Farklı düzenleyicilerde ve sdes 'lerde aynı projede çalışan birden çok geliştirici için tutarlı kodlama stillerini zorlamak üzere her kod tabanına uyarlanmış özel düzenleyici ayarlarını kullanın.Use custom editor settings, tailored to each codebase, to enforce consistent coding styles for multiple developers working on the same project across different editors and IDEs. Tüm takımınızın aynı dil kurallarına, adlandırma kurallarına ve biçimlendirme kurallarına uyduğundan emin olun.Ensure your whole team follows the same language conventions, naming conventions, and formatting rules. Bu özel ayarlar taşınabilir olduğundan ve kodunuzla birlikte gezindiğinden, Visual Studio dışında bile kodlama stillerini zorunlu kılabilirsiniz.Since these custom settings are portable and travel with your code, you can enforce coding styles even outside of Visual Studio. Daha fazla bilgi için bkz. Seçenekler, metin düzenleyici, tüm diller, sekmeler.For more information, see Options, Text Editor, All Languages, Tabs.

Kodunuzda belirli konumları daha hızlı bir şekilde bulmak ve taşımak için çeşitli teknikler kullanabilirsiniz.You can use various techniques to find and move to specific locations in your code more quickly. Tercihlerinize göre Visual Studio pencerelerinin yerleşimini de değiştirebilirsiniz.You can also change the layout of your Visual Studio windows based on your preferences.

  • Kod satırları yer işareti.Bookmark lines of code. Bir dosyadaki belirli kod satırlarına hızlıca gezinmek için yer işaretlerini kullanabilirsiniz.You can use bookmarks to navigate quickly to specific lines of code in a file.

    Bir yer işareti ayarlamak için, menü çubuğunda Edit > yer imleriniDüzenle yer işaretlerini Seç > yer işaretiniseçin.To set a bookmark, on the menu bar, choose Edit > Bookmarks > Toggle Bookmark. Bir çözümün tüm yer imlerini yer işaretleri penceresinde görüntüleyebilirsiniz.You can view all of the bookmarks for a solution in the Bookmarks window. Daha fazla bilgi için bkz. koddaki yer Imlerini ayarlama.For more information, see Set bookmarks in code.

  • Bir dosyada sembol tanımlarını arayın.Search for symbol definitions in a file. Sembol tanımlarını ve dosya adlarını bulmak için bir çözüm içinde arama yapabilirsiniz, ancak arama sonuçları ad alanları veya yerel değişkenler içermez.You can search within a solution to locate symbol definitions and file names, but search results don't include namespaces or local variables.

    Bu özelliğe erişmek için, menü çubuğunda, Edit > Git 'e git' i seçin.To access this feature, on the menu bar, choose Edit > Navigate To.

  • Kodunuzun genel yapısına gözatın.Browse the overall structure of your code. Çözüm Gezgini, Koleksiyonlarınızda sınıfları ve bunların türlerini ve üyelerini arayabilir ve bunlara gözatabilirler.In Solution Explorer, you can search and browse classes and their types and members in your projects. Ayrıca sembolleri arayabilir, yöntemin Çağrı hiyerarşisini görüntüleyebilir, sembol başvurularını bulabilir ve diğer görevleri gerçekleştirebilirsiniz.You can also search for symbols, view a method's Call Hierarchy, find symbol references, and perform other tasks. Çözüm Gezginibir kod öğesi seçerseniz, ilişkili dosya bir Önizleme sekmesinde açılır ve imleç dosyadaki öğeye gider.If you choose a code element in Solution Explorer, the associated file opens in a Preview tab, and the cursor moves to the element in the file. Daha fazla bilgi için bkz. kod yapısını görüntüleme.For more information, see View the structure of code.

  • Eşleme modundaki bir dosyadaki konuma atlayın.Jump to a location in a file with map mode. Harita modu, kod satırlarını, kaydırma çubuğunda küçük olarak görüntüler.Map mode displays lines of code, in miniature, on the scroll bar. Bu görüntü modu hakkında daha fazla bilgi için bkz. nasıl yapılır: kaydırma çubuğunu özelleştirme.For more information about this display mode, see How to: Customize the scroll bar.

  • Kod eşlemesiyle kod yapınızı anlayın.Understand your code structure with code map. Kod haritaları kodunuzda bağımlılıkları görselleştirmenize yardımcı olabilir ve dosya ve kod satırları arasında okuma yapmadan nasıl sığdığını görürsünüz.Code maps can help you visualize dependencies across your code, and see how it fits together without reading through files and lines of code. Daha fazla bilgi için bkz. kod eşlemeleriyle harita bağımlılıkları.For more information, see Map dependencies with code maps.

  • En son dosyayı Düzenle/git ile sık kullanılan dosyalara bakın.See frequently used files with Edit/Go to Recent File. Belirli öğeleri hızlı bir şekilde bulmanıza yardımcı olması için kodunuzda odaklanmış bir arama gerçekleştirmek üzere Visual Studio 'daki git komutlarını kullanın.Use the Go To commands in Visual Studio to perform a focused search of your code to help you quickly find specified items. Ayrıntılı yönergeler için bkz. Go komutunu kullanarak kodu bulma.For detailed instructions, see Find code using Go To commands.

  • ** Özellikler penceresi sağ tarafa taşıyın**.Move the Properties window to the right-hand side. Daha tanıdık bir pencere düzeni arıyorsanız, F4tuşuna basarak Visual Studio 'daki Özellikler penceresi taşıyabilirsiniz.If you're looking for a more familiar window layout, you can move the Properties window in Visual Studio by pressing F4.

Öğeleri daha hızlı bulunFind items faster

Araç pencerelerinin içeriğini yalnızca geçerli göreviniz için ilgili bilgileri gösterecek şekilde filtrelemeye ek olarak komutlar, dosyalar ve seçenekler için IDE genelinde arama yapabilirsiniz.You can search across the IDE for commands, files, and options, in addition to filtering the contents of tool windows to show only relevant information for your current task.

  • Araç pencerelerinin Içeriğini filtreleyin.Filter the contents of tool windows. Araç kutusu, özellikler penceresi ve Çözüm Gezginigibi birçok araç penceresinin içeriği içinde arama yapabilirsiniz ancak yalnızca adları belirttiğiniz karakterleri içeren öğeleri görüntüleyebilirsiniz.You can search within the contents of many tool windows, such as the Toolbox, the Properties window, and Solution Explorer, but display only items whose names contain the characters that you specify.

  • Yalnızca ele almak istediğiniz hataları görüntüleyin.Display only the errors you want to address. Hata listesi araç çubuğunda filtre düğmesini seçerseniz, hata listesi penceresinde görüntülenen hata sayısını azaltabilirsiniz.If you choose the Filter button on the Error List toolbar, you can reduce the number of errors that appear in the Error List window. Yalnızca düzenleyicide açık olan dosyalardaki hataları, yalnızca geçerli dosyadaki hataları veya yalnızca geçerli projedeki hataları görüntüleyebilirsiniz.You can display only the errors in the files that are open in the editor, only the errors in the current file, or only the errors in the current project. Ayrıca, belirli hataları bulmak için hata listesi penceresi içinde arama yapabilirsiniz.You can also search within the Error List window to find specific errors.

  • İletişim kutularını, menü komutlarını, seçenekleri ve daha fazlasını bulun.Find dialog boxes, menu commands, options, and more. Arama kutusuna bulmaya çalıştığınız öğeler için anahtar sözcükler veya ifadeler girin.In the search box, enter keywords or phrases for the items that you're trying to find. Örneğin, Yeni projegirdiğinizde aşağıdaki seçenekler görüntülenir:For example, the following options appear if you enter new project:

    ' Yeni proje ' için hızlı başlatma sonuçları

    Hızlı başlatma , yeni bir proje oluşturmak, projeye yeni bir öğe eklemek ve Seçenekler Iletişim kutusundaki Projeler ve çözümler sayfasına diğerleri arasında bağlantılar görüntüler.Quick Launch displays links to create a new project, to add a new item to a project, and to the Projects and Solutions page in the Options dialog box, among others. Arama sonuçları, proje dosyalarını ve araç pencerelerini de içerebilir.Search results can also include project files and tool windows.

    ' Yeni proje ' için arama sonuçları

    Ctrl + Doğrudan arama kutusuna gitmek için CTRLQ tuşlarına basın.Press Ctrl+Q to jump straight to the search box.

Kod hatalarını ayıklamaDebug code

Hata ayıklama çok fazla zaman alabilir, ancak aşağıdaki ipuçları süreci hızlandırabilmeniz için size yardımcı olabilir.Debugging can consume a lot of time, but the following tips can help you speed up the process.

  • Visual Studio hata ayıklayıcısı araçları 'Nı kullanın.Use the Visual Studio debugger tools. Visual Studio bağlamında, uygulamanızda hata ayıklarken, genellikle uygulamayı hata ayıklayıcı modunda çalıştırdığınız anlamına gelir.In the Visual Studio context, when you debug your app, it usually means that you are running the application in debugger mode. Hata ayıklayıcı, çalışma sırasında kodunuzun ne yaptığını görmek için birçok yol sunar.The debugger provides many ways to see what your code is doing while it runs. Başlamak için bir kılavuz için bkz. Visual Studio hata ayıklayıcısına bakın.See First look at the Visual Studio Debugger for a guide to getting started.

  • Aynı sayfayı, uygulamayı veya siteyi farklı tarayıcılarda test edin.Test the same page, application, or site in different browsers. Kodunuzun hatalarını ayıkladığınızda, sayfa denetçisi (Visual Studio)dahil olmak üzere yüklü Web tarayıcıları arasında kolayca geçiş yapabilirsiniz iletişim kutusunu açmaya gerek yoktur.As you debug your code, you can easily switch among the installed web browsers, including Page Inspector (Visual Studio), without having to open the Browse With dialog box. Hata ayıklama Başlat düğmesinin yanındaki Standart araç çubuğunda bulunan hata ayıklama hedefi listesini kullanabilirsiniz. Bu işlem, hata ayıklama veya sayfaları görüntüleme olarak hangi tarayıcıyı kullandığınızı hızlıca doğrulamak için kullanılır.You can use the Debug Target list, which is on the Standard toolbar next to the Start Debugging button, to quickly verify which browser you're using as you debug or view pages.

    Web tarayıcısı hata ayıklama seçeneklerini belirleyin

  • Geçici kesme noktaları ayarlayın.Set temporary breakpoints. Geçerli kod satırında geçici bir kesme noktası oluşturabilir ve hata ayıklayıcıyı eşzamanlı olarak başlatabilirsiniz.You can create a temporary breakpoint in the current line of code and start the debugger simultaneously. Bu kod satırını vurduktan sonra, hata ayıklayıcı kesme moduna girer.When you hit that line of code, the debugger enters break mode. Daha fazla bilgi için bkz. hata ayıklayıcıyla kod Içinde gezinme.For more information, see Navigate through code with the debugger.

    Bu özelliği kullanmak için CTRL + F10 tuşlarını seçin veya kesmek istediğiniz kod satırı için kısayol menüsünü açın ve ardından imlece Çalıştır' ı seçin.To use this feature, choose the Ctrl+F10 keys, or open the shortcut menu for the line of code on which you want to break, and then choose Run To Cursor.

  • Hata ayıklama sırasında yürütme noktasını taşıyın.Move the execution point during debugging. Geçerli yürütme noktasını kodun farklı bir bölümüne taşıyabilir ve sonra bu noktadan hata ayıklamayı yeniden başlatabilirsiniz.You can move the current execution point to a different section of code and then restart debugging from that point. Bu teknik, bu bölüme ulaşmak için gereken adımların tümünü yeniden oluşturmak zorunda kalmadan kod bölümünün hatalarını ayıklamak istiyorsanız kullanışlıdır.This technique is useful if you want to debug a section of code without having to recreate all of the steps that are required to reach that section. Daha fazla bilgi için bkz. hata ayıklayıcıyla kod Içinde gezinme.For more information, see Navigate through code with the debugger.

    Yürütme noktasını taşımak için, sarı ok ucunu aynı kaynak dosyasında bir sonraki ifadeyi ayarlamak istediğiniz konuma sürükleyin ve sonra hata ayıklamaya devam etmek için F5 tuşunu seçin.To move the execution point, drag the yellow arrowhead to a location where you want to set the next statement in the same source file, and then choose the F5 key to continue debugging.

  • Değişkenler için değer bilgilerini yakalayın.Capture value information for variables. Kodunuzda bir değişkene bir DataTip ekleyebilir ve hata ayıklama işlemi tamamlandıktan sonra değişken için bilinen son değere erişebilmek üzere onu sabitleyebilir.You can add a DataTip to a variable in your code and pin it so that you can access the last known value for the variable after debugging has finished. Daha fazla bilgi için bkz. veri İpuçlarında veri değerlerini görüntüleme.For more information, see View data values in Data Tips.

    Bir DataTip eklemek için, hata ayıklayıcı kesme modunda olmalıdır.To add a DataTip, the debugger must be in break mode. İmleci değişkenine yerleştirin ve ardından görüntülenen veri Ipucunda sabitle düğmesini seçin.Place the cursor on the variable, and then choose the pin button on the DataTip that appears. Hata ayıklama durdurulduğunda, değişkeni içeren kod satırının yanına kaynak dosyada mavi bir pin simgesi görünür.When debugging is stopped, a blue pin icon appears in the source file next to the line of code that contains the variable. Mavi PIN 'e işaret ederseniz, en son hata ayıklama oturumundan değişkenin değeri görünür.If you point to the blue pin, the value of the variable from the most recent debugging session appears.

  • Hemen penceresini temizleyin.Clear the Immediate window. Tasarım zamanında, veya girerek hemen pencerenin içeriğini silebilirsiniz. >cls``>Edit.ClearAllYou can erase the contents of the Immediate window at design time by entering >cls or >Edit.ClearAll

    Ek komutlar hakkında daha fazla bilgi için bkz. Visual Studio komut diğer adları.For more information about additional commands, see Visual Studio command aliases.

  • CodeLens ile kod değişikliklerini ve diğer geçmişi bulun.Find code changes and other history with CodeLens. CodeLens, Düzenleyiciden çıkmadan kodunuzda ne olduğunu öğrenirken çalışmanıza odaklanmanızı sağlar — .CodeLens lets you stay focused on your work while you find out what happened to your code—without leaving the editor. Kod parçasına, kodunuzda değişikliklere, bağlantılı hatalara, iş öğelerine, kod incelemelerine ve birim testlerine yönelik başvuruları bulabilirsiniz.You can find references to a piece of code, changes to your code, linked bugs, work items, code reviews, and unit tests.

  • Diğer kişilerle gerçek zamanlı hata ayıklamak için Live Share kullanın.Use Live Share to debug in real time with others. Live Share, kullandığınız programlama dillerinden veya oluşturduğunuz uygulama türlerinden bağımsız olarak başkalarıyla gerçek zamanlı işbirliği yaparak kodu düzenlemenize ve hataları ayıklamanıza olanak tanır.Live Share enables you to collaboratively edit and debug with others in real time, regardless of the programming languages you're using or app types you're building. Daha fazla bilgi için bkz. Visual Studio Live Share nedir?For more information, see What is Visual Studio Live Share?

  • Küçük kod yazmak ve test etmek Için etkileşimli pencere kullanın.Use Interactive Window to write and test small code. Visual Studio, rastgele bir kod girmenize ve anında sonuçları görebilmenizi sağlayan etkileşimli bir okuma-değerlendirme-Yazdır-döngüsü (REPL) penceresi sağlar.Visual Studio provides an interactive read-evaluate-print-loop (REPL) window that lets you enter arbitrary code and see immediate results. Bu kodlama yöntemi, API 'Leri ve kitaplıkları öğrenmenize ve denemenize ve etkileşimli olarak, projelerinize dahil etmek üzere çalışma kodu geliştirmenize yardımcı olur.This way of coding helps you to learn and experiment with APIs and libraries, and to interactively develop working code to include in your projects. Python için bkz. Python etkileşimli penceresiyle çalışma.For Python, see Work with the Python Interactive window. Etkileşimli pencere özelliği C# için de kullanılabilir.The Interactive Window feature is also available for C#.

Visual Studio araçlarına erişinAccess Visual Studio tools

Geliştirici Komut İstemi veya başka bir Visual Studio aracına hızlı bir şekilde, Başlat menüsüne veya görev çubuğuna sabitlemeyi sağlayabilirsiniz.You can quickly access the Developer Command Prompt, or another Visual Studio tool, if you pin it to the Start menu or the taskbar.

  1. Windows Gezgini 'nde %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2017 \ Visual Studio Araçlarıkonumuna gidin.In Windows Explorer, browse to %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2017\Visual Studio Tools.
  1. Windows Gezgini 'nde %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2019 \ Visual Studio Araçlarıkonumuna gidin.In Windows Explorer, browse to %ProgramData%\Microsoft\Windows\Start Menu\Programs\Visual Studio 2019\Visual Studio Tools.
  1. Geliştirici komut istemiiçin sağ tıklayın veya bağlam menüsünü açın, sonra başlatmak veya görev çubuğuna sabitlemek için Sabitle ' yi seçin.Right-click or open the context menu for Developer Command Prompt, and then choose Pin to Start or Pin to taskbar.

Dosyaları, araç çubuklarını ve pencereleri yönetmeManage files, toolbars, and windows

Herhangi bir zamanda birden fazla kod dosyasında çalışıyor olabilir ve bir uygulama geliştirirken çeşitli araç pencereleri arasında hareket edebilirsiniz.At any one time, you may be working in multiple code files and moving among several tool windows as you develop an application. Aşağıdaki ipuçlarını kullanarak düzeninizi izleyebilirsiniz:You can keep organized by using the following tips:

  • Sık kullandığınız dosyaları düzenleyicide görünür tutun.Keep files that you frequently use visible in the editor. Düzenleyicide kaç dosya açık olursa olsun, görünür kalması için dosyaları sekmenin sol tarafına sabitleyebilirsiniz.You can pin files to the left side of the tab so that they remain visible regardless of how many files are open in the editor.

    Bir dosyayı sabitlemek için dosyanın sekmesini seçin ve ardından pin durumunu aç düğmesini seçin.To pin a file, choose the file's tab, and then choose the Toggle Pin Status button.

  • Belgeleri ve pencereleri diğer Izleyicilere taşıyın.Move documents and windows to other monitors. Uygulama geliştirirken birden fazla izleyici kullanırsanız, düzenleyicide açık olan dosyaları başka bir monitöre taşıyarak uygulamanızın bölümlerinde daha kolay çalışabilirsiniz.If you use more than one monitor when you develop applications, you can work on portions of your application more easily by moving files that are open in the editor to another monitor. Ayrıca, hata ayıklayıcı pencereleri gibi araç pencerelerini başka bir monitöre ve sekmeye yerleştir belge ve araç pencerelerini birlikte "Rafts" oluşturmak için de taşıyabilirsiniz.You can also move tool windows, such as debugger windows, to another monitor and tab dock document and tool windows together to create "rafts." Daha fazla bilgi için bkz. Visual Studio 'da pencere düzenlerini özelleştirme.For more information, see Customize window layouts in Visual Studio.

    Ayrıca, başka bir Çözüm Gezgini örneği oluşturup başka bir monitöre taşıyarak dosyaları daha kolay bir şekilde yönetebilirsiniz.You can also manage files more easily by creating another instance of Solution Explorer and moving it to another monitor. Çözüm Gezginibaşka bir örneğini oluşturmak için Çözüm Gezginibir kısayol menüsü açın ve sonra Yeni Çözüm Gezgini Görünüm' ü seçin.To create another instance of Solution Explorer, open a shortcut menu in Solution Explorer, and then choose New Solution Explorer View.

  • Visual Studio 'da görünen yazı tiplerini özelleştirin.Customize the fonts that appear in Visual Studio. IDE 'deki metin için kullanılan yazı tipini, boyutunu ve rengi değiştirebilirsiniz.You can change the font face, size, and color that's used for text in the IDE. Örneğin, düzenleyicideki belirli kod öğelerinin rengini ve araç pencereleri ya da IDE genelinde yazı tipi yüzünü özelleştirebilirsiniz.For example, you can customize the color of specific code elements in the editor and the font face in tool windows or throughout the IDE. Daha fazla bilgi için bkz. nasıl yapılır: yazı tiplerini ve renkleri değiştirme ve nasıl yapılır: düzenleyicideki yazı tiplerini ve renkleri değiştirme.For more information, see How to: Change fonts and colors and How to: Change fonts and colors in the editor.

Ayrıca bkz.See also