Bağımlılıkları kod eşlemeleriyle eşleyinMap dependencies with code maps

Kod Haritası oluşturarak kodunuzun içindeki bağımlılıkları görselleştirebilirsiniz.You can visualize dependencies across your code by creating a code map. Kod haritaları, kodun dosyalar ve kod satırları arasında okuma yapmadan nasıl bir araya oturduğunu görmenizi sağlamaya yardımcı olur.Code maps help you see how the code fits together without reading through files and lines of code.

Visual Studio 'da kod eşlemeleriyle bağımlılıkları görüntüleme

Kod haritaları oluşturmak ve düzenlemek için Visual Studio Enterprise sürümüne ihtiyacınız vardır.To create and edit code maps, you need Visual Studio Enterprise edition. Visual Studio Community ve Professional sürümlerinde, Enterprise Edition 'da oluşturulan diyagramları açabilir, ancak düzenleyemezsiniz.In Visual Studio Community and Professional editions, you can open diagrams that were generated in Enterprise edition, but you cannot edit them.

Not

Visual Studio Enterprise içinde oluşturulan haritaları, Visual Studio Professional kullanan kullanıcılarla paylaşmadan önce, haritadaki tüm öğelerin (gizli öğeler, genişletilmiş gruplar ve çapraz grup bağlantıları gibi) göründüğünden emin olun.Before you share maps created in Visual Studio Enterprise with others who use Visual Studio Professional, make sure that all the items on the map (such as hidden items, expanded groups, and cross-group links) are visible.

Bu dillerdeki kod bağımlılıklarını eşleyebilirsiniz:You can map dependencies for code in these languages:

  • Visual C# veya çözüm veya derlemelerde Visual Basic (. dll veya . exe)Visual C# or Visual Basic in a solution or assemblies (.dll or .exe)

  • Visual C++ projelerinde yerel veya yönetilen C veya C++ kodu, üst bilgi dosyaları (. h veya #include ) ya da ikili dosyalarNative or managed C or C++ code in Visual C++ projects, header files (.h or #include), or binaries

  • X + + projeleri ve Microsoft Dynamics AX için .NET modüllerinden oluşturulan derlemelerX++ projects and assemblies made from .NET modules for Microsoft Dynamics AX

Not

C# veya Visual Basic dışındaki projeler için, bir kod eşlemesi başlatmak veya varolan bir kod eşlemesine öğe eklemek için daha az seçenek vardır.For projects other than C# or Visual Basic, there are fewer options for starting a code map or adding items to an existing code map. Örneğin, bir C++ projesinin metin düzenleyicisinde bir nesneye sağ tıklayıp bir kod haritasına ekleyebilirsiniz.For example, you cannot right-click an object in the text editor of a C++ project and add it to a code map. Ancak, Çözüm Gezgini, sınıf görünümüve nesne tarayıcısıbağımsız kod öğelerini veya dosyalarını sürükleyip bırakabilirsiniz.However, you can drag and drop individual code elements or files from Solution Explorer, Class View, and Object Browser.

Kod haritasını ve canlı bağımlılık doğrulamasını yüklerInstall Code Map and Live Dependency Validation

Visual Studio 'da bir kod haritası oluşturmak için önce kod haritasını ve canlı bağımlılık doğrulama bileşenlerini yüklemeniz gerekir:To create a code map in Visual Studio, first install the Code Map and Live Dependency Validation components:

  1. Visual Studio yükleyicisiaçın.Open Visual Studio Installer. Windows Başlat menüsünden veya Visual Studio içinde Araçlar > Al araçlar ve Özellikler' i seçerek açabilirsiniz.You can open it from the Windows Start menu, or within Visual Studio by selecting Tools > Get Tools and Features.

  2. Ayrı bileşenler sekmesini seçin.Select the Individual components tab.

  3. Kod araçları bölümüne gidin ve kod Haritası ve canlı bağımlılık doğrulaması' nı seçin.Scroll down to the Code tools section and select Code Map and Live Dependency Validation.

    Visual Studio Yükleyicisi 'de kod Haritası ve canlı bağımlılık doğrulama bileşenleri

  4. Değiştir'i seçin.Select Modify.

    Kod Haritası ve canlı bağımlılık doğrulama bileşenleri yüklemeye başlar.The Code Map and Live Dependency Validation components begin installing. Visual Studio 'Yu kapatmanız istenebilir.You may be asked to close Visual Studio.

Kod Eşlemesi EkleAdd a code map

Derleme başvuruları, dosyalar ve klasörler de dahil olmak üzere boş bir kod Haritası oluşturabilir ve öğeleri üzerine sürükleyebilirsiniz veya çözümünüzün tümü veya bir kısmı için bir kod Haritası oluşturabilirsiniz.You can create an empty code map and drag items onto it, including assembly references, files and folders, or you can generate a code map for all or part of your solution.

Boş bir kod eşlemesi eklemek için:To add an empty code map:

  1. Çözüm Gezgini' de, en üst düzey çözüm Düğümünüzün kısayol menüsünü açın.In Solution Explorer, open the shortcut menu for your top-level solution node. Add > Yeni öğeEkle ' yi seçin.Choose Add > New Item.

  2. Yeni öğe Ekle iletişim kutusunda, yüklüaltında genel kategorisini seçin.In the Add New Item dialog, under Installed, choose the General category.

  3. Yönlendirilmiş grafik belgesi (. dgml) şablonunu seçin ve ardından Ekle' yi seçin.Choose the Directed Graph Document(.dgml) template and then select Add.

    İpucu

    Bu şablon alfabetik görüntülenmeyebilir, bu nedenle listede görmüyorsanız şablon listesinin en altına gidin.This template may not appear alphabetically, so scroll down to the bottom of the template list if you don't see it.

    Çözümünüzün Çözüm öğeleri klasöründe boş bir harita görüntülenir.A blank map appears in your solution's Solution Items folder.

Benzer şekilde, mimari > Yeni kod eşlemesi veya Dosya > Yeni > Dosya dosyasıseçerek çözümünüze eklemeden yeni bir kod eşleme dosyası oluşturabilirsiniz.Similarly, you can create a new code map file without adding it to your solution by selecting Architecture > New Code Map or File > New > File.

Çözümünüz için bir kod Haritası oluşturmaGenerate a code map for your solution

Çözümünüzdeki tüm bağımlılıkları görmek için:To see all the dependencies in your solution:

  1. Menü çubuğunda, mimari > çözüm için kod Haritası Oluştur' u seçin.On the menu bar, choose Architecture > Generate Code Map for Solution. Kodunuz son kez derlenmeden bu yana değiştirilmediyse, Architecture > bunun yerineYapı olmadan çözüm için kod Haritası üret ' i seçebilirsiniz.If your code hasn't changed since the last time you built it, you can select Architecture > Generate Code Map for Solution Without Building instead.

    Kod Haritası komutu oluştur

    Üst düzey derlemeleri ve bunlar arasındaki toplanmış bağlantıları gösteren bir harita oluşturulur.A map is generated that shows the top-level assemblies and aggregated links between them. Toplama bağlantısı ne kadar geniş olursa, temsil ettiği daha fazla bağımlılıklardır.The wider the aggregate link, the more dependencies it represents.

  2. Proje türü simgelerinin listesini (örneğin, test, Web ve telefon Projesi), kod öğelerini (sınıflar, Yöntemler ve özellikler gibi) ve ilişki türlerini (örneğin, devralır, Implements ve çağrılar) göstermek veya gizlemek için kod Haritası araç çubuğundaki gösterge düğmesini kullanın.Use the Legend button on the code map toolbar to show or hide the list of project type icons (such as Test, Web, and Phone Project), code items (such as Classes, Methods, and Properties), and relation types (such as Inherits From, Implements, and Calls).

    Derlemelerin en üst düzey bağımlılık grafiği

    Bu örnek çözüm, Çözüm klasörlerini (testler ve Bileşenler), test projelerini, Web projelerini ve derlemeleri içerir.This example solution contains Solution Folders (Tests and Components), Test Projects, Web Projects, and assemblies. Varsayılan olarak, tüm kapsama ilişkileri Grupolarak görünür ve bu, genişletebilir ve daraltabilirsiniz.By default, all containment relationships appear as groups, which you can expand and collapse. Dışlar grubu, platform bağımlılıkları da dahil olmak üzere çözümünüzün dışındaki her şeyi içerir.The Externals group contains anything outside your solution, including platform dependencies. Dış derlemeler yalnızca kullanılan öğeleri gösterir.External assemblies show only those items that are used. Varsayılan olarak, sistem tabanlı türler, dağınıklığı azaltmak için haritada gizlidir.By default, system base types are hidden on the map to reduce clutter.

  3. Haritanın detayına gitmek için, projeleri ve derlemeleri temsil eden grupları genişletin.To drill down into the map, expand the groups that represent projects and assemblies. Tüm düğümleri seçmek için CTRL + A tuşlarına basarak her şeyi genişletebilir ve ardından Grup' u seçerek kısayol menüsünden ' i genişletin .You can expand everything by pressing CTRL+A to select all the nodes and then choosing Group, Expand from the shortcut menu.

    Kod eşlemesindeki tüm grupları genişletme

  4. Ancak bu, büyük bir çözüm için yararlı olmayabilir.However, this may not be useful for a large solution. Aslında, karmaşık çözümler için bellek sınırlamaları tüm grupları genişletmesinin engellenmesini sağlayabilir.In fact, for complex solutions, memory limitations may prevent you from expanding all the groups. Bunun yerine, tek bir düğümün içini görmek için genişletin.Instead, to see inside an individual node, expand it. Fare işaretçinizi düğümün üzerine taşıyın ve göründüğünde köşeli çift ayraca (aşağı ok) tıklayın.Move your mouse pointer on top of the node and then click the chevron (down arrow) when it appears.

    Kod haritasında düğüm genişletme

    Ya da öğeyi seçip artı tuşuna () basarak klavyeyi kullanın + .Or use the keyboard by selecting the item then pressing the plus key (+). Daha derin kod düzeylerini araştırmak için ad alanları, türler ve Üyeler için de aynısını yapın.To explore deeper levels of code, do the same for namespaces, types, and members.

    İpucu

    Fare, klavye ve dokunma kullanarak kod eşlemeleriyle çalışma hakkında daha fazla ayrıntı için bkz. kod haritalarını inceleyin ve yeniden düzenleyin.For more details about working with code maps using the mouse, keyboard, and touch, see Browse and rearrange code maps.

  5. Haritayı basitleştirmek ve tek tek bölümlere odaklanmak için, kod Haritası araç çubuğunda Filtreler ' i seçin ve yalnızca ilgilendiğiniz düğümlerin ve bağlantıların türlerini seçin.To simplify the map and focus on individual parts, choose Filters on the code map toolbar and select just the types of nodes and links you are interested in. Örneğin, tüm çözüm klasörünü ve derleme kapsayıcılarını gizleyebilirsiniz.For example, you can hide all the Solution Folder and Assembly containers.

    Kapsayıcıları filtreleyerek eşlemeyi basitleştirme

    Ayrıca, temel çözüm kodunu etkilemeden haritalardan ayrı grupları ve öğeleri gizleyerek veya kaldırarak Haritayı basitleştirebilirsiniz.You can also simplify the map by hiding or removing individual groups and items from the map, without affecting the underlying solution code.

  6. Öğeler arasındaki ilişkileri görmek için haritada seçin.To see the relationships between items, select them in the map. Bağlantıların renkleri, gösterge bölmesinde gösterildiği gibi ilişki türlerini gösterir.The colors of the links indicate the types of relationship, as shown in the Legend pane.

    Çözümlerinizi genelinde bağımlılıkları görüntüleme

    Bu örnekte, mor bağlantılar çağrılardır, noktalı bağlantılar başvurudur ve açık mavi bağlantıları alan erişimdir.In this example, the purple links are calls, the dotted links are references, and the light blue links are field access. Yeşil bağlantılar devralma yapabilir veya birden fazla ilişki türü (veya kategorisi) gösteren Birleşik bağlantılar olabilir.Green links can be inheritance, or they may be aggregate links that indicate more than one type of relationship (or category).

    İpucu

    Yeşil bir bağlantı görürseniz yalnızca bir devralma ilişkisi olduğu anlamına gelebilir.If you see a green link, it might not mean there's just an inheritance relationship. Yöntem çağrıları da olabilir, ancak bunlar devralma ilişkisi tarafından gizlenir.There might also be method calls, but these are hidden by the inheritance relationship. Belirli bağlantı türlerini görmek için, ilgilendiğiniz türleri gizlemek için Filtreler bölmesindeki onay kutularını kullanın.To see specific types of links, use the checkboxes in the Filters pane to hide the types you aren't interested in.

  7. Bir öğe veya bağlantı hakkında daha fazla bilgi edinmek için, bir araç ipucu görünene kadar işaretçiyi en üstüne taşıyın.To get more information about an item or link, move the pointer on top of it until a tooltip appears. Bu, bir kod öğesinin ayrıntılarını veya bir bağlantının temsil ettiği kategorileri gösterir.This shows details of a code element or the categories that a link represents.

    İlişki kategorilerini göster

  8. Bir toplama bağlantısıyla temsil edilen öğeleri ve bağımlılıkları incelemek için, önce bağlantıyı seçin ve ardından kısayol menüsünü açın.To examine items and dependencies represented by an aggregate link, first select the link and then open its shortcut menu. Katkıda bulunan bağlantıları göster ' i seçin (veya Yeni kod haritasında katkıda bulunan bağlantıları göster).Choose Show Contributing Links (or Show Contributing Links on New Code Map). Bu,, bağlantının her iki ucunda da grupları genişletir ve yalnızca bağlantıya katılan öğe ve bağımlılıkları gösterir.This expands the groups at both ends of the link and shows only those items and dependencies that participate in the link.

  9. Haritanın belirli bölümlerine odaklanmak için, ilgilendiğiniz öğeleri kaldırmaya devam edebilirsiniz.To focus in on specific parts of the map, you can continue to remove items you aren't interested in. Örneğin, sınıf ve üye görünümü detayına gitmek için Filtreler bölmesindeki tüm ad alanı düğümlerini filtrelemeniz yeterlidir.For example, to drill into class and member view, simply filter all the namespace nodes in the Filters pane.

    Sınıf ve üye düzeyinde detaya gitme

  10. Karmaşık bir çözüm eşlemesine odaklanmak için başka bir yol da var olan bir haritadan seçili öğeleri içeren yeni bir eşleme oluşturmak.Another way to focus in on a complex solution map is to generate a new map containing selected items from an existing map. Odaklanmak istediğiniz öğeleri seçerken CTRL tuşunu basılı tutun, kısayol menüsünü açın ve seçimden yeni grafik' i seçin.Hold Ctrl while selecting the items you want to focus on, open the shortcut menu, and choose New Graph from Selection.

    Seçili öğeleri yeni kod haritasında göster

  11. İçeren bağlam, yeni haritaya taşınır.The containing context is carried over to the new map. Filtre bölmesini kullanarak görmek Istemediğiniz Çözüm klasörlerini ve diğer kapsayıcıları gizleyin.Hide Solution Folders and any other containers you don't want to see using the Filters pane.

    Görünümü basitleştirmek için kapsayıcıları filtreleyin

  12. İlişkileri görüntülemek için grupları genişletin ve haritadaki öğeleri seçin.Expand the groups and select items in the map to view the relationships.

    İlişkileri görüntülemek için öğeleri seçin

Ayrıca bkz:Also see:

Kod haritasında belirli bağımlılıkları görüntülemeView specific dependencies in a code map

Bekleyen değişikliklerle bazı dosyalarda gerçekleştirilecek bir kod incelemesinin olduğunu varsayalım.Suppose you have a code review to perform in some files with pending changes. Bu değişikliklerle ilgili bağımlılıkları görmek için, bu dosyalardan bir kod Haritası oluşturabilirsiniz.To see the dependencies in those changes, you can create a code map from those files.

Kod haritasında belirli bağımlılıkları göster

  1. Çözüm Gezgini, eşlemek istediğiniz projeleri, derleme başvurularını, klasörleri, dosyaları, türleri veya üyeleri seçin.In Solution Explorer, select the projects, assembly references, folders, files, types, or members that you want to map.

    Eşlemek istediğiniz öğeleri seçin

  2. Çözüm Gezgini araç çubuğunda, kod eşlemesinde göster ' i seçerek  seçili düğümlerden yeni grafik oluştur düğmesini seçin .On the Solution Explorer toolbar, choose Show on Code Map Create New Graph From Selected Nodes Button. Ya da bir grup öğe için kısayol menüsünü açın ve kod eşlemesinde göster ' i seçin.Or, open the shortcut menu for one or a group of items and choose Show on Code Map.

    Ayrıca Çözüm Gezgini, sınıf görünümüveya nesne tarayıcısıöğeleri Yeni veya varolan bir kod haritasına sürükleyebilirsiniz.You can also drag items from Solution Explorer, Class View, or Object Browser, into a new or existing code map. Öğelerinizin üst hiyerarşisini dahil etmek için, öğeleri sürüklerken CTRL tuşuna basın ve basılı tutun ya da varsayılan eylemi belirtmek için kod Haritası araç çubuğundaki üst öğeleri dahil et düğmesini kullanın.To include the parent hierarchy for your items, press and hold the Ctrl key while you drag items, or use the Include Parents button on the code map toolbar to specify the default action. Ayrıca, derleme dosyalarını Windows Gezginigibi Visual Studio 'nun dışından da sürükleyebilirsiniz.You can also drag assembly files from outside Visual Studio, such as from Windows Explorer.

    Not

    Birden çok uygulama genelinde paylaşılan bir projeden (Windows Phone veya Microsoft Store gibi) öğeler eklediğinizde, bu öğeler geçerli etkin uygulama projesiyle haritada görüntülenir.When you add items from a project that's shared across multiple apps, like Windows Phone or Microsoft Store, those items appear on the map with the currently active app project. Bağlamı başka bir uygulama projesi olarak değiştirirseniz ve paylaşılan projeden daha fazla öğe eklerseniz, bu öğeler yeni etkin olan uygulama projesiyle görünür.If you change context to another app project and add more items from the shared project, those items now appear with the newly active app project. Eşleme üzerinde bir öğeyle gerçekleştirdiğiniz işlemler, yalnızca aynı bağlamı paylaşılan öğeler için geçerlidir.Operations that you perform with an item on the map apply only to those items that share the same context.

  3. Eşleme, seçili öğeleri kapsayan derlemeler içinde gösterir.The map shows the selected items within their containing assemblies.

    Haritada gruplar olarak gösterilen seçili öğeler

  4. Öğeleri araştırmak için bunları genişletin.To explore items, expand them. Fare işaretçisini bir öğenin üzerine taşıyın ve göründüğünde çift köşeli ayraç (aşağı ok) simgesine tıklayın.Move the mouse pointer on top of an item, then click the chevron (down arrow) icon when it appears.

    Kod haritasında bir düğümü genişletme

    Tüm öğeleri genişletmek için, CTRL + A'yı kullanarak bunları seçin, sonra haritanın kısayol menüsünü açın ve Grup > Genişlet' i seçin.To expand all items, select them using Ctrl+A, then open the shortcut menu for the map and choose Group > Expand. Ancak, tüm grupların genişletilmesi kullanılamaz bir eşleme veya bellek sorunları oluşturursa, bu seçenek kullanılamaz.However, this option isn't available if expanding all groups creates an unusable map or memory issues.

  5. İlgilendiğiniz öğeleri genişletmeye devam edin, gerekirse sınıf ve üye düzeyine doğru bir şekilde geçin.Continue to expand items you are interested in, right down to the class and member level if necessary.

    Grupları sınıfa ve üye düzeyine Genişlet

    Koddaki, ancak haritada görünmeyen üyeleri görmek için, Refetch Children  bir grubun sol üst köşesindeki tekrar al Children Icon tekrar al Children simgesine tıklayın.To see members that are in the code but don't appear on the map, click the Refetch Children icon Refetch Children Icon in the top left corner of a group.

  6. Haritadaki öğelerle ilgili daha fazla öğe görmek için, bir tane seçin ve kod Haritası araç çubuğunda ilgili öğe göster ' i seçin, ardından haritaya eklenecek ilgili öğelerin türünü seçin.To see more items related to those on the map, select one and choose Show Related on the code map toolbar, then select the type of related items to add to the map. Alternatif olarak, bir veya daha fazla öğe seçin, kısayol menüsünü açın ve ardından haritaya eklenecek ilgili öğelerin türünün göster seçeneğini seçin.Alternatively, select one or more items, open the shortcut menu, and then choose the Show option for the type of related items to add to the map. Örneğin:For example:

    Bir derlemeiçin şunları seçin:For an assembly, choose:

    SeçenekOption AçıklamaDescription
    Bu başvuruların derlemelerini gösterShow Assemblies This References Bu derlemenin başvurduğu derlemeleri ekleyin.Add assemblies that this assembly references. Dış derlemeler dışlar grubunda görünür.External assemblies appear in the Externals group.
    Buna başvuran derlemeleri gösterShow Assemblies Referencing This Çözümde bu derlemeye başvuran derlemeleri ekleyin.Add assemblies in the solution that reference this assembly.

    Bir ad alanıiçin, görünür değilse, içerilen derlemeyi göster' i seçin.For a namespace, choose Show Containing Assembly, if it's not visible.

    Bir sınıf veya arabirimiçin şunları seçin:For a class or interface, choose:

    SeçenekOption AçıklamaDescription
    Temel türleri gösterShow Base Types Bir sınıf için taban sınıfı ve uygulanan arabirimleri ekleyin.For a class, add the base class and the implemented interfaces.

    Bir arabirim için temel arabirimleri ekleyin.For an interface, add the base interfaces.
    Türetilmiş türleri gösterShow Derived Types Bir sınıf için türetilmiş sınıfları ekleyin.For a class, add the derived classes.

    Bir arabirim için türetilmiş arabirimleri ve uygulama sınıflarını veya yapılarını ekleyin.For an interface, add the derived interfaces and the implementing classes or structs.
    Bu başvuru türlerini gösterShow Types This References Tüm sınıfları ve bu sınıfın kullandığı üyeleri ekleyin.Add all classes and their members that this class uses.
    Buna başvuran türleri gösterShow Types Referencing This Tüm sınıfları ve bu sınıfı kullanan üyelerini ekleyin.Add all classes and their members that use this class.
    Içerilen ad alanını gösterShow Containing Namespace Üst ad alanını ekleyin.Add the parent namespace.
    Kapsayan ad alanını ve derlemeyi gösterShow Containing Namespace and Assembly Üst kapsayıcı hiyerarşisini ekleyin.Add the parent container hierarchy.
    Tüm temel türleri gösterShow All Base Types Yinelemeli olarak taban sınıf veya arabirim hiyerarşisi ekleyin.Add the base class or interface hierarchy recursively.
    Tüm türetilmiş türleri gösterShow All Derived Types Bir sınıf için tüm türetilmiş sınıfları yinelemeli olarak ekleyin.For a class, add all the derived classes recursively.

    Bir arabirim için türetilmiş tüm arabirimleri ve uygulama sınıflarını veya yapılarını yinelemeli olarak ekleyin.For an interface, add all the derived interfaces and implementing classes or structs recursively.

    Bir Yöntemiçin şunları seçin:For a method, choose:

    SeçenekOption AçıklamaDescription
    Bu çağrıların yöntemlerini gösterShow Methods This Calls Bu yöntemin çağırdığı yöntemleri ekleyin.Add methods that this method calls.
    Bu başvuruların alanlarını gösterShow Fields This References Bu yöntemin başvurduğu alanları ekleyin.Add fields that this method references.
    Kapsayan türü gösterShow Containing Type Üst türü ekleyin.Add the parent type.
    Kapsayan türü, ad alanını ve derlemeyi gösterShow Containing Type, Namespace, and Assembly Üst kapsayıcı hiyerarşisini ekleyin.Add the parent container hierarchy.
    Geçersiz kılınan yöntemleri gösterShow Overridden Methods Diğer yöntemleri geçersiz kılan veya bir arabirimin yöntemini uygulayan bir yöntem için geçersiz kılınan taban sınıflardaki tüm soyut ya da sanal yöntemleri ve varsa arabirimin uygulanan yöntemini ekleyin.For a method that overrides other methods or implements an interface's method, add all the abstract or virtual methods in base classes that are overridden and, if any, the interface's method that is implemented.

    Bir alan veya özellikiçin şunları seçin:For a field or property, choose:

    SeçenekOption AçıklamaDescription
    Kapsayan türü gösterShow Containing Type Üst türü ekleyin.Add the parent type.
    Kapsayan türü, ad alanını ve derlemeyi gösterShow Containing Type, Namespace, and Assembly Üst kapsayıcı hiyerarşisini ekleyin.Add the parent container hierarchy.

    Bu üye tarafından çağrılan yöntemleri göster

  7. Haritada ilişkiler gösterilmektedir.The map shows the relationships. Bu örnekte, eşleme yöntemi tarafından çağrılan yöntemleri Find ve çözüm veya dışarıdan konumunu gösterir.In this example, the map shows the methods called by the Find method and their location in the solution or externally.

    Kod haritasında belirli bağımlılıkları göster

  8. Haritayı basitleştirmek ve tek tek bölümlere odaklanmak için, kod Haritası araç çubuğunda Filtreler ' i seçin ve yalnızca ilgilendiğiniz düğümlerin ve bağlantıların türlerini seçin.To simplify the map and focus on individual parts, choose Filters on the code map toolbar and select just the types of nodes and links you are interested in. Örneğin, çözüm klasörlerinin, derlemelerin ve ad alanlarının görüntülenmesini devre dışı bırakın.For example, turn off display of Solution Folders, Assemblies, and Namespaces.

    Ekranı basitleştirmek için Filtre bölmesini kullanın

Ayrıca bkz.See also