MAPI solutions do not work because Outlook.exe is not properly registered under the \App Paths key in the Registry

Original KB number:   2698523

Symptoms

If you are using a custom MAPI solution (for example, an Outlook add-in), the solution may not work because Outlook.exe is not properly registered in the Windows registry.

Note

The actual problem you experience with the custom solution depends on how it uses the Outlook.exe registration information.

Cause

This problem can occur if Outlook.exe is not registered correctly under the following keys in the Windows registry:

  • 32-bit versions of Windows

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths

  • 64-bit versions of Windows

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\App Paths

If Outlook.exe is properly registered, you will find an \Outlook.exe subkey under the above key, and under the \Outlook.exe subkey you will find a string value called Path whose data references the correct path to Outlook.exe on your computer. The following figure shows the correct Outlook.exe registration on a 32-bit version of Windows.

The screenshot for the Outlook.exe registration

Note

The path to Outlook.exe on your computer may vary from the above figure if you installed Office in a non-default location.

Resolution

To resolve this problem, repair your installation of Office using the following steps:

  • Windows 7 or Windows Vista
    1. Exit Outlook.
    2. Select Start, and then select Control Panel.
    3. Then, select Programs and Features.
    4. In the list of installed products, select your Microsoft Office product and then select Change.
    5. Select Repair, and then select Continue.
  • Windows XP
    1. Exit outlook.
    2. On the Start menu, point to Settings, and then select Control Panel.
    3. Double-click Add/Remove Programs.
    4. In the list of currently installed programs, select your Microsoft Office product and then select Change.
    5. Select Repair, and then select Continue.