在 Microsoft Dynamics 365 中测试和启用邮箱时,无法确定邮箱位置时出现错误
本文提供了在 Microsoft Dynamics 365 中尝试测试和启用邮箱时发生的错误的解决方案。
适用于: Microsoft Dynamics 365 Customer Engagement Online
原始 KB 编号: 4513810
症状
尝试在 Dynamics 365 中测试和启用邮箱时,结果显示为失败,并出现以下错误警报:
"在发送电子邮件时无法确定邮箱位置"你的邮箱现已连接到 Dynamics 365"。 邮箱 [邮箱名称] 未同步。 已通知关联电子邮件服务器配置文件的所有者 [Email Server Profile Name]。
"接收电子邮件时无法确定邮箱 [邮箱名称] 的位置。 已通知关联电子邮件服务器配置文件 [Email Server Profile Name] 的所有者。 系统稍后将尝试再次接收电子邮件。"
原因
当 Exchange连接到本地服务器,且 Dynamics 365 中的电子邮件服务器配置文件记录配置为"自动发现服务器位置"设置为"是"时,可能会发生 此错误。 选择此选项后,您不会提供 web Exchange URL。 Dynamics 365 会尝试使用自动发现Exchange检索正确的位置。 如果自动发现服务出现问题或配置不正确,则可能会发生此错误。
解决方案
修复自动发现问题Exchange将"自动发现 服务器 位置"设置更改为 " 否",并提供Exchange Web 服务 URL。 使用以下步骤更改自动发现服务器位置设置。
- 作为具有系统管理员安全角色的用户访问 Dynamics 365 Web 应用程序。
- 导航到 "设置", 然后选择"电子邮件配置"。
- 选择 "电子邮件服务器配置文件"。
- 为本地配置打开Exchange配置文件记录。
- 将" 自动发现服务器位置" 设置更改为 "否"。
- 将"传入服务器位置" 和"传出 服务器位置"设置设置为 Exchange Web 服务 URL。
例如:https://mail.yourdomain.com/EWS/Exchange.asmx
- 选择“保存”。
- 尝试再次测试和启用邮箱。