一个仪表板在 2003.5 版发布后无法加载
本文提供了一个解决方案,用于解决 在 2003.5 版本发布后 一个 更新仪表板无法加载的问题。
适用于: Microsoft Dynamics 365 Customer Engagement Online
原始 KB 编号: 4558635
症状
更新到 2003.5 版本后,具有已配置为使用自定义控件 (例如,可编辑网格) 的子网格的仪表板不会在 一起加载。
仪表板可能卡在加载微调框上,或者它可能会显示一条常规错误消息:
("出现问题。 查看技术详细信息了解更多详细信息") 。
原因
当仪表板上存在已配置为使用自定义控件而非所有外形因素的子网格时,将引发此问题。 如果有自定义控件配置,但并非所有外形因素都有一个,则最终成为阻止仪表板加载的未处理空异常。
例如,控件配置可能如下所示:
或者,它可能是由不用于任何外形因素的控件配置导致的,如下所示:
解决方案
Bug 在 2004.3 版本中已修复。 但是,客户可以通过添加所有外形因素的控件配置来更早地解决该问题。
在某些情况下,使用的自定义控件可能不允许设置所有外形类型 (例如,无法为电话外形类型) 设置可编辑网格,或者客户可能希望将默认只读网格用于某些外形类型。 在这种情况下,此解决方法仍然适用,因为只读网格也可以选作自定义控件配置。
例如,可以将上述"原因"部分的第一个控制配置更改为类似这样的配置,以缓解此问题:
或者,如果由于未在任何外形设置上使用的控件配置而发生此问题,可以删除该控件配置。