UnknownIncomingEmailIntegrationError -2147220891 Microsoft Dynamics 365 中的邮箱警报中出现异常错误

本文提供了 Microsoft Dynamics 365 中邮箱警报内发生的错误的解决方案。

适用于:   Microsoft Dynamics 365
原始 KB 编号:   4466423

症状

在 Dynamics 365 中查看邮箱记录中的警报部分时,会看到下列邮件之一:

  • "通过邮箱接收电子邮件时发生未知 <Mailbox Name> 错误"。 已通知关联电子邮件服务器 <Profile Name> 配置文件的所有者。 系统稍后将尝试再次接收电子邮件。

    电子邮件服务器错误代码:Exchange 返回 UnknownIncomingEmailIntegrationError -2147220891异常。"

  • "同步邮箱的约会、联系人和任务时发生内部 Microsoft Dynamics 365 <Mailbox Name> 错误" "。 已通知关联电子邮件服务器 <Profile Name> 配置文件的所有者。 系统稍后将重试。

    电子邮件服务器错误代码: Crm.80040265.ISV 代码中止了操作。"

原因

错误代码80040265和 -2147220891指示 IsvAborted 错误。

如果看到"症状"部分中列出的第一封邮件,通常是由创建电子邮件记录时运行的工作流或自定义插件导致的。

如果看到"症状"部分中列出的第二条消息,通常是由创建约会、联系人或任务记录时运行的工作流或自定义插件导致的。

解决方案

检查是否有自定义插件或工作流,这些插件或工作流在创建错误记录类型时同步运行,例如 (类型。 电子邮件、约会、联系人或任务) 。 如果插件或工作流在记录创建过程中导致错误,Server-Side同步无法成功创建记录。 以下步骤可以帮助您确定组织是否有在电子邮件创建期间运行的工作流或插件。 如果无法创建记录类型,则相同的步骤可用于约会等其他实体:

工作流

  1. 在 Dynamics 365 Web 应用程序中,导航到 "设置", 然后选择"进程 "。

  2. 将视图更改为 "已激活进程"。

  3. 在" 主要实体 "列上排序,查找以 "电子邮件 "作为主要实体和" 工作流 "作为类别的任何行。

    相反,您可以使用网格中的筛选选项筛选 类别 = 工作流主实体 = 电子邮件

  4. 打开您找到的满足上述条件的每个 ((如果有) )。

  5. 如果选择了"创建记录选项时启动"选项,并且未选择"在后台运行此工作流 (推荐) "选项,则此工作流可能是原因。

  6. 选择 页面左侧 的"进程会话"部分,并查找与未成功创建的电子邮件相关的任何故障。

插件

  1. 在 Dynamics 365 Web 应用程序中,导航到设置自定义 ", 然后选择"自定义系统"。
  2. 选择 "Sdk 消息处理步骤"。
  3. "SdkMessage Filter ("列上) 对象类型代码排序,并查找 Email 实体的任何行。
  4. 如果发现任何行且执行模式为 Synchronous,则可能会干扰电子邮件的创建。

如果问题一直重现,并且可以暂时禁用工作流或插件作为测试,它可以允许你确定工作流或插件是原因。