如何在 Windows SERVER 2003 中0xC000021A STOP Windows 错误

本文介绍 STOP 错误的高级疑难0xC000021A步骤。

家庭用户:本文供支持代理和 IT 专业人员使用。 如果要在使用计算机时查找有关蓝屏错误代码的详细信息,请参阅蓝 屏错误疑难解答

适用于:  Windows 10 - 所有版本,Windows Server 2012 R2
原始 KB 编号:  156669

本文适用于高级计算机用户。 如果你对高级疑难解答不习惯,请询问某人帮助或联系技术支持人员。

在使用运行"适用于"部分中列出的操作系统之一的服务器或工作站时,您可能会收到以下错误消息:

STOP: c000021a {Fatal System Error}
登录Windows进程进程意外终止,状态为 0xc0000034 (0x00000000 0x0000000)
系统已关闭。

备注

括号中的参数特定于您的计算机配置,并且每次出现时可能有所不同。

原因

当0xC000021A或失败时,将Winlogon.exe STOP Csrss.exe错误。 当Windows NT内核检测到其中任一进程已停止时,它会停止系统并引发 STOP 0xC000021A错误。 此错误可能有几个原因,包括:

  • 已安装不匹配的系统文件。
  • Service Pack 安装失败。
  • 用于还原硬盘的备份程序未正确还原可能已被使用的文件。
  • 已安装不兼容的第三方程序。

解决方案

若要解决此问题,您必须确定哪些进程失败以及原因。

若要确定哪个进程失败,请注册 Dr. Watson 作为默认系统调试程序(如果它不是默认调试程序)。 Watson Windows NT将有关进程失败的诊断信息记录到 Drwtsn32.log 日志文件 Drwtsn32.log。 此外,还可以配置此程序以生成失败进程的内存转储文件。 然后,你可以分析调试器中的文件以确定进程失败的原因。

若要将 Dr. Watson 设置为捕获用户模式程序错误,请按照以下步骤操作:

  1. 在命令提示符下,Root\System32\Drwtsn32.exe -I", 然后按 Enter。

    此命令将 Dr. Watson 配置为默认系统调试程序。

  2. 在命令提示符下,Root\System32\Drwtsn32.exe"System Root\System32\Drwtsn32.exe", 然后选择以下选项:

    • 追加到现有日志文件
    • 创建故障转储
    • 可视通知
  3. 在计算机从 STOP 0xC000021A后,运行 Dr. Watson (Drwtsn32.exe) 。

  4. 查看 Dr. Watson 日志以确定可能导致该问题的用户模式进程。

  5. 如果 Dr. Watson 日志没有足够的信息来确定问题的原因,请分析 User.dmp 文件以确定 STOP 0xC000021A原因。

    如果 Watson Dr 没有为 Winlogon.exe 或 Csrss.exe 创建 User.dmp 文件,您可能必须使用不同的工具来生成失败进程的内存转储文件。 有关详细信息,请参阅以下文章:

    241215 如何使用 Userdump.exe 工具创建转储文件

    备注

    按照知识库文章中的说明对异常关闭的过程进行疑难解答。 在按照以下说明进行操作时,请监视以下过程以排查 STOP 0xC000021A错误:

    • Winlogon.exe
    • Csrss.exe

    大多数 STOP 0xC000021A错误发生,因为Winlogon.exe失败。 这通常发生在 GINA DLL 中错误的第三方图形标识 (身份验证) DLL。 GINA 是可加载的可Winlogon.exe组件。 GINA 实现交互式登录模型的身份验证策略。 GINA 执行所有标识和身份验证用户交互。

某些类型的远程控制软件通常将默认控件Windows GINA DLL (Msgina.dll) 。 一个很好的第一步是检查系统,以查看其是否具有第三方 GINA DLL。 为此,请找到以下注册表项:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\WinlogonValue = GinaDLL REG_SZ

  • 如果存在 Gina DLL 值,并且它是除 Msgina.dll 值外,这可能意味着第三方产品已更改此值。
  • 如果此值不存在,系统将 Msgina.dll作为默认 GINA DLL。 如果在安装新的或更新的设备驱动程序、系统服务或第三方程序后首次发生此错误,应删除或禁用新软件。 请与软件的制造商联系,以查看更新是否可用。

上次已知良好配置

如果本文中的上述步骤无法解决问题,则使用上一个已知的良好配置启动计算机。 若要使用上次已知的良好配置启动计算机,请按照以下步骤操作。

备注

由于存在多个版本的 Microsoft Windows,因此以下步骤可能不同于您的计算机。 如果是,请参阅产品文档以完成这些步骤。

  1. 选择 " > 开始""关闭"。

  2. 选择 "重新启动 > 确定"。

  3. 在指示的时间按 F8:

    • 对于基于 x86 的计算机:当出现文本屏幕然后消失时,按 F8。 (文本屏幕可能包括内存测试、有关 BIOS 的行和其他行。) 还可能会提示您何时按 F8。
    • 对于基于 Itanium 体系结构的计算机:从启动菜单中选择后,按 F8。 系统可能会提示你何时按 F8。
  4. 使用箭头键选择" 上次已知良好配置", 然后按 Enter。

    NUM LOCK 必须关闭,数字键盘上的箭头键才能正常工作。

  5. 使用箭头键突出显示操作系统,然后按 Enter。

备注

  • 选择"上次已知良好配置"启动选项可提供一种从问题(例如新添加的驱动程序)中恢复的方法,这些驱动程序对于硬件可能不正确。 但是,它不能解决由驱动程序或文件损坏或缺失导致的问题。
  • 选择"上次已知良好配置"选项时,仅还原注册表项 HKLM\System\CurrentControlSet 中的信息。 您在其他注册表项中做出的任何更改将保留。

使用恢复控制台删除不兼容的软件

如果本文中的上述步骤无法解决问题,则使用恢复控制台删除不兼容的软件。 介绍如何这样做的完整步骤不在本文的讨论范围之内。 但是,您可以使用以下文章作为指南:

816104如何使用 Windows Server 2003 中的恢复控制台替换驱动程序
326215如何在未启动的基于 Windows Server 2003 的计算机上使用恢复控制台
307654如何在 Windows XP 中安装和使用恢复控制台