嘗試安裝 Microsoft Dynamics 365 App for Outlook 時,GeneralIncomingEmailServerError

本文提供在嘗試安裝 Microsoft Dynamics 365 App for Outlook 時,可能會收到 GeneralIncomingEmailServerError 錯誤的問題解決方案。

適用於:Microsoft Dynamics CRM
原始 KB 編號: 4019040

徵狀

當您嘗試安裝 Microsoft Dynamics 365 App for Outlook 時,您會遇到下列錯誤:

嘗試將應用程式新增至 Outlook 時發生問題。

SoapException:GeneralIncomingEmailServerError

如果您選取 [ 詳細 資料] 連結,則會出現下列其他詳細資料:

錯誤:System.Web.Services.Protocols.SoapException:指定的伺服器版本無效。 at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse (SoapClientMessage message, WebResponse response, System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke (IA 上的 Stream responseStream、Boolean asyncCall) 在 Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndInstallApp (IAsyncResult asyncResult) 位於 Microsoft.Crm.Asynchronous.EmailConnector.OfficeAppsDeploymentStep.EndCall () 的 iAsyncResult) Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation ()

原因

如果您使用 Exchange 內部部署,且版本不符合需求,就會發生此錯誤。

解決方案

確認您使用的 Exchange 內部部署版本符合支援 Microsoft Exchange 設定中所述 的需求

注意事項

如果使用者的信箱位於支援的 Microsoft Exchange 版本,但您的組織已從舊版 Exchange 移轉,例如 Exchange Server 2010,如果您尚未移轉系統信箱,可能會發生此錯誤。 如需移動系統信箱的詳細資訊,請參閱 將 Exchange 2010 系統信箱移至 Exchange 2013