在 Microsoft Dynamics 365 中測試及啟用信箱時,出現信箱錯誤的傳送電子郵件時出現錯誤

本文提供當您嘗試在 Microsoft Dynamics 365 中測試及啟用信箱時發生的錯誤解決方案。

適用于:   Microsoft Dynamics 365
原始 KB 編號:   4092737

徵狀

當您嘗試在 Microsoft Dynamics 365 中測試及啟用信箱時,會收到下列錯誤:

「信箱傳送電子郵件時發生錯誤」連線至電子郵件伺服器時,您的信箱現在已連線至 Dynamics 365 "。 已通知相關電子郵件伺服器設定檔的擁有者 <Mailbox Name> 。 系統稍後會嘗試再次傳送電子郵件。
電子郵件伺服器錯誤碼: 網頁伺服器傳回 ConnectFailure 例外狀況。

原因

如果 Dynamics 365 無法連線到您的電子郵件伺服器,便會發生此錯誤。

如果您在內部部署 Exchange 使用 Dynamics 365 Online,則當您的防火牆不允許從 Dynamics 365 線上進行通訊時,可能會發生此問題。

如果您使用的是 SMTP/POP3 提供者(例如 Gmail),可能會發生此情況,如果電子郵件伺服器設定檔的 [高級] 區段中的埠值不正確。

解決方案

使用內部部署 Exchange 的 Dynamics 365 線上
確認您的防火牆允許從 Dynamics 365 線上進行通訊。 如需 Dynamics 365 可能使用的 ip 位址範圍清單,請參閱Microsoft Dynamics CRM Online IP 位址範圍

POP3/SMTP 提供者(例如 Gmail)
確認已指定正確的埠:

  1. 流覽至 [設定] [電子郵件 設定],然後選取 [電子郵件伺服器設定檔]。

  2. 開啟信箱會議所用的電子郵件伺服器設定檔此錯誤。

    注意

    您也可以選取錯誤訊息中的電子郵件伺服器設定檔名稱。 它會顯示為超連結,以開啟正確的電子郵件伺服器設定檔記錄。

  3. 選取 [ 高級]。

  4. 請確認 傳入的埠外寄埠 值,然後選取 [ 儲存]。

    注意

    連線至 SMTP 服務時,請參閱電子郵件供應商的檔,以取得正確的埠供使用。 對於 Gmail,傳入的 POP3 埠為995,而待發的 SMTP 埠為587。

  5. 選取 [ 信箱 ],然後選取接收錯誤的信箱。

  6. 選取 [ 測試 & 啟用信箱 ] 按鈕。

  7. 測試完成後,開啟信箱記錄並查看 [ 警示 ] 區段(如果結果未顯示為 [成功])。