UnknownIncomingEmailIntegrationError -2147220956例外狀況出現在 Microsoft Server-Side 同步處理警示內 Dynamics 365

本文提供 Microsoft Dynamics 365 信箱記錄內所發生錯誤的解決方案。

適用於:Microsoft Dynamics 365
原始 KB 編號: 4471762

徵狀

Dynamics 365 信箱記錄內會出現類似下列訊息的警告層級警示:

「透過信箱 」[Mailbox Name] “ 接收電子郵件時發生未知的錯誤。 已通知相關聯電子郵件伺服器設定檔 [配置檔名稱] 的擁有者。 系統稍後會嘗試再次收到電子郵件。

Email 伺服器錯誤碼:Exchange Server 傳回 UnknownIncomingEmailIntegrationError -2147220956 exception」。

原因

錯誤碼 -2147220956表示IsvUnexpected錯誤。 這通常表示自定義外掛程式或工作流程擲回錯誤,並導致專案建立失敗。

解決方案

下列步驟使用無法建立的電子郵件記錄範例。 如果您看到針對另一種類型的項目記錄此錯誤,例如約會、聯繫人或工作,可以將電子郵件的參考取代為您要進行疑難解答的記錄類型來套用相同類型的步驟。

檢查您是否有任何在建立電子郵件時同步執行的自訂外掛程式或工作流程。 如果外掛程式或工作流程造成錯誤,Server-Side 同步處理不會建立電子郵件。 下列步驟可協助您識別組織中是否有任何在建立電子郵件期間執行的工作流程或外掛程式:

工作流程

  1. 在 Dynamics 365 Web 應用程式中,流覽至 [設定],然後選取 [處理程式]

  2. 將檢視變更為 [已啟動的進程]

  3. 在 [主要實體] 數據行上排序,並尋找 Email 為主要實體和工作流程作為類別的任何數據列。

    相反地,您可以使用方格中的篩選選項來篩選 Category = Workflow 和 Primary Entity = Email

  4. 如果有任何) ,請開啟您發現符合上述準則的每個工作流程 (。

  5. 如果已選取 [建立記錄時啟動] 選項,而且未選取 [在背景執行此工作流程 (建議) 選項,則此工作流程可能是原因。

    注意事項

    如果您要使用約會、聯繫人或工作來針對這類錯誤進行疑難解答,也請檢查工作流程是否已設定為在該記錄類型的更新期間執行。

  6. 選取頁面左側的 [ 處理會話 ] 區段,並尋找與未成功建立的電子郵件相關的任何失敗。

外掛程式

  1. 在 Dynamics 365 Web 應用程式中,流覽至 [設定][自定義],然後選取 [自定義系統]
  2. 取 [Sdk 訊息處理步驟]
  3. 排序 [主要物件類型代碼] (SdkMessage 篩選) 數據行,並尋找 Email 實體的任何數據列。
  4. 如果您發現任何數據列且執行模式是同步的,則可能會干擾電子郵件的建立。

如果問題持續重現,而且可以暫時停用工作流程或外掛程式做為測試,這可讓您判斷工作流程或外掛程式是否為原因。