UnknownIncomingEmailIntegrationError-2147220956 例外狀況會出現在 Microsoft Dynamics 365 的 Server-Side 同步處理警示內

本文提供在 Microsoft Dynamics 365 信箱記錄中發生錯誤的解決方案。

適用于:   Microsoft Dynamics 365
原始 KB 編號:   4471762

徵狀

會出現一則警告層級警示,類似下列訊息會出現 Dynamics 365 信箱記錄中:

「透過信箱「[信箱名稱」接收電子郵件時發生未知錯誤。 已通知相關聯的電子郵件伺服器設定檔 [設定檔名稱] 的擁有者。 系統稍後會嘗試再次接收電子郵件。

電子郵件伺服器錯誤碼: Exchange Server 傳回 UnknownIncomingEmailIntegrationError-2147220956 例外狀況。

原因

錯誤碼-2147220956 表示 IsvUnexpected 錯誤。 這通常表示自訂外掛程式或工作流程引發錯誤,導致專案建立失敗。

解決方案

下列步驟會使用無法建立的電子郵件記錄的範例。 如果您針對另一種類型的專案(例如約會、連絡人或工作)看到記錄的此錯誤,則可以使用相同的步驟類型,取代您要進行疑難排解之記錄類型的電子郵件參考。

檢查是否有任何自訂的外掛程式或工作流程,可在建立電子郵件時同步執行。 如果外掛程式或工作流程導致錯誤,Server-Side 同步處理不會建立電子郵件。 下列步驟可協助您識別在組織中建立電子郵件的過程中,是否有任何工作流程或外掛程式在執行中:

工作流程

  1. 在 Dynamics 365 web 應用程式內,流覽至 [設定],然後選取 [處理 程式]。

  2. 變更為 啟用 程式的視圖。

  3. 在 [ 主要實體 ] 欄上排序,並尋找包含 電子郵件 作為主要實體和 工作流程 作為類別的任何列。

    相反地,您可以使用格線中的篩選選項來篩選類別 = 工作流程和主要實體 = 電子郵件

  4. 開啟每個找到的符合上述準則的工作流程 ((如果有的話)) 。

  5. 如果已選取 [ 開始時間 ] [ 建立記錄 ] 選項,且未選取 [在 後臺執行此工作流程 (建議) ] 選項,則此工作流程可能為原因。

    注意

    如果您要針對約會、連絡人或工作進行這種錯誤的疑難排解,也請檢查工作流程是否設定為在更新該類型的記錄期間執行。

  6. 選取頁面左側的 [ 進程會話 ] 區段,並尋找與未成功建立之電子郵件相關的任何失敗。

外掛程式

  1. 在 Dynamics 365 web 應用程式內,流覽至 [設定]、 [自訂], 然後選取 [自訂系統]。
  2. 選取 [ Sdk 郵件處理] 步驟
  3. 主要物件類型程式碼排序 (SdkMessage Filter) ] 欄,並尋找電子郵件實體的任何列。
  4. 如果您發現任何列,而且執行模式是同步的,就可能會干擾電子郵件的建立。

如果問題持續發生,而且可以暫時停用工作流程或外掛程式做為測試,可讓您判斷工作流程或外掛程式是否為原因。