新的 Operations Manager 代理程式的 Windows 作業系統欄包含未監控的狀態

本文可協助您在刪除代理程式後,針對 Windows 作業系統 欄的 [Windows 作業系統] 欄中的 [ 受監視 ] 狀態進行解決,然後在 Operations Manager 中建立具有相同 NetBIOS 名稱的新代理程式。

原始產品版本:   Microsoft System Center 2012 Operations Manager
原始 KB 編號:   979387

徵狀

在 System Center Operations Manager 的 Operations Manager 主控台中, Windows 作業系統 欄可能會具有新用戶端代理程式的 非監控 狀態。 此外,此狀態永遠不會變更為「 狀況良好」。

原因

因為新的代理程式與先前安裝的代理人具有相同的 NetBIOS 名稱,因此可能會發生此問題。 從 Operations Manager 刪除代理時,已刪除之代理程式的整理會在兩天之後進行硬編碼。 因此,代理程式不會立即完全從資料庫中徹底整理出來。

因應措施

若要在從主控台刪除舊的代理程式後解決此問題,請等候三天,然後將新的代理程式新增至 Operations Manager。 或者,請確定已超過兩天,然後將新的代理程式新增至 Operations Manager。

其他相關資訊

如果舊 NetBIOS 名稱中的資料不會從資料庫中進一步整理 ((例如從監控資料或狀態變更) 記錄檔),Operations Manager 會使用 NetBIOS 名稱來搜尋該資料庫中的部分資訊。

一面效果是,新代理程式的探索資料和探索的物件的狀態,會連結至舊 NetBIOS 名稱的實例。 因此,新代理程式的狀態不正確,而且 Operations Manager 主控台的 Windows 作業系統 欄可能會具有新代理程式的「 未監視 」狀態。