啟用失敗及 (非正版) 在大量授權 Windows 7 Service Pack 1 KMS 用戶端上的2019通知

本文提供的解決方案是使用者可能會收到 Windows 啟用或「Windows 不是正版」的通知,該問題是在 10:00 UTC (年1月 8 2019 日)開始或之後。

適用于:  Windows 7 Service Pack 1
原始 KB 編號:   4487266

摘要

本文適用于大量授權的 Windows 7 Service Pack 1 裝置,使用金鑰管理服務 (KMS) 啟用,且已安裝KB 971033更新。 有些使用者可能會收到「Windows 啟用」或「Windows 不是真品」的通知,其開始時間為10:00 年1月8日(即2019)。

在2019年1月9日,我們已恢復對 Microsoft 啟用和驗證服務器所做的變更。 針對繼續報告啟用和「非正版」通知的裝置,您應該依照解決一節中的步驟,移除KB 971033

支援大量授權啟用 Windows 版本包括下列各項:

  • Windows 7 專業版
  • Windows 7 專業版 N
  • Windows 7 專業版 E
  • Windows 7 企業版
  • Windows 7 企業版 N
  • Windows 7 企業版 E

針對經驗2019年1月8日不是由 Microsoft activation and 驗證服務器所導致之啟用和「非正版」錯誤的 Windows 版本,我們建議您遵循標準啟用疑難排解。

徵狀

  1. 您在登入之後,收到 Windows 不是正版的 錯誤訊息。

    Windows 的螢幕擷取畫面不是正版錯誤訊息。

  2. windows 的此副本不是正版 浮水印出現在 Windows 桌面的右下角,以黑底為單位。

    浮水印的螢幕擷取畫面會出現在 Windows 桌面的右下角。

  3. slmgr /dlv輸出報告錯誤0xC004F200。

    命令輸出的螢幕擷取畫面,它會報告錯誤0xC004F200。

  4. 使用 slmgr /ato 命令失敗所進行的啟動,會傳回下列訊息:

    Windows 在非正版通知週期內執行。 執行 ' slui.exe ' 以線上並驗證 Windows。

    使用命令之後傳回之訊息的螢幕擷取畫面。

  5. 下列事件會記錄在事件記錄檔中。

事件記錄檔 事件來源 事件識別碼 描述
應用程式 Microsoft Windows 安全性-SPP 8209 設定為應用程式識別碼55c92734-d682-4d71-983e-d6ec3f16059f 的正版狀態設定為非正版 (0x00000000)
應用程式 Microsoft Windows 安全性-SPP 8208 購買真品憑證失敗 (hr = 0xC004C4A2) 範本識別碼66c92734-d682-4d71-983e-d6ec3f16059f
應用程式 Windows 啟用技術 13 正版驗證結果: hrOffline = 0x00000000、hrOnline = 0xC004C4A2
應用程式 Microsoft Windows 安全性-SPP 8196 授權啟用排程程式 (sppuinotify.dll) 無法自動啟動。 錯誤碼:0xC004F200:

原因

最近對 Microsoft 啟用和驗證的更新,在已安裝KB971033的大量授權 Windows 7 用戶端上,意外導致「非正版」錯誤。 變更已于10:00:00 年1月 2019 8 日在 UTC 中引入,且已于2019年1月9日的 4:30:00 UTC 還原。

注意

這項時間與發行「1B」2019年1月更新 (kb 4480960KB 4480970) ,可在星期二的年1月8日2019)上發行。 這兩個事件不相關。

Windows 7 裝置上已安裝KB971033 ,但在變更 (10:00:00 年1月8日、2019) 和該變更的反轉期間之間未遇到此問題。 (4:30:00 UTC,年1月9日,2019) 應該不會出現本文所述的問題。

KB971033 包含下列文字:

「附注針對使用金鑰管理服務 (KMS) 或多重啟用金鑰 (MAK) 大量啟用的 Enterprise 客戶,我們一般建議不要將此更新安裝在其參考映射中或已部署的電腦。 此更新是以使用零售啟用 Windows 的消費者安裝為目標。

強烈建議您從所有大量授權的 Windows 7 裝置上卸載KB971033 。 這包括目前不會受到 [ 徵兆 ] 區段中所述問題影響的裝置。

解決方案

若要判斷是否已安裝 KB 971033 ,請使用下列其中一種方法。

  • 在 [控制台] 中開啟 [已安裝的更新 專案] (控制台 > 中 Windows 更新 > View Update history > 已安裝更新) ],然後在清單中尋找 Microsoft Windows (KB971033) 的更新

  • 在命令提示字元視窗中以系統管理員身分執行下列命令,然後在結果中尋找「Microsoft Windows-WindowsActivationTechnologies-package ~ 31bf3856ad364e35 ~ amd64 ~ ~ 7.1.7600.16395」。

    dism /online /get-packages
    
  • 在命令提示字元中執行下列命令,然後查看結果中是否有安裝 KB 971033 的指示:

    wmic qfe where HotFixID="KB971033"
    
  • 在 Windows PowerShell 中執行下列命令,然後查看結果中是否有安裝KB 971033的指示:

    Get-Hotfix -id KB971033
    

    如果目前已安裝 KB 971033 ,請使用下列其中一種方法來移除更新。 建議您在刪除更新之後,重新開機系統。

  • 在 [控制台] 中的 [已安裝的更新] 專案中 (控制台 > Windows 更新 > View Update history > 已安裝更新]) 中,以滑鼠右鍵按一下 [ Microsoft Windows 的更新] (KB971033)],然後選取 [卸載]。

  • 在命令提示字元視窗中,以系統管理員身分執行下列命令:

    wusa /uninstall /kb:971033
    
  • 在命令提示字元視窗中,以系統管理員身分執行下列命令:

    dism /online /Remove-Package /PackageName:Microsoft-Windows-Security-WindowsActivationTechnologies-Package~31bf3856ad364e35~amd64~~7.1.7600.16395
    

在卸載 KB 971033 之後,或不再顯示為已安裝之後,請重建啟用相關檔案,然後在 [命令提示字元] 視窗中,以系統管理員身分執行下列命令,以重新開機系統。

net stop sppuinotify
sc config sppuinotify start= disabled
net stop sppsvc
del %windir%\system32\7B296FB0-376B-497e-B012-9C450E1B7327-5P-0.C7483456-A289-439d-8115-601632D005A0 /ah
del %windir%\system32\7B296FB0-376B-497e-B012-9C450E1B7327-5P-1.C7483456-A289-439d-8115-601632D005A0 /ah
del %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform\tokens.dat
del %windir%\ServiceProfiles\NetworkService\AppData\Roaming\Microsoft\SoftwareProtectionPlatform\cache\cache.dat
net start sppsvc
cscript c:\windows\system32\slmgr.vbs /ipk <edition-specific KMS client key>
cscript c:\windows\system32\slmgr.vbs /ato
sc config sppuinotify start= demand

注意

在第一個 cscript 命令中,以實際按鍵取代 <edition-specific KMS client key> 。 如需詳細資訊,請參閱KMS Client Setup Keys

下表列出每個 Windows 7 版本的 KMS 用戶端機碼。

作業系統版本 KMS Client Setup Key
Windows 7 專業版 FJ82H-XT6CR-J8D7P-XQJJ2-GPDD4
Windows 7 專業版 N MRPKT-YTG23-K7D7T-X2JMM-QY7MG
Windows 7 專業版 E W82YF-2Q76Y-63HXB-FGJG9-GF7QX
Windows 7 企業版 33PXH-7Y6KF-2VJC9-XBBR8-HVTHH
Windows 7 企業版 N YDRBP-3D83W-TY26F-D46B2-XCKRJ
Windows 7 企業版 E C29WB-22CC8-VJ326-GHFJW-H9DH4

注意

  • 包含 KMS client setup 機碼的腳本必須以對應的作業系統版本為目標。
  • 如果服務未安裝 KB 971033 ,但遇到 [ 徵兆 ] 區段中所述的問題,您也可以重建啟用相關檔案,並使用重新啟用命令清單中所述的腳本重新開機系統。