Visual Studio 中的鍵盤快速鍵

適用于:yesVisual Studio no Visual Studio for Mac no Visual Studio Code

您可以選擇適當的鍵盤快速鍵,以在 Visual Studio 中存取各種 命令 和視窗。 此頁面會針對您可能已經在安裝 Visual Studio 時選擇的 [一般] 設定檔,列出預設命令捷徑。 無論您選擇哪一個設定檔,都可以開啟 [選項] 對話方塊、展開 [環境] 節點,然後選擇 [鍵盤] 來識別命令的快捷方式。 您也可以為指定的命令指派不同的捷徑,以自訂捷徑。

如需常用鍵盤快速鍵的清單和其他產能資訊,請參閱:

如需 Visual Studio 中協助工具的詳細資訊,請參閱 協助工具秘訣和訣竅如何:獨佔使用鍵盤

可列印快捷方式速查表

按一下以取得 Visual Studio 的可列印鍵盤快速鍵速查表

Printable cheatsheet for keyboard shortcuts.

除非另有指定,否則本節中的所有快捷方式都會全域套用。 「全域」內容表示快速鍵適用於 Visual Studio 中的任何工具視窗。

提示

您可以開啟 [選項] 對話方塊,展開 [環境] 節點,然後選擇 [鍵盤],以查看任何命令的捷徑

命令 鍵盤快速鍵 命令 ID
建置解決方案 Ctrl+Shift+B Build.BuildSolution
取消 Ctrl+Break Build.Cancel
編譯 Ctrl+F7 Build.Compile
在解決方案上執行程式碼分析 Alt+F11 Build.RunCodeAnalysisonSolution
命令 鍵盤快速鍵 [特殊內容] 命令 ID
遇到函數時中斷 Ctrl+B Debug.BreakatFunction
全部中斷 Ctrl+Alt+Break Debug.BreakAll
刪除所有中斷點 Ctrl+Shift+F9 Debug.DeleteAllBreakpoints
例外狀況 Ctrl+Alt+E Debug.Exceptions
快速監看 Ctrl+Alt+Q

Shift+F9
Debug.QuickWatch
重新啟動 Ctrl+Shift+F5 Debug.Restart
執行至游標處 Ctrl+F10 Debug.RunToCursor
設定下一個陳述式 Ctrl+Shift+F10 Debug.SetNextStatement
開始 F5 Debug.Start
啟動但不偵錯 Ctrl+F5 Debug.StartWithoutDebugging
逐步執行 F11 Debug.StepInto
跳出 Shift+F11 Debug.StepOut
逐程序 F10 Debug.StepOver
停止偵錯 Shift+F5 Debug.StopDebugging
切換中斷點 F9 Debug.ToggleBreakpoint
命令 鍵盤快速鍵 [特殊內容] 命令 ID
分行符號 Enter [文字編輯器、報表設計工具、Windows Form 設計工具]

Shift+Enter [文字編輯器]
Edit.BreakLine
折迭至定義 Ctrl+MCtrl+O [文字編輯器] Edit.CollapseToDefinitions
批註選取 Ctrl+KCtrl+C [文字編輯器] Edit.CommentSelection
自動完成文字 Alt+向右鍵 [文字編輯器,工作流程設計工具]

Ctrl+空格鍵 [文字編輯器、工作流程設計工具]

Ctrl+KW [工作流程設計工具]

Ctrl+K、Ctrl+W [工作流程設計工具]
Edit.CompleteWord
複製 Ctrl+C

Ctrl+Insert
Edit.Copy
剪下 Ctrl+X

Shift+Delete
Edit.Cut
刪除 刪除 [Team Explorer]

Shift+Delete [時序圖、UML 活動圖、圖層圖]

Ctrl+Delete [類別圖]
Edit.Delete
Find Ctrl+F Edit.Find
尋找所有參考 Shift+F12 Edit.FindAllReferences
檔案中尋找 Ctrl+Shift+F Edit.FindinFiles
尋找下一個 F3 Edit.FindNext
尋找下一個選取的專案 Ctrl+F3 Edit.FindNextSelected
格式化文件 Ctrl+K、Ctrl+D [文字編輯器] Edit.FormatDocument
格式選取項目 Ctrl+K、Ctrl+F [文字編輯器] Edit.FormatSelection
移至 Ctrl+G Edit.GoTo
移至宣告 Ctrl+F12 Edit.GoToDeclaration
移至定義 F12 Edit.GoToDefinition
移至尋找下拉式 Ctrl+D Edit.GoToFindCombo
移至下一個位置 F8 Edit.GoToNextLocation
插入程式碼片段 Ctrl+KCtrl+X Edit.InsertSnippet
插入索引標籤 Tab [報表設計工具、Windows Form 設計工具、文字編輯器] Edit.InsertTab
線條剪下 Ctrl+L [文字編輯器] Edit.LineCut
向下行擴充資料行 Shift+Alt+向下鍵 [文字編輯器] Edit.LineDownExtendColumn
開啟上方的線條 Ctrl+Enter [文字編輯器] Edit.LineOpenAbove
列出成員 Ctrl+J [文字編輯器、工作流程設計工具]

Ctrl+K、Ctrl+L [工作流程設計工具]

Ctrl+K、L [工作流程設計工具]
Edit.ListMembers
導覽至 Ctrl+、 Edit.NavigateTo
開啟檔案 Ctrl+Shift+G Edit.OpenFile
過度類型模式 插入 [文字編輯器] Edit.OvertypeMode
參數資訊 Ctrl+Shift+空格鍵 [文字編輯器、工作流程設計工具]

Ctrl+K、Ctrl+P [工作流程設計工具]

Ctrl+K、P [工作流程設計工具]
Edit.ParameterInfo
貼上 Ctrl+V

Shift+Insert
Edit.Paste
查看定義 Alt+F12 [文字編輯器] Edit.PeekDefinition
取消復原 Ctrl+Y

Shift+Alt+Backspace

Ctrl+Shift+Z
Edit.Redo
取代 Ctrl+H Edit.Replace
全選 Ctrl+A Edit.SelectAll
選取目前的字組 Ctrl+W [文字編輯器] Edit.SelectCurrentWord
選取範圍取消 Esc [文字編輯器, 報表設計師, 設定設計工具, Windows Forms 設計工具, Managed 資源編輯器] Edit.SelectionCancel
括住 Ctrl+K、Ctrl+S
(僅適用于 Visual Studio 2019 和更早版本)
Edit.SurroundWith
左標籤 Shift+Tab [文字編輯器、報表設計工具、Windows Form 編輯器] Edit.TabLeft
切換所有大綱 Ctrl+M、Ctrl+L [文字編輯器] Edit.ToggleAllOutlining
切換書籤 Ctrl+K、Ctrl+K [文字編輯器] Edit.ToggleBookmark
切換完成模式 Ctrl+Alt+空格鍵 [文字編輯器] Edit.ToggleCompletionMode
切換大綱展開 Ctrl+M、Ctrl+M [文字編輯器] Edit.ToggleOutliningExpansion
取消批註選取 Ctrl+K、Ctrl+U [文字編輯器] Edit.UncommentSelection
復原 Ctrl+Z

Alt+Backspace
Edit.Undo
Word 刪除至結尾 Ctrl+Delete [文字編輯器] Edit.WordDeleteToEnd
要啟動的 Word 刪除 Ctrl+退格鍵 [文字編輯器] Edit.WordDeleteToStart
命令 鍵盤快速鍵 [特殊內容] 命令 ID
結束 Alt+F4 File.Exit
新增檔案 Ctrl+N File.NewFile
新增專案 Ctrl+Shift+N File.NewProject
新增網站 Shift+Alt+N File.NewWebSite
開啟檔案 Ctrl+O File.OpenFile
開啟專案 Ctrl+Shift+O File.OpenProject
開啟網站 Shift+Alt+O File.OpenWebSite
重新命名 F2 [Team Explorer] File.Rename
全部儲存 Ctrl+Shift+S File.SaveAll
儲存選取的專案 Ctrl+S File.SaveSelectedItems
在瀏覽器中檢視 Ctrl+Shift+W File.ViewinBrowser
命令 鍵盤快速鍵 [特殊內容] 命令 ID
新增現有專案 Shift+Alt+A Project.AddExistingItem
新增項目 Ctrl+Shift+A Project.AddNewItem
Command 鍵盤快速鍵 [特殊內容] 命令 ID
擷取方法 Ctrl+R、Ctrl+M Refactor.ExtractMethod
Command 鍵盤快速鍵 [特殊內容] 命令 ID
附加至處理序 Ctrl+Alt+P Tools.AttachtoProcess
命令 鍵盤快速鍵 [特殊內容] 命令 ID
類別檢視 Ctrl+Shift+C View.ClassView
編輯標籤 F2 View.EditLabel
錯誤清單 Ctrl+\、Ctrl+E

Ctrl+\、E
View.ErrorList
向後巡覽 Ctrl+- View.NavigateBackward
向前流覽 Ctrl+Shift+- View.NavigateForward
物件瀏覽器 Ctrl+Alt+J View.ObjectBrowser
輸出 Ctrl+Alt+O View.Output
屬性視窗 F4 View.PropertiesWindow
重新整理 F5 [Team Explorer] View.Refresh
伺服器總管 Ctrl+Alt+S View.ServerExplorer
顯示智慧標籤 Ctrl+。

Shift+Alt+F10 [HTML 編輯器設計檢視]
View.ShowSmartTag
方案總管 Ctrl+Alt+L View.SolutionExplorer
TFS Team Explorer Ctrl+\、Ctrl+M View.TfsTeamExplorer
工具箱 Ctrl+Alt+X View.Toolbox
檢視程式碼 Enter [類別圖表]

F7 [設定設計工具]
View.ViewCode
檢視表設計工具 Shift+F7 [HTML 編輯器原始碼檢視] View.ViewDesigner
命令 鍵盤快速鍵 [特殊內容] 命令 ID
啟動文件視窗 Esc Window.ActivateDocumentWindow
關閉文件視窗 Ctrl+F4 Window.CloseDocumentWindow
下一個文件視窗 Ctrl+F6 Window.NextDocumentWindow
下一個文件視窗導覽 Ctrl+Tab Window.NextDocumentWindowNav
下一個分割窗格 F6 Window.NextSplitPane

全域快速鍵

這些鍵盤快速鍵都是全域的,也就是說,您可以在任何 Visual Studio 視窗有焦點時使用這些快速鍵。

分析:全域快捷方式

命令 鍵盤快速鍵 命令 ID
向後巡覽 Shift+Alt+3 Analyze.NavigateBackward
向前流覽 Shift+Alt+4 Analyze.NavigateForward

架構:全域快捷方式

命令 鍵盤快速鍵 命令 ID
新增圖表 Ctrl+\、Ctrl+N Architecture.NewDiagram

Azure:全域快捷方式

命令 鍵盤快速鍵 命令 ID
重試行動服務腳本作業 Ctrl+Num *、Ctrl+R WindowsAzure.RetryMobileServiceScriptOperation
顯示行動服務腳本錯誤詳細資料 Ctrl+Num *、Ctrl+D WindowsAzure.ShowMobileServiceScriptErrorDetails

組建:全域快捷方式

命令 鍵盤快速鍵 命令 ID
組建選取專案 Ctrl+B (Visual Studio 2019) Build.BuildSelection
建置解決方案 Ctrl+Shift+B Build.BuildSolution
取消 Ctrl+Break Build.Cancel
編譯 Ctrl+F7 Build.Compile
在解決方案上執行程式碼分析 Alt+F11 Build.RunCodeAnalysisonSolution

類別檢視操作功能表:全域快捷方式

命令 鍵盤快速鍵 命令 ID
屬性 Alt+Enter ClassViewContextMenus.ClassViewMultiselectProjectreferencesItems.Properties

偵錯:全域快捷方式

命令 鍵盤快速鍵 命令 ID
套用程式碼變更 Alt+F10 Debug.ApplyCodeChanges
附加至處理序 Ctrl+Alt+P Debug.AttachtoProcess
自動 Ctrl+Alt+V、A Debug.Autos
全部中斷 Ctrl+Alt+Break Debug.BreakAll
中斷點 Ctrl+Alt+B Debug.Breakpoints
呼叫堆疊 Ctrl+Alt+C Debug.CallStack
刪除所有中斷點 Ctrl+Shift+F9 Debug.DeleteAllBreakpoints
啟動 Alt+F2 Debug.DiagnosticsHub.Launch
反組譯碼 Ctrl+Alt+D Debug.Disassembly
Dom 總管 Ctrl+Alt+V、D Debug.DOMExplorer
啟用中斷點 Ctrl+F9 Debug.EnableBreakpoint
例外狀況 Ctrl+Alt+E Debug.Exceptions
函式中斷點 Ctrl+K、B (Visual Studio 2019)
Ctrl+B (Visual Studio 2017)
Debug.FunctionBreakpoint
移至先前的呼叫或 IntelliTrace 事件 Ctrl+Shift+F11 Debug.GoToPreviousCallorIntelliTraceEvent
啟動診斷 Alt+F5 Debug.Graphics.StartDiagnostics
立即 Ctrl+Alt+I Debug.Immediate
IntelliTrace 呼叫 Ctrl+Alt+Y、T Debug.IntelliTraceCalls
IntelliTrace 事件 Ctrl+Alt+Y、F Debug.IntelliTraceEvents
JavaScript 主控台 Ctrl+Alt+V、C Debug.JavaScriptConsole
本機 Ctrl+Alt+V、L Debug.Locals
進程下拉式 Ctrl+5 Debug.LocationToolbar.ProcessCombo
堆疊框架下拉式 Ctrl+7 Debug.LocationToolbar.StackFrameCombo
執行緒下拉式 Ctrl+6 Debug.LocationToolbar.ThreadCombo
切換目前的執行緒標幟狀態 Ctrl+8 Debug.LocationToolbar.ToggleCurrentThreadFlaggedState
切換標幟的執行緒 Ctrl+9 Debug.LocationToolbar.ToggleFlaggedThreads
記憶體 1 Ctrl+Alt+M、1 Debug.Memory1
記憶體 2 Ctrl+Alt+M、2 Debug.Memory2
記憶體 3 Ctrl+Alt+M、3 Debug.Memory3
記憶體 4 Ctrl+Alt+M、4 Debug.Memory4
單元 Ctrl+Alt+U Debug.Modules
平行堆疊 Ctrl+Shift+D、S Debug.ParallelStacks
平行監看式 1 Ctrl+Shift+D、1 Debug.ParallelWatch1
平行監看式 2 Ctrl+Shift+D、2 Debug.ParallelWatch2
平行監看式 3 Ctrl+Shift+D、3 Debug.ParallelWatch3
平行監看式 4 Ctrl+Shift+D、4 Debug.ParallelWatch4
處理序 Ctrl+Alt+Z Debug.Processes
快速監看 Shift+F9Ctrl+Alt+Q Debug.QuickWatch
重新附加至進程 Shift+Alt+P Debug.ReattachtoProcess
重新整理 windowsapp Ctrl+Shift+R Debug.RefreshWindowsapp
暫存器 Ctrl+Alt+G Debug.Registers
重新啟動 Ctrl+Shift+F5 Debug.Restart
執行至游標處 Ctrl+F10 Debug.RunToCursor
設定下一個陳述式 Ctrl+Shift+F10 Debug.SetNextStatement
在程式碼對應上顯示呼叫堆疊 Ctrl+Shift+' Debug.ShowCallStackonCodeMap
顯示下一個陳述式 Alt+Num * Debug.ShowNextStatement
開始 F5 Debug.Start
啟動 Windows Phone 應用程式分析 Alt+F1 Debug.StartWindowsPhoneApplicationAnalysis
啟動但不偵錯 Ctrl+F5 Debug.StartWithoutDebugging
逐步執行 F11 Debug.StepInto
逐步執行目前的程式 Ctrl+Alt+F11 Debug.StepIntoCurrentProcess
逐步執行特定 Shift+Alt+F11 Debug.StepIntoSpecific
跳出 Shift+F11 Debug.StepOut
逐步執行目前的程式 Ctrl+Shift+Alt+F11 Debug.StepOutCurrentProcess
逐程序 F10 (偵錯時:執行動作) Debug.StepOver
逐程序 F10 (未偵錯時:在使用者程式碼的第一行啟動偵錯並停止) Debug.StepOver
逐步執行目前的程式 Ctrl+Alt+F10 Debug.StepOverCurrentProcess
停止偵錯 Shift+F5 Debug.StopDebugging
停止效能分析 Shift+Alt+F2 Debug.StopPerformanceAnalysis
工作 Ctrl+Shift+D、K Debug.Tasks
執行緒 Ctrl+Alt+H Debug.Threads
切換中斷點 F9 Debug.ToggleBreakpoint
切換反組解碼 Ctrl+F11 Debug.ToggleDisassembly
監看式 1 Ctrl+Alt+W、1 Debug.Watch1
監看 2 Ctrl+Alt+W、2 Debug.Watch2
監看 3 Ctrl+Alt+W、3 Debug.Watch3
監看 4 Ctrl+Alt+W、4 Debug.Watch4

偵錯工具操作功能表:全域快捷方式

命令 鍵盤快速鍵 命令 ID
刪除 Alt+F9、D DebuggerContextMenus.BreakpointsWindow.Delete
移至反組解碼 Alt+F9、A DebuggerContextMenus.BreakpointsWindow.GoToDisassembly
移至原始程式碼 Alt+F9、S DebuggerContextMenus.BreakpointsWindow.GoToSourceCode

診斷中樞:全域快捷方式

Command 鍵盤快速鍵 命令 ID
停止收集 Ctrl+Alt+F2 DiagnosticsHub.StopCollection

編輯:全域快捷方式

命令 鍵盤快速鍵 命令 ID
複製 Ctrl+C



Ctrl+Ins
Edit.Copy
剪下 Ctrl+X



Shift+Delete
Edit.Cut
迴圈剪貼簿通道 Ctrl+Shift+V



Ctrl+Shift+Ins
Edit.CycleClipboardRing
刪除 刪除 Edit.Delete
重複 Ctrl+D Edit.Duplicate
Find Ctrl+F Edit.Find
尋找所有參考 Shift+F12 Edit.FindAllReferences
檔案中尋找 Ctrl+Shift+F Edit.FindinFiles
尋找下一個 F3 Edit.FindNext
尋找下一個選取的專案 Ctrl+F3 Edit.FindNextSelected
尋找上一個 Shift+F3 Edit.FindPrevious
尋找先前選取的專案 Ctrl+Shift+F3 Edit.FindPreviousSelected
產生方法 Ctrl+K、Ctrl+M Edit.GenerateMethod
移至 Ctrl+G Edit.GoTo
移至全部 Ctrl+,Ctrl+T Edit.GoToAll
移至宣告 Ctrl+F12 Edit.GoToDeclaration
移至定義 F12 Edit.GoToDefinition
移至成員 Ctrl+1、Ctrl+MCtrl+1、MAlt+\ Edit.GoToMember
移至下一個位置 F8 (錯誤清單或 [輸出] 視窗中的下一個錯誤) Edit.GoToNextLocation
移至上一個位置 Shift+F8 (錯誤清單或 [輸出] 視窗中的上一個錯誤) Edit.GoToPrevLocation
插入程式碼片段 Ctrl+K、Ctrl+X Edit.InsertSnippet
向下移動控制項 Ctrl+向下鍵 Edit.MoveControlDown
將控制項向下移動格線 向下箭號 Edit.MoveControlDownGrid
向左移動控制項 Ctrl+向左鍵 Edit.MoveControlLeft
移動控制項左方格 向左鍵 Edit.MoveControlLeftGrid
向右移動控制項 Ctrl+向右鍵 Edit.MoveControlRight
移動控制項右方格 向右鍵 Edit.MoveControlRightGrid
向上移動控制項 Ctrl+向上鍵 Edit.MoveControlUp
將控制項向上移動格線 向上箭號 Edit.MoveControlUpGrid
下一個書籤 Ctrl+K、Ctrl+N Edit.NextBookmark
資料夾中的下一個書簽 Ctrl+Shift+K、Ctrl+Shift+N Edit.NextBookmarkInFolder
開啟檔案 Ctrl+Shift+G (開啟資料指標底下的檔案名稱) Edit.OpenFile
貼上 Ctrl+V



Shift+Ins
Edit.Paste
上一個書籤 Ctrl+K、Ctrl+P Edit.PreviousBookmark
資料夾中的上一個書簽 Ctrl+Shift+K、Ctrl+Shift+P Edit.PreviousBookmarkInFolder
快速尋找符號 Shift+Alt+F12 Edit.QuickFindSymbol
取消復原 Ctrl+Y



Ctrl+Shift+Z



Shift+Alt+退格鍵
Edit.Redo
重新整理遠端參考 Ctrl+Shift+J Edit.RefreshRemoteReferences
取代 Ctrl+H Edit.Replace
在檔案中取代 Ctrl+Shift+H Edit.ReplaceinFiles
全選 Ctrl+A Edit.SelectAll
選取下一個控制項 Tab Edit.SelectNextControl
選取上一個控制項 Shift+Tab Edit.SelectPreviousControl
顯示圖格格線 Enter Edit.ShowTileGrid
縮小大小控制 Ctrl+Shift+向下鍵 Edit.SizeControlDown
大小控制向下格線 Shift+向下鍵 Edit.SizeControlDownGrid
左方大小控制 Ctrl+Shift+向左鍵 Edit.SizeControlLeft
大小控制左方格 Shift+向左鍵 Edit.SizeControlLeftGrid
正確調整大小控制 Ctrl+Shift+向右鍵 Edit.SizeControlRight
大小控制右方格 Shift+向右鍵 Edit.SizeControlRightGrid
增加大小控制 Ctrl+Shift+向上鍵 Edit.SizeControlUp
大小控制向上方格 Shift+向上鍵 Edit.SizeControlUpGrid
停止搜尋 Alt+F3、S Edit.StopSearch
括住 Ctrl+K、Ctrl+S
(僅適用于 Visual Studio 2019 和更早版本)
Edit.SurroundWith
復原 Ctrl+Z



Alt+Backspace
Edit.Undo

編輯器操作功能表:全域快捷方式

命令 鍵盤快速鍵 命令 ID
中斷點條件 Alt+F9、C EditorCoNtextMenus.CodeWindow.Breakpoint.BreakpointConditions
中斷點編輯標籤 Alt+F9、L EditorContextMenus.CodeWindow.Breakpoint.BreakpointEditlabels
插入暫時中斷點 Shift+Alt+F9、T EditorCoNtextMenus.CodeWindow.Breakpoint.InsertTemporaryBreakpoint
顯示專案 Ctrl+' EditorContextMenus.CodeWindow.CodeMap.ShowItem
執行 Ctrl+Alt+F5 EditorContextMenus.CodeWindow.Execute
移至檢視 Ctrl+M、Ctrl+G EditorContextMenus.CodeWindow.GoToView
切換頭程式碼檔案 Ctrl+K、Ctrl+O (字母 'O') EditorContextMenus.CodeWindow.ToggleHeaderCodeFile
檢視呼叫階層 Ctrl+K、Ctrl+T



Ctrl+K、T
EditorContextMenus.CodeWindow.ViewCallHierarchy

檔案:全域快捷方式

命令 鍵盤快速鍵 命令 ID
結束 Alt+F4 File.Exit
新增檔案 Ctrl+N File.NewFile
新增專案 Ctrl+Shift+N File.NewProject
新增網站 Shift+Alt+N File.NewWebSite
開啟檔案 Ctrl+O (字母 'O') File.OpenFile
開啟專案 Ctrl+Shift+O (字母 'O') File.OpenProject
開啟網站 Shift+Alt+O (字母 'O') File.OpenWebSite
列印 Ctrl+P File.Print
全部儲存 Ctrl+Shift+S File.SaveAll
儲存選取的專案 Ctrl+S File.SaveSelectedItems
在瀏覽器中檢視 Ctrl+Shift+W File.ViewinBrowser

說明:全域快捷方式

命令 鍵盤快速鍵 命令 ID
新增和移除說明內容 Ctrl+Alt+F1 Help.AddandRemoveHelpContent
F1 說明 F1 Help.F1Help
檢視說明 Ctrl+F1 Help.ViewHelp
視窗說明 Shift+F1 Help.WindowHelp

負載測試:全域快捷方式

Command 鍵盤快速鍵 命令 ID
跳至計數器窗格 Ctrl+R、Q LoadTest.JumpToCounterPane

其他操作功能表:全域快捷方式

Command 鍵盤快速鍵 命令 ID
新增圖表 插入 OtherContextMenus.MicrosoftDataEntityDesignContext.AddNewDiagram

專案:全域快捷方式

命令 鍵盤快速鍵 命令 ID
新增現有專案 Shift+Alt+A Project.AddExistingItem
新增項目 Ctrl+Shift+A Project.AddNewItem
類別精靈 Ctrl+Shift+X Project.ClassWizard
覆寫 Ctrl+Alt+Ins Project.Override
預覽變更 Alt+; 然後 Alt+C Project.Previewchanges
發佈選取的檔案 Alt+; 然後 Alt+P Project.Publishselectedfiles
從伺服器取代選取的檔案 Alt+; 然後 Alt+R Project.Replaceselectedfilesfromserver

專案和方案操作功能表:全域快捷方式

命令 鍵盤快速鍵 命令 ID
下移 Alt+向下鍵 ProjectandSolutionContextMenus.Item.MoveDown
上移 Alt+向上箭 ProjectandSolutionContextMenus.Item.MoveUp

重構:全域快捷方式

命令 鍵盤快速鍵 命令 ID
封裝欄位 Ctrl+R、Ctrl+E Refactor.EncapsulateField
擷取介面 Ctrl+R、Ctrl+I Refactor.ExtractInterface
擷取方法 Ctrl+R、Ctrl+M Refactor.ExtractMethod
移除參數 Ctrl+R、Ctrl+V Refactor.RemoveParameters
重新命名 Ctrl+R、Ctrl+R Refactor.Rename
重新排序參數 Ctrl+R、Ctrl+O (字母 'O') Refactor.ReorderParameters

方案總管:全域快捷方式

命令 鍵盤快速鍵 命令 ID
開啟檔案篩選 Ctrl+[O (字母 'O')



Ctrl+[Ctrl+O (字母 'O')
SolutionExplorer.OpenFilesFilter
擱置的變更篩選 Ctrl+[P



Ctrl+[Ctrl+P
SolutionExplorer.PendingChangesFilter
與使用中檔同步 Ctrl+[S



Ctrl+[Ctrl+S
SolutionExplorer.SyncWithActiveDocument

小組:全域快捷方式

命令 鍵盤快速鍵 命令 ID
移至 Git 分支 Ctrl+0 (零)、Ctrl+N



Ctrl+0、N
Team.Git.GoToGitBranches
移至 Git 變更 Ctrl+0 (零)、Ctrl+G



Ctrl+0、G
Team.Git.GoToGitChanges
移至 Git 認可 Ctrl+0 (零)、Ctrl+O (字母 'O')



Ctrl+0、O
Team.Git.GoToGitCommits
Team Explorer 搜尋 Ctrl+' Team.TeamExplorerSearch

Team Foundation 操作功能表:全域快捷方式

命令 鍵盤快速鍵 命令 ID
移至組建 Ctrl+0 (零)、Ctrl+B



Ctrl+0、B
TeamFoundationContextMenus.Commands.GoToBuilds
移至連線 Ctrl+0 (零)、Ctrl+C



Ctrl+0、C
TeamFoundationContextMenus.Commands.GoToConnect
移至檔 Ctrl+0 (零)、Ctrl+D



Ctrl+0、D
TeamFoundationContextMenus.Commands.GoToDocuments
移至首頁 Ctrl+0 (零)、Ctrl+H



Ctrl+0、H
TeamFoundationContextMenus.Commands.GoToHome
移至我的工作 Ctrl+0 (零)、Ctrl+M



Ctrl+0、M
TeamFoundationContextMenus.Commands.GoToMyWork
移至擱置中的變更 Ctrl+0 (零)、Ctrl+P



Ctrl+0、P
TeamFoundationContextMenus.Commands.GoToPendingChanges
移至報表 Ctrl+0 (零)、Ctrl+R



Ctrl+0、R
TeamFoundationContextMenus.Commands.GoToReports
移至設定 Ctrl+0 (零)、Ctrl+S



Ctrl+0、S
TeamFoundationContextMenus.Commands.GoToSettings
移至 Web 存取 Ctrl+0 (零)、Ctrl+A



Ctrl+0、A
TeamFoundationContextMenus.Commands.GoToWebAccess
移至工作專案 Ctrl+0 (零)、Ctrl+W



Ctrl+0、W
TeamFoundationContextMenus.Commands.GoToWorkItems

測試:全域快捷方式

命令 鍵盤快速鍵 命令 ID
使用自動程式化 UI 測試產生器 Ctrl+\、Ctrl+C Test.UseCodedUITestBuilder
使用現有的動作錄製 Ctrl+\、Ctrl+A Test.UseExistingActionRecording

測試總管:全域快捷方式

命令 鍵盤快速鍵 命令 ID
偵錯所有測試 Ctrl+R、Ctrl+A TestExplorer.DebugAllTests
偵錯內容中的所有測試 Ctrl+R、Ctrl+T TestExplorer.DebugAllTestsInContext
偵錯上次執行 Ctrl+R、D TestExplorer.DebugLastRun
重複上次執行 Ctrl+R、L TestExplorer.RepeatLastRun
執行所有測試 Ctrl+R、A TestExplorer.RunAllTests
在內容中執行所有測試 Ctrl+R、T TestExplorer.RunAllTestsInContext
顯示測試總管 Ctrl+E、T TestExplorer.ShowTestExplorer
開啟索引標籤 Ctrl+E、L LiveUnitTesting.OpenTab
程式碼涵蓋範圍結果 Ctrl+E、C Test.CodeCoverageResults

工具:全域快捷方式

命令 鍵盤快速鍵 命令 ID
附加至處理序 Ctrl+Alt+P Tools.AttachtoProcess
程式碼片段管理員 Ctrl+K、Ctrl+B Tools.CodeSnippetsManager
強制 gc Ctrl+Shift+Alt+F12、Ctrl+Shift+Alt+F12 Tools.ForceGC

檢視:全域快捷方式

命令 鍵盤快速鍵 命令 ID
所有視窗 Shift+Alt+M View.AllWindows
架構總管 Ctrl+\、Ctrl+R View.ArchitectureExplorer
一層 Alt+向左鍵 (不同於文字編輯器中 View.NavigateBackward 的功能) View.Backward
書簽視窗 Ctrl+K、Ctrl+W View.BookmarkWindow
流覽下一個 Ctrl+Shift+1 View.BrowseNext
流覽上一個 Ctrl+Shift+2 View.BrowsePrevious
呼叫階層 Ctrl+Alt+K View.CallHierarchy
類別檢視 Ctrl+Shift+C View.ClassView
類別檢視移至搜尋下拉式 Ctrl+K、Ctrl+V View.ClassViewGoToSearchCombo
程式碼定義視窗 Ctrl+\、D



Ctrl+\、Ctrl+D
View.CodeDefinitionWindow
命令視窗 Ctrl+Alt+A View.CommandWindow
資料來源 Shift+Alt+D View.DataSources
檔大綱 Ctrl+Alt+T View.DocumentOutline
編輯標籤 F2 View.EditLabel
錯誤清單 Ctrl+\、E



Ctrl+\、Ctrl+E
View.ErrorList
F# Interactive Ctrl+Alt+F View.F#Interactive
尋找符號結果 Ctrl+Alt+F12 View.FindSymbolResults
轉寄 Alt+向右鍵 (與 [文字編輯器] 中的 View.NavigateForward 不同) View.Forward
向前流覽內容 Ctrl+Shift+7 View.ForwardBrowseContext
全螢幕 Shift+Alt+Enter View.FullScreen
向後巡覽 Ctrl+- View.NavigateBackward
向前流覽 Ctrl+Shift+- View.NavigateForward
下一個錯誤 Ctrl+Shift+F12 View.NextError
通知 Ctrl+W、N



Ctrl+W、Ctrl+N
View.Notifications
物件瀏覽器 Ctrl+Alt+J View.ObjectBrowser
物件瀏覽器移至搜尋下拉式 Ctrl+K、Ctrl+R View.ObjectBrowserGoToSearchCombo
輸出 Ctrl+Alt+O (字母 'O') View.Output
快顯流覽內容 Ctrl+Shift+8 (僅限 C++) View.PopBrowseContext
屬性視窗 F4 View.PropertiesWindow
「屬性頁」 Shift+F4 View.PropertyPages
資源檢視 Ctrl+Shift+E View.ResourceView
伺服器總管 Ctrl+Alt+S View.ServerExplorer
顯示智慧標籤 Shift+Alt+F10



Ctrl+。
View.ShowSmartTag
方案總管 Ctrl+Alt+L View.SolutionExplorer
SQL Server 物件總管 Ctrl+\、Ctrl+S View.SQLServerObjectExplorer
工作清單 Ctrl+\、T



Ctrl+\、Ctrl+T
View.TaskList
TFS 小組總管 Ctrl+\、Ctrl+M View.TfsTeamExplorer
工具箱 Ctrl+Alt+X View.Toolbox
UML 模型總管 Ctrl+\、Ctrl+U View.UMLModelExplorer
檢視程式碼 F7 View.ViewCode
檢視表設計工具 Shift+F7 View.ViewDesigner
網頁瀏覽器 Ctrl+Alt+R View.WebBrowser
放大 Ctrl+Shift+。 View.ZoomIn
縮小 Ctrl+Shift+、 View.ZoomOut
顯示測試總管 Ctrl+E、T TestExplorer.ShowTestExplorer

視窗:全域快捷方式

命令 鍵盤快速鍵 命令 ID
啟動文件視窗 Esc Window.ActivateDocumentWindow
將索引標籤新增至選取範圍 Ctrl+Shift+Alt+空格鍵 Window.AddTabtoSelection
關閉文件視窗 Ctrl+F4 Window.CloseDocumentWindow
關閉工具視窗 Shift+Esc Window.CloseToolWindow
保持索引標籤開啟 Ctrl+Alt+Home Window.KeepTabOpen
移至導覽列 Ctrl+F2 Window.MovetoNavigationBar
下一個文件視窗 Ctrl+F6 Window.NextDocumentWindow
下一個文件視窗導覽 Ctrl+Tab Window.NextDocumentWindowNav
下一個窗格 Alt+F6 Window.NextPane
下一個分割窗格 F6 Window.NextSplitPane
下一個 Tab 點 Ctrl+Alt+PgDn



Ctrl+PgDn
Window.NextTab
下一個索引標籤並新增至選取範圍 Ctrl+Shift+Alt+PgDn Window.NextTabandAddtoSelection
下一個工具視窗導覽 Alt+F7 Window.NextToolWindowNav
上一個文件視窗 Ctrl+Shift+F6 Window.PreviousDocumentWindow
上一個文件視窗導覽 Ctrl+Shift+Tab Window.PreviousDocumentWindowNav
上一個窗格 Shift+Alt+F6 Window.PreviousPane
上一個分割窗格 Shift+F6 Window.PreviousSplitPane
上一個 Tab 點 Ctrl+Alt+PgUp



Ctrl+PgUp
Window.PreviousTab
上一個索引標籤並新增至選取範圍 Ctrl+Shift+Alt+PgUp Window.PreviousTabandAddtoSelection
上一個工具視窗導覽 Shift+Alt+F7 Window.PreviousToolWindowNav
快速啟動 Ctrl+Q Window.QuickLaunch
快速啟動上一個類別 Ctrl+Shift+Q Window.QuickLaunchPreviousCategory
顯示停駐功能表 Alt+- Window.ShowDockMenu
顯示 Ex MDI 檔案清單 Ctrl+Alt+向下鍵 Window.ShowEzMDIFileList
方案總管搜尋 Ctrl+; Window.SolutionExplorerSearch
視窗搜尋 Alt+' Window.WindowSearch

內容特定的快捷方式

這些鍵盤快速鍵是內容特定的,這表示您可以使用它們搭配 Visual Studio 中的功能表和專案,而這些專案是專案類型、程式設計語言或平臺特有的。

ADO.NET 實體資料模型設計工具:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
向下 Alt+向下鍵 OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.Down
向下 5 Alt+PgDn OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.Down5
置底 Alt+End OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.ToBottom
置頂 Alt+Home OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.ToTop
上移 Alt+向上箭 OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.Up
最多 5 個 Alt+PgUp OtherContextMenus.MicrosoftDataEntityDesignContext.MoveProperties.Up5
重新命名 Ctrl+R、R OtherContextMenus.MicrosoftDataEntityDesignContext.Refactor.Rename
從圖表移除 Shift+Del OtherContextMenus.MicrosoftDataEntityDesignContext.RemovefromDiagram
實體資料模型瀏覽器 Ctrl+1 View.EntityDataModelBrowser
實體資料模型對應詳細資料 Ctrl+2 View.EntityDataModelMappingDetails

類別圖表:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
摺疊 Num - ClassDiagram.Collapse
展開 Num + ClassDiagram.Expand
刪除 Ctrl+Del Edit.Delete
展開折迭基底類型清單 Shift+Alt+B Edit.ExpandCollapseBaseTypeList
流覽至 lollipop Shift+Alt+L Edit.NavigateToLollipop
從圖表移除 刪除 Edit.RemovefromDiagram
檢視程式碼 Enter View.ViewCode

自動程式化 UI 測試編輯器:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
複製剪貼簿的參考 Ctrl+C OtherContextMenus.UITestEditorContextMenu.CopyReferencetoClipboard
在 之前插入延遲 Ctrl+Alt+D OtherContextMenus.UITestEditorContextMenu.InsertDelayBefore
找出全部 Shift+Alt+L OtherContextMenus.UITestEditorContextMenu.LocateAll
找出 ui 控制項 Ctrl+Shift+L OtherContextMenus.UITestEditorContextMenu.LocatetheUIControl
移動程式碼 Ctrl+Alt+C OtherContextMenus.UITestEditorContextMenu.Movecode
分割成新的方法 Ctrl+Shift+T OtherContextMenus.UITestEditorContextMenu.Splitintoanewmethod

資料集編輯器:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
插入資料行 插入 OtherContextMenus.ColumnContext.InsertColumn
資料行 Ctrl+L OtherContextMenus.DbTableContext.Add.Column

差異檢視器:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
忽略修剪空白字元 Ctrl+\、Ctrl+空格鍵 Diff.IgnoreTrimWhitespace
內嵌檢視 Ctrl+\、Ctrl+1 Diff.InlineView
僅左側檢視 Ctrl+\、Ctrl+3 Diff.LeftOnlyView
[下一項差異] F8 Diff.NextDifference
[前一項差異] Shift+F8 Diff.PreviousDifference
僅限右方檢視 Ctrl+\、Ctrl+4 Diff.RightOnlyView
並排檢視 Ctrl+\、Ctrl+2 Diff.SideBySideView
在左與右之間切換 Ctrl+\、Ctrl+Tab Diff.SwitchBetweenLeftAndRight
同步檢視切換 Ctrl+\、Ctrl+向下鍵 Diff.SynchronizeViewToggle
加入註解 Ctrl+Shift+K EditorContextMenus.CodeWindow.AddComment
編輯本機檔案 Ctrl+Shift+P EditorContextMenus.CodeWindow.EditLocalFile

DOM 總管:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
重新整理 F5 DOMExplorer.Refresh
選取項目 Ctrl+B DOMExplorer.SelectElement
顯示版面配置 Ctrl+Shift+I DOMExplorer.ShowLayout

F# 互動式:內容特定快捷方式

此內容特有的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
取消互動式評估 Ctrl+Break OtherContextMenus.FSIConsoleContext.CancelInteractiveEvaluation

圖形檔編輯器:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
新增節點 插入 ArchitectureContextMenus.DirectedGraphContextMenu.Advanced.Add.AddNode
兩個相依性 B ArchitectureContextMenus.DirectedGraphContextMenu.Advanced.Select.BothDependencies
傳入相依性 I ArchitectureContextMenus.DirectedGraphContextMenu.Advanced.Select.IncomingDependencies
傳出相依性 O ArchitectureContextMenus.DirectedGraphContextMenu.Advanced.Select.OutgoingDependencies
新增批註 Ctrl+Shift+K



Ctrl+E、C
ArchitectureContextMenus.DirectedGraphContextMenu.NewComment
移除 刪除 ArchitectureContextMenus.DirectedGraphContextMenu.Remove
重新命名 F2 ArchitectureContextMenus.DirectedGraphContextMenu.Rename

圖形診斷:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
擷取 Debug.Graphics.CaptureFrame
將圖元選取向下移動 Shift+Alt+向下鍵 Graphics.MovePixelSelectionDown
向左移動圖元選取範圍 Shift+Alt+向左鍵 Graphics.MovePixelSelectionLeft
向右移動圖元選取範圍 Shift+Alt+向右鍵 Graphics.MovePixelSelectionRight
向上移動圖元選取 Shift+Alt+向上鍵 Graphics.MovePixelSelectionUp
縮放至實際大小 Shift+Alt+0 (零) Graphics.ZoomToActualSize
縮放以放入視窗 Shift+Alt+9 Graphics.ZoomToFitInWindow
放大 Shift+Alt+= Graphics.ZoomIn
縮小 Shift+Alt+- Graphics.ZoomOut

HTML 編輯器:內容特定快捷方式

此內容特有的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
移至控制器 Ctrl+M、Ctrl+G OtherContextMenus.HTMLContext.GoToController

HTML 編輯器設計檢視:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
向下移動控制項 Ctrl+向下鍵 Edit.MoveControlDown
向上移動控制項 Ctrl+向上鍵 Edit.MoveControlUp
粗體 Ctrl+B Format.Bold
轉換成超連結 Ctrl+L Format.ConverttoHyperlink
插入書簽 Ctrl+Shift+L Format.InsertBookmark
斜體 Ctrl+I Format.Italic
Underline Ctrl+U Format.Underline
新增內容頁面 Ctrl+M、Ctrl+C Project.AddContentPage
左邊的資料行 Ctrl+Alt+向左鍵 Table.ColumntotheLeft
右邊的資料行 Ctrl+Alt+向右鍵 Table.ColumntotheRight
上方的資料列 Ctrl+Alt+向上鍵 Table.RowAbove
下方的資料列 Ctrl+Alt+向下鍵 Table.RowBelow
Net 非visual 控制項 Ctrl+Shift+N View.ASP.NETNonvisualControls
編輯主圖形 Ctrl+M、Ctrl+M View.EditMaster
下一個檢視 Ctrl+PgDn View.NextView
顯示智慧標籤 Shift+Alt+F10 View.ShowSmartTag
檢視標記 Shift+F7 View.ViewMarkup
上一個 Tab 點 Ctrl+PgUp Window.PreviousTab

HTML 編輯器來源檢視:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
移至控制器 Ctrl+M、Ctrl+G OtherContextMenus.HTMLContext.GoToController
下一個檢視 Ctrl+PgDn View.NextView
同步檢視 Ctrl+Shift+Y View.SynchronizeViews
檢視表設計工具 Shift+F7 View.ViewDesigner
上一個 Tab 點 Ctrl+PgUp Window.PreviousTab

分層圖:內容特定快捷方式

此內容特有的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
刪除 Shift+Delete Edit.Delete

Managed 資源編輯器:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
編輯儲存格 F2 Edit.EditCell
移除 刪除 Edit.Remove
移除資料列 Ctrl+Delete Edit.RemoveRow
選取專案取消 ESC 鍵 Edit.SelectionCancel
音訊 Ctrl+4 Resources.Audio
檔案 Ctrl+5 Resources.Files
圖示 Ctrl+3 Resources.Icons
映像 Ctrl+2 Resources.Images
其他 Ctrl+6 Resources.Other
字串 Ctrl+1 Resources.Strings

合併編輯器視窗:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
在左視窗上設定焦點 Alt+1 TeamFoundationContextMenus.MergeContextMenu.SetFocusonLeftWindow
設定結果視窗的焦點 Alt+2 TeamFoundationContextMenus.MergeContextMenu.SetFocusonResultWindow
在右視窗上設定焦點 Alt+3 TeamFoundationContextMenus.MergeContextMenu.SetFocusonRightWindow

Microsoft SQL Server Data Tools,架構比較:內容特定的快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
SSDT 架構比較 Shift+Alt+C SQL.SSDTSchemaCompareCompare
SSDT 架構比較產生腳本 Shift+Alt+G SQL.SSDTSchemaCompareGenerateScript
SSDT 架構比較下一項變更 Shift+Alt+。 SQL.SSDTSchemaCompareNextChange
SSDT 架構比較先前的變更 Shift+Alt+, SQL.SSDTSchemaComparePreviousChange
SSDT 架構比較停止 Alt+Break SQL.SSDTSchemaCompareStop
SSDT 架構比較寫入更新 Shift+Alt+U SQL.SSDTSchemaCompareWriteUpdates

Microsoft SQL Server Data Tools、資料表設計工具:內容特定的快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
認可所有編輯 Shift+Alt+U CommitAllEdits
展開萬用字元 Ctrl+R、E



Ctrl+R、Ctrl+E
SQL.ExpandWildcards
完整限定名稱 Ctrl+R、Q



Ctrl+R、Ctrl+Q
SQL.FullyqualifyNames
移至架構 Ctrl+R、M



Ctrl+R、Ctrl+M
SQL.MovetoSchema
重新命名 F2



Ctrl+R、R



Ctrl+R、Ctrl+R
SQL.Rename
在腳本面板中檢視檔案 Shift+Alt+PgDn ViewFileInScriptPanel

Microsoft SQL Server Data Tools, T-SQL 編輯器:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
認可所有編輯 Shift+Alt+U CommitAllEdits
使用偵錯工具執行 Alt+F5 SQL.ExecuteWithDebugger
展開萬用字元 Ctrl+R、E



Ctrl+R、Ctrl+E
SQL.ExpandWildcards
完整限定名稱 Ctrl+R、Q



Ctrl+R、Ctrl+Q
SQL.FullyqualifyNames
移至架構 Ctrl+R、M



Ctrl+R、Ctrl+M
SQL.MovetoSchema
重新命名 F2



Ctrl+R、R



Ctrl+R、Ctrl+R
SQL.Rename
T SQL 編輯器取消查詢 Alt+Break SQL.TSqlEditorCancelQuery
T SQL 編輯器執行查詢 Ctrl+Shift+E SQL.TSqlEditorExecuteQuery
T SQL 編輯器結果作為檔案 Ctrl+D、F SQL.TSqlEditorResultsAsFile
T SQL 編輯器結果作為方格 Ctrl+D、G SQL.TSqlEditorResultsAsGrid
T SQL 編輯器結果為文字 Ctrl+D、T SQL.TSqlEditorResultsAsText
T SQL 編輯器顯示預估計畫 Ctrl+D、E SQL.TSqlEditorShowEstimatedPlan
T SQL 編輯器切換執行計畫 Ctrl+D、A SQL.TSqlEditorToggleExecutionPlan
T SQL 編輯器切換結果窗格 Ctrl+D、R SQL.TSqlEditorToggleResultsPane
T SQL 編輯器複製查詢 Ctrl+Alt+N SQL。TSqlEditorCloneQuery
T SQL 編輯器資料庫下拉式 Shift+Alt+PgDn SQL。TSqlEditorDatabaseCombo

Microsoft SQL Server Data Tools, T-SQL PDW 編輯器:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
T SQL 編輯器取消查詢 Alt+Break SQL.TSqlEditorCancelQuery
T SQL 編輯器執行查詢 Ctrl+Shift+E SQL.TSqlEditorExecuteQuery
T SQL 編輯器結果作為檔案 Ctrl+D、F SQL.TSqlEditorResultsAsFile
T SQL 編輯器結果作為方格 Ctrl+D、G SQL.TSqlEditorResultsAsGrid
T SQL 編輯器結果為文字 Ctrl+D、T SQL.TSqlEditorResultsAsText
T SQL 編輯器顯示預估計畫 Ctrl+D、E SQL.TSqlEditorShowEstimatedPlan
T SQL 編輯器切換執行計畫 Ctrl+D、A SQL.TSqlEditorToggleExecutionPlan
T SQL 編輯器切換結果窗格 Ctrl+D、R SQL.TSqlEditorToggleResultsPane
T SQL 編輯器複製查詢 Ctrl+Alt+N SQL。TSqlEditorCloneQuery
T SQL 編輯器複製查詢 Shift+Alt+PgDn SQL。TSqlEditorCloneQuery

頁面偵測器:內容特定快捷方式

此內容專屬的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
最小化 F12 PageInspector.Minimize

查詢設計工具:內容特定的快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
取消擷取資料 Ctrl+T QueryDesigner.CancelRetrievingData
準則 Ctrl+2 QueryDesigner.Criteria
圖表 Ctrl+1 QueryDesigner.Diagram
執行 SQL。 Ctrl+R QueryDesigner.ExecuteSQL
Goto 列 Ctrl+G QueryDesigner.GotoRow
聯結模式 Ctrl+Shift+J QueryDesigner.JoinMode
結果 Ctrl+4 QueryDesigner.Results
Sql Ctrl+3 QueryDesigner.SQL

查詢結果:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
查詢結果新資料列 Alt+End SQL.QueryResultsNewRow
查詢結果重新整理 Shift+Alt+R SQL.QueryResultsRefresh
查詢結果停止 Alt+Break SQL.QueryResultsStop

報表設計師:內容特定的快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
分行符號 Enter Edit.BreakLine
左字元 向左鍵 Edit.CharLeft
字元左延伸 Shift+向左鍵 Edit.CharLeftExtend
字元右 向右鍵 Edit.CharRight
字元右延伸 Shift+向右鍵 Edit.CharRightExtend
插入索引標籤 Tab Edit.InsertTab
向下捲動一行 向下箭號 Edit.LineDown
向下行延伸 Shift+向下鍵 Edit.LineDownExtend
向上捲動一行 向上箭號 Edit.LineUp
換行延伸 Shift+向上鍵 Edit.LineUpExtend
向下移動控制項 Ctrl+向下鍵 Edit.MoveControlDown
向左移動控制項 Ctrl+向左鍵 Edit.MoveControlLeft
向右移動控制項 Ctrl+向右鍵 Edit.MoveControlRight
向上移動控制項 Ctrl+向上鍵 Edit.MoveControlUp
選取範圍取消 Esc Edit.SelectionCancel
縮小大小控制 Ctrl+Shift+向下鍵 Edit.SizeControlDown
左方大小控制 Ctrl+Shift+向左鍵 Edit.SizeControlLeft
正確調整大小控制 Ctrl+Shift+向右鍵 Edit.SizeControlRight
增加大小控制 Ctrl+Shift+向上鍵 Edit.SizeControlUp
左標籤 Shift+Tab Edit.TabLeft
報表資料 Ctrl+Alt+D View.ReportData

順序圖:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
流覽至程式碼 F12 ArchitectureDesigner.Sequence.NavigateToCode
刪除 Shift+Del Edit.Delete

設定設計工具:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
編輯儲存格 F2 Edit.EditCell
移除資料列 Ctrl+Delete Edit.RemoveRow
選取專案取消 Esc Edit.SelectionCancel
檢視程式碼 F7 View.ViewCode

方案總管:內容特定的快捷方式

此內容特有的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
在頁面偵測器中檢視 Ctrl+K、Ctrl+G ClassViewContextMenus.ClassViewProject.View.ViewinPageInspector

Team Explorer:內容特定快捷方式

此內容特有的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
刪除 刪除 Edit.Delete
重新命名 F2 File.Rename
移至 Team Explorer 流覽 Alt+Home TeamFoundationContextMenus.Commands.GoToTeamExplorerNavigation
移至 Team Explorer 下一節內容 Alt+向下鍵 TeamFoundationContextMenus.Commands.GoToTeamExplorerNextSectionContent
移至 Team Explorer 頁面內容 Alt+0 (零) TeamFoundationContextMenus.Commands.GoToTeamExplorerPageContent
移至 Team Explorer 上一節內容 Alt+向上箭 TeamFoundationContextMenus.Commands.GoToTeamExplorerPreviousSectionContent
移至 Team Explorer 第 1 節內容 Alt+1 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection1Content
移至 Team Explorer 第 2 節內容 Alt+2 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection2Content
移至 Team Explorer 第 3 節內容 Alt+3 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection3Content
移至 Team Explorer 第 4 節內容 Alt+4 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection4Content
移至 Team Explorer 第 5 節內容 Alt+5 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection5Content
移至 Team Explorer 第 6 節內容 Alt+6 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection6Content
移至 Team Explorer 第 7 節內容 Alt+7 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection7Content
移至 Team Explorer 第 8 節內容 Alt+8 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection8Content
移至 Team Explorer 第 9 節內容 Alt+9 TeamFoundationContextMenus.Commands.GoToTeamExplorerSection9Content
Team Explorer 向後流覽 Alt+向左鍵 TeamFoundationContextMenus.Commands.TeamExplorerNavigateBackward
Team Explorer 向前流覽 Alt+向右鍵 TeamFoundationContextMenus.Commands.TeamExplorerNavigateForward
TFS 內容我的工作頁面建立複本 wi Shift+Alt+C TeamFoundationContextMenus.MyWorkPageInProgress.TfsContextMyWorkPageCreateCopyWI
TFS 內容我的工作頁面新連結 wi Shift+Alt+L TeamFoundationContextMenus.MyWorkPageInProgress.TfsContextMyWorkPageNewLinkedWI
重新整理 F5 View.Refresh

測試總管:內容特定快捷方式

此內容特有的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
開啟測試 F12 TestExplorer.OpenTest

文字編輯器:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
分行符號 Enter



Shift+Enter
Edit.BreakLine
左字元 向左鍵 Edit.CharLeft
字元左延伸 Shift+向左鍵 Edit.CharLeftExtend
字元左側擴充資料行 Shift+Alt+向左鍵 Edit.CharLeftExtendColumn
字元右 向右鍵 Edit.CharRight
字元右延伸 Shift+向右鍵 Edit.CharRightExtend
字元右擴充資料行 Shift+Alt+向右鍵 Edit.CharRightExtendColumn
清除書籤 Ctrl+K、Ctrl+L Edit.ClearBookmarks
折迭所有大綱 Ctrl+M、Ctrl+A Edit.CollapseAllOutlining
折迭目前區域 Ctrl+M、Ctrl+S Edit.CollapseCurrentRegion
折迭標記 Ctrl+M、Ctrl+T Edit.CollapseTag
折迭至定義 Ctrl+M、Ctrl+O (字母 'O') Edit.CollapseToDefinitions
縮小選取範圍 Shift+Alt+- Edit.ContractSelection
批註選取 Ctrl+K、Ctrl+C Edit.CommentSelection
自動完成文字 Ctrl+空格鍵



Alt+向右鍵
Edit.CompleteWord
複製參數提示 Ctrl+Shift+Alt+C Edit.CopyParameterTip
減少篩選層級 Alt+, Edit.DecreaseFilterLevel
回溯刪除 Backspace



Shift+退格鍵
Edit.DeleteBackwards
刪除水準空白字元 Ctrl+K、Ctrl+\ Edit.DeleteHorizontalWhiteSpace
檔結尾 Ctrl+End Edit.DocumentEnd
檔結束延伸 Ctrl+Shift+End Edit.DocumentEndExtend
檔開始 Ctrl+Home Edit.DocumentStart
檔開始延伸 Ctrl+Shift+Home Edit.DocumentStartExtend
展開所有大綱 Ctrl+M、Ctrl+X Edit.ExpandAllOutlining
展開目前的區域 Ctrl+M、Ctrl+E Edit.ExpandCurrentRegion
展開選取範圍 Shift+Alt+= Edit.ExpandSelection
展開選取範圍以包含區塊 Shift+Alt+] Edit.ExpandSelectiontoContainingBlock
格式化文件 Ctrl+K、Ctrl+D Edit.FormatDocument
格式選取項目 Ctrl+K、Ctrl+F Edit.FormatSelection
全部移至 Ctrl+T



Ctrl+、
Edit.GotoAll
Goto 大括弧 Ctrl+] Edit.GotoBrace
Goto 大括弧擴充 Ctrl+Shift+] Edit.GotoBraceExtend
Goto 最近 Ctrl+T、R Edit.GotoRecent
檔案中的下一個問題 Alt+PgDn Edit.GotoNextIssueinFile
移至檔案中先前的問題 Alt+PgUp Edit.GotoPreviousIssueinFile
隱藏選取 Ctrl+M、Ctrl+H Edit.HideSelection
增加篩選層級 Alt+。 Edit.IncreaseFilterLevel
累加式搜尋 Ctrl+I Edit.IncrementalSearch
在所有相符專案插入號 Shift+Alt+; Edit.InsertCaretsatAllMatching
插入下一個相符插入號 Shift+Alt+。 Edit.InsertNextMatchingCaret
插入索引標籤 Tab Edit.InsertTab
線條剪下 Ctrl+L Edit.LineCut
行刪除 Ctrl+Shift+L Edit.LineDelete
向下捲動一行 向下箭號 Edit.LineDown
向下行延伸 Shift+向下鍵 Edit.LineDownExtend
向下行擴充資料行 Shift+Alt+向下鍵 Edit.LineDownExtendColumn
線條結尾 結束 Edit.LineEnd
行尾延伸 Shift+End Edit.LineEndExtend
行尾擴充資料行 Shift+Alt+End Edit.LineEndExtendColumn
開啟上方的線條 Ctrl+Enter Edit.LineOpenAbove
下方開啟的行 Ctrl+Shift+Enter Edit.LineOpenBelow
行開始 首頁 Edit.LineStart
行開始延伸 Shift+Home Edit.LineStartExtend
行開始擴充資料行 Shift+Alt+Home Edit.LineStartExtendColumn
線條轉置 Shift+Alt+T Edit.LineTranspose
向上捲動一行 向上箭號 Edit.LineUp
換行延伸 Shift+向上鍵 Edit.LineUpExtend
換行擴充資料行 Shift+Alt+向上鍵 Edit.LineUpExtendColumn
列出成員 Ctrl+J Edit.ListMembers
製作小寫 Ctrl+U Edit.MakeLowercase
製作大寫 Ctrl+Shift+U Edit.MakeUppercase
向下移動選取的行 Alt+向下鍵 Edit.MoveSelectedLinesDown
向上移動選取的行 Alt+向上箭 Edit.MoveSelectedLinesUp
下一個醒目提示的參考 Ctrl+Shift+向下鍵 Edit.NextHighlightedReference
過度類型模式 插入 Edit.OvertypeMode
向下捲動一頁 PgDn Edit.PageDown
向下頁面延伸 Shift+PgDn Edit.PageDownExtend
向上捲動一頁 PgUp Edit.PageUp
向上分頁擴充 Shift+PgUp Edit.PageUpExtend
參數資訊 Ctrl+Shift+空格鍵 Edit.ParameterInfo
貼上參數提示 Ctrl+Shift+Alt+P Edit.PasteParameterTip
向後查看 Ctrl+Alt+- Edit.PeekBackward
查看定義 Alt+F12 Edit.PeekDefinition
向前查看 Ctrl+Alt+= Edit.PeekForward
先前醒目提示的參考 Ctrl+Shift+向上鍵 Edit.PreviousHighlightedReference
快速諮詢 Ctrl+K、Ctrl+I Edit.QuickInfo
反向累加搜尋 Ctrl+Shift+I Edit.ReverseIncrementalSearch
向下捲動線條 Ctrl+向下鍵 Edit.ScrollLineDown
向上捲動線條 Ctrl+向上鍵 Edit.ScrollLineUp
選取目前的字組 Ctrl+W Edit.SelectCurrentWord
選取範圍取消 ESC 鍵 Edit.SelectionCancel
選取以最後返回 Ctrl+= Edit.SelectToLastGoBack
顯示程式碼鏡頭功能表 Ctrl+K、Ctrl+' Edit.ShowCodeLensMenu
顯示流覽功能表 Alt+' Edit.ShowNavigateMenu
停止隱藏目前 Ctrl+M、Ctrl+U Edit.StopHidingCurrent
停止大綱 Ctrl+M、Ctrl+P Edit.StopOutlining
交換錨點 Ctrl+K、Ctrl+A Edit.SwapAnchor
左標籤 Shift+Tab Edit.TabLeft
切換所有大綱 Ctrl+M、Ctrl+L Edit.ToggleAllOutlining
切換書籤 Ctrl+K、Ctrl+K Edit.ToggleBookmark
切換完成模式 Ctrl+Alt+空格鍵 Edit.ToggleCompletionMode
切換大綱展開 Ctrl+M、Ctrl+M Edit.ToggleOutliningExpansion
切換工作清單快捷方式 Ctrl+K、Ctrl+H Edit.ToggleTaskListShortcut
切換自動換行 Ctrl+E、Ctrl+W Edit.ToggleWordWrap
取消批註選取 Ctrl+K、Ctrl+U Edit.UncommentSelection
檢視底部 Ctrl+PgDn Edit.ViewBottom
檢視底部延伸 Ctrl+Shift+PgDn Edit.ViewBottomExtend
檢視頂端 Ctrl+PgUp Edit.ViewTop
檢視頂端擴充 Ctrl+Shift+PgUp Edit.ViewTopExtend
檢視空白字元 Ctrl+R、Ctrl+W Edit.ViewWhiteSpace
Word 刪除至結尾 Ctrl+Delete Edit.WordDeleteToEnd
要啟動的 Word 刪除 Ctrl+Backspace Edit.WordDeleteToStart
下一個 Word Ctrl+向右鍵 Edit.WordNext
Word next extend Ctrl+Shift+向右鍵 Edit.WordNextExtend
Word next extend column Ctrl+Shift+Alt+向右鍵 Edit.WordNextExtendColumn
Word 上一頁 Ctrl+向左鍵 Edit.WordPrevious
Word 上一個擴充 Ctrl+Shift+向左鍵 Edit.WordPreviousExtend
Word 上一個擴充資料行 Ctrl+Shift+Alt+向左鍵 Edit.WordPreviousExtendColumn
Word 轉置 Ctrl+Shift+T Edit.WordTranspose
在互動式中執行 Alt+Enter EditorContextMenus.CodeWindow.ExecuteInInteractive
互動式中的執行行 Alt+' EditorContextMenus.CodeWindow.ExecuteLineInInteractive
在頁面偵測器中檢視 Ctrl+K、Ctrl+G OtherContextMenus.HTMLContext.ViewinPageInspector
TFS 批註移動下一個區域 Alt+PgDn TeamFoundationContextMenus.Annotate.TfsAnnotateMoveNextRegion
TFS 批註移動上一個區域 Alt+PgUp TeamFoundationContextMenus.Annotate.TfsAnnotateMovePreviousRegion

UML 活動圖表:內容特定快捷方式

此內容專屬的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
刪除 Shift+Del Edit.Delete

UML 類別圖表:內容特定快捷方式

此內容專屬的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
從模型中刪除 Shift+Del Edit.DeleteFromModel

UML 元件圖表:內容特定快捷方式

此內容專屬的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
從模型中刪除 Shift+Del Edit.DeleteFromModel

UML 使用案例圖表:內容特定快捷方式

此內容專屬的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
從模型中刪除 Shift+Del Edit.DeleteFromModel

VC 快速鍵編輯器:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
新增加速器 插入 Edit.NewAccelerator
下一個輸入的索引鍵 Ctrl+W Edit.NextKeyTyped

VC 對話方塊編輯器:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
向下移動控制項 向下箭號 Edit.MoveControlDown
向左移動控制項 向左鍵 Edit.MoveControlLeft
向右移動控制項 向右鍵 Edit.MoveControlRight
向上移動控制項 向上箭號 Edit.MoveControlUp
向左捲動欄 Ctrl+向左鍵 Edit.ScrollColumnLeft
向右捲動資料行 Ctrl+向右鍵 Edit.ScrollColumnRight
向下捲動線條 Ctrl+向下鍵 Edit.ScrollLineDown
向上捲動線條 Ctrl+向上鍵 Edit.ScrollLineUp
縮小大小控制 Shift+向下鍵 Edit.SizeControlDown
左方大小控制 Shift+向左鍵 Edit.SizeControlLeft
正確調整大小控制 Shift+向右鍵 Edit.SizeControlRight
增加大小控制 Shift+向上鍵 Edit.SizeControlUp
靠下對齊 Ctrl+Shift+向下鍵 Format.AlignBottoms
對齊中心 Shift+F9 Format.AlignCenters
靠左對齊 Ctrl+Shift+向左鍵 Format.AlignLefts
對齊中間 F9 Format.AlignMiddles
對齊許可權 Ctrl+Shift+向右鍵 Format.AlignRights
對齊頂端 Ctrl+Shift+向上鍵 Format.AlignTops
按鈕底部 Ctrl+B Format.ButtonBottom
按鈕右鍵 Ctrl+R Format.ButtonRight
置中水準 Ctrl+Shift+F9 Format.CenterHorizontal
置中垂直 Ctrl+F9 Format.CenterVertical
檢查助憶鍵 Ctrl+M Format.CheckMnemonics
大小為內容 Shift+F7 Format.SizetoContent
跨空間 Alt+向右鍵



Alt+向左鍵
Format.SpaceAcross
縮小空間 Alt+向上箭



Alt+向下鍵
Format.SpaceDown
定位順序 Ctrl+D Format.TabOrder
測試對話方塊 Ctrl+T Format.TestDialog
切換指南 Ctrl+G Format.ToggleGuides

VC 影像編輯器:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
Airbrush 工具 Ctrl+A Image.AirbrushTool
筆刷工具 Ctrl+B Image.BrushTool
複製和大綱選取 Ctrl+Shift+U Image.CopyandOutlineSelection
繪製不透明 Ctrl+J Image.DrawOpaque
橢圓形工具 Alt+P Image.EllipseTool
清除工具 Ctrl+Shift+I Image.EraseTool
填滿橢圓形工具 Ctrl+Shift+Alt+P Image.FilledEllipseTool
填滿矩形工具 Ctrl+Shift+Alt+R Image.FilledRectangleTool
填滿圓角矩形工具 Ctrl+Shift+Alt+W Image.FilledRoundedRectangleTool
填滿工具 Ctrl+F Image.FillTool
水準翻轉 Ctrl+H Image.FlipHorizontal
垂直翻轉 Shift+Alt+H Image.FlipVertical
較大的筆刷 Ctrl+= Image.LargerBrush
線條工具 Ctrl+L Image.LineTool
放大工具 Ctrl+M Image.MagnificationTool
放大 Ctrl+Shift+M Image.Magnify
新的影像類型 插入 Image.NewImageType
下一個色彩 Ctrl+]



Ctrl+向右鍵
Image.NextColor
右下一個色彩 Ctrl+Shift+]



Ctrl+Shift+向右鍵
Image.NextRightColor
大綱省略號工具 Shift+Alt+P Image.OutlinedEllipseTool
外框矩形工具 Shift+Alt+R Image.OutlinedRectangleTool
外框圓角矩形工具 Shift+Alt+W Image.OutlinedRoundedRectangleTool
鉛筆工具 Ctrl+I Image.PencilTool
上一個色彩 Ctrl+[



Ctrl+向左鍵
Image.PreviousColor
上一個右色彩 Ctrl+Shift+[



Ctrl+Shift+向左鍵
Image.PreviousRightColor
矩形選取工具 Shift+Alt+S Image.RectangleSelectionTool
矩形工具 Alt+R Image.RectangleTool
旋轉 90 度 Ctrl+Shift+H Image.Rotate90Degrees
圓角矩形工具 Alt+W Image.RoundedRectangleTool
顯示方格 Ctrl+Alt+S Image.ShowGrid
顯示磚格線 Ctrl+Shift+Alt+S Image.ShowTileGrid
小型筆刷 Ctrl+。 Image.SmallBrush
較小的筆刷 Ctrl+- Image.SmallerBrush
文字工具 Ctrl+T Image.TextTool
使用選取專案作為筆刷 Ctrl+U Image.UseSelectionasBrush
放大 Ctrl+Shift+。



Ctrl+向上鍵
Image.ZoomIn
縮小 Ctrl+Shift+、



Ctrl+向下鍵
Image.ZoomOut

VC 字串編輯器:內容特定快捷方式

此內容特有的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
新字串 插入 Edit.NewString

檢視設計工具:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
取消擷取資料 Ctrl+T QueryDesigner.CancelRetrievingData
準則 Ctrl+2 QueryDesigner.Criteria
圖表 Ctrl+1 QueryDesigner.Diagram
執行 SQL。 Ctrl+R QueryDesigner.ExecuteSQL
Goto 列 Ctrl+G QueryDesigner.GotoRow
聯結模式 Ctrl+Shift+J QueryDesigner.JoinMode
結果 Ctrl+4 QueryDesigner.Results
Sql Ctrl+3 QueryDesigner.SQL

Visual Studio:內容特定快捷方式

此內容特有的快捷方式如下:

Command 鍵盤快速鍵 命令 ID
隱藏方法窗格 Ctrl+1 OtherContextMenus.ORDesignerContext.HideMethodsPane

Windows Forms 設計工具:內容特定快捷方式

此內容特有的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
分行符號 Enter Edit.BreakLine
左字元 向左鍵 Edit.CharLeft
字元左延伸 Shift+向左鍵 Edit.CharLeftExtend
字元右 向右鍵 Edit.CharRight
字元右延伸 Shift+向右鍵 Edit.CharRightExtend
檔結束 結束 Edit.DocumentEnd
檔結束延伸 Shift+End Edit.DocumentEndExtend
檔開始 首頁 Edit.DocumentStart
檔開始擴充 Shift+Home Edit.DocumentStartExtend
插入索引標籤 Tab Edit.InsertTab
向下捲動一行 向下箭號 Edit.LineDown
向下行延伸 Shift+向上鍵 Edit.LineDownExtend
向上捲動一行 向上箭號 Edit.LineUp
換行延伸 Shift+向下鍵 Edit.LineUpExtend
向下移動控制項 Ctrl+向下鍵 Edit.MoveControlDown
向左移動控制項 Ctrl+向左鍵 Edit.MoveControlLeft
向右移動控制項 Ctrl+向右鍵 Edit.MoveControlRight
向上移動控制項 Ctrl+向上鍵 Edit.MoveControlUp
選取範圍取消 ESC 鍵 Edit.SelectionCancel
縮小大小控制 Ctrl+Shift+向下鍵 Edit.SizeControlDown
左方大小控制 Ctrl+Shift+向左鍵 Edit.SizeControlLeft
正確調整大小控制 Ctrl+Shift+向右鍵 Edit.SizeControlRight
增加大小控制 Ctrl+Shift+向上鍵 Edit.SizeControlUp
左標籤 Shift+Tab Edit.TabLeft

工作專案編輯器:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
建立工作專案複本 Shift+Alt+C Edit.CreateCopyofWorkItem
重新整理工作專案 F5 Edit.RefreshWorkItem
新增連結的工作專案 Shift+Alt+L Team.NewLinkedWorkItem

工作專案查詢檢視:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
建立工作專案複本 Shift+Alt+C Edit.CreateCopyofWorkItem
縮排 Shift+Alt+向右鍵 Edit.Indent
凸排 Shift+Alt+向左鍵 Edit.Outdent
新增連結的工作專案 Shift+Alt+L Team.NewLinkedWorkItem
重新整理 F5 Team.Refresh
切換 Shift+Alt+V Window.Toggle

工作專案結果檢視:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
建立工作專案複本 Shift+Alt+C Edit.CreateCopyofWorkItem
縮排 Shift+Alt+向右鍵 Edit.Indent
凸排 Shift+Alt+向左鍵 Edit.Outdent
移至下一個工作專案 Shift+Alt+N Team.GotoNextWorkItem
移至先前的工作專案 Shift+Alt+P Team.GotoPreviousWorkItem
新增連結的工作專案 Shift+Alt+L Team.NewLinkedWorkItem
重新整理 F5 Team.Refresh
切換 Shift+Alt+V Window.Toggle

工作流程設計工具:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
自動完成文字 Ctrl+K、W



Ctrl+K、Ctrl+W



Ctrl+空格鍵



Alt+向右鍵
Edit.CompleteWord
減少篩選層級 Alt+, Edit.DecreaseFilterLevel
增加篩選層級 Alt+。 Edit.IncreaseFilterLevel
列出成員 Ctrl+K、L



Ctrl+K、Ctrl+L



Ctrl+J
Edit.ListMembers
參數資訊 Ctrl+K、P



Ctrl+K、Ctrl+P



Ctrl+Shift+空格鍵
Edit.ParameterInfo
快速諮詢 Ctrl+K、I



Ctrl+K、Ctrl+I
Edit.QuickInfo
摺疊 Ctrl+E、Ctrl+C



Ctrl+E、C
WorkflowDesigner.Collapse
全部摺疊 WorkflowDesigner.CollapseAll
連接節點 Ctrl+E、Ctrl+F



Ctrl+E、F
WorkflowDesigner.ConnectNodes
建立變數 Ctrl+E、Ctrl+N



Ctrl+E、N
WorkflowDesigner.CreateVariable
全部展開 Ctrl+E、Ctrl+X



Ctrl+E、X
WorkflowDesigner.ExpandAll
就地展開 Ctrl+E、Ctrl+E



Ctrl+E、E
WorkflowDesigner.ExpandInPlace
移至父系 Ctrl+E、Ctrl+P



Ctrl+E、P
WorkflowDesigner.GoToParent
移動焦點 Ctrl+E、Ctrl+M



Ctrl+E、M
WorkflowDesigner.MoveFocus
流覽設計工具 Ctrl+Alt+F6 WorkflowDesigner.NavigateThroughDesigner
還原 Ctrl+E、Ctrl+R



Ctrl+E、R
WorkflowDesigner.Restore
顯示隱藏引數設計工具 Ctrl+E、Ctrl+A



Ctrl+E、A
WorkflowDesigner.ShowHideArgumentDesigner
顯示隱藏匯入設計工具 Ctrl+E、Ctrl+I



Ctrl+E、I
WorkflowDesigner.ShowHideImportsDesigner
顯示隱藏概觀地圖 Ctrl+E、Ctrl+O (字母 'O')



Ctrl+E、O
WorkflowDesigner.ShowHideOverviewMap
顯示隱藏變數設計工具 Ctrl+E、Ctrl+V



Ctrl+E、V
WorkflowDesigner.ShowHideVariableDesigner
切換選取範圍 Ctrl+E、Ctrl+S



Ctrl+E、S
WorkflowDesigner.ToggleSelection
放大 Ctrl+Num + WorkflowDesigner.ZoomIn
縮小 Ctrl+Num - WorkflowDesigner.ZoomOut

XAML UI 設計工具:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
全部調整 Ctrl+0 (零) Design.FitAll
顯示控點 F9 Design.ShowHandles
放大 Ctrl+Alt+= Design.ZoomIn
縮小 Ctrl+Alt+- Design.ZoomOut
編輯文字 F2 Format.EditText
全部 Ctrl+Shift+R Format.ResetLayout.All
執行專案程式碼 Ctrl+F9 Design.RunProjectCode
僅隱藏 Blend () Ctrl+H Timeline.Hide (僅限混合)
僅鎖定 Blend () Ctrl+L Timeline.Lock (僅限混合)
僅顯示 Blend () Ctrl+Shift+H Timeline.Show (僅限混合)
僅解除鎖定 Blend () Ctrl+Shift+L Timeline.Unlock (僅限混合)
左邊緣向左移動 Ctrl+Shift+、 View.EdgeLeftMoveLeft
向左移動邊緣 Ctrl+Shift+。 View.EdgeLeftMoveRight
邊緣向左移動 Ctrl+Shift+Alt+, View.EdgeRightMoveLeft
右邊緣向右移動 Ctrl+Shift+Alt+。 View.EdgeRightMoveRight
顯示內容標記功能表 Ctrl+空格鍵 View.ShowPropertyMarkerMenu

如需詳細資訊,請參閱Blend for Visual Studio 中XAML 設計工具的鍵盤快速鍵和鍵盤快速鍵。

XML (文本) 編輯器:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
啟動 XSLT 偵錯 Alt+F5 XML.StartXSLTDebugging
啟動 XSLT 而不偵錯 Ctrl+Alt+F5 XML.StartXSLTWithoutDebugging

XML 架構設計工具:內容特定快捷方式

此內容專屬的快捷方式如下:

命令 鍵盤快速鍵 命令 ID
由下至上 Alt+向上箭 GraphView.BottomtoTop
由左至右 Alt+向右鍵 GraphView.LefttoRight
由右至左 Alt+向左鍵 GraphView.RighttoLeft
由上至下 Alt+向下鍵 GraphView.ToptoBottom
從工作區中移除 刪除 OtherContextMenus.GraphView.RemovefromWorkspace
顯示內容模型檢視 Ctrl+2 XsdDesigner.ShowContentModelView
顯示圖表檢視 Ctrl+3 XsdDesigner.ShowGraphView
顯示開始檢視 Ctrl+1 XsdDesigner.ShowStartView