您现在访问的是微软AZURE全球版技术文档网站,若需要访问由世纪互联运营的MICROSOFT AZURE中国区技术文档网站,请访问 https://docs.azure.cn.

Threat Modeling Tool 更新版 7.1.60126.1 - 2019 年 1 月 29 日Threat Modeling Tool update release 7.1.60126.1 - 1/29/2019

Microsoft Threat Modeling Tool 7.1.60126.1 版已于 2019 年 1 月 29 日发布,包含以下更改:Version 7.1.60126.1 of the Microsoft Threat Modeling Tool was released on January 29 2019 and contains the following changes:

  • .NET 4.7.1 的最低要求版本已增加到.netThe minimum required version of .NET has been increased to .NET 4.7.1.
  • 由于 .NET 依赖关系,Windows 所需的最低版本已增至 Windows 10 周年更新The minimum required version of Windows has been increased to Windows 10 Anniversary Update due to the .NET dependency.
  • 模型验证切换功能已添加到此工具的“选项”菜单中。A model validation toggle feature has been added to the tool's Options menu.
  • 威胁属性中的多个链接已更新。Several links in the Threat Properties were updated.
  • 对此工具的主屏幕进行了些许 UX 更改。Minor UX changes to the tool's home screen.
  • Threat Modeling Tool 现在继承了主机操作系统的 TLS 设置,并在需要 TLS 1.2 或更高版本的环境中受支持。The Threat Modeling Tool now inherits the TLS settings of the host operating system and is supported in environments that require TLS 1.2 or greater.

功能更改Feature changes

“模型验证”选项Model validation option

根据客户反馈,已向该工具添加一个选项以启用或禁用模型验证。Based on customer feedback, an option has been added to the tool to enable or disable the model validation. 以前,如果你的模板在两个对象之间使用了单单向数据流,则你可能会在消息框中收到一条错误消息,指出: ObjectsName 至少需要一个 "Any"。Previously, if your template used a single unidirectional data flow between two objects, you may have received an error message in the Messages frame stating: ObjectsName requires at least one 'Any'. 禁用模型验证将阻止在视图中显示这些警告。Disabling model validation will prevent these warnings from showing in the view.

可在“文件”->“设置”->“选项”菜单中找到打开和关闭模型验证的切换选项。The option to toggle model validation on and off can be found in the File->Settings->Options menu. 此设置的默认值为“禁用”。The default value for this setting is Disabled.

“模型验证”选项

系统要求System requirements

已知问题Known issues

不受支持的系统Unsupported systems

问题Issue

无法安装 .NET 4.7.1 或更高版本的 Windows 10 系统的用户,例如 Windows 10 企业版 LTSB(版本 1507),将无法在升级后打开该工具。Users of Windows 10 systems that are unable to install .NET 4.7.1 or later, such as Windows 10 Enterprise LTSB (version 1507), will be unable to open the tool after upgrading. 这些较旧版本的 Windows 不再是 Threat Modeling Tool 的支持平台,不应安装最新更新。These older versions of Windows are no longer supported platforms for the Threat Modeling Tool, and should not install the latest update.

解决方法Workaround

已安装最新更新的 Windows 10 企业版 LTSB (版本 1507)的用户可以通过“应用和功能”中的卸载对话框,还原到以前版本的 Threat Modeling Tool。Users of Windows 10 Enterprise LTSB (version 1507) that have installed the latest update can revert to the previous version of the Threat Modeling Tool through the uninstall dialog in Apps & Features.

文档和反馈Documentation and feedback

后续步骤Next steps

下载最新版本的 Microsoft Threat Modeling ToolDownload the latest version of the Microsoft Threat Modeling Tool.