Exchange 2013 系统必备Exchange 2013 prerequisites

适用于: Exchange Server 2013Applies to: Exchange Server 2013

本主题提供了为 Microsoft Exchange 2013 邮箱、客户端访问和边缘传输安装必需的 Windows Server 2012 R2、Windows Server 2012 和 Windows Server 2008 R2 Service Pack 1 (SP1)操作系统先决条件的步骤服务器角色。This topic provides the steps for installing the necessary Windows Server 2012 R2, Windows Server 2012 and Windows Server 2008 R2 with Service Pack 1 (SP1) operating system prerequisites for the Microsoft Exchange 2013 Mailbox, Client Access, and Edge Transport server roles. 此外,它还提供在 Windows 8、Windows 8.1 和 Windows 7 客户端计算机上安装 Exchange 2013 管理工具所需的必备组件。It also provides the prerequisites required to install the Exchange 2013 management tools on Windows 8, Windows 8.1, and Windows 7 client computers.

开始前,需要知道什么?What do you need to know before you begin?

  • 本主题中的信息适用于 Exchange 2013 的 Service Pack 1 和更高版本。The information in this topic is applicable to Service Pack 1 and later versions of Exchange 2013.

  • 边缘传输服务器角色可从 Exchange 2013 SP1 开始。The Edge Transport server role is available starting with Exchange 2013 SP1.

  • 请确保林的功能级别至少为 Windows Server 2003,并且架构主机运行的是 Windows Server 2003 Service Pack 2 或更高版本。Make sure that the functional level of your forest is at least Windows Server 2003, and that the schema master is running Windows Server 2003 with Service Pack 2 or later. 有关 Windows 功能级别的详细信息,请参阅管理域和林For more information about the Windows functional level, see Managing Domains and Forests.

  • Windows Server 2012 R2、Windows Server 2012 和 Windows Server 2008 R2 SP1 的完全安装选项必须用于运行 Exchange 2013 服务器角色或管理工具的所有服务器。The full installation option of Windows Server 2012 R2, Windows Server 2012 and Windows Server 2008 R2 SP1 must be used for all servers running Exchange 2013 server roles or management tools.

  • 必须首先将计算机加入恰当的内部 Active Directory 林和域。You must first join the computer to the appropriate internal Active Directory forest and domain.

  • 一些必备项要求您重启服务器才能完成安装。Some prerequisites require you to reboot the server to complete installation.

    • 在计算机上安装最新的 Windows 更新。有关详细信息,请参阅部署安全性核对清单Install the latest Windows updates on your computer. For more information, see Deployment security checklist.

      备注

      如果要安装邮箱服务器角色,并且希望服务器成为数据库可用性组(DAG)的成员,则必须运行 Windows Server 2012 R2 Standard 或 Datacenter Edition、Windows Server 2012 Standard 或 Datacenter Edition 或 WindowsServer 2008 R2 SP1 Enterprise Edition。If you're installing the Mailbox server role and you intend for the server to be a member of a database availability group (DAG), you must be running Windows Server 2012 R2 Standard or Datacenter Edition, Windows Server 2012 Standard or Datacenter Edition, or Windows Server 2008 R2 SP1 Enterprise Edition. Windows Server 2008 R2 SP 1 Standard Edition 不支持 Dag 所需的功能。Windows Server 2008 R2 SP 1 Standard Edition doesn't support the features needed for DAGs.
      当 Exchange 安装在服务器上时,无法升级 Windows。You can't upgrade Windows when Exchange is installed on the server.
      若要升级到 Microsoft 统一通信托管 API (UCMA)4.0,必须先卸载使用 "添加/删除程序" 安装的任何以前版本的 UCMA。To upgrade to Microsoft Unified Communications Managed API (UCMA) 4.0, you must first uninstall any previous versions of UCMA that are installed by using Add/Remove programs.

提示

是否有任何疑问?Having problems? 在 Exchange 论坛中寻求帮助。Ask for help in the Exchange forums. 访问Exchange Server上的论坛。Visit the forums at Exchange Server.

Active Directory 准备Active Directory preparation

要用于为 Exchange 2013 准备 Active Directory 的计算机具有必须满足的特定必备组件。The computer you want to use to prepare Active Directory for Exchange 2013 has specific prerequisites that must be met.

按照显示的顺序,在将用于准备 Active Directory 的计算机上安装以下软件:Install the following software, in the order shown, on the computer that will be used to prepare Active Directory:

  1. .NET Framework 4.7.2.NET Framework 4.7.2

  2. Windows Management Framework 4.0 (包含在 windows Server 2012 R2 中)Windows Management Framework 4.0 (included with Windows Server 2012 R2)

在您安装上面所列软件后,完成以下步骤来安装远程工具管理包。安装远程工具管理包后,您将能够使用计算机来准备 Active Directory。有关 Active Directory 的详细信息,请参阅 准备 Active Directory 和域After you've installed the software listed above, complete the following steps to install the Remote Tools Administration Pack. After you've installed the Remote Tools Administration Pack you'll be able to use the computer to prepare Active Directory. For more information about preparing Active Directory, see Prepare Active Directory and domains.

  1. 打开 Windows PowerShell。Open Windows PowerShell.

  2. 安装远程工具管理包。Install the Remote Tools Administration Pack.

    • 在 Windows Server 2012 R2 或 Windows Server 2012 计算机上,运行以下命令。On a Windows Server 2012 R2 or Windows Server 2012 computer, run the following command.

      Install-WindowsFeature RSAT-ADDS
      
    • 在 Windows Server 2008 R2 SP1 计算机上,运行以下命令。On a Windows Server 2008 R2 SP1 computer, run the following command.

      Add-WindowsFeature RSAT-ADDS
      

Windows Server 2012 R2 和 Windows Server 2012 必备组件Windows Server 2012 R2 and Windows Server 2012 prerequisites

在 Windows Server 2012 R2 或 Windows Server 2012 计算机上安装 Exchange 2013 所需的先决条件取决于要安装的 Exchange 角色。The prerequisites that are needed to install Exchange 2013 on a Windows Server 2012 R2 or Windows Server 2012 computer depends on which Exchange roles you want to install. 阅读下面与您要安装的角色相匹配的部分。Read the section below that matches the roles you want to install.

邮箱或客户端访问服务器角色Mailbox or Client Access server roles

按照此部分中的说明操作,在要执行下列操作之一的 Windows Server 2012 R2 或 Windows Server 2012 计算机上安装必备组件:Follow the instructions in this section to install the prerequisites on Windows Server 2012 R2 or Windows Server 2012 computers where you want to do one of the following:

  • 仅在计算机上安装邮箱服务器角色。Install only the Mailbox server role on a computer.

  • 仅在计算机上安装客户端访问服务器角色。Install only the Client Access server role on a computer.

  • 在同一台计算机上同时安装邮箱和客户端访问服务器角色。Install both the Mailbox and Client Access server roles on the same computer.

请执行下列操作,安装必需的 Windows 角色和功能:Do the following to install the required Windows roles and features:

  1. 打开 Windows PowerShell。Open Windows PowerShell.

  2. 运行以下命令,安装必需的 Windows 组件。Run the following command to install the required Windows components.

    Install-WindowsFeature AS-HTTP-Activation, Desktop-Experience, NET-Framework-45-Features, RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-Clustering-CmdInterface, RSAT-Clustering-Mgmt, RSAT-Clustering-PowerShell, Web-Mgmt-Console, WAS-Process-Model, Web-Asp-Net45, Web-Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-Compression, Web-Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-Http-Tracing, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Lgcy-Mgmt-Console, Web-Metabase, Web-Mgmt-Console, Web-Mgmt-Service, Web-Net-Ext45, Web-Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content, Web-Windows-Auth, Web-WMI, Windows-Identity-Foundation, RSAT-ADDS
    

在您安装操作系统角色和功能后,请按以下显示的顺序安装下列软件:After you've installed the operating system roles and features, install the following software in the order shown:

  1. .NET Framework 4.7.2.NET Framework 4.7.2

    重要

    Exchange 2013 CU23需要.net Framework 4.7.2。Exchange 2013 CU23 requires .NET Framework 4.7.2. 在安装 Exchange 2013 CU23之前,请将服务器升级到 .net Framework 4.7.2,否则将会收到错误。Upgrade your servers to .NET Framework 4.7.2 before you install Exchange 2013 CU23 or you'll receive an error. 如果您运行的是 .NET Framework 4.7.1,请先升级到 Exchange 2013 CU22,然后再安装 .NET Framework 4.7.2。If you're running .NET Framework 4.7.1, upgrade to Exchange 2013 CU22 before you install .NET Framework 4.7.2. 如果您运行的是 .NET Framework 4.6.2,请先升级到 Exchange 2013 CU20,然后再安装 .NET Framework 4.7.1。If you're running .NET Framework 4.6.2, upgrade to Exchange 2013 CU20 before you install .NET Framework 4.7.1.

  2. Windows Management Framework 4.0 (包含在 windows Server 2012 R2 中)Windows Management Framework 4.0 (included with Windows Server 2012 R2)

  3. Microsoft Unified Communications Managed API 4.0 Core Runtime(64 位)Microsoft Unified Communications Managed API 4.0, Core Runtime 64-bit

  4. 适用于 Visual Studio 2012 的 Visual C++ 可再发行组件包Visual C++ Redistributable Package for Visual Studio 2012

  5. Visual c + + 可再发行程序包 for Visual Studio 2013Visual C++ Redistributable Package for Visual Studio 2013

备注

你可以在此找到支持的最新 Visual C++ Redistributable 版本的概述Here you'll find an overview of the latest supported Visual C++ Redistributable versions

边缘传输服务器角色Edge Transport server role

按照此部分中的说明操作,在要在计算机上安装边缘传输服务器角色的 Windows Server 2012 R2 或 Windows Server 2012 计算机上安装必备组件。Follow the instructions in this section to install the prerequisites on Windows Server 2012 R2 or Windows Server 2012 computers where you want to install the Edge Transport server role on a computer.

请执行下列操作,安装必需的 Windows 角色和功能:Do the following to install the required Windows roles and features:

  1. 打开 Windows PowerShell。Open Windows PowerShell.

  2. 运行以下命令,安装必需的 Windows 组件。Run the following command to install the required Windows components.

    Install-WindowsFeature ADLDS
    

安装与您正在安装的 Exchange 2013 版本对应的 Microsoft .NET Framework 版本:Install the version of Microsoft .NET Framework that corresponds to the version of Exchange 2013 you're installing:

  1. .NET Framework 4.7.2.NET Framework 4.7.2

    重要

    Exchange 2013 CU23需要.net Framework 4.7.2。Exchange 2013 CU23 requires .NET Framework 4.7.2. 在安装 Exchange 2013 CU23之前,请将服务器升级到 .net Framework 4.7.2,否则将会收到错误。Upgrade your servers to .NET Framework 4.7.2 before you install Exchange 2013 CU23 or you'll receive an error. 如果您运行的是 .NET Framework 4.7.1,请先升级到 Exchange 2013 CU22,然后再安装 .NET Framework 4.7.2。If you're running .NET Framework 4.7.1, upgrade to Exchange 2013 CU22 before you install .NET Framework 4.7.2. 如果您运行的是 .NET Framework 4.6.2,请先升级到 Exchange 2013 CU20,然后再安装 .NET Framework 4.7.1。If you're running .NET Framework 4.6.2, upgrade to Exchange 2013 CU20 before you install .NET Framework 4.7.1.

  2. Windows Management Framework 4.0 (包含在 windows Server 2012 R2 中)Windows Management Framework 4.0 (included with Windows Server 2012 R2)

  3. 适用于 Visual Studio 2012 的 Visual C++ 可再发行组件包Visual C++ Redistributable Package for Visual Studio 2012

备注

你可以在此找到支持的最新 Visual C++ Redistributable 版本的概述Here you'll find an overview of the latest supported Visual C++ Redistributable versions

Windows Server 2008 R2 SP1 必备组件Windows Server 2008 R2 SP1 prerequisites

在 Windows Server 2008 R2 SP1 计算机上安装 Exchange 2013 所需的先决条件取决于要安装的 Exchange 角色。The prerequisites that are needed to install Exchange 2013 on a Windows Server 2008 R2 SP1 computer depends on which Exchange roles you want to install. 阅读下面与您要安装的角色相匹配的部分。Read the section below that matches the roles you want to install.

邮箱或客户端访问服务器角色Mailbox or Client Access server roles

按照此部分中的说明操作,在要执行以下操作之一的 Windows Server 2008 R2 SP1 计算机上安装必备组件:Follow the instructions in this section to install the prerequisites on Windows Server 2008 R2 SP1 computers where you want to do one of the following:

  • 仅在计算机上安装邮箱服务器角色。Install only the Mailbox server role on a computer.

  • 仅在计算机上安装客户端访问服务器角色。Install only the Client Access server role on a computer.

  • 在同一台计算机上同时安装邮箱和客户端访问服务器角色。Install both the Mailbox and Client Access server roles on the same computer.

请执行下列操作,安装必需的 Windows 角色和功能:Do the following to install the required Windows roles and features:

  1. 打开 Windows PowerShell。Open Windows PowerShell.

  2. 运行以下命令以加载服务器管理器模块。Run the following command to load the Server Manager module.

    Import-Module ServerManager
    
  3. 运行以下命令,安装必需的 Windows 组件。Run the following command to install the required Windows components.

    Add-WindowsFeature Desktop-Experience, NET-Framework, NET-HTTP-Activation, RPC-over-HTTP-proxy, RSAT-Clustering, RSAT-Web-Server, WAS-Process-Model, Web-Asp-Net, Web-Basic-Auth, Web-Client-Auth, Web-Digest-Auth, Web-Dir-Browsing, Web-Dyn-Compression, Web-Http-Errors, Web-Http-Logging, Web-Http-Redirect, Web-Http-Tracing, Web-ISAPI-Ext, Web-ISAPI-Filter, Web-Lgcy-Mgmt-Console, Web-Metabase, Web-Mgmt-Console, Web-Mgmt-Service, Web-Net-Ext, Web-Request-Monitor, Web-Server, Web-Stat-Compression, Web-Static-Content, Web-Windows-Auth, Web-WMI, RSAT-ADDS
    

在您安装操作系统角色和功能后,请按以下显示的顺序安装下列软件:After you've installed the operating system roles and features, install the following software in the order shown:

  1. .NET Framework 4.7.2.NET Framework 4.7.2

    重要

    Exchange 2013 CU23需要.net Framework 4.7.2。Exchange 2013 CU23 requires .NET Framework 4.7.2. 在安装 Exchange 2013 CU23之前,请将服务器升级到 .net Framework 4.7.2,否则将会收到错误。Upgrade your servers to .NET Framework 4.7.2 before you install Exchange 2013 CU23 or you'll receive an error. 如果您运行的是 .NET Framework 4.7.1,请先升级到 Exchange 2013 CU22,然后再安装 .NET Framework 4.7.2。If you're running .NET Framework 4.7.1, upgrade to Exchange 2013 CU22 before you install .NET Framework 4.7.2. 如果您运行的是 .NET Framework 4.6.2,请先升级到 Exchange 2013 CU20,然后再安装 .NET Framework 4.7.1。If you're running .NET Framework 4.6.2, upgrade to Exchange 2013 CU20 before you install .NET Framework 4.7.1.

  2. Windows Management Framework 4。0Windows Management Framework 4.0

  3. Microsoft Unified Communications Managed API 4.0 Core Runtime(64 位)Microsoft Unified Communications Managed API 4.0, Core Runtime 64-bit

  4. 适用于 Visual Studio 2012 的 Visual C++ 可再发行组件包Visual C++ Redistributable Package for Visual Studio 2012

  5. Visual c + + 可再发行程序包 for Visual Studio 2013Visual C++ Redistributable Package for Visual Studio 2013

    备注

    你可以在此找到支持的最新 Visual C++ Redistributable 版本的概述Here you'll find an overview of the latest supported Visual C++ Redistributable versions

  6. Microsoft 知识库文章 KB974405 (Windows Identity Foundation)Microsoft Knowledge Base article KB974405 (Windows Identity Foundation)

  7. 知识库文章 KB2619234 (启用 RPC over HTTP 使用的关联 Cookie/GUID,还可用于 Windows 7 和 Windows Server 2008 R2 中的 RPC 层)Knowledge Base article KB2619234 (Enable the Association Cookie/GUID that is used by RPC over HTTP to also be used at the RPC layer in Windows 7 and in Windows Server 2008 R2)

  8. 知识库文章 KB2533623 (不安全的库加载可能允许远程代码执行)Knowledge Base article KB2533623 (Insecure library loading could allow remote code execution)

    备注

    如果您已将 Windows 更新配置为在您的计算机上安装安全更新,则可能已安装此修补程序。This hotfix may already be installed if you've configured Windows Update to install security updates on your computer.

边缘传输服务器角色Edge Transport server role

按照此部分中的说明操作,在要在计算机上安装边缘传输服务器角色的 Windows Server 2008 R2 SP1 计算机上安装必备组件。Follow the instructions in this section to install the prerequisites on Windows Server 2008 R2 SP1 computers where you want to install the Edge Transport server role on a computer.

请执行下列操作,安装必需的 Windows 角色和功能:Do the following to install the required Windows roles and features:

  1. 打开 Windows PowerShell。Open Windows PowerShell.

  2. 运行以下命令以加载服务器管理器模块。Run the following command to load the Server Manager module.

    Import-Module ServerManager
    
  3. 运行以下命令,安装必需的 Windows 组件。Run the following command to install the required Windows components.

    Add-WindowsFeature NET-Framework, ADLDS
    

在您安装操作系统角色和功能后,请按以下显示的顺序安装下列软件:After you've installed the operating system roles and features, install the following software in the order shown:

  1. .NET Framework 4.7.2.NET Framework 4.7.2

    重要

    Exchange 2013 CU23需要.net Framework 4.7.2。Exchange 2013 CU23 requires .NET Framework 4.7.2. 在安装 Exchange 2013 CU23之前,请将服务器升级到 .net Framework 4.7.2,否则将会收到错误。Upgrade your servers to .NET Framework 4.7.2 before you install Exchange 2013 CU23 or you'll receive an error. 如果您运行的是 .NET Framework 4.7.1,请先升级到 Exchange 2013 CU22,然后再安装 .NET Framework 4.7.2。If you're running .NET Framework 4.7.1, upgrade to Exchange 2013 CU22 before you install .NET Framework 4.7.2. 如果您运行的是 .NET Framework 4.6.2,请先升级到 Exchange 2013 CU20,然后再安装 .NET Framework 4.7.1。If you're running .NET Framework 4.6.2, upgrade to Exchange 2013 CU20 before you install .NET Framework 4.7.1.

  2. Windows Management Framework 4。0Windows Management Framework 4.0

  3. Microsoft Unified Communications Managed API 4.0 Core Runtime(64 位)Microsoft Unified Communications Managed API 4.0, Core Runtime 64-bit

  4. 适用于 Visual Studio 2012 的 Visual C++ 可再发行组件包Visual C++ Redistributable Package for Visual Studio 2012

    备注

    你可以在此找到支持的最新 Visual C++ Redistributable 版本的概述Here you'll find an overview of the latest supported Visual C++ Redistributable versions

Windows 7 先决条件(仅限管理工具)Windows 7 prerequisites (admin tools only)

按照此部分中的说明操作,在要安装 Exchange 管理工具的加入域的 Windows 7 64 位计算机上安装必备组件。Follow the instructions in this section to install the prerequisites on domain-joined Windows 7 64-bit computers where you want to install the Exchange management tools.

  1. 打开 "控制面板",然后选择 "程序"。Open Control Panel, and then select Programs.

  2. 单击 "打开或关闭 Windows 功能"Click Turn Windows features on or off.

  3. 导航至 " Internet 信息服务 > Web 管理工具 > " IIS 6 管理兼容性Navigate to Internet Information Services > Web Management Tools > IIS 6 Management Compatibility.

  4. 选中 " IIS 6 管理控制台" 对应的复选框,然后单击 "确定"Select the check box for IIS 6 Management Console, and then click OK.

在安装操作系统功能之后,按显示的顺序安装以下软件:After you've installed the operating system features, install the following software in the order shown:

  1. .NET Framework 4.7.2.NET Framework 4.7.2

  2. Windows Management Framework 4。0Windows Management Framework 4.0

  3. 知识库文章 KB974405 (Windows Identity Foundation)Knowledge Base article KB974405 (Windows Identity Foundation)

Windows 8 和 Windows 8.1 先决条件(仅限管理工具)Windows 8 and Windows 8.1 prerequisites (admin tools only)

.NET Framework 4.7.2.NET Framework 4.7.2