Excel.Interfaces.RangeViewCollectionLoadOptions interface

Represents a collection of RangeView objects.

[ API set: ExcelApi 1.3 ]

Properties

$all
cellAddresses

For EACH ITEM in the collection: Represents the cell addresses of the RangeView. Read-only.

[ API set: ExcelApi 1.3 ]

columnCount

For EACH ITEM in the collection: Returns the number of visible columns. Read-only.

[ API set: ExcelApi 1.3 ]

formulas

For EACH ITEM in the collection: Represents the formula in A1-style notation.

[ API set: ExcelApi 1.3 ]

formulasLocal

For EACH ITEM in the collection: Represents the formula in A1-style notation, in the user's language and number-formatting locale. For example, the English "=SUM(A1, 1.5)" formula would become "=SUMME(A1; 1,5)" in German.

[ API set: ExcelApi 1.3 ]

formulasR1C1

For EACH ITEM in the collection: Represents the formula in R1C1-style notation.

[ API set: ExcelApi 1.3 ]

index

For EACH ITEM in the collection: Returns a value that represents the index of the RangeView. Read-only.

[ API set: ExcelApi 1.3 ]

numberFormat

For EACH ITEM in the collection: Represents Excel's number format code for the given cell.

[ API set: ExcelApi 1.3 ]

rowCount

For EACH ITEM in the collection: Returns the number of visible rows. Read-only.

[ API set: ExcelApi 1.3 ]

text

For EACH ITEM in the collection: Text values of the specified range. The Text value will not depend on the cell width. The # sign substitution that happens in Excel UI will not affect the text value returned by the API. Read-only.

[ API set: ExcelApi 1.3 ]

values

For EACH ITEM in the collection: Represents the raw values of the specified range view. The data returned could be of type string, number, or a boolean. Cells that contain an error will return the error string.

[ API set: ExcelApi 1.3 ]

valueTypes

For EACH ITEM in the collection: Represents the type of data of each cell. Read-only.

[ API set: ExcelApi 1.3 ]

Property Details

$all

$all?: boolean;

Property Value

boolean

cellAddresses

For EACH ITEM in the collection: Represents the cell addresses of the RangeView. Read-only.

[ API set: ExcelApi 1.3 ]

cellAddresses?: boolean;

Property Value

boolean

columnCount

For EACH ITEM in the collection: Returns the number of visible columns. Read-only.

[ API set: ExcelApi 1.3 ]

columnCount?: boolean;

Property Value

boolean

formulas

For EACH ITEM in the collection: Represents the formula in A1-style notation.

[ API set: ExcelApi 1.3 ]

formulas?: boolean;

Property Value

boolean

formulasLocal

For EACH ITEM in the collection: Represents the formula in A1-style notation, in the user's language and number-formatting locale. For example, the English "=SUM(A1, 1.5)" formula would become "=SUMME(A1; 1,5)" in German.

[ API set: ExcelApi 1.3 ]

formulasLocal?: boolean;

Property Value

boolean

formulasR1C1

For EACH ITEM in the collection: Represents the formula in R1C1-style notation.

[ API set: ExcelApi 1.3 ]

formulasR1C1?: boolean;

Property Value

boolean

index

For EACH ITEM in the collection: Returns a value that represents the index of the RangeView. Read-only.

[ API set: ExcelApi 1.3 ]

index?: boolean;

Property Value

boolean

numberFormat

For EACH ITEM in the collection: Represents Excel's number format code for the given cell.

[ API set: ExcelApi 1.3 ]

numberFormat?: boolean;

Property Value

boolean

rowCount

For EACH ITEM in the collection: Returns the number of visible rows. Read-only.

[ API set: ExcelApi 1.3 ]

rowCount?: boolean;

Property Value

boolean

text

For EACH ITEM in the collection: Text values of the specified range. The Text value will not depend on the cell width. The # sign substitution that happens in Excel UI will not affect the text value returned by the API. Read-only.

[ API set: ExcelApi 1.3 ]

text?: boolean;

Property Value

boolean

values

For EACH ITEM in the collection: Represents the raw values of the specified range view. The data returned could be of type string, number, or a boolean. Cells that contain an error will return the error string.

[ API set: ExcelApi 1.3 ]

values?: boolean;

Property Value

boolean

valueTypes

For EACH ITEM in the collection: Represents the type of data of each cell. Read-only.

[ API set: ExcelApi 1.3 ]

valueTypes?: boolean;

Property Value

boolean