Excel.Interfaces.RangeViewLoadOptions interface

RangeView 表示父范围的一组可见单元格。RangeView represents a set of visible cells of the parent range.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

属性

$all
cellAddresses

表示 RangeView 的单元格地址。Represents the cell addresses of the RangeView. 只读。Read-only.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

columnCount

返回可见列数。Returns the number of visible columns. 只读。Read-only.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

formulas

表示采用 A1 表示法的公式。Represents the formula in A1-style notation.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

formulasLocal

表示采用 A1 表示法的公式,使用用户语言和数字格式区域设置。例如,英语中的公式 "=SUM(A1, 1.5)" 在德语中变为 "=SUMME(A1; 1,5)"。Represents the formula in A1-style notation, in the user's language and number-formatting locale. For example, the English "=SUM(A1, 1.5)" formula would become "=SUMME(A1; 1,5)" in German.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

formulasR1C1

表示采用 R1C1 表示法的公式。Represents the formula in R1C1-style notation.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

index

返回表示 RangeView 的索引的值。Returns a value that represents the index of the RangeView. 只读。Read-only.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

numberFormat

表示 Excel 中指定单元格的数字格式代码。Represents Excel's number format code for the given cell.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

rowCount

返回可见行数。Returns the number of visible rows. 只读。Read-only.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

text

指定区域的文本值。Text values of the specified range. 文本值与单元格宽度无关。The Text value will not depend on the cell width. Excel # UI 中发生的符号替换不会影响 API 返回的文本值。The # sign substitution that happens in Excel UI will not affect the text value returned by the API. 只读。Read-only.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

values

表示指定的 RangeView 的原始值。Represents the raw values of the specified range view. 返回的数据可能是字符串、数字,也可能是布尔值。The data returned could be of type string, number, or a boolean. 包含错误的单元格将返回错误字符串。Cells that contain an error will return the error string.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

valueTypes

表示每个单元格的数据类型。Represents the type of data of each cell. 只读。Read-only.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

属性详细信息

$all

$all?: boolean;

属性值

boolean

cellAddresses

表示 RangeView 的单元格地址。Represents the cell addresses of the RangeView. 只读。Read-only.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

cellAddresses?: boolean;

属性值

boolean

columnCount

返回可见列数。Returns the number of visible columns. 只读。Read-only.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

columnCount?: boolean;

属性值

boolean

formulas

表示采用 A1 表示法的公式。Represents the formula in A1-style notation.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

formulas?: boolean;

属性值

boolean

formulasLocal

表示采用 A1 表示法的公式,使用用户语言和数字格式区域设置。例如,英语中的公式 "=SUM(A1, 1.5)" 在德语中变为 "=SUMME(A1; 1,5)"。Represents the formula in A1-style notation, in the user's language and number-formatting locale. For example, the English "=SUM(A1, 1.5)" formula would become "=SUMME(A1; 1,5)" in German.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

formulasLocal?: boolean;

属性值

boolean

formulasR1C1

表示采用 R1C1 表示法的公式。Represents the formula in R1C1-style notation.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

formulasR1C1?: boolean;

属性值

boolean

index

返回表示 RangeView 的索引的值。Returns a value that represents the index of the RangeView. 只读。Read-only.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

index?: boolean;

属性值

boolean

numberFormat

表示 Excel 中指定单元格的数字格式代码。Represents Excel's number format code for the given cell.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

numberFormat?: boolean;

属性值

boolean

rowCount

返回可见行数。Returns the number of visible rows. 只读。Read-only.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

rowCount?: boolean;

属性值

boolean

text

指定区域的文本值。Text values of the specified range. 文本值与单元格宽度无关。The Text value will not depend on the cell width. Excel # UI 中发生的符号替换不会影响 API 返回的文本值。The # sign substitution that happens in Excel UI will not affect the text value returned by the API. 只读。Read-only.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

text?: boolean;

属性值

boolean

values

表示指定的 RangeView 的原始值。Represents the raw values of the specified range view. 返回的数据可能是字符串、数字,也可能是布尔值。The data returned could be of type string, number, or a boolean. 包含错误的单元格将返回错误字符串。Cells that contain an error will return the error string.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

values?: boolean;

属性值

boolean

valueTypes

表示每个单元格的数据类型。Represents the type of data of each cell. 只读。Read-only.

[API 集: ExcelApi 1.3][ API set: ExcelApi 1.3 ]

valueTypes?: boolean;

属性值

boolean