尝试为用户启用或禁用存档邮箱或Exchange Online邮箱到本地环境时出错
备注
Office 365 ProPlus 正在重命名为 适用于企业的 Microsoft 365 应用。 有关此更改的详细信息, 请阅读此博客文章。
原始 KB 编号: 3050691
问题
当您尝试为现有 Exchange Online 用户启用或禁用存档邮箱时,或者当您尝试将邮箱从 Exchange Online 移动到本地环境时,您将收到类似于以下之一的错误消息:
错误:UserAlreadyBeingMigratedException:用户' <User Email Address> 已具有挂起的请求。 请删除现有请求并恢复当前批处理或为此用户启动新批处理。
Mailbox ' <User Display Name> ' has a completed move request associated with it. 为邮箱创建新的移动请求之前,请运行 Remove-MoveRequest cmdlet 以清除已完成的移动请求。
邮箱' <User Display Name> ' 具有移动状态 <move status> 。 在移动邮箱时,无法启用或禁用存档。
运行命令以检查移动请求时,将验证请求是否Office 365 Get-MoveRequest | fl 移动请求。 这由 IntraOrg 标志指示。
原因
出现此问题的原因是尚未从系统中删除失败的移动请求。
若要维护服务运行状况,Exchange Online在不同的服务器之间定期移动邮箱。 已完成Office 365数据中心移动请求将非常快速地清理。 数据中心Office 365请求失败的时间可能稍长一些,但一段时间之后仍将清理。 这些失败的移动请求不会影响用户。 如果需要,该服务将在将来重试移动。
解决方案
通常,如果内部数据中心移动不会影响您执行管理任务的能力,您可以放心地忽略错误消息。
如果移动请求影响管理任务,请按照以下步骤操作:
连接远程Exchange Online远程Windows PowerShell。 有关详细信息,请参阅连接Exchange Online PowerShell 进行远程访问。
验证邮箱是否正在移动。 为此,请运行下列命令:
Get-MoveRequest | fl Status, Protect, "Display Name", Identity如果"显示名称"占位符与要启用或禁用存档的邮箱匹配,则邮箱移动正在进行中。 移动阻止了更改。
检查输出,然后根据情况执行以下操作之一:
如果 Status 为 Queued 或 InProgre, 请等待移动完成。 这应在一到两天内发生。 如果无法等待那么长时间,请运行以下命令删除移动请求:
Remove-MoveRequest -Identity IdentityOfFailedRequest如果 Status 为 Failed, 则通过运行以下命令删除移动请求:
Remove-MoveRequest -Identity IdentityOfFailedRequest
此操作不应影响用户访问或导致任何问题。 此外,也不必通知 Microsoft 或邮箱所有者你正在采取此操作。
更多信息
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