"邮箱已满"警告,即使邮箱未达到存储限制
症状
用户遇到以下症状之一。
症状 1
用户收到未达到存储限制的邮箱的"邮箱已满"警告消息。
症状 2
当用户删除电子邮件时,将显示以下警告消息:
无法完成操作。
症状 3
用户不能更改或接受日历邀请。
原因
如果邮箱大小超过邮箱配额,则会出现此问题。 用户看到的邮箱大小不是实际大小,因为它不包括"可恢复的项目"文件夹。 此文件夹对用户不可见。
解决方案
下面将了解如何解决此问题:
通过运行以下 cmdlet 验证用户邮箱的存储配额:
Get-Mailbox user@contoso.com | fl ProhibitSendReceiveQuota,RecoverableItemsQuota然后,通过运行此 cmdlet 验证邮箱配额的状态:
Get-MailboxStatistics user@contoso.com | fl StorageLimitStatus,TotalItemSize,TotalDeletedItemSize- 如果
StorageLimitStatus值不为空,则意味着邮箱大小超过配额。 用户将遇到"症状"部分中提到的问题。 TotalItemSize值是指对用户可见的邮箱部分。 值是指用户看不到的"可恢复的项目"TotalDeletedItemSize文件夹的大小。
- 如果
如果
TotalItemSize值超过ProhibitSendReceiveQuota值,或者TotalDeletedItemSize值超出RecoverableItemsQuota值:- 对于症状 1 和 3,您可以要求受影响的用户从邮箱中删除项目,也可以按照后续步骤操作。
- 对于症状 2,请按照后续步骤操作。
以下是解决此问题的步骤:
通过运行以下 cmdlet 验证是否对受影响的用户的邮箱启用了存档:
Get-Mailbox user@contoso.com | fl ArchiveStat*如果
ArchiveStatus值为 Archive,且值为ArchiveStateLocal, 则云服务中已启用存档。 在这种情况下,请转到步骤 3。如果未启用存档,请通过运行以下 cmdlet 检查用户是否保持状态:
Get-Mailbox user@contoso.com | fl *HoldEnabled如果返回的值中至少有一个为 True,则意味着用户处于保留状态。 如果您不想为该用户启用存档,则必须从"可恢复的项目"文件夹中删除邮件。 若要了解有关"可恢复的项目"文件夹、存储配额以及该文件夹如何与 In-Place 保留和诉讼保留进行交互,请参阅 Exchange Online 中的"可恢复的项目"文件夹。
启用存档,并设置保留或删除策略以自动处理电子邮件。 若要了解更多信息,请参阅 为组织中邮箱设置存档和删除策略。
通过运行以下 cmdlet 验证将哪个保留策略应用于受影响的用户:
Get-Mailbox user@contoso.com | fl RetentionPolicy请注意,此类策略会在一段时间之后自动存档或删除邮箱中的项目。
如果最近修改保留策略或将保留策略应用于受影响的用户,请通过以下 cmdlet 手动运行邮箱处理:
Start-ManagedFolderAssistant user@contoso.com此 cmdlet 启动运行保留策略的邮箱处理任务,并清除配置的邮件。 请至少等待一小时,然后再次检查邮箱。
如果这些步骤无法解决问题,请联系 Microsoft 支持 人员寻求帮助。
更多信息
仍然需要帮助? 请转到 Microsoft 社区。