当80048163用户尝试登录 Azure、Azure 或 Intune Office 365时出现错误
备注
Office 365 ProPlus 正在重命名为 适用于企业的 Microsoft 365 应用。 有关此更改的详细信息, 请阅读此博客文章。
问题
当联合用户尝试从 URL 以 开头的登录网页登录 Microsoft 云服务(如 Office 365、Microsoft Azure 或 Microsoft Intune)时,该用户的身份验证将 https://login.microsoftonline.com 失败。 用户收到以下错误消息:
Sorry, but we're having trouble signing you in
Please try again in a few minutes. If this doesn't work, you might want to contact your admin and report the following error:
80048163
原因
如果满足下列条件之一,则可能会出现此问题:
- 更新了用户的 UPN,旧的登录信息缓存在 Active Directory 联合身份验证服务 (AD FS) 服务器上。 更改用户的 SAM 帐户时,缓存的登录信息可能会导致用户在下次尝试访问服务时出现问题。
- 在信赖方信任中设置Azure Active Directory (Azure AD) 返回意外数据。 手动编辑或删除与信赖方信任关联的声明时,可能会发生此行为。
解决方案
解决方案 1:禁用本地安全 (LSA) AD FS 服务器上凭据缓存
可以在 AD FS 服务器上更新 LSA 缓存的退出设置,以禁用 Active Directory 凭据信息缓存。 请谨慎使用此方法。 它可能会给服务器和 Active Directory 增加额外的负载。
重要
此方法包含的步骤告诉您如何修改注册表。 但是,注册表修改不当可能会出现严重问题。 因此,请务必严格按照这些步骤操作。 为了加强保护,应先备份注册表,再进行修改。 如果出现问题,可以还原注册表。 若要详细了解如何备份和还原注册表,请单击以下文章编号以查看如何在注册表中备份和还原Windows。
若要解决此问题,请按照下列步骤操作:
确保用户 UPN 的更改通过目录同步进行同步。
指示用户注销计算机,然后重新登录。
如果步骤 1 和步骤 2 无法解决问题,请按照以下步骤操作:
打开注册表编辑器,然后找到以下子项:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
右键单击 "Lsa", 单击 "新建",然后单击 "DWORD 值"。
键入 LsaLookupCacheMaxSize,然后按 Enter 命名新值。
右键单击 "LsaLookupCacheMaxSize", 然后单击"修改 "。
在"值数据" 框中,键入 0, 然后单击"确定 "。
退出注册表编辑器。
LsaLookupCacheMaxSize 重新配置可能会影响登录性能,在出现症状后不需要此重新配置。 此方法只应临时使用,我们强烈建议在问题解决后删除 LsaLookupCacheMaxSize 值。 为此,请按照下列步骤操作:
打开注册表编辑器,然后找到以下子项:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
右键单击 "LsaLookupCacheMaxSize", 然后单击"删除 "。
退出注册表编辑器。
解决方案 2:使用解决方案更新信赖方Azure AD
若要更新信赖方信任,请参阅以下 Microsoft 文章的"如何更新 Office 365 联合域的配置"部分:
如何在 Office 365、Azure 或 Intune 中更新或修复联合域的设置
更多信息
仍然需要帮助? 转到 Microsoft 社区或 Azure Active Directory 论坛网站。