"已存在具有此名称的用户。 请使用其他名称。" 错误Office 365门户

备注

Office 365 ProPlus 正在重命名为 适用于企业的 Microsoft 365 应用。 有关此更改的详细信息, 请阅读此博客文章

问题

在Microsoft Office 365中,您将收到一条错误消息,此消息在 Microsoft Office 365 门户中类似:

已存在具有此名称的用户。使用不同的名称。

原因

如果已使用用户名或已存在基于用户名的现有电子邮件地址,则可能会发生此问题。

如果设置过程确定另一个对象已具有与正在创建的用户名匹配的用户名或电子邮件地址,则许可尝试将失败。

默认情况下,添加或分配用户Exchange Online许可证时,会为用户提供基于其用户名的主 SMTP 地址。 此外,还为用户提供了一个基于 Microsoft Online Direct Routing Domain (MODRD) 的电子邮件地址,例如,contoso.onmicrosoft.com。 此外,当更改用户名时,主 SMTP 地址也可能更改。 但是,不会更新或删除备用地址。

下面是一些示例方案。

场景 1

添加用户名为 的用户,组织的 MODRD contoso.onmicrosoft.com,并且该用户分配有Exchange Online john@contoso.com 许可证。 在此方案中,提供以下电子邮件地址:

  • 为用户提供的主 SMTP 地址为 john@contoso.com 。
  • 会向用户提供备用电子邮件地址,即 john@contoso.onmicrosoft.com 。

场景 2

添加用户名为 的用户,组织的 MODRD contoso.onmicrosoft.com,并且该用户分配有Exchange Online john@contoso.onmicrosoft.com 许可证。 在此方案中,提供以下电子邮件地址:

  • 为用户提供的主 SMTP 地址为 john@contoso.onmicrosoft.com 。

场景 3

用户名从 更改为 john@contoso.com johnsmith@contoso.com 。 在此方案中,将发生以下事件:

  • 主 SMTP 地址 可能会 john@contoso.com 更改为 johnsmith@contoso.com 。
  • 不会更改备用电子邮件地址 john@contoso.com 。 因此,如果您尝试稍后添加,将 john@contoso.com 出现问题。
  • 不创建备用 johnsmith@contoso.onmicrosoft.com 电子邮件地址。

解决方案

若要解决此问题,请执行下列一项或多个操作:

  • 添加用户时,请使用其他用户名。
  • 添加用户时,查找并更改现有用户名,以便可以使用遇到问题的用户名。
  • 向用户添加或分配Exchange Online许可证时,请查找并更改基于您尝试使用的用户名的现有电子邮件地址。

若要检查电子邮件地址是否已经存在,请按照以下步骤操作:

  1. 通过使用远程 PowerShell 连接到 Exchange Online。 若要详细了解如何操作,请转到以下 Microsoft 网站:

    使用远程 PowerShell 连接到 Exchange Online

  2. 运行以下 cmdlet:

    get-mailbox| where {$_.EmailAddresses -match "user name"} | ft Name, RecipientType, EmailAddresses
    

    备注

    "用户名"是遇到问题的用户名。

  3. 根据在运行 cmdlet 后收到的结果,更新或删除现有电子邮件地址。

仍然需要帮助? 请转到 Microsoft 社区