Exchange Online中的电子数据展示搜索将无限期排队
原始 KB 编号: 2979630
症状
您可以在 Exchange Online 管理中心Exchange电子数据展示Exchange Online。 但是,搜索的状态仍保持搜索 已排队 状态。
原因
如果区域设置为英语或加拿大英语 , () 。 使用开始日期和结束日期筛选搜索时,加拿大英语 (区域设置 ) 将属性配置为使用 DateFormat DD/MM/YY 格式。 此时间格式将传递给 .NET Framework 方法,这将导致搜索 DateTime.TryParse 失败并引发异常。
解决方法
若要解决此问题,请执行下列操作之一:
不指定开始日期和结束日期。 相反,在"搜索 查询"页上的"关键字"框中,使用使用 MM/DD/YY 格式的日期查询词。 例如:
Received>="06/01/2009 7:00:00 AM" AND Received<="06/01/2014 7:00:00 AM"
指定时间时,请确保使用 UTC 格式。
使用
Set-MailboxRegionalConfigurationcmdlet 将用户属性DateFormat设置为 MM/DD/YY 格式。 有关此 cmdlet 详细信息,请参阅 Set-MailboxRegionalConfiguration。
状态
这是一个已知问题。 我们正在努力解决此问题,并且将在本文提供时发布详细信息。
更多信息
有关关键字查询语言和 KQL (语法) ,请参阅关键字查询语言 (KQL) 语法参考。
仍然需要帮助? 请转到 Microsoft 社区。