登录登录时出现"抱歉,但无法登录"Office 365

备注

Office 365 ProPlus 正在重命名为 适用于企业的 Microsoft 365 应用。 有关此更改的详细信息, 请阅读此博客文章

症状

当您尝试登录到 Office 365 门户时,您将收到以下错误消息:

抱歉,登录时遇到问题。

此外,您可能还看到以下错误消息:

AADSTS7000112:应用程序"00000002-0000-0ff1-ce00-00000000000000" (Office 365 Exchange Online) 禁用。

原因

如果租户禁用了 Exchange Online 应用程序的服务主体,则会发生此问题。

解决方案

执行这些步骤之前,请确保满足以下先决条件:

  • 安装Azure Active Directory模块Windows PowerShell。 有关详细信息,请转到 连接Office 365 PowerShell
  • 这些步骤由全局管理员Office 365执行。

若要解决此问题,请按照下列步骤操作:

  1. 检查应用程序服务主体的当前Exchange Online状态。 为此,请运行以下 cmdlet:

    (Get-MsolServicePrincipal -AppPrincipalId 00000002-0000-0ff1-ce00-000000000000).accountenabled
    
  2. 通过运行以下 cmdlet Exchange Online启用服务主体:

    Get-MsolServicePrincipal -AppPrincipalId 00000002-0000-0ff1-ce00-000000000000 | Set-MsolServicePrincipal -AccountEnabled $true